Exported Projects

 Exported Projects:

  • http://excel.blogfa.com


آموزش جامع نرم افزار اکسل 2007 EXCEL

تبليغات X
آموزش محیط و توانایی های صفحه گسترده اکسل 2007 توابع ، نمودارها، روش های تحلیل داده - اکسل پیشرفته
معرفی امکانات جدید اکسل 2012
گروه فعال سایت فرساران بازهم مطلبی جدید را درباره اکسل ۲۰۱۲ ارائه نموده که خواندن آنرا به همه توصیه می کنم.

این مطلب را می توانید از لینک زیر مشاهده کنید.

http://farsaran.ir/Excel%202012%20News

با عضویت در این سایت غنی مطالب جدید را به صورت مرتب با ایمیل دریافت کنید.

باز هم از زحمات گروه فعال فرساران و جناب آقای مهندس فرشید میدانی تشکر می کنیم .

www.farsaran.ir

نوشته شده در پنجشنبه سی ام تیر 1390ساعت 12:5 توسط علی توضیح |
ساخت یک گزارش پویا در اکسل 2010
بیشتر اوقات کاربران اکسل برای گزارش گیری از مجموعه ی عظیمی از داده ها در اکسل به مشکل برخورد می کنند. ابزار جداول محوری یا pivottables در اکسل این توانایی را در آنها ایجاد می کند.این ابزار به کاربران کمک می کند تا بر اساس فیلد ها گزارش تهیه کنند .

مثال- فرض کنید جدول شماره یک مجموعه ای از داده های مربوط به افراد یک کارگاه است که مرتب در حال دریافت و پرداخت میباشند . حال اگر بخواهیم گزارشی از تمام دریافتی ها ی همه کارکنان بیابیم به روش زیر اقدام می کنیم :

حل : ابتدا یک سلول از جدول داه را انتخاب کرده ، از منوی insert گزینه pivot tableرا انتخاب می کنیم .

با انتخاب محدوده جدول داده یا حتی بیشتر از آن ، اکسل متوجه فیلد ها و داده ها می گردد.

فیلد ها و منوی pivottable tools پدیدار می گردد و کاربر قادر است فیلدها را انتخاب کرده و عملیات محاسباتی خود را تغییر دهد.

هر جدول محوری دارای 4 بخش است .

1- ستون ها : که داده ها به صورت ستونی در جدول نمایش داده می شوند.

2- report : که اصلی ترین فیلد مجموعه محسوب می گردد و سایر فیلد ها زیر مجموعه ی آن محسوب می گردند.

3- سیگما : یا بخش محاسباتی جدول

4- ردیف ها : که داده ها به صورت سطری در جدول نمایش داده می شوند.

کافی است فیلد های مورد نظر را گرفته و به یکی از این چهار بخش بکشیم یا آنها را تیک بزنیم.

شکل جدول پدیدار می گردد و شما قادرید از گزارش ساخته شده اطلاعات بگیرید.

برخی اوقات به مشکل برخورد می کنیم . جدول محوری تفاوتی بین یک فیلد محاسباتی را با غیر آن به درستی درک نمی کند . در مثال زیر فیلد اتخاب شده سال به بخش محاسباتی منتقل شده است در حالیکه ما قصد جمع و ضرب آنرا نداریم و می خواهیم دریافتی افراد را طی سال های مختلف بررسی کنیم . بنابراین باید آنرا به بخش سطر ها کشید تا در کنار اسامی اطلاعات را شفافتر منتقل کنند.

خروجی جدول بیانگر دریافتی هر فرد طی سال های مورد نظر است .

لینک دانلود جدول و تمرین های بیشتر را در بخش تمرین جداول محوری در روز شانزدهم فروردین ۹۰ قرار داده ام. موفق باشید

نوشته شده در دوشنبه نهم خرداد 1390ساعت 9:2 توسط علی توضیح |
توضیح بیشتر درباره تمرین قبل
در تمرین انبار از سه تابع match index , dsum استفاده شده است. همانطور که قبلا توضیح دادم دو تابع match , index برعکس یکدیگرند.

تایع index شماره ردیف داده را در یک مجموعه دریافت کرده خود داده را نمایش می دهد در حالیکه تابع match داده را دریافت کرده شماره ردیف آن در مجموعه را نمایش می دهد.

=index( شماره ردیف داده , مجموعه ) ====> data

=match ( data , مجموعه , type ) ======> data row

در این تمرین کافی است ابتدا با استفاده از تابع match شماره اولین ردیفی را که داده در آن نمایش داده شده را بیابید . با این کار شما قادر خواهید بود نام کالا را یافته و آنرا در سلولی دیگر نمایش دهید.

تابع dsum هم عملیات جمع را با شرط انجام می دهد . این تابع سه پارامتر دارد . ابتدا نشانی کل جدول را از کاربر گرفته ، شماره فیلدی را که قرار است عملیات جمع روی آن انجام گیرد را نیز دریافت می کند آنگاه با دریافت آدرس محدوده شرط ، عملیات جمع را انجام می دهد . نکته مهم آنست که آدرس محدوده ی شرط باید شامل عناوینی باشد که در آدرس کل جدول نیز وجود دارند. مثلا اگر شما می خواهید به دنبال جمع تعداد کالای خریداری شده بگردید ( فیلد شماره 6) باید محدوده شرط را طوری انتخاب کنید که کد کالا و شماره ی آن در محدوده ی شرط باشند ( m1 :m2 )

البته در تابع match پارامتر آخر دارای سه مقدار 0 و 1 و -1 است که بسته به نوع جستجو از آنها استفاده می کنیم :

1 برای جستجوی مقادیری کوچکتر از مقدار داده شده

0 برای جستجوی دقیق مقادیر داده شده

-1 برای جستجوی مقادیر بزرگتر از مقدار داده شده

نوشته شده در یکشنبه بیست و پنجم اردیبهشت 1390ساعت 14:7 توسط علی توضیح |
تمرین - یافتن داده ها روش استفاده از توابع match , dsum
در بسیاری از مواقع کاربران برای یافتن یک کالا یا شخص با استفاده از کد با مشکل روبرو می شوند و می خواهند بدون استفاده از vba نیز بر مشکل برطرف شود.

برای اینکار می توان از تابع match برای یافتن اولین ردیف از داده استفاده کرد و سپس نام داده را با استفاده از تابع index شناخت , بالاخره برای یافتن جمع ها از توابعی مانند dsum یا خانواده sumifs استفاده کرد. برای این منظور تمرین طراحی و با پاسخ در اختیار شما دوستان قرار می دهم تا بیشتر تمرین کنید.

تمرین - در جدول انبار ساختاری طراحی کنید که با نوشتن کد هر کالا شماره اولین ردیف ،نام کالا و سپس جمع خریداری شده و فروخته شده و مانده ی هر کالا را نمایش دهد.

دانلود فایل تمرین

نوشته شده در یکشنبه هجدهم اردیبهشت 1390ساعت 9:8 توسط علی توضیح |
طراحی جدول داده
توجه کاربران محترم اکسل را برای طراحی یک جدول به نکات زیر جلب می کنم:

۱- از گسستگی داده ها بپرهیزید . ( سطر یا ستون کاملا خالی در جدول نداشته باشید )

۲- از انجام عملیات merge بپرهیزید ( اینکار مانع از مرتب سازی و فیلترینگ صحیح داده ها در جدول می گردد)

3- تمام فیلد های مربوط به یک موضوع را در یک جدول قرار دهید تا قادر به دریافت اطلاعات صحیح تر باشید ( فیلدها همان ستون های جدولند )

4- فیلد های جدول حتما باید دارای عنوان باشند (هدر )

5- حتما سعی کنید از سمت ستون A جدول را طراحی کنید.

۶- از ورود داده های نامعتبر جلوگیری کنید ( validation).

7- از تخریب سلول هایی که نباید دستکاری شوند با protection جلوگیری کنید.

8- سعی کنید در بالای عناوین فیلدها محاسبات و سرجمع آنهارا نشان دهید( subtotal ) نه در پایین جدول

9- هر چه بیشتر فیلد در جدول شما باشد گزارشات شما دقیقتر و بنابراین اطلاعات شما صحیحتر خواهد بود (pivottable).

۱۰-منطق ورود داده را فراموش نکنید ( جایی که قرار است نام وارد شود فامیل وارد نکنیم )

نوشته شده در سه شنبه سیزدهم اردیبهشت 1390ساعت 13:48 توسط علی توضیح |
روز معلم مبارک
تقدیم به همه معلمان مربیان آموزگاران اساتید و...

روزگاری است که سودای بتان دین من است غم اینکار نشاط دل غمگین من است

دیدن روی تو را دیده ی جان بین باید وین کجا مرتبه چشم جهان بین من است

یار من باش که زیب فلک و زینت دهر از مه روی تو و اشک چو پروین من است

تا مرا عشق تو تعلیم سخن گفتن داد خلق را ورد زبان مدحت و تحسین من است

دولت فقر خدایا به من ارزانی دار کاین کرامت سبب حشمت و تمکین من است

یا رب آن کعبه مقصود تماشاگه کیست ؟ که مغیلان طریقش گل و نسرین من است

واعظ شحنه شناس این عظمت گو مفروش زانکه منزلگه سلطان دل مسکین من است

حافظ از حشمت پرویز دگر قصه مخوان که لبش جرعه کش خسرو و شیرین من است

نوشته شده در سه شنبه سیزدهم اردیبهشت 1390ساعت 13:0 توسط علی توضیح |
تمرین مدیریت داده -اکسل پیشرفته
تمرین - فرض کنید یک لیست از شماره های دانشجویی یک کلاس داریم و می خواهیم نمره ی هر دانشجو را در جلوی شماره اش وارد کنیم .فرمی لازم داریم تا با تایپ شماره دانشجویی آنرا در فهرست یافته و پس از ورود نمره آنرا در مقابلش ثبت کرده َ شماره دانشجویی بعدی را از کاربر بگیرد.

پاسخ: ابتدا یک سلول از جدول انتخاب شود.سپس ابزار form را از بخش ابزار های اکسل :

QAT\MORE COMMANDS \ ALL COMMANDS\FORM..

انتخاب می کنیم. حال با انتخاب این ابزار کاربر قادر است بسیاری از قابلیت های یک فرم ساده در ورود و نمایش داده ها را استفاده کند.

با فشردن کلید CRITERIA کاربر می تواند شرط مورد نظر را وارد کند . مثلا شماره دانشجویی. حال با فشردن کلید اینتر رکورد مورد نظر یافت شده می توانید داده متناظر آنرا وارد نمایید. اگر در حالت شرط ( CRITERIA ) باشید بجای این کلمه گزینه FORM فعال است.

با کلید NEW می توانید رکورد جدید وارد کنید و با کلید های NEXT , PREV هم به رکوردهای قبل و بعد وارد میشوید.

نوشته شده در پنجشنبه هشتم اردیبهشت 1390ساعت 9:38 توسط علی توضیح |
تمرین جداول محوری - pivottable
در فایل زیر که شامل سه کاربرگ است ، تمرین های زیر را حل کنید:

1- در جدول یک مطلوبست جمع دریافتی هر نفر؟

2- میانگین دریافتی هر نفر از هر بانک ؟

3- بیشترین دریافتی هر نفر در هر سال ؟

4- کمترین مقداری که هر بانک به عنوان دریافتی ، در هر سال به هر فرد داده است ؟

5- در جدول شماره دو ، مقدار خریداری شده و فروخته شده هر کالا را نمایش داده و سپس مانده ی هر کدام را نمایش دهید.

6- در جدول شماره سه هر فروشگاه در هر شهر از هر کالا چه مبلغی ( جمع کل ) فروش داشته است.

7- نمودار فروش پاکن را در تمام فروشگاه ها مقایسه کنید.

دانلود تمرین

موفق باشید

نوشته شده در سه شنبه شانزدهم فروردین 1390ساعت 11:17 توسط علی توضیح |
توابع مالی - بخش دوم

تابع RATE

این تابع درصد نرخ سود سالانه را محاسبه می کند.

=RATE( تعداد اقساط ; مبلغ هر قسط ; مبلغ وام )

مثال 3 : فرض کنید وامی به مبلغ سی میلیون ریال به مدت هفت سال باید بازپرداخت شود اگر مبلغ هر قسط

سالیانه ی آن 5,184,594.55 ریال باشد نرخ سود سالیانه ی آن چقدر است ؟

=RATE( 7 ; 5,184,594.55 ; 30000000) = 5%

تابع NPER

این تابع تعداد اقساط یک وام را مشخص می کند.

=NPER( سالانه نرخ سود ; مبلغ هر قسط ; مبلغ وام )

مثال 4 : فرض کنید وامی به مبلغ سی میلیون ریال با نرخ سود سالانه پنج درصد و با مبلغ هر قسط 5,184,594.55 ریال را از بانک دریافت کرده ایم . چند قسط سالیانه باید بپردازیم؟

=NPER( 5% ; 5,184,594.55 ; 30000000) = 7

نوشته شده در دوشنبه پانزدهم فروردین 1390ساعت 11:23 توسط علی توضیح |
برخی توابع مالی در اکسل - اکسل 2007 پیشرفته

برخی توابع مالی در اکسل

برخی از توابع مالی استفاده های زیادی در اکسل دارند ، که به طور خلاصه به شرح 4 مورد از آنها خواهیم پرداخت:

تابع PMT

این تابع برای محاسبه مبلغ اقساط سالیانه یک وام با بهره ثابت بکار می رود.

=PMT( نرخ بهره سالانه; تعداد اقساط سالانه ; مبلغ کل وام )

در مورد توابع مالی این نکته ضروری است که اگر تمام مواردمثبت باشد اکسل به صورت خودکار جواب را منفی نمایش می دهد ( شما را بدهکار می کند ) برای جلوگیری از این کار ، معمولا مبلغ وام را منفی نمایش می دهند تا سایر جواب ها مثبت نشان داده شود.

این نکته هم ضروری است که بدانیم ساختار ها باید همگون باشند یعنی اگر کاربر بهره سالانه استفاده می کند مبلغ قسط هم سالانه نمایش داده می شود ، تعداد اقساط هم همان تعداد سال های پرداخت وام تلقی می گردد.

مثال 1 : فرض کنید وامی را به مبلغ سی میلیون ریال ( سه میلیون تومان ) با بهره سالانه پنج درصد طی هفت سال می خواهیم بازپس دهیم ، آیا می توان مبلغ اقساط سالانه آنرا محاسبه کرد؟

=PMT( 5% ; 7 ; 30000000) = ريال 5,184,594.55

در حقیقت شما باید سالانه مبلغ ريال 5,184,594.55 را بابت اقساط بپردازید .

نرخ بهره سالانه | تعداد اقساط ( سال ) | مبلغ وام | مبلغ هر قسط ( سالانه ) | مبلغ هر قسط (ماهانه ) | جمع کل اقساط | جمع کل سود پرداختی
5% | 7 | 30,000,000- | ريال 5,184,594.55 | ريال 432,049.55 | ريال 36,292,161.87 | ريال 6,292,161.87

تابع IPMT

این تابع برای محاسبه مبلغ سود هر قسط سالیانه یک وام با بهره ثابت بکار می رود.

=IPMT( نرخ بهره سالانه;شماره قسط ; تعداد اقساط سالانه ; مبلغ کل وام )

این تابع که شبیه تابع PMT است ، مبلغ سود هر قسط را محاسبه می کند.

مثال 2: در مثال شماره یک مبلغ سود هر قسط را محاسبه کنید، مثلا برای قسط سال اول :

=IPMT(5% ; 1 ; 7 ; 30000000)

نرخ بهره سالانه | شماره قسط | تعداد اقساط ( سال ) | مبلغ وام | مبلغ سود ه قسط
5% | 1 | 7 | 30,000,000- | 1,500,000.00
5% | 2 | 7 | 30,000,000- | 1,315,770.27
5% | 3 | 7 | 30,000,000- | 1,122,329.06
5% | 4 | 7 | 30,000,000- | 919,215.78
5% | 5 | 7 | 30,000,000- | 705,946.85
5% | 6 | 7 | 30,000,000- | 482,014.46
5% | 7 | 7 | 30,000,000- | 246,885.45

نرخ بهره سالانه | شماره قسط | تعداد اقساط ( سال ) | مبلغ وام | مبلغ سود هر قسط
5% | 1 | 7 | 30,000,000- | ريال 1,500,000.00
5% | 2 | 7 | 30,000,000- | ريال 1,315,770.27
5% | 3 | 7 | 30,000,000- | ريال 1,122,329.06
5% | 4 | 7 | 30,000,000- | ريال 919,215.78
5% | 5 | 7 | 30,000,000- | ريال 705,946.85
5% | 6 | 7 | 30,000,000- | ريال 482,014.46
5% | 7 | 7 | 30,000,000- | ريال 246,885.45

نوشته شده در دوشنبه پانزدهم فروردین 1390ساعت 10:21 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )

RSS

POWERED BY BLOGFA.COM


تبليغات X
تابع subtotal
تابع subtotal

این تابع نسبت به فیلتر ها حساس بوده و دارای ساختار زیر است :

=subtotal( شماره تابع , range)

این تابع دارای 11 تابع درونی است که شماره های آنها عبارتند از:

یازده تابع درونی subtotal

محدوده عمل تابع است range

به مثال زیر توجه کنید

جمع دریافتی های علی چقدر است ؟

شماره 9 تابع sum است

هنگامی که لیست بر روی نام علی فیلتر می شود ، تابع فقط جمع دریافتی های علی را نمایش می دهد.

طرز استفاده تابع

نوشته شده در یکشنبه سی ام بهمن 1384ساعت 13:40 توسط علی توضیح |
اکسل پیشرفته advance excel
مراحل آموزش اکسل پیشرفته:

  1. استفاده از تابع subtotal
  2. استفاده از تابع sumif, countif
  3. استفاده از توابع روند سازی round , int,abs ,floor,ceiling,odd,even,...
  4. استفاده از توابع پایگاه داده dfunctions,dsum,daverage,dvar,dget,...
  5. استفاده از توابع آرایه ای array functions
  6. استفاده از جداول محوری
  7. استفاده از فرم ها
  8. استفاده از ماکروها
نوشته شده در پنجشنبه بیست و هفتم بهمن 1384ساعت 11:25 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
فرم ها در اکسل 2
مراحل ساخت یک کمبو باکس:

حال اگر کمبو را باز کنید ملاحظه می کنید که داده های داده شده مطابق لیست در آن دیده می شوند .اگر یکی از آنها را انتخاب کنیم شماره آن در لیست ، در CELL LINK نمایش داده می شود .

نوشته شده در یکشنبه سی و یکم اردیبهشت 1385ساعت 13:56 توسط علی توضیح |
ابزارهای فرم سازی
برای ساخت فرم هایی شبیه درس قبل ، که به وسیله آنها بتوان داده های مورد نظر را کنترل شده به کاربرگ ها وارد کرد یا اینکه محاسبات را به دقت انجام داد ، با ابتدا نوار ابزار FORMS را ظاهر کرد :

نوار ابزار فرم

ابزارهای موجود در این نوار ابزار عبارتند از :

این ابزار به صورت یک صفحه بروی کاربرگ ، قرار می گیرند . برای اتصال این ابزار به کاربرگ ، سلولی به نام سلول اتصال یا CELL LINK طراحی شده است که حاصل انتخاب هر ابزار را به سلول های کاربرگ انتقال می دهد .

به طور مثال اگر CHECKBOX را انتخاب نمایید و آنرا برروی کاربرگ ترسیم کنید یک جعبه انتخاب نمایش داده می شود . برچسب آنرا تغییر داده بروی آن راست کلیک کرده و گزینه FORMAT CONTROLرا انتخاب نمایید.

اگر این گزینه انتخاب شود سلول اتصال علامت TRUE و در غیر این صورت علامت FALSE را نمایش می دهد.با استفاده از همین سلول کاربر قادر است فرمول نویسی مورد نظر خود را اعمال نماید .

نوشته شده در پنجشنبه هفتم اردیبهشت 1385ساعت 12:42 توسط علی توضیح |
فرم ها در اکسل
فرم ها در اکسل روشی متفاوت برای ورود و نمایش داده ها در سلول های کاربرگ می باشد.

به طور مثال برای ورود داده به لیست از طریق فرم ، مسیر نمایش داده شده را طی کنید :

مسیر اجرای فرم

لازم به ذکر است که فیلدهای محاسباتی قابلیت تغییر ندارند .

نوشته شده در پنجشنبه هفتم اردیبهشت 1385ساعت 8:39 توسط علی توضیح |
کلاس روز چهارشنبه 6/2/85 برگزار خواهد شد .

کلاس اکسل پیشرفته سازمان مدیریت صنعتی

امروز چهارشنبه 6/2/85 برگزار می گردد .

مبحث : فرم سازی و مباحث کنترل داده

نوشته شده در چهارشنبه ششم اردیبهشت 1385ساعت 8:22 توسط علی توضیح |
تغییر قالب بندی اعداد در جداول محوری

هرگاه بخواهیم قالب بندی اعداد فیلد های محاسباتی ( DATA) را تغییر دهیم بر روی نام فیلد مورد نظر ( مبلغ واحد خرید ) دبل کلیک کرده تا پنجره آبی رنگ PIVOTTABLE FIELD ظاهر شود .

تغییر فرمت اعداد

سپس کلید NUMBER را فشار داده و نوع قالب بندی مورد نظر را انتخاب می کنیم .

نوشته شده در شنبه دوم اردیبهشت 1385ساعت 12:26 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
فرم سازی

تمرین استفاده از ابزار فرم سازی

با استفاده از ابزار فرم سازی ( FORMS ) فرم ساده ای برای سفارش غذا و دسر با حق سرویس 12 درصد طراحی نمایید .

شکل این فاکتور می تواند به فرم زیر باشد :

پس از انتخاب نوع غذا قیمت باید به صورت خودکار پدیدار گردد . توجه کنید که جدول زیر فقط چاپ می گردد .

دانلود مثال فوق

نوشته شده در چهارشنبه سی و یکم خرداد 1385ساعت 8:54 توسط علی توضیح |
تمرین جداول محوری
صورت تمرین ها :

۱- از هر کالا در هر فروشگاه چه تعداد فروخته شده است ؟

۲- از هر کالا در هر فروشگاه در هر شهر چه مبلغی فروش رفته است ؟

تمرین ساخت جداول محوری: دانلود کنید ( کلاس پیشرفته)

نوشته شده در سه شنبه شانزدهم خرداد 1385ساعت 10:2 توسط علی توضیح |
تواابع جستجو LOOKUP & REFRENCE
۱- تابع INDIRECT

شکل تابع

(INDIRECT(ref_text,a1

این تابع یک آدرس سلول را دریافت کرده ، به سراغ آن سلول می رود سپس محتویات آنرا که الزاما آدرس سلولی دیگر است دریافت کرده و نهایتا محتویات آخرین آدرس را نمایش می دهد .

۲- تابع ( )row

این تابع شماره سطری را که تابع در آن قرار دارد نمایش می دهد . اگر در میان پرانتز ها آدرس یک سلول نوشته شود شماره سطر آنرا باز می گرداند .

3- تابع ( ) column

این تابع شماره ستونی را که تابع در آن قرار دارد نمایش می دهد . اگر در میان پرانتز ها آدرس یک سلول نوشته شود شماره ستون آنرا باز می گرداند .

۴- توابع ( محدوده ) rows و ( محدوده ) columns

این توابع تعداد سطر و یا ستون محدوده را نمایش می دهند .

نوشته شده در پنجشنبه یازدهم خرداد 1385ساعت 12:19 توسط علی توضیح |
انواع آدرس دهی ها در اکسل

روش های آدرس دهی در اکسل

1- آدرس دهی نسبی : در این مدل آدرس دهی ، سلول ها نسبت به مکان اولیه تغییر می کنند .

مثال : در شکل زیر اگر سلول اول شامل فرمول D3 را به سلول پایین تر D4 انتقال دهیم ، فرمول های آن به شکل زیر تغییر می کند :

۲- آدرس دهی مطلق : در این مدل آدرس دهی ، سلول ها نسبت به مکان اولیه تغییر نمی کنند .

مثال : در فرمول D1* $A$2= سلول A2 به صورت مطلق استفاده شده است. ( یک علامت $ در پشت ستون و یک علامت $ پشت عدد سطر آمده) در این حالت با کپی فرمول در سلول های دیگر آدرس A2 تغییر نمی کند .

۳- آدرس دهی ترکیبی : در این نوع آدرس دهی یا سطر ثابت است یا ستون

علامت دلار پشت سر سطر یا ستون آنها را ثابت نگه می دارد .به طور مثال در A$5 سطر 5 را ثابت نگه می دارد و در 4 A$ ستون A ثابت است .

نوشته شده در چهارشنبه دهم خرداد 1385ساعت 10:34 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
جداول محوری 3 - محاسبات در جدول
جداول محوری قادرند محاسبات مورد نظر کاربران را به راحتی انجام دهند ، به طور مثال فرض کنید در جدول کالاها در زیر کاربر قصد دارد تفاوت تعداد کالای وروردی و خروجی را( موجودی انبار ) بیابد .

حل مساله : ابتدا جدولی با محوریت کالا و فیلدهای محاسباتی تعداد ورودی و خروجی می سازیم آنگاه از نوار ابزار pivottable مسیر نمایش داده شده را طی می کنیم .

سپس نام فیلد محاسباتی جدید را نوشته ( موجودی انبار ) و در قسمت مشخص شده فرمول مورد نظر را وارد می کنیم .

کلید OK را می فشاریم ، نتیجه نهایی :

فیلد جدید ، موجودی انبار

انواع عملگرها و توابع را در این بخش می توانید استفاده نمایید :

توابع نیز قابل استفاده اند .

نوشته شده در شنبه بیست و ششم فروردین 1385ساعت 9:57 توسط علی توضیح |
سلام بر دوستان کلاس ها ی اکسل سازمان این هفته برقرار است .
نوشته شده در شنبه بیست و ششم فروردین 1385ساعت 9:31 توسط علی توضیح |
جداول محوری 2 - آشنایی با محاسبات و نمودارها در PIVOTTALBLE
مثال :فرض کنید لیستی از کالاهای وارد شده و خارج شده ی یک انبار را به فرم زیر داریم و قصد داریم از این داده های گسترده ، اطلاعات مورد نظر را خارج کنیم .

به طور مثال می خواهیم بدانیم از هر نام و نوع و اندازه کالا چه مقدار به انبار وارد و یا خارج شده است؟

پاسخ : ابتدا یک جدول محوری مطابق با روشی که قبلا شرح داده شده است طراحی می کنیم .

به ترتیب فیلدها توجه کنید

برای رسم نمودار کافی است برروی جدول محوری راست کلیک نمایید تا منوی زیر پدیدار شود آنگاه گزینه PIVOTCHART را انتخاب می کنیم .

لازم به ذکر است که با تغییر نمودار جدول نیز تغییر می کند .

به ترتیب قرار گرفتن عناصر نمودار دقت کنید ، درست شبیه جدول چیده شده اند .

نوشته شده در یکشنبه ششم فروردین 1385ساعت 14:53 توسط علی توضیح |
تمرین توابع آرایه ای

با توجه به جدول پایین :

تمرین ۱: میانگین دریافتی های رضا چقدر است؟

راهنمایی : ترکیب دو تابع IF, AVERAGE

تمرین 2: بیشترین مقداری که از بانک ملی به کارمندان پرداخت شده چه مبلغی است؟

راهنمایی : MAX , IF با شرط بانک ملی

تمرین ۳: علی از بانک ملی چقدر دریافتی داشته است ؟

راهنمایی : استفاده از دو تابع IF متداخل و ترکیب آن با SUM

در فرمول های فوق CTRL+SHIFT+ENTER فراموش نشود .

نوشته شده در شنبه پنجم فروردین 1385ساعت 8:28 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
توابع آرایه ای 2
تابع TRANSPOSE

=TRANSPOSE( محدوده)

این تابع داده های افقی را به حالت عمودی و برعکس کپی می کند .

مانند حالت قبل انتخاب مقصد را فراموش نکنید و سپس CTRL+SHIFT+ENTER

ترکیب توابع SUM , IF

ترکیب دو تابع فوق هنگامی صورت می گیرد که کاربر قصد محاسبه جمع مقادیر یک عنصر خاص را دارد.

مثال : جدول زیر جمع دریافتی های علی چقدر است ؟

ترکیب دو تابع SUM , IF

بعد از نوشتن فرمول باید CTRL+SHIFT+ENTER فشرد .

نوشته شده در شنبه بیست و هفتم اسفند 1384ساعت 12:3 توسط علی توضیح |
توابع آرایه ای ARRAY FUNCTIONS
این توابع محدوده ای را به عنوان جواب باز می گردانند یا محدوده ای را مقایسه می کنند .

برای جواب گرفتن این توابع باید از ترکیب کلید های

CTRL+SHIFT+ENTER

تابع FREQUENCY

شکل تابع

=FREQUENCY(کل آرایه ، محدوده مقایسه )

شرح تابع : این تابع کل آرایه را برای یافتن فراوانی اعداد موجود در محدوده مقایسه جستجو کرده فراوانی هر دسته را نمایش می دهد .

به مثال زیر توجه کنید:

در این مثال فراوانی هر دسته از اعداد را بدست آورید :

انتخاب خیلی مهم است !!!

فرمول در حالت انتخاب وارد می شود .

به آکولادهای انتهای فرمول توجه کنید

تمام ساختارهای آرایه ای دارای چنین علامتی هستند .

نوشته شده در پنجشنبه بیست و پنجم اسفند 1384ساعت 10:20 توسط علی توضیح |
توابع روند سازی
 |  |  | توابع روند سازی عبارتند از : |
نام تابع | NUM | پاسخ | فرمول | شرح تابع
ABS | -12 | 12 | =ABS(F2) | قدر مطلق ( عدد با علامت مثبت)
INT | 12.568 | 12 | =INT(B5) | جزء صحیح عدد (عدد بدون اعشار )
CEILING | 12.134 | 14 | =CEILING(F3;2) | گرد كردن به کوچکترین مضرب عدد داده شده که از NUM بزرگتر باشد.
FLOOR | 12.134 | 12 | =FLOOR(F4;2) | گرد كردن به بزرگترین مضرب عدد داده شده که از NUM کوچکتر باشد.
ODD | 7.01 | 9 | =ODD(F6) | به کوچکترین عدد فرد بزرگتر گرد می کند
EVEN | 7.01 | 8 | =EVEN(F7) | به کوچکترین عدد زوج بزرگتر گرد می کند
ROUND | 2.875 | 2.88 | =ROUND(F10;2) | گرد كردن با قاعده ( 5 )
ROUNDDOWN | 2.873 | 2.87 | =ROUNDDOWN(F11;2) | گرد كردن به پايين به تعداد داده شده( 2 )، بدون قاعده
ROUNDUP | 2.873 | 2.88 | =ROUNDUP(F12;2) | گرد كردن به بالا به تعداد داده شده( 2 )، بدون قاعده
TRUNC | 6578 | 6570 | =TRUNC(C15;-1) | از سمت راست جدا مي كند
TRUNC | 2.875 | 2 | =TRUNC(F14) | قسمت صحيح عدد
نوشته شده در دوشنبه بیست و دوم اسفند 1384ساعت 23:23 توسط علی توضیح |
تواابع جستجو LOOKUP & REFRENCE
توابع جستجو عبارتند از :

نام تابع | شکل تابع | شرح تابع
ROW | =ROW() | شماره ردیف سلول جاری
ROWS | =ROWS(محدوده) | تعداد ردیف های محدوده
COLUMN | =COLUMN() | شماره ستون سلول جاری
COLUMNS | =COLUMNS(محدوده) | تعداد ستون های محدوده
CHOOSE | =CHOOSE(شاخص 29;….;شاخص 2;شاخص1;شماره شاخص ) | یکی از شماره های بین 1 تا 29 را گرفته سپس آن شاخص را نمایش می دهد .
ADDRESS | =ADDRESS(شماره ستون;شماره سطر) | شماره سطر و ستون را گرفته آدرس سلول را نمایش می دهد .
INDEX | =INDEX(شماره ردیف;محدوده ) | در یک ردیف از داده ها ، شماره ردیف را دریافت کرده داده مورد نظر را نمایش می دهد.
MATCH | =MATCH(روش جستجو;محدوده;مقدار جستجو) | در یک ردیف از داده ها ، داده مورد نظر را گرفته شماره ردیف آنرا نمایش می دهد.
VLOOKUP | =VLOOKUP(شماره ستون جستجو;آدرس کامل جدول ;مقدار جستجو) | در یک جدول ، داده های ستون اول را بصورت عمودی جستجو کرده و سپس در ستون جستجو داده متناظر آنرا باز می گرداند.
HLOOKUP | =HLOOKUP(شماره ستون جستجو;آدرس کامل جدول ;مقدار جستجو) | در یک جدول ، داده های سطر اول را بصورت افقی جستجو کرده و سپس در سطر جستجو داده متناظر آنرا باز می گرداند.
LOOKUP | =LOOKUP(محدوده;مقدار جستجو) | در یک جدول ، داده های ستون اول را برای داده مورد نظرجستجو کرده و سپس داده متناظر را در آخرین ستون نمایش می دهد.

نوشته شده در یکشنبه بیست و یکم اسفند 1384ساعت 15:59 توسط علی توضیح |
توابع پایگاه داده 2
مثال در جدول زیر میانگین دریافتی های علی از بانک ملی چقدر است ؟

میانگین دریافتی های علی از بانک ملی

نوشته شده در یکشنبه بیست و یکم اسفند 1384ساعت 15:37 توسط علی توضیح |
توابع پایگاه داده
(DFUNCTIONS ( DATABASE FUNCTIONS

این توابع عملیات گزارش گیری بر اساس شرط های مختلف و ترکیبی را به راحتی انجام می دهند .

شکل این توابع به صورت زیر است :

=DFUNCTION( شرط ، شماره فیلد محاسباتی ، آدرس جدول )

DSUM , DAVERAGE, DCOUNT , DVAR , DMIN, DMAX, .....

مثال : جمع دریافتی های علی چقدر است ؟

  1. آدرس جدول : کلیه محدوده جدول حتی سر ستون ها A2:C8
  2. شماره فیلد محاسباتی : فیلدی از جدول که قرار است عملیات جمع بر روی آن انجام شود. 3
  3. شرط : محدوده ای که سر ستون و مورد شرط در آن قرار دارند. F3:F4

نوشته شده در یکشنبه بیست و یکم اسفند 1384ساعت 8:20 توسط علی توضیح |
استفاده از توابع SUMIF , COUNTIF
تابع SUMIF

شکل تابع

= SUMIF(محدوده جمع , شرط , محدوده شرط )

این تابع در محدوده شرط به دنبال شرط گشته و سپس سلول های متناظر آنرا در محدوده جمع با هم جمع می کند .

مثال :جمع دریافتی های علی چقدر است ؟

سلول های متناظر علی در قسمت دریافتی

تابع COUNTIF

اما تابع COUNTIF تعداد سلول های شرط را شمارش می کند .

=COUNTIF( شرط , محدوده شرط)

مثال : در جدول فوق تعداد دریافتی های علی چقدر است ؟

نوشته شده در شنبه بیستم اسفند 1384ساعت 14:55 توسط علی توضیح |
تمرین ساخت جداول محوری ویژه کلاس
تمرین های جداول محوری دانلود کنید :

تمرین

تمرین ۲ ( فروشگاههای زنجیره ای )

جداول ونمودار های محوری PIVOT TABLE AND PIVOT CHART

این ابزار برای گزارش گیری با محوریت یکی از فیلدها ، استفاده می شود ، شاید به همین خاطر با نام جداول محوری شناخته شده اند . نحوه ساخت جداول به این شرح است :

فرض کنید در جدول زیر می خواهید ، مجموع فروش هر فروشگاه در هر شهررا بدست آورید :

مراحل زیر را به ترتیب طی می کنیم :

دانلود کنید

نوشته شده در پنجشنبه هجدهم اسفند 1384ساعت 12:19 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
ماکرو ها 2
حال اگر بخواهیم این عملیات را در سایر شرایط نیز اجرا کنیم باید ماکرو را در حالت نسبی قرار دهیم .

به طور مثال اگر ۵ عدد دیگر در جای دیگر از کاربرگ قرار داشته باشند و کاربر بخواهد با همان ماکرویی که در ابتدا ایجاد کرده جمع آنها را نیز به دست آورد باید کلید relative refrence را قبل از انجام هر کاری در ذخیره ماکرو بفشارد .

این کلید باعث می گردد تا ماکرو در تمام محیط اکسل با شرایط داده شده ( ۵ سلول ) عمل کند . سپس بقیه عملیات ماکرو انجام تا ذخیره گردد .

به طور مثال قصد داریم تا جدول زیر را با استفاده از چهار کلید کامل کنیم .

نوشته شده در چهارشنبه بیست و یکم تیر 1385ساعت 17:21 توسط علی توضیح |
ماکروها در اکسل
برای انجام عملیات تکراری در اکسل از ماکروها استفاده می کنیم .

فرض کنید می خواهیم جمع این ۵ عدد را با استفاده از ماکرو ها محاسبه کنیم :

ابتدا از منوی tools ابزار macro و سپس record macro را فعال می کنیم نام ماکرو را وارد کرده و عملیات مورد نظر را انجام می دهیم .

به طور مثال جمع این ۵ سلول را محاسبه می کنیم .

فرمول نویسی و انجام عملیات

برای توقف ذخیره ماکرو کلید stop recording را می فشاریم.

نوشته شده در چهارشنبه چهاردهم تیر 1385ساعت 13:22 توسط علی توضیح |
لینک دانلود ها درست شد
نوشته شده در چهارشنبه چهاردهم تیر 1385ساعت 13:0 توسط علی توضیح |
تمرین نمودار های پیشرفته
تمرین :نمودارهای زیر را ایجاد کنید :

دانلود تمرین

نوشته شده در چهارشنبه هفتم تیر 1385ساعت 11:28 توسط علی توضیح |
تمرین ساخت صورت وضعیت مالی و کاری با اکسل

نوعی از صورت وضعیت که توسط اکسل طراحی شده است .

دانلود کنید .

نوشته شده در یکشنبه چهارم تیر 1385ساعت 11:43 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
فیلتر سازی پیشرفته
برای فیلتر سازی یک جدول با استفاده از advance filter یا فیلتر سازی پیشرفته ابتدا عنوان ستونی را می خواهیم شرط شامل آن باشد ، در سلولی دیگر به همراه خود شرط طراحی می کنیم ( i3 : i4 ) آنگاه یک سلول از جدول را انتخاب کرده و از مسیر زیر حرکت می کنیم :

DATA | FILTER | ADVANCE FILTER

تمرین زیر افرادی را فیلتر می کند که حقوق مبنای آنها کمتر از 1000 است .

برای بازگشت از حالت فیلتر ، کافی است از مسیر فوق ، گزینه SHOW ALL را انتخاب کنیم .

نوشته شده در شنبه یازدهم فروردین 1386ساعت 11:49 توسط علی توضیح |
ارتباط بین اشیا و اشکال با محتویات سلول ها در اکسل
اگر بخواهیم متن یک سلول به درون یک شی انتقال یابد کافی است

  1. شکل مورد نظر را انتخاب کرده
  2. آنگاه در نوار فرمول علامت مساوی را تایپ کرده
  3. آدرس سلول مورد نظر را تایپ می کنیم :

a1=

نوشته شده در چهارشنبه هشتم فروردین 1386ساعت 9:20 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
پرسش
با سلام لطفا درباره تبدیل درجه ها بیشتر توضیح دهید .

نوشته شده در سه شنبه بیست و دوم اسفند 1385ساعت 12:10 توسط علی توضیح |
ارتباط بین ورد و اکسل EXCEL AND WORD
برای ارتباط بین اکسل و ورد برای ایجاد کارنامه و یا فیش حقوقی افرادی که نام و اطلاعات آنها در اکسل تایپ شده است مراحل زیر را طی می کنیم .

ابتدا جدولی را که در کاربرگ اکسل داریم ، تمام سطرهای اضافی بالای آن را حذف می کنیم به طوری که عناوین جدول در سطر اول قرار گیرد . آنگاه به نرم افزار ورد رفته و سپس طراحی کارنامه را شروع می کنیم . قابی را که می خواهیم داده های اکسل در آن قرار گیرد طراحی می شود و جای داده ها خالی گذاشته می شود .

حال به سراغ منوی TOOLS از ورد رفته و گزینه ی LETTER AND MAILING را انتخاب کرده و سپس گزینه ی MAIL MERGE را انتخاب می کنیم.

نوشته شده در سه شنبه بیست و دوم اسفند 1385ساعت 10:26 توسط علی توضیح |
استفاده از ابزار find , replace
هرگاه کاربر بخواهد درون سلول های کاربرگ واژه یا عددی را پیدا یا جایگزین نماید از آن استفاده می کند

به مثال زیر توجه کنید :

فرض کنید می خواهیم درون جدول زیر بجای واژه شیراز از واژه ی شهرراز استفاده کنیم:

کاربران قادرند درون کاربرگ یا درون کارپوشه ( book ) جستجو انجام دهند . within

;کاربران قادرند سطری یا ستونی جستجو انجام دهند : search

کاربران قادرند درون فرمول ها و توابع و محتویات سلول ها را نیز جستجو و تغییر دهند . lookin

گزینه match case حساسیت نسبت به حروف بزرگ و کوچک لاتین و گزینه match entire cell contents برای جستجو عین کلمه مورد نظر است .

توجه داشته باشید که کلید replace all برای جایگزینی تما موارد بدون پرسش است .

این ابزار قادر است جستجوی قالب بندی مورد نیاز را نیز انجام دهد .مثلا بخواهیم سلول هایی را بیابیم که متن آنها قرمز رنگ باشد از کلید format استفاده می کنیم . به مثال زیر توجه کنید ، سلول های قرمز رنگ را یافته و آدرس آنها را در زیر نمایش داده است .

نوشته شده در دوشنبه هفتم اسفند 1385ساعت 10:39 توسط علی توضیح |
معرفی تابع mmult ماتریسی

این تابع ويژه ضرب ماتریس هاست . هرگاه بخواهیم دو ماتریس هم مرتبه را در هم ضرب کنیم ، ماتریس اول را بجای آرایه ی اول array1 و ماتریس دوم را بجای آرایه ی دوم array2 می گذاریم .

MMULT

Returns the matrix product of two arrays. The result is an array with the same number of rows as array1 and the same number of columns as array2.

Syntax

MMULT(array1,array2)

Array1, array2 are the arrays you want to multiply.

Remarks

  • The number of columns in array1 must be the same as the number of rows in array2, and both arrays must contain only numbers.

  • Array1 and array2 can be given as cell ranges, array constants, or references.
  • MMULT returns the #VALUE! error when:
    • Any cells are empty or contain text.
    • The number of columns in array1 is different from the number of rows in array2.
    • The size of the resulting array is equal to or greater than a total of 5,461 cells.
  • The matrix product array a of two arrays b and c is:

    where i is the row number, and j is the column number.

  • Formulas that return arrays must be entered as array formulas.

Example 1

The example may be easier to understand if you copy it to a blank worksheet.

Create a blank workbook or worksheet.

  1. Select the example in the Help topic.

    Note Do not select the row or column headers.

    Selecting an example from Help

  2. Press CTRL+C.
  3. In the worksheet, select cell A1, and press CTRL+V.
  4. To switch between viewing the results and viewing the formulas that return the results, press CTRL+` (grave accent), or on the Tools menu, point to Formula Auditing, and then click Formula Auditing Mode.
1
2
3
4
5
6
A | B
Array 1 | Array 1
1 | 3
7 | 2
Array 2 | Array 2
2 | 0
0 | 2
Formula | Formula
=MMULT(A2:B3,A5:B6) |

Note The formula in the example must be entered as an array formula. After copying the example to a blank worksheet, select the range A8:B9 starting with the formula cell. Press F2, and then press CTRL+SHIFT+ENTER. If the formula is not entered as an array formula, the single result is 2.

Example 2

The example may be easier to understand if you copy it to a blank worksheet.

  1. Create a blank workbook or worksheet.
  2. Select the example in the Help topic.

    Note Do not select the row or column headers.

    Selecting an example from Help

  3. Press CTRL+C.
  4. In the worksheet, select cell A1, and press CTRL+V.
  5. To switch between viewing the results and viewing the formulas that return the results, press CTRL+` (grave accent), or on the Tools menu, point to Formula Auditing, and then click Formula Auditing Mode.
1
2
3
4
5
6
A | B
Array 1 | Array 1
3 | 0
2 | 0
Array 2 | Array 2
2 | 0
0 | 2
Formula | Formula
=MMULT(A2:B3,A5:B6) |

Note The formula in the example must be entered as an array formula. After copying the example to a blank worksheet, select the range A8:B9 starting with the formula cell. Press F2, and then press CTRL+SHIFT+ENTER. If the formula is not entered as an array formula, the single result is 6.

نوشته شده در دوشنبه هفتم اسفند 1385ساعت 7:48 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
وبلاگ معادل
یک وبلاگ شبیه وبلاگ بنده وجود دارد .شاید برخی از صفحات در آن فعال شود :

www.excelxp.mihanblog.com

اگر وبلاگ فعال نشد ، از وبلاگ بالا استفاده کنید .

نوشته شده در یکشنبه بیست و نهم بهمن 1385ساعت 13:11 توسط علی توضیح |
حل یک دستگاه دو معادله دو مجهول با استفاده از اکسل
دوستان عزیز پس از یک غیبت طولانی ، حل یک دستگاه دو معادله دو مجهول را با استفاده از توابع ماتریسی ، بررسی می کنیم :

اگر ۲X+۳Y=3 , 5X-Y=8 باشد X و Y را بیابید :

ماتریس ضرایب A و ماتریس متغیرها X و ماتریس جواب B .

با استفاده از تابع MINVERSE معکوس ماتریس را میابیم :

MINVERSE

Returns the inverse matrix for the matrix stored in an array.

Syntax

MINVERSE(array)

Array is a numeric array with an equal number of rows and columns.

Remarks

  • Array can be given as a cell range, such as A1:C3; as an array constant, such as {1,2,3;4,5,6;7,8,9}; or as a name for either of these.

  • If any cells in array are empty or contain text, MINVERSE returns the #VALUE! error value.

  • MINVERSE also returns the #VALUE! error value if array does not have an equal number of rows and columns.

  • Formulas that return arrays must be entered as array formulas.
  • Inverse matrices, like determinants, are generally used for solving systems of mathematical equations involving several variables. The product of a matrix and its inverse is the identity matrix— the square array in which the diagonal values equal 1, and all other values equal 0.
  • As an example of how a two-row, two-column matrix is calculated, suppose that the range A1:B2 contains the letters a, b, c, and d that represent any four numbers. The following table shows the inverse of the matrix A1:B2.
    Column A | Column B
    Row 1 | d/(a*d-b*c) | b/(b*c-a*d)
    Row 2 | c/(b*c-a*d) | a/(a*d-b*c)
  • MINVERSE is calculated with an accuracy of approximately 16 digits, which may lead to a small numeric error when the cancellation is not complete.
  • Some square matrices cannot be inverted and will return the #NUM! error value with MINVERSE. The determinant for a noninvertable matrix is 0.

حال برای محاسبه نهایی باید معکوس ماتریس را در ماتریس جواب ضرب کنیم ، تابع حاصل ضرب ماتریس MMULT است .

توجه داشته باشید هر دوی این توابع آرایه ای هستند و باید CTRL +SHIFT+ENTER را بجای ENTER استفاده کرد .

طریقه استفاده از تابع minverse :

نوشته شده در یکشنبه بیست و نهم بهمن 1385ساعت 8:12 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
تمرین 2- فرم سازی
تمرین1 : فرض کنید اسامی تعدادی کارمند را در یک کاربرگ ،به همراه مشخصات فردی آنها ذخیره کرده ایم . حال قصد داریم با استفاده از یک کمبوباکس و ابزار های فرم سازی در اکسل ، فرمی را طراحی کنیم که با انتخاب نام یک کارمند ، مشخصات فردی وی پدیدار گردد و سپس قادر باشید تمام محاسبات را بر روی داده ها انجام دهیم .

دانلود تمرین

تمرین 2: فرم ساده ای را ایجاد کنید که بتوان با آن در یک رستوران، یک نوع غذا همراه با چند نوع دسر و نوشیدنی سفارش داده و سپس درصد سرویس و تخفیف را محاسبه کرده و سپس مبلغ کل فاکتور ثبت شود .

توجه کنید که با انتخاب نوع غذا ،قیمت واحد با استفاده از تابع index نمایش داده شده و پس از انتخاب تعداد ، جمع هر غذا نمایش داده شود .

دانلود تمرین رستوران

نوشته شده در سه شنبه بیست و یکم شهریور 1385ساعت 11:57 توسط علی توضیح |
پاسخ به یک پرسش: تبدیل گراد و رادیان و درجه به یکدیگر
توابع مثلثاتی در اکسل زاوایا را به صورت پیش فرض بر اساس رادیان محاسبه می کنند .

به طور مثال :

=sin( 90 )

سینوس 90 رادیان را محاسبه و نمایش می دهد . برای گریز از این مشکل توابعی مثل radians , degrees شما را یاری می دهد .

radians درجه را به رادیان و degrees رادیان را به درجه تبدیل می کنند .

به طور مثال سینوس زاویه 90 درجه را به شکل زیر نمایش می دهند :

=sin(radians(90))

اما برای گراد تابع مستقلی نداریم و برای تبدیل آنها کافی است از فرمول تبدیل استفاده کنیم

d/180=g/200=r/pi

یعنی برای محاسبه سینوس ۱۰۰ رادیان به روش زیر عمل می کنیم

1=sin(radians(100*180/200))

برخی دیگر از توابع مثلثاتی عبارتند از :

cos , tan , asin , acos , sinh , cosh, tanh, pi , ...

مثال: ارک سینوس زیر برای تبدیل بر اساس درجه طراحی شده است .

=ASIN(-0.5)*180/PI()

نوشته شده در سه شنبه چهاردهم شهریور 1385ساعت 9:35 توسط علی توضیح |
پاسخ به یک پرسش : در جدول زیر اسامی دانش آموزان برتر در هر درس چگونه نمایش داده می شود ؟
منظور از دانش آموز برتر ، بالاترین نمره در هر درس است . دو روش برای اینکار ارائه می شود :

۱- تابع dget یکی از توابع پایگاه اطلاعاتی اکسل است که به همراه تابع max قادر است این مشکل را برطرف نماید.

=DGET( database , field , criteria )

این تابع در فیلد مورد نظر از پایگاه ( آدرس جدول ) داده شده ، آدرس محدوه شرط را دریافت کرده، داده مورد نظر را نمایش می دهد .

۲- ترکیب توابع index , match , max

dget , match , index

نوشته شده در دوشنبه سیزدهم شهریور 1385ساعت 11:3 توسط علی توضیح |
اموزش و راهنمای استفاده از برخی توابع آماری در تحلیل داده های علوم تربیتی و کلاس و مدرسه
یک مثال ساده برای استفاده از اکسل در طراحی و تجزیه و تحلیل نمرات دانش آموزان و دروس آنها با استفاده از این توابع مدیران آموزشی ، حتی مدرسین گرامی قادرند کلاس و یا مدرسه را ارزیابی آموزشی کنند .

مثال : فرض کنید نمرات تعدادی دانش آموز در یک کلاس را در اکسل به فرم زیر وارد می کنیم . حال قصد بررسی و تجزیه و تحلیل نمرات هر دانش آموز( سطری) و هر درس ( ستون) را در جدول طراحی شده داریم .میخواهیم بدانیم جایگاه هر دانش آموز و کیفیت آموزش هر درس کجاست ؟

توابعی که در مثال فوق استفاده شده اند عبارتند از :

جمع | SUM
مد | MODE
میانه کلاس | MEDIAN
میانگین کلاس | AVERAGE
کمترین نمره | MIN
بیشترین نمره | MAX
دامنه تغییرات | MAX-MIN
چارک اول | QUQRTILE 1
چارک سوم | QUQRTILE 3
انحراف چارکی | (Q3-Q1)/2
واریانس کلاس | VAR
انحراف از معیار | STDEV
کشیدگی یا کجی | SKEW
نقطه اوج توزیع | KURT

نوشته شده در پنجشنبه نهم شهریور 1385ساعت 8:30 توسط علی توضیح |
روش ساخت جدول محوری pivot table - ابزاری مناسب برای گزارش گیری و تحلیل داده
جدول محوری چیست؟ هرگاه لیستی از داد ه های تکرار شده داشته باشیم و بخواهیم از این داد ه ها گزارش گرفته و اطلاعات خارج کنیم ، از این ابزار استفاده می کنیم . اطلاعات حول محور یکی از فیلد های لیست ارائه می شود .

به طور مثال ، فرض کنید لیست تعدادی فروشگاه که لوازم التحریر می فروشند ، همراه نوع کالا ، تعداد و مبلغ فروش هر کالا و اسامی شهرهای هر فروشگاه موجود است . در این لیست هرگاه فروشگاهی کالایی را فروخته باشد مثل یک دفتر روزنامه ثبت شده است .

مساله : می خواهیم بدانیم هر فروشگاه از هر کالا چقدر فروخته است ؟

یعنی محوریت جدول با اسامی فروشگاه هاست .

روش ساخت جدول محوری

برای ایجاد یک گزارش یا جدول محوری از یک لیست ، کافی است مراحل زیر را به ترتیب انجام دهیم :

  1. انتخاب یکی از سلول های لیست
  2. data | pivottable and pivotchart report
  3. next
  4. next
  5. layout
  6. انتخاب ساختار جدول
  7. انتخاب قالب جدول
  8. finish

مراحل تصویری:

انتخاب یک سلول از لیست و سپس منوی DATA ....

این گزینه ها برای انتخاب جدول یا ترسیم نمودار آن و یا انتخاب نوع لیست داده هاست . منظور از نوع لیست ، لیست داده های درون یا بیرون از اکسل و یا ترکیبی از لیست های متفاوت از داده های یکسان ( مثلا دریافتی و پرداختی افراد در دو شیت متفاوت باشد ) و یا ترکیب دو جدول محوری

انتخاب محدوده لیست ( بهتر است بیشتر انتخاب کنید )

جدول محوری در همان کاربرگ یا یک کاربرگ جدید و کلید LAYOUT

هر فیلدی به جای مورد نظر کشیده می شود . ( ROW به صورت ردیفی COLUMN به صورت ستونی و DATA داده های محاسباتی و بخش PAGE به عنوان محور تمام جدول )

فیلد های کالا ، فروشگاه و جمع کل همگی زیر مجموعه فیلد شهر می باشند . با دبل کلیک برروی جمع کل میتوانید توابع دیگری غیر از SUM را انتخاب کنید .

جدول به صورت فوق نمایش داده می شود . مبلغ فروش هر کالا در هر فروشگاه و در تمام شهر ها نمایش داده شده است . ( PAGE = ALL )

انتخاب یک قالب زیبا برای جدول محوری

جدول آماده استخراج اطلاعات و اتخاذ تصمیم نهایی است . سطر و ستون آخر جمع نهایی است .

مثال ها در بخش تمرین آماده دانلود است .

نوشته شده در دوشنبه ششم شهریور 1385ساعت 11:55 توسط علی توضیح |
تابع LOOKUP
این تابع دارای دو حالت برداری و آرایه ای است .

VECTOR-1 برداری : ماتریسی، یک سطری یک ستونی

2- ARRAY آرایه ای : چند سطری و یا چند ستونی

در حالت اول این تابع مقدار جستجو را در اولین ستون دریافت کرده و سپس مقدار متناظر آنرا در ستون انتخاب شده ،به کاربر نمایش می دهد . بردار جستجو باید مرتب باشد ( sort)

=LOOKUP( بردار داده متناظر، بردار داده جستجو ، مقدار جستجو )

مثال : در جدول زیر دریافتی علی چقدر است ؟

اما در حالت دوم ، تابع مقدار جستجو را در یک جدول و آنهم ستون اول ، جستجو کرده و سپس در ستون آخر داده متناظر را باز می گرداند .

=lookup( آرایه جستجو ، مقدار جستجو )

مثال : کد علی چقدر است ؟

نوشته شده در یکشنبه پنجم شهریور 1385ساعت 13:25 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
برخی لینکها درست شد
از همه دوستانی که موفق نشدند تمرین ها را دانلود کنند عذر خواهی می کنم . برخی از آنها تغییر کردند و فعلا جواب می دهند .
نوشته شده در یکشنبه چهارم شهریور 1386ساعت 13:39 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
قالب بندی های عددی

قالب بندی ويژه اعداد

1-Currency (مالي) $ : اين قالب بندي ويژه فرمتهاي مالي مي باشد ويك نوع پول دلخواه را به نمايش مي گذارد .( براي تغيير واحد مالي برروي سلول مورد نظر راست كليك كرده گزينه Format cellsرا انتخاب كرده و سپس از زير مجموعه Number گزينه Currencyو از كادر Symbol واحد پول مورد نظر را انتخاب ميكنيم ) .

2- Percen t % : اين كليد براي تبديل اعداد به قالب درصدی مي باشد .

مثال : 0.3 % 30%

0.03 % 3%

3- و (کاما) : كليد كاما سه رقم ، سه رقم از سمت راست عدد ، ارقام را جدا مي كند .

4- Increase Decimal و Decrease Decimal: افزايش اعشار وكاهش اعشار در ارقام سلول .

نوشته شده در یکشنبه بیست و هفتم آذر 1384ساعت 13:22 توسط علی توضیح |
قالب بندی عمومی داده ها

-قالبندي ظاهر داده ها

براي تغيير ظاهري دادههااز نوار ابزار Formattingاستفاده ميشود .دو نوع قالبندي براي داد‏ه ها موجود است قالب بندي نوع اول , قالب بندي عمومي است كه ويژه تمامي داده هاست ( متن و اعداد ) وقالبندي نوع دوم مخصوص اعداد است .

1-قالب بندي عمومي

ابزار های :

Font: قادر است نوع خط داده را تغييردهد.

Font Size: اندازه خط را تغيير ميدهد.

Bold: تيره كردن رنگ نوشته ها

Italic: كج كردن نوشته ها

Underline : کلمه زيرخط دار نمايش داده می شود .

كليدهاي صف بندي (Align) : اين مجموعه شامل كليدهاي چپ چين , وسط چين و راست چين می باشد .

Merge and Center : اين كليد سلولهاي انتخاب شده را به هم پيوسته ومتن نوشته شده را درست در ميانه آن نمايش ميدهد براي تغيير مكان متن در سلول كافي است برروي اين سلول راست كليك كرده گزينه Alignment |Format Cells دو گزينه Horو Ver را برابر با Center قرار می دهيم .

Decrease Indentو Increase Indent: اين كليد ها جهت افزايش وكاهش فاصله متن با ديواره سلول استفاده ميشود .

Border: اين كليد جهت ترسيم جدول و كادر در سلولها استفاده ميشود وشامل زير مجموعه Draw Borderاست. اين نوار ابزار , زير مجموعه‏اي از كليد های ترسيم کادر ميباشد و قسمتهاي مختلف آن عبارتند از :

1- ترسيم Border يا Grid

2- پاكن : کادرها را پاک می کند.

3- نوع خط ( Line Style) .

4- رنگ خط را مشخص ميكند ( Line Color) .

Fill color: رنگ زير زمينه را مشخص مي كند.

Font color: رنگ متن را تغيير مي دهد.

نوشته شده در یکشنبه بیست و هفتم آذر 1384ساعت 13:14 توسط علی توضیح |
داده ها و قالب بندی آنها

از برخورد هرسطر با هر ستون يك سلول ( Cell) ايجاد ميشود . به مجموعه اين سلول ها ، كاربرگ Sheet ) ) گفته ميشود.هر فايل Excel در ابتدا معمولا با سه كاربرگ فعال ميشود .

براي افزايش تعداد كاربرگها به دو روش مي توان اقدام نمود :

روش اول : برروي نام كاربرگ راست كليك كرده گزينه Insert وسپس Ok را مي فشاريم .

روش دوم : از Menu Insert گزينه Worksheetرا كليك مي كنيم در هر دو حالت يك كاربرگ به سيستم اضافه ميشود .

براي تغييرنام كاربرگ كافي است برروي آن راست كليك كرده گزينه Rename را انتخاب کنيم . سپس نام جديد را می نويسيم وكليد Enterرا فشار ميدهيم .

استفاد ه از راهنمای اکسل : براي استفاد ه از راهنمای ( HELP) گروه Officeكافي است از كليد F1براي نمايش مجموعه راهنما استفاده كنيم . اين مجموعه داراي سه قسمت اساسي است :

1- Contents ۲- Answer Wizard-۳ Index

در قسمت اول كاربر نيازي به تايپ نداشته ومحتواي راهنما به صورت دسته بندي شده نمايش ميشود .

در قسمت دوم كاربر سئوال مورد نظر خود را تايپ ميكند و راهنما پاسخ را ارائه می نماید .

در قسمت سوم با استفاد ه از كلمات كليدي كاربر قادر است به راهنما مورد نظر خود دسترسي پيدا مي‏كند .

۲-انواع داده در Excel

در اكسل كاربر قادر است درهرسلول 4 نوع داده را وارد نمايد :

1- متن : اكسل نسبت به متن حساسيت نشان نميدهد وآنها را درسمت چپ سلول نمايش ميدهد .محدوديت خاصي براي تايپ متن در سلولهاي اكسل وجود ندارد براي تايپ دوسطر در يك سلول اكسل از تركيب كليد Alt + Enter استفاده ميكنيم .

2- اعداد : در اكسل اعداد قابليت فراواني دارند و كاربر قادر است به هر نحوي از آنها استفاده كند .

براي تبديل اعداد اعشاري به اعداد كسري برروي سلولي كه عدد اعشاري در آن قراردارد راست كليك كرده گزينه Format Cells | Number | Fraction با توجه به مخرج دلخواه ، كسر مورد نظر را انتخاب مي كنيم .

3- تاريخ وزمان : اكسل نسبت به تاريخ و زمان حساسيت نشان داده وآنها را به سمت راست سلول مي كشاند . براي تغير قالبندي هاي تاريخ وزمان كافي است برروي سلول مورد نظر راست كليك كرده گزينه Format Cells و سپس از قسمت Number گزينه Dateيا Timeرا انتخاب نموده وتغيرات لازم را ايجاد نمود . براي نمايش تاريخ و زمان جاري در سلول از تركيب كليد Ctrl + ;و Cttl + shift + ;استفاده مي شود .

4- توضيحات يا Comment : هرگاه كاربر بخواهد شرحي براي سلول جاري بنويسد از توضيحات يا Comment استفاده می کند . براي ايجاد يك توضيح در سلول ابتدا برروي سلول راست كليك كرده , گزينه Insert Comment را انتخاب ميكنيم , پنجره‏اي باز وآماده نوشتن متن يادداشت می باشد پس از نوشتن متن , در سلولی ديگر کلِيک می کنيم , مثلث قرمز رنگی پديدار می گردد و هر گاه به اين مثلث نزديك شويم , توضيح مورد نظر نمايان می شود . براي ويرايش توضيح مورد نظر برروي همان سلول راست كليك كرده گزينه Edit Comment را كليك مي كنيم . براي حذف يك توضيح برروي آن راست كليك كرده گزينه Comment Deleteرا انتخاب ميكنيم و براي نمايش دائمي يك توضيح برروي آن سلول راست كليك کرده گزينه Comment Show را انتخاب ميكنيم .

نوشته شده در یکشنبه بیست و هفتم آذر 1384ساعت 13:5 توسط علی توضیح |
محیط اکسل

1 - شناخت اکسل

اين نرم ‏افزاربخشي از مجموعه نرم افزارآفيس مي باشد. نرم افزار هاي اين مجموعه عبارتند از :

Word, Excel, FrontPage, Access, Outlook, Publisher, PowerPoint

كه هر كدام وظايف خاصي را بر عهده دارند .

Excel : به معناي عالي , نرم افزاری قدرتمند براي محاسبه, مديريت و تحليل داده ها مي باشد .

ازجمله توانايي هاي منحصر به فرد اين نرم افزار راحتي كار با آنست كه استفاده از آن به عنوان يك نرم افزار پايگاه مديريت داده ها را بسيار لذت بخش مي نمايد . انجام عمليات حسابداري و مالي ، مهندسي ، آمار و حتي كنترل پروژه با آن امكان پذير است.استفاده از سلول هاي مجزا ، امكانات فيلترگذاري و مرتب سازي داده ها ، فرمول نويسي و ترسيم نمودار هاي متنوع و گويا و همچنين توابع بسيار قدرتمند آماري و محاسباتي از جمله امكانات اين نرم افزار است . اين نرم افزار داراي ويرايش هاي متفاوتي است که 97 , 2000 و XP از آن جمله می باشند .

محيط اكسل:

محيط Excel : نرم افزار Excel مانند هر نرم افزارديگر تحت ويندوز ، با يك پنجره بازمي شود که اجزاي مختلف اين پنجره عبارتند از :

1-نوار عنوان : نام فايل وعبارت : " Microsoft Excel " به چشم مي خورد .

2- نوار منو : (File ,Edit,……………) در نوار Menuتمام قابليت هاي Excelنهفته است .

3-نوار ابزار : شامل نمادهايي است كه كاربر نسبت به وجود آنها احساس نياز بيشتري مي كند .

4-جعبه نام : (Name box ) در اين قسمت آدرس سلول فعال به نمايش در مي ‏آيد. از اين قسمت ميتوان به سلول مورد نظر نيزحركت كرد .

5-نوار فرمول : نوار باريكي است كه مقابل جعبه نام قرار گرفته وهر متني كه در سلول فعال نوشته شود در اين قسمت نمايش داده مي‏‏ شود .

6-پنجره Excel: در اين قسمت 256 ستون و 65536 سطر وجود دارد. ستون ها با حروف لاتين (A,……..Z,AA…………IV ) وسطرها با اعداد شماره گذاري شده‏اند.

از برخورد هرسطر با هر ستون يك سلول ( Cell) ايجاد ميشود . به اين مجموعه كاربرگ Sheet ) ) گفته ميشود.هر فايل Excel در ابتدا معمولا با سه كاربرگ فعال ميشود .

نوشته شده در پنجشنبه بیست و چهارم آذر 1384ساعت 12:38 توسط علی توضیح |
آشنایی با اکسل ( مقدماتی تا پیشرفته )

راهنماي مقدماتي استفاده از نرم افزار صفحه گسترده

EXCEL

علي توضيح

مقدمه

شايد كمتر كسي فكر مي كرد كه روزي اطلاعات اينقدر مهم و حياتي باشد که كسب و مديريت آن يكي از نشانه هاي قدرت در هر جامعه محسوب گردد . جهان اطراف ما ، مالامال داده هاي خام و بي معني است كه با ايجاد ارتباط بين آنها ، اطلاعات مورد نياز حاصل مي گردد ، روش هاي حصول و استفاده از اين اطلاعات را تكنولوژي اطلاعات يا فناوري اطلاعات ( IT ) مي ناميم. جهت دهي به اين اطلاعات ، موجبات ايجاد علم ، را فراهم مي كند . اما مخزن علم بودن نيز به تنهايي كمال را به ارمغان نمي آورد ، چه بسيار پزشكان متخصص قلب كه هنگام نوشتن مقاله مضرات دخانيات ، سيگار خود را با ولع دود مي كنند . اين افراد كساني هستند كه عليرغم داشتن علم به آن عمل نمي كنند و در اصطلاح خردمند نيستند .

يكي از سريعترين روش هاي كسب اطلاعات در عصر جديد استفاده از رايانه و ابزارهاي مرتبط با آنست .شايد به جرات مي توان گفت كه نرم افزار اكسل كه يكي از اجزاي مجموعه نرم افزارهاي آفيس مي باشد ، بهترين ابزار جهت نگهداري ، مديريت و تحليل داده ها در سطوح متوسط است . راحتي كار با اكسل ، آنرا به يك وسيله همگاني در بخش مديريت دادهها تبديل نموده است .

مجموعه حاضر كه مروري است كوتاه به محيط و امكانات اين نرم افزار صفحه گسترده قدرتمند، چكيده منابع معتبري چون راهنماي جامع اكسل 2000 ترجمه آقاي محمد حسن مهدوي و كتاب راهنمای جامع EXCEL XP ترجمه آقاي امير حسين رضوي است .

بخش اول

آشنايي با محيط و توانايي هاي

EXCEL

نوشته شده در پنجشنبه بیست و چهارم آذر 1384ساعت 12:27 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
ماکرو نویسی استفاده از زبان وی بی ای VBA

بنام خدا

ماکرو نویسی در اکسل VBA

برای انجام عملیات تکراری و جستجو ی داده های مورد نظر می توان از ابزار قدرتمند ماکروها در اکسل استفاده کرد. ورود به ساختار برنامه نویسی ویژال بیسیک در اکسل که با عنوان VBA یا VISUAL BASIC FOR APPLICATION در اکسل و یا آفیس از آن یاد می گردد ، از مسیر زیر انجام می گیرد :

TOOLS | MACRO | VISAUL BASIC EDITOR

در حقیقت ماکرو ها، همان کدهایی هستد که توسط کاربر یا ماشین تولید می شوند. اگر شما یک ماکرو را با استفاده از ابزار ماکرو سازی طراحی و اجرا کنید آنرا توسط ماشین ساخته اید ولی اگر بخواهید انعطاف بیشتری به آن بدهید باید آنرا بنویسید( کد نویسی ). زبان وب بی ای در حقیقت معماری درونی اکسل و ابزاری قدرتمند برای نوشتن برنامه های پیشرفته و حلقوی است . این زبان که یک زبان شئ گراست ، اجزای درونی خود را به شکل اشیائی در نظر می گیرد که نرم افزار اکسل را تشکیل می دهند، مثل فایل ( کارپوشه WORKBOOK ) ، کاربرگ یا WORKSHEET و یا سلول RANGE .در حقیقت کارپوشه ها از اشیاء کاربرگ تشکیل شده اند و کاربرگ ها با اشیاء سلول کامل می شوند . هر شیء دارای یک سری خاصیت است . مثلا شما یک سنگ را در نظر بگیرید ، رنگ ، وزن ، شکل و... خواص سنگ محسوب می شوند .در وی بی ای VBA نیز همینطور است ، مثلا یک سلول دارای خواصی مثل محتویات ، اندازه فونت ، نام فونت ، رنگ ، فرمول ، کادر و .... می باشد. کاربران در برنامه نویسی در حقیقت این خواص را تغییر می دهند .

بیایید یک تمرین را باهم انجام دهیم :

ابتدا نوار ابزار ویژال بیسیک را فعال کنید ، سپس ماکرویی را طراحی کنید که در سلول A1 از کاربرگ 2 وارد شود .

مراحل ساخت ماکرو :

ابتدا کلید RECORD MACRO را می فشاریم و سپس به کاربرگ 2 و سلول A1 وارد می شویم و در آخر کلید STOP را می فشاریم .

حال برای دیدن کد ماکرو مسیر زیر را دنبال کنید :

کلید RUN را فشرده تا اسامی ماکرو ها ظاهر شود سپس ماکروی مورد نظر را انتخاب کرده کلید EDIT را می فشاریم تا متن ماکرو ( کد ) نمایش داده شود .

همانطور که مشاهده می کنید ماکرو با SUB و نام ماکرو ،شروع و با END SUB تمام می شود و در بین آنها عبارات برنامه نویسی نوشته شده است . سه رنگ در بدنه ی ماکرو بکار رفته 1- سبز: که معرف توضیحات برنامه است و هیچ تاثیری بر عملکرد ماکرو ندارد 2- آبی : کلمات کلیدی 3- سیاه : دستورات

Sub Macro1()

' Macro1 Macro

' Macro recorded 2007/04/23 by tozih

Sheets("Sheet2").Select

Range("A1").Select

End Sub

همانطور که از کد ها مشخص است ماکرویی بنام MACRO1 به کاربرگ 2 رفته و سلول A1 را در آن انتخاب می کند . در ساختار برنامه نویسی VBA تغییر خواص به صورت توارثی انجام می پذیرد ، یعنی هر خاصیت باید به شئ مورد نظر، با یک نقطه متصل باشد .

Range("A1").Select

در حقیقت برای تغییر خاصیت اشیاء باید ابتدا نام شئ را ذکر کرده سپس نقطه را قرار داده و آنگاه خاصیت مورد نظر را ذکر کنیم و مقادیر آنرا تغییر دهیم . مثلا :

RANGE("A2:A10").FONT.SIZE = 16

اندازه فونت محتویات سلول های A1 تا A10 را به 16 تغییر می دهد .

مثال دیگر ، محتویات سلول D2 از کاربرگ 3 را عبارت ALI TOZIH قرار دهید .

SHEETS("SHEET3").RANGE("D5").VALUE = "ALI TOZIH"

در ضمن خاصیت VALUE پیش فرض است و می توان آنرا حذف کرد :

SHEETS("SHEET3").RANGE("D5") = "ALI TOZIH"

نوشته شده در دوشنبه سوم اردیبهشت 1386ساعت 12:11 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
ورود و خروج داده ها و پیام ها INPUTBOX , MSGBOX
هرگاه کاربر قصد دادن هشدار و یا پیامی را به کار بر داشته باشد از ابزار MSGBOX استفاده می کند

به طور مثال این ماکرو پیام " I AM ALI TOZIH " را نمایش می دهد .

Sub ALI4()

MsgBox " I AM ALI TOZIH "

End Sub

شکل این تابع به صورت زیر است :

MsgBox(prompt[, buttons] [, title] [, helpfile, context])

MSGBOX " متن جعبه ", buttons," عنوان جعبه"

ساختار این تابع به شرح زیر است :

MsgBox Function

Displays a message in a dialog box, waits for the user to click a button, and returns an Integer indicating which button the user clicked.

Syntax

MsgBox(prompt[, buttons] [, title] [, helpfile, context])

The MsgBox function syntax has these named arguments:

Part | Description
prompt | Required. String expression displayed as the message in the dialog box. The maximum length of prompt is approximately 1024 characters, depending on the width of the characters used. If prompt consists of more than one line, you can separate the lines using a carriage return character (Chr(13)), a linefeed character (Chr(10)), or carriage return – linefeed character combination (Chr(13) & Chr(10)) between each line.
buttons | Optional. Numeric expression that is the sum of values specifying the number and type of buttons to display, the icon style to use, the identity of the default button, and the modality of the message box. If omitted, the default value for buttons is 0.
title | Optional. String expression displayed in the title bar of the dialog box. If you omit title, the application name is placed in the title bar.
helpfile | Optional. String expression that identifies the Help file to use to provide context-sensitive Help for the dialog box. If helpfile is provided, context must also be provided.
context | Optional. Numeric expression that is the Help context number assigned to the appropriate Help topic by the Help author. If context is provided, helpfile must also be provided.

Settings

The buttons argument settings are:

Constant | Value | Description
vbOKOnly | 0 | Display OK button only.
vbOKCancel | 1 | Display OK and Cancel buttons.
vbAbortRetryIgnore | 2 | Display Abort, Retry, and Ignore buttons.
vbYesNoCancel | 3 | Display Yes, No, and Cancel buttons.
vbYesNo | 4 | Display Yes and No buttons.
vbRetryCancel | 5 | Display Retry and Cancel buttons.
vbCritical | 16 | Display Critical Message icon.
vbQuestion | 32 | Display Warning Query icon.
vbExclamation | 48 | Display Warning Message icon.
vbInformation | 64 | Display Information Message icon.
vbDefaultButton1 | 0 | First button is default.
vbDefaultButton2 | 256 | Second button is default.
vbDefaultButton3 | 512 | Third button is default.
vbDefaultButton4 | 768 | Fourth button is default.
vbApplicationModal | 0 | Application modal; the user must respond to the message box before continuing work in the current application.
vbSystemModal | 4096 | System modal; all applications are suspended until the user responds to the message box.
vbMsgBoxHelpButton | 16384 | Adds Help button to the message box
VbMsgBoxSetForeground | 65536 | Specifies the message box window as the foreground window
vbMsgBoxRight | 524288 | Text is right aligned
vbMsgBoxRtlReading | 1048576 | Specifies text should appear as right-to-left reading on Hebrew and Arabic systems

The first group of values (0–5) describes the number and type of buttons displayed in the dialog box; the second group (16, 32, 48, 64) describes the icon style; the third group (0, 256, 512) determines which button is the default; and the fourth group (0, 4096) determines the modality of the message box. When adding numbers to create a final value for the buttons argument, use only one number from each group.

Note These constants are specified by Visual Basic for Applications. As a result, the names can be used anywhere in your code in place of the actual values.

Return Values

Constant | Value | Description
vbOK | 1 | OK
vbCancel | 2 | Cancel
vbAbort | 3 | Abort
vbRetry | 4 | Retry
vbIgnore | 5 | Ignore
vbYes | 6 | Yes
vbNo | 7 | No

Remarks

When both helpfile and context are provided, the user can press F1 (Windows) or HELP (Macintosh) to view the Help topic corresponding to the context. Some host applications, for example, Microsoft Excel, also automatically add a Help button to the dialog box.

If the dialog box displays a Cancel button, pressing the ESC key has the same effect as clicking Cancel. If the dialog box contains a Help button, context-sensitive Help is provided for the dialog box. However, no value is returned until one of the other buttons is clicked.

Note To specify more than the first named argument, you must use MsgBox in an expression. To omit some positional arguments, you must include the corresponding comma delimiter.

مثال دیگر : در این مثال علاوه بر متن نمایش داده شده ، یک علامت تعجب زرد نیز دیده می شود و در ضمن کلمه "My Application" در بالای جعبه مشاهده می شود .

SUB ALI5()

MsgBox "Wrong button!@This button doesn't work.@Try Another.", vbOKOnly + Exclamation, "My Application"

END SUB

vbCritical | 16 | Display Critical Message icon.
vbQuestion | 32 | Display Warning Query icon.
vbExclamation | 48 | Display Warning Message icon.
vbInformation

Excel question message box MsgBox excel information MsgBox Excel VBA Exclamation message box

Excel critical MsgBox

نوشته شده در سه شنبه هشتم خرداد 1386ساعت 14:57 توسط علی توضیح |
متد ها Methodes

Methodes

متد ها : عملیاتی هستند که برروی شیء انجام می گیرند . آنها نیز مانند خصوصیات شیء با یک نقطه به آن وصل می شوند. به طور مثال یکی از متد هایی که بروی شی worksheets فعال میشود ، select است . worksheets("sheet2").select این دستور باعث فعال شدن کاربرگ دوم می شود .

برخی از متد هایی اشیا در وی بی ای اکسل :

workbooks

Workbooks("book1").Close کارپوشه ی book1 را می بندد .

worksheets

Worksheets("sheet2").PrintPreview پیش نمایش چاپ کاربرگ را نشان می دهد.

Worksheets("sheet2").Protect "123" کاربرگ را با رمز 123 به حالت محافظت می برد .

Worksheets("sheet2").Unprotect "123" کاربرگ را با رمز 123 از حالت محافظت خارج می کند .

range

Range("a1").Clear محتویات و قالب بندی و توضیحات سلول a1 را حذف می کند .

Range("a1").ClearContents فقط محتویات سول را حذف می کند .

Range("a1").ClearFormats فقط قالب بندی سول را حذف می کند .

نوشته شده در یکشنبه ششم خرداد 1386ساعت 9:53 توسط علی توضیح |
فرمول نویسی با vba
تمرین : ماکرویی بنویسید که حاصل جمع اعداد درون سلول های a2 تا a1000 را درون b1 نمایش دهد .

sub alisum()

range("b1") . formula = " = sum(a2:a1000) "

end sub

نوشته شده در شنبه پنجم خرداد 1386ساعت 15:11 توسط علی توضیح |
معرفی برخی از اشیا و خصوصیات آنها
برای ایجاد محیطی که بتوان ماکرو را در آن نوشت ابتدا باید وارد محیط vbe شد سپس از منوی insert گزینه module را انتخاب می کنیم تا محیط کد نویسی فعال شود . ماکرو ها ، ماژول ها را می سازند و ماژول ها ، پروژه ها را . در حقیقت پروژه از تعدادی شی و ماژول تشکیل شده است .

اشیا یی مانند range دارای تعدای خصوصیت به شرح زیر می باشند :

  1. value
  2. font . name
  3. font . size
  4. font . bold
  5. font . italic
  6. font . underline
  7. font . colorindex
  8. interior.colorindex
  9. formula

تمرین 1 - ماکرویی بنویسید که اندازه فونت محتویات سلول d3 را به 25 و حالت پررنگ تغییر دهد و نوع فونت را به titr .

sub ali23()

range("d3").font.name ="titr"

range("d3").font.size = 25

range("d3").font.bold = true

end sub

نوشته شده در شنبه پنجم خرداد 1386ساعت 14:58 توسط علی توضیح |
نوشتن چند ماکرو ساده
برای تسلط به VBA یا همان زبان برنامه نویسی آفیس ، چند تمرین ساده را مرور می کنیم و بعد به سراغ معرفی اشیاء درون وی بی ای خواهیم رفت تا برخی از خصوصیات و متد های آنها را معرفی کنیم .

تمرین 1 - ماکروییی بنام EDITB1 بنویسید که محتویات سلول A1 را در درون سلول B1 قرار دهد .

SUB EDITB1()

RANGE("B1") = range("a1")

END SUB

تمرین 2- ماکرویی بنویسید که عدد 14 را درون c1 و عدد ۱۴- را درون c2 قرار دهد .

SUB ali22()

RANGE("c1") = 14

RANGE("c2") = -14

END SUB

نوشته شده در شنبه پنجم خرداد 1386ساعت 12:0 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
دانلود تمرین ویژه اکسل پیشرفته
۱-در جدول زیر جمع دریافتی های ALI چقدر است ؟

دانلود تمرین

۲- جمع دریافتی های علی از بانک ملی چقدر است ؟

ترکیب فیلتر ها و تابع SUBTOTAL

SUBTOTAL

See Also

Returns a subtotal in a list or database. It is generally easier to create a list with subtotals using the Subtotals command (Data menu). Once the subtotal list is created, you can modify it by editing the SUBTOTAL function.

Syntax

SUBTOTAL(function_num, ref1, ref2, ...)

Function_num is the number 1 to 11 (includes hidden values) or 101 to 111 (ignores hidden values) that specifies which function to use in calculating subtotals within a list.

Function_num (includes hidden values) | Function_num (ignores hidden values) | Function
1 | 101 | AVERAGE
2 | 102 | COUNT
3 | 103 | COUNTA
4 | 104 | MAX
5 | 105 | MIN
6 | 106 | PRODUCT
7 | 107 | STDEV
8 | 108 | STDEVP
9 | 109 | SUM
10 | 110 | VAR
11 | 111 | VARP

Ref1, ref2, are 1 to 29 ranges or references for which you want the subtotal.

Remarks

  • If there are other subtotals within ref1, ref2,… (or nested subtotals), these nested subtotals are ignored to avoid double counting.
  • For the function_num constants from 1 to 11, the SUBTOTAL function includes the values of rows hidden by the Hide command under the Row submenu of the Format menu). Use these constants when you want to subtotal hidden and nonhidden numbers in a list. For the function_Num constants from 101 to 111, the SUBTOTAL function ignores values of rows hidden by the Hide command under the Row submenu of the Format menu). Use these constants when you want to subtotal only nonhidden numbers in a list.
  • The SUBTOTAL function ignores any rows that are not included in the result of a filter, no matter which function_num value you use.
  • The SUBTOTAL function is designed for columns of data, or vertical ranges. It is not designed for rows of data, or horizontal ranges. For example, when you subtotal a horizontal range using a function_num of 101 or greater, such as SUBTOTAL(109,B2:G2), hiding a column does not affect the subtotal. But, hiding a row in a subtotal of a vertical range does affect the subtotal.
  • If any of the references are 3-D references, SUBTOTAL returns the #VALUE! error value.

Example

The example may be easier to understand if you copy it to a blank worksheet.

  1. Create a blank workbook or worksheet.
  2. Select the example in the Help topic. Do not select the row or column headers.

    Selecting an example from Help

  3. Press CTRL+C.
  4. In the worksheet, select cell A1, and press CTRL+V.
  5. To switch between viewing the results and viewing the formulas that return the results, press CTRL+` (grave accent), or on the Tools menu, point to Formula Auditing, and then click Formula Auditing Mode.

1
2
3
4
5
A
Data
120
10
150
23
Formula | Description (Result)
=SUBTOTAL(9,A2:A5) | Subtotal of the column above using the SUM function (303)
=SUBTOTAL(1,A2:A5) | Subtotal of the column above using the AVERAGE function (75.75)

نوشته شده در چهارشنبه سوم مرداد 1386ساعت 10:49 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
جستجوی یک مقدار منتناظر در جدول VLOOKUP
این تابع قادر است در ستون نخست یک جدول به دنبال مقدار مورد نظر شما گشته و سپس از همان جدول از ستون مورد نظر داده متناظر را نمایش دهد .

به طور مثال فرض کنید که تعدادی اسامی و شماره ماشین در یک جدول داشته باشیدکه نام ها د رستون اول جدول و شماره ماشین ها در ستون دوم باشند برای اینکه هر نامی که نوشته می شود شماره ماشین متناظر با آن نمایش داده شود باید از این تابع استفاده کرد:

=VLOOKUP(نام مورد نظر ، آدرس کل محدوده جدول ، شماره فیلد شماره ماشین ، عدد صفر)

VLOOKUP( "ALI",A1:B10;2;0)

عدد صفر بر مبنای صعودی یا نزولی بودن و یا نا مرتب بودن فیلد جستجو استفاده می شود .

VLOOKUP

Searches for a value in the leftmost column of a table, and then returns a value in the same row from a column you specify in the table. Use VLOOKUP instead of HLOOKUP when your comparison values are located in a column to the left of the data you want to find.

The V in VLOOKUP stands for "Vertical."

Syntax

VLOOKUP(lookup_value,table_array,col_index_num,range_lookup)

Lookup_value is the value to be found in the first column of the array. Lookup_value can be a value, a reference, or a text string.

Table_array is the table of information in which data is looked up. Use a reference to a range or a range name, such as Database or List.

  • If range_lookup is TRUE, the values in the first column of table_array must be placed in ascending order: ..., -2, -1, 0, 1, 2, ..., A-Z, FALSE, TRUE; otherwise VLOOKUP may not give the correct value. If range_lookup is FALSE, table_array does not need to be sorted.

  • You can put the values in ascending order by choosing the Sort command from the Data menu and selecting Ascending.

  • The values in the first column of table_array can be text, numbers, or logical values.

  • Uppercase and lowercase text are equivalent.

Col_index_num is the column number in table_array from which the matching value must be returned. A col_index_num of 1 returns the value in the first column in table_array; a col_index_num of 2 returns the value in the second column in table_array, and so on. If col_index_num is less than 1, VLOOKUP returns the #VALUE! error value; if col_index_num is greater than the number of columns in table_array, VLOOKUP returns the #REF! error value.

Range_lookup is a logical value that specifies whether you want VLOOKUP to find an exact match or an approximate match. If TRUE or omitted, an approximate match is returned. In other words, if an exact match is not found, the next largest value that is less than lookup_value is returned. If FALSE, VLOOKUP will find an exact match. If one is not found, the error value #N/A is returned.

Remarks

  • If VLOOKUP can't find lookup_value, and range_lookup is TRUE, it uses the largest value that is less than or equal to lookup_value.
  • If lookup_value is smaller than the smallest value in the first column of table_array, VLOOKUP returns the #N/A error value.
  • If VLOOKUP can't find lookup_value, and range_lookup is FALSE, VLOOKUP returns the #N/A value.

Example

The example may be easier to understand if you copy it to a blank worksheet.

  1. Create a blank workbook or worksheet.
  2. Select the example in the Help topic. Do not select the row or column headers.

    Selecting an example from Help

  3. Press CTRL+C.
  4. In the worksheet, select cell A1, and press CTRL+V.
  5. To switch between viewing the results and viewing the formulas that return the results, press CTRL+` (grave accent), or on the Tools menu, point to Formula Auditing, and then click Formula Auditing Mode.

The example uses values for air at 1 atm pressure.

1
2
3
4
5
6
7
8
9
10
A | B | C
Density | Viscosity | Temperature
0.457 | 3.55 | 500
0.525 | 3.25 | 400
0.616 | 2.93 | 300
0.675 | 2.75 | 250
0.746 | 2.57 | 200
0.835 | 2.38 | 150
0.946 | 2.17 | 100
1.09 | 1.95 | 50
1.29 | 1.71 | 0
Formula | Description (Result)
=VLOOKUP(1,A2:C10,2) | Looks up 1 in column A, and returns the value from column B in the same row (2.17)
=VLOOKUP(1,A2:C10,3,TRUE) | Looks up 1 in column A, and returns the value from column C in the same row (100)
=VLOOKUP(.7,A2:C10,3,FALSE) | Looks up 0.746 in column A. Because there is no exact match in column A, an error is returned (#N/A)
=VLOOKUP(0.1,A2:C10,2,TRUE) | Looks up 0.1 in column A. Because 0.1 is less than the smallest value in column A, an error is returned (#N/A)
=VLOOKUP(2,A2:C10,2,TRUE) | Looks up 2 in column A, and returns the value from column B in the same row (1.71)

نوشته شده در چهارشنبه دهم بهمن 1386ساعت 12:0 توسط علی توضیح |
عدد با قالب متن
برای نوشتن اعداد باقالب متن می توان از علامت ` قبل از عدد مورد نظر استفاده کرد:

به طور مثال کد 012 را به صورت 012` ( کلید پ زیر ESC ~ ) وارد کنید .

یا قبل از نوشتن عدد ،سلول را قابل بندی متن کنید:

FORMAT CELLS>NUMBER>TEXT

نوشته شده در چهارشنبه دهم بهمن 1386ساعت 11:38 توسط علی توضیح |
محافظت از کاربرگ
برای محافظت از کاربرگ در برابر تغییرات نا خواسته باید مراحل زیر را به ترتیب طی کنید:

۱- ابتدا سلول هایی را که می خواهید فرمول های درونشان دیده نشوند یا تغییر نکنند پس از انتخاب سلول مورد نظر، از منوی :

FORMAT>FORMAT CELLS> PROTECTION

گزینه های LOCKED , HIDEN راانتخاب می کنیم تا سلول قفل شود اما این قفل تا زمانی که کاربرگ قفل نشود فعال نمی گردد. برای قفل کردن کاربرگ باید آنرا سیو کرده و سپس از منوی

TOOLS>PROTECTION>PROTECT SHEET

را انتخاب نماییم تا کاربرگ با شروط ذکر شده قفل شود آنگاه سلول های قفل شده دیگر تغییر نخواهند کرد.

سلولهایی که گزینه HIDEN آنها فعال است، فرمول هایشان را در نوار فرمول نشان نمی دهند ( پس از قفل شدن کاربرگ )

نوشته شده در چهارشنبه دهم بهمن 1386ساعت 10:58 توسط علی توضیح |
فایل PDF اکسل مقدماتی
با عرض پوزش از همه دوستان به علت دوری از وبلاگ ؛

فایل آموزشی اکسل مقدماتی را برای دانلود روی وبلاگ قرار دادم ؛ این فایل ویراستاری نشده و از تمام دوستانی که نظرات، انتقادات و پیشنهادات خود را یادداشت می کنند متشکرم.

دانلود جزوه مقدماتی آموزش اکسل

نوشته شده در چهارشنبه دهم بهمن 1386ساعت 10:24 توسط علی توضیح |
تمرین گزارش گیری با جداول محوری
با استفاده از جدول زیر به سوالات داده شده پاسخ دهید :

جدول را از اینجا دانلود کنید.

در کاربرگ در یافتی:

۱- مجموع دریافتی های علی چقدر است ؟

۲- مجموع دریافتی های هر فرد چقدر است؟

۳- مجموع دریافتی های هر فرد در هر ماه چقدر است؟ ( لیست حقوقی)

۴- میانگین دریافتی های هر فرد از هر بانک چقدر است ؟

در کاربرگ لوازم التحریر :

۱- هر فروشگاه از هر کالا چقدر فروخته ؟

۲- چه کلاهایی در چه شهرهایی بیشتر فروش داشته اند ؟

نوشته شده در سه شنبه نهم بهمن 1386ساعت 8:32 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
نامگذاري محدوده اي از سلول ها در اكسل 2007
گاهي اوقات لازم ميشود بجاي استفاده از آدرس محدوده ها ، انها را نامگذاري كرده و سپس از اسامي آنها در فرمول ها استفاده كنيم .

به تصوير زير نگاه كنيد تا متوجه نامگذاري محدوه ي انتخاب شده شويد :

ابتدا محدوده مورد نظر را انتخاب كرده و سپس از مسير :
formulas > creat from selection
را انتخاب مي كنيم :اين سيستم به صورت خودكار تشخيص مي دهد كه رديف بالا و ستون سمت راست نام ها را تشكيل مي دهند.

پس از نام گذاري در بخش name box اسامي نام هاي هر محدوده مشخص مي شود :(تصوير زير)

با استفاده از اين روش قادر خواهيد بود اسامي ساخته شده را بجاي آدرس آنها در فرمول نويسي استفاده كنيد :( تصوير زير)

نوشته شده در سه شنبه نهم مهر 1387ساعت 13:20 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
تمرین IF
تمرین IF : ماکرویی طراحی کنید که نمره ی دانش آموزی را از کاربر گرفته اگر

0=<نمره =<7 ضعیف

7<نمره =<14 متوسط

14<نمره =<20 خوب

پیام های مقابل آنها را چاپ نماید .

Sub NOMREH()

Dim NOM As Single

NOM = InputBox(" نمره را وارد کنید")

If NOM >= 0 And NOM <= 7 Then MsgBox "BAD"

If NOM > 7 And NOM <= 14 Then MsgBox " NOT BAD"

If NOM > 14 And NOM <= 20 Then MsgBox "GOOD"

End Sub

به این نکته توجه داشته باشید که اگر فرامین IF فقط یک دستور باشند دیگر نیازی به END IF نیست البته دستور مورد نظر را باید در پشت سر THEN نوشت .

نوشته شده در سه شنبه نوزدهم تیر 1386ساعت 9:53 توسط علی توضیح |
راهنمای استفاده از دستور شرطی IF

If...Then...Else Statement

*برگرفته از راهنمای اکسل*

Conditionally executes a group of statements, depending on the value of an expression.

Syntax

If condition Then [statements] [Else elsestatements]

Or, you can use the block form syntax:

If condition Then
[statements]

[ElseIf condition-n Then
[elseifstatements] ...

[Else
[elsestatements]]

End If

The If...Then...Else statement syntax has these parts:

Part | Description
condition | Required. One or more of the following two types of expressions:
 | A numeric expression or string expression that evaluates to True or False. If condition is Null, condition is treated as False.
 | An expression of the form TypeOf objectname Is objecttype. The objectname is any object reference and objecttype is any valid object type. The expression is True if objectname is of the object type specified by objecttype; otherwise it is False.
statements | Optional in block form; required in single-line form that has no Else clause. One or more statements separated by colons; executed if condition is True.
condition-n | Optional. Same as condition.
elseifstatements | Optional. One or more statements executed if associated condition-n is True.
elsestatements | Optional. One or more statements executed if no previous condition or condition-n expression is True.

Remarks

You can use the single-line form (first syntax) for short, simple tests. However, the block form (second syntax) provides more structure and flexibility than the single-line form and is usually easier to read, maintain, and debug.

Note With the single-line form, it is possible to have multiple statements executed as the result of an If...Then decision. All statements must be on the same line and separated by colons, as in the following statement:

If A > 10 Then A = A + 1 : B = B + A : C = C + B

A block form If statement must be the first statement on a line. The Else, ElseIf, and End If parts of the statement can have only a line number or line label preceding them. The block If must end with an End If statement.

To determine whether or not a statement is a block If, examine what follows the Then keyword. If anything other than a comment appears after Then on the same line, the statement is treated as a single-line If statement.

The Else and ElseIf clauses are both optional. You can have as many ElseIf clauses as you want in a block If, but none can appear after an Else clause. Block If statements can be nested; that is, contained within one another.

When executing a block If (second syntax), condition is tested. If condition is True, the statements following Then are executed. If condition is False, each ElseIf condition (if any) is evaluated in turn. When a True condition is found, the statements immediately following the associated Then are executed. If none of the ElseIf conditions are True (or if there are no ElseIf clauses), the statements following Else are executed. After executing the statements following Then or Else, execution continues with the statement following End If.

Tip Select Case may be more useful when evaluating a single expression that has several possible actions. However, the TypeOf objectname Is objecttype clause can't be used with the Select Case statement.

Note TypeOf cannot be used with hard data types such as Long, Integer, and so forth other than Object.

نوشته شده در سه شنبه نوزدهم تیر 1386ساعت 9:41 توسط علی توضیح |
شرط ها و ساختار های تصمیم گیری در وی بی ای IF IN VBA
یکی از مهمترین بخش های هر زبان برنامه نویسی ساختار های تصمیمگیری در آنهاست .

IF یکی از پرکاربرد ترین دستورات VBA می باشد ، ساختار آن عبارت است از :

IF شرط THEN

عملیات مورد نظر

END IF

مثال : می خواهیم ساختار شرطی ایجاد کنیم که اگر محتویات سلول A1 از عدد 10 کوچکتر بود یک پیام مردودی نمایش دهد . ( فقط ساختار IF را نمایش می دهیم )

IF RANGE("A1")<10 THEN

MSGBOX" مردود"

END IF

نوشته شده در سه شنبه نوزدهم تیر 1386ساعت 9:30 توسط علی توضیح |
تمرین 2
تمرین 2 - ماکرویی طراحی کنید که نام و نام خانوادگی را از کاربر دریافت کرده سپس آنها را در کنار یکدیگر نمایش دهد .

SUB NAM()

DIM N AS STRING

DIM F AS STRING

N= INPUTBOX("ENTER NAME :")

F=INPUTBOX("ENTER FAMILY :")

MSGBOX N&" "&F

END SUB

نوشته شده در سه شنبه نوزدهم تیر 1386ساعت 9:15 توسط علی توضیح |
تمرین
تمرین : ماکرویی بنویسید که دو عدد را از کاربر گرفته و سپس ضرب آنها را نمایش دهد :

SUB ZARB()

DIM I AS SINGLE

DIM J AS SINGLE

DIM K AS SINGLE

I= INPUTBOX(" ENTER I :")

J= INPUTBOX(" ENTER J :")

K=I*J

MSGBOX " I*J = " &K

END SUB

نوشته شده در سه شنبه نوزدهم تیر 1386ساعت 9:9 توسط علی توضیح |
معرفی متغیر ها در وی بی ای
برای استفاده از متغیر ها در وی بی ای VBA بهتر است که آنها را تعریف کنیم ، دو نوع متغیر عددی و غیر عددی وجود دارد که عددی ها عبارتند از :

  1. BYTE
  2. INTEGER
  3. LONG
  4. SINGLE
  5. DOUBLE
  6. CURRENCY
  7. DECIMAL

و غیر عددی عا عبارتند از:

  1. BOOLEAN
  2. OBJECT
  3. STRING
  4. VARIANT
  5. DATE

روش معرفی متغیر ها استفاده از کلمه ی کلیدی DIM بعد از نام ماکروست . به مثال زیر توجه کنید:

I به عنوان یک عدد صحیح ( متغیر) معرفی شده است .

SUB ALI()

DIM I AS INTEGER ' I به عنوان یک عدد صحیح معرفی

I = INPUTBOX (" ENTER A NUMBER INTEGER:")

END SUB

Data Type Summary

The following table shows the supported data types, including storage sizes and ranges.

Data type | Storage size | Range
Byte | 1 byte | 0 to 255
Boolean | 2 bytes | True or False
Integer | 2 bytes | -32,768 to 32,767
Long (long integer) | 4 bytes | -2,147,483,648 to 2,147,483,647
Single (single-precision floating-point) | 4 bytes | -3.402823E38 to -1.401298E-45 for negative values; 1.401298E-45 to 3.402823E38 for positive values
Double (double-precision floating-point) | 8 bytes | -1.79769313486231E308 to -4.94065645841247E-324 for negative values; 4.94065645841247E-324 to 1.79769313486232E308 for positive values
Currency (scaled integer) | 8 bytes | -922,337,203,685,477.5808 to 922,337,203,685,477.5807
Decimal | 14 bytes | +/-79,228,162,514,264,337,593,543,950,335 with no decimal point; +/-7.9228162514264337593543950335 with 28 places to the right of the decimal; smallest non-zero number is +/-0.0000000000000000000000000001
Date | 8 bytes | January 1, 100 to December 31, 9999
Object | 4 bytes | Any Object reference
String (variable-length) | 10 bytes + string length | 0 to approximately 2 billion
String (fixed-length) | Length of string | 1 to approximately 65,400
Variant (with numbers) | 16 bytes | Any numeric value up to the range of a Double
Variant (with characters) | 22 bytes + string length | Same range as for variable-length String
User-defined (using Type) | Number required by elements | The range of each element is the same as the range of its data type.

Note Arrays of any data type require 20 bytes of memory plus 4 bytes for each array dimension plus the number of bytes occupied by the data itself. The memory occupied by the data can be calculated by multiplying the number of data elements by the size of each element. For example, the data in a single-dimension array consisting of 4 Integer data elements of 2 bytes each occupies 8 bytes. The 8 bytes required for the data plus the 24 bytes of overhead brings the total memory requirement for the array to 32 bytes.

A Variant containing an array requires 12 bytes more than the array alone.

Note Use the StrConv function to convert one type of string data to another.

نوشته شده در سه شنبه پنجم تیر 1386ساعت 13:16 توسط علی توضیح |
INPUTBOX جعبه دریافت داده
هر گاه کاربر قصد دریافت داده ها را از کاربرگ نداشته باشد و بخواهد آنها را مستقیما دریافت کند از این ابزار استفاده می کند :

Sub ALI()
I = InputBox(" عدد مورد نظر را وارد کنيد ")
End Sub

در مثال فوق ماکرو ساده ای را مشاهده می کنید که پیام " عدد مورد نظر را وارد کنید " را نمایش داده و عدد یا متن کاربر را دریافت کرده و در متغییر I می ریزد .

شکل این تابع به صورت زیر است :

InputBox Function

Displays a prompt in a dialog box, waits for the user to input text or click a button, and returns a String containing the contents of the text box.

Syntax

InputBox(prompt[, title] [, default] [, xpos] [, ypos] [, helpfile, context])

The InputBox function syntax has these named arguments:

Part | Description
prompt | Required. String expression displayed as the message in the dialog box. The maximum length of prompt is approximately 1024 characters, depending on the width of the characters used. If prompt consists of more than one line, you can separate the lines using a carriage return character (Chr(13)), a linefeed character (Chr(10)), or carriage return–linefeed character combination (Chr(13) & Chr(10)) between each line.
title | Optional. String expression displayed in the title bar of the dialog box. If you omit title, the application name is placed in the title bar.
default | Optional. String expression displayed in the text box as the default response if no other input is provided. If you omit default, the text box is displayed empty.
xpos | Optional. Numeric expression that specifies, in twips, the horizontal distance of the left edge of the dialog box from the left edge of the screen. If xpos is omitted, the dialog box is horizontally centered.
ypos | Optional. Numeric expression that specifies, in twips, the vertical distance of the upper edge of the dialog box from the top of the screen. If ypos is omitted, the dialog box is vertically positioned approximately one-third of the way down the screen.
helpfile | Optional. String expression that identifies the Help file to use to provide context-sensitive Help for the dialog box. If helpfile is provided, context must also be provided.
context | Optional. Numeric expression that is the Help context number assigned to the appropriate Help topic by the Help author. If context is provided, helpfile must also be provided.

Remarks

When both helpfile and context are provided, the user can press F1 (Windows) or HELP (Macintosh) to view the Help topic corresponding to the context. Some host applications, for example, Microsoft Excel, also automatically add a Help button to the dialog box. If the user clicks OK or presses ENTER , the InputBox function returns whatever is in the text box. If the user clicks Cancel, the function returns a zero-length string ("").

Note To specify more than the first named argument, you must use InputBox in an expression. To omit some positional arguments, you must include the corresponding comma delimiter.

مثال :

Sub proInput()

J = InputBox("For what year do you need this report?")

End Sub

نوشته شده در سه شنبه پنجم تیر 1386ساعت 10:3 توسط علی توضیح |
دانلود تمرین وی بی for & if

برای دانلود

تمرین وی بی کلیک کنید.

ابتدا تمرین را دانلود کرده و سپس سعی کنید آنرا بدون ااستفاده از راهنما حل کنید:

صورت مسله : ماکرویی بنویسید که اعداد ستون اول را در در ستون دوم جستجو کرده و تکراری های آنرا یافته با رنگ سرخ و پررنگ نمایش دهد .

نوشته شده در دوشنبه چهارم تیر 1386ساعت 14:6 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
تابع جدید SUMIFS 2007
تابع SUM عملیات جمع زدن را بدون شرط انجام میدهد اما تابع SUMIF در اکسل 2003 قابلیت شرط گذاری را برای کاربران فراهم میکند .شکل این تابع به صورت زیر است:

=SUMIF(range,criteria,sum_range)

این تابع ابتدا در محدوده RANGE به دنبال شرط ( criteria) گشته و سپس در محدوه جمع ( sum_range) مقادیر متناظر آنها را با هم جمع می کند .

به طور مثال در فایل تمرین در جدول یک ، جمع دریافتی های علی چقدر است ؟

اما این تابع تنها قادر به استفاده از یک شرط برای کاربران است و بیش از یک شرط را نمی پذیرد. به طور مثال

می خواهیم بدانیم علی در سال 82 چقدر دریافتی داشته است ؟

در اکسل 2007 تابع جدید SUMIFS به کاربران در این زمینه کمک می کند.

=SUMIFS(sum_range,criteria_range1,criteria1,criteria_range2,criteria2…)

این تابع ابتدا محدوده جمع را میگیرد و سپس شرط ها و محدود های هر شرط را تا 127 مرحله از کاربر می گیرد.

نوشته شده در پنجشنبه دوازدهم اردیبهشت 1387ساعت 13:24 توسط علی توضیح |
دانلود
در دانلود قبل ...

دانلود لینک از تصویر جداست .

فایل پیوستی به فرمت MDI می باشد و با نرم افزار MICROSOFT OFFICE DOCUMENT IMAGING قابل مشاهده و دسترسی است .

نوشته شده در پنجشنبه دوازدهم اردیبهشت 1387ساعت 12:54 توسط علی توضیح |
جزوه مقدماتی به صورت تصویری

دانلود جزوه مقدماتی برای کسانی که موفق به تماشای آن به صورت پی دی اف نشده اند.

نوشته شده در چهارشنبه یازدهم اردیبهشت 1387ساعت 7:30 توسط علی توضیح |
تمرین پیشرفته
در جدول یک از تمرین زیر به سوالات داده شده با استفاده از ابزار فیلتر و تابع subtotal پاسخ دهید :

1- جمع دریافتی های علی چقدر است ؟

2- میانگین کارکرد های رضا چقدر است ؟

3- جمع دریافتی های حسین در نیمه ی اول سال 83 چقدر است ؟

4- جمع دریافتی و میانگین کارکرد های علی چقدر است ؟

تمرین را از اینجا دانلود کنید .

نوشته شده در سه شنبه دهم اردیبهشت 1387ساعت 13:11 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
آرايه هاي چند بعدي در وي بي اي اكسل
تعريف يك آرايه ي چند بعدي نيز مانند يك بعدي هاست با اين تفاوت كه بعد ها در تعريف مشخص ميشوند

DIM A(2,4,5) AS LONG

يك ارايه سه بعدي با بعد اول 2 بعد دوم 4 و بعد سوم 5 است كه عناصر آن از جنس لانگ مي باشند

نوشته شده در پنجشنبه بیست و هشتم آذر 1387ساعت 8:21 توسط علی توضیح |
آرايه ها در و ي بي اي اكسل ARRAY IN VBA EXCEL
آرايه مجموعه اي از داده هاست كه به ترتيب در كنار يكديگر قرار مي گيرند به طور مثال A يك آرايه با 5 عضو است كه چهار تاي آن عددي و يكي از آنها متني است.

A={ 1 , 2.57 , 17 , "ALI" , 122 }

آرايه ها يا يك بعدي هستند يا چند بعدي

تعريف يك آرايه يك بعدي در وي بي اي مانند تعريف يك متغير انجام مي پذيرد :مثال

DIM A(5) AS STRING

كه در آن پس از كلمه ديم نام آرايه و انتهاي آن ذكر مي گردد و در انتها نوع داده هاي آن

آرايه ها هميشه از ابتداي صفر آغاز مي كنند به تصاوير زير دقت كنيد

توجه كنيد كه دو عنصري از آرايه كه مقدار دهي نشده اند صفر در نظر گرفته شده اند .

براي اينكه يك آرايه يك بعدي از ابتداي يك آغاز كند مي توان در تعريف آن به روش زير اقدام كرد

DIM ALIARR(1 TO 7) AS SINGLE

كه 7 عنصر از جنس سينگل دارد با ابتداي يك aliarr يك آرايه يك بعدي با نام

براي پر كردن يك آرايه كافي است عناصر آنرا پر كنيم

A(1)="ALI"

A(2)=22

A(3)="ALI TOZIH"

A(6)="REZA"

نوشته شده در پنجشنبه بیست و هشتم آذر 1387ساعت 7:45 توسط علی توضیح |
تمرين وي بي اي VBA EXCEL

تمرين - فرض كنيد ليستي داريد به شكل زير ، كه از سلول A2 آغاز شده است . حال قصد داريم تابعي طراحي كنيم كه با ارسال سلول آغازين ليست به آن تعداد سطر هاي ليست محاسبه شود .

نوشته شده در شنبه بیست و سوم آذر 1387ساعت 11:26 توسط علی توضیح |
خرید کتاب الکترونیکی Excel VBA Professional Projects
بچه ها یک کتاب جدید آموزش وي بي اي اكسل را آقاي بهرام صمديان بصورت سي دي آماده كرده اند كه توصيه مي كنم حتما بخريد و مطالعه كنيد لينكش و ببينيد و استفاده كنيد .

خرید کتاب الکترونیکی Excel VBA Professional Projects

موفق باشيد .

نوشته شده در جمعه بیست و دوم آذر 1387ساعت 8:5 توسط علی توضیح |
ارسال يك متغير به يك ماكرو يا تابع در وي بي اي اكسل
براي جلو گيري از استفاده ي تكراري از تابع inputbox كافي است متغيرهاي مورد استفاده را به صورت پارامتر يا آرگومان به تابع يا ماكرو ارسال كنيم ،براي اين منظور كافي است متغير ها را درون پرانتز جلوي نام تعريف كنيم :

function ali_link(a as string, b as string)

ali_link = a & " " & b

end function

اين تابع دو رشته را از كاربر دريافت كرده آنها را با يك فاصله در كنار هم قرار داده و به خروجي تابع ارسال مي كند. براي استفاده از آن كافي است آنرا به همراه دو متغيرش درون يك ماكرو صدا بزنيم :

sub ali_text()

msgbox ali_link("ali","tozih")

end sub

نوشته شده در جمعه بیست و دوم آذر 1387ساعت 8:0 توسط علی توضیح |
مثال هاي توابع و ماكرو ها در VBA EXCEL
مثال ۱- ماكرويي طراحي كنيد كه نام و نام خانوادگي را از كاربر گرفته سپس آنها را در كنار هم در يك جعبه پیام نشان دهد .

مثال 2 - در مثال بالا نام و نام خانوادگي زير هم در يك جعبه نام قرار گيرند ( VBCR)

مثال 3 - ماكرويي طراحي كنيد كه شعاع يك دايره را گرفته محيط و مساحت آنرا نمايش دهد.

مثال 4 - مثال بالا را با استفاده از يك ماكرو و دو تابع محيط و مساحت انجام دهيد .

مثال 5 - تابعي طراحي كنيد كه ميانگين وزني اعداد داده شده را محاسبه نمايد:

عدد : 10 31 15 5

ضريب :2 4 7 9

توجه كنيد كه تابع بايد هر 8 عدد را دريافت كند.

مثال 6 - تابعي طراحي كنيد كه قادر باشد با دريافت ضرايب عددي معادله درجه اول ax+b=0 آنرا حل كرده جوابش را بازگرداند.

نوشته شده در جمعه بیست و دوم آذر 1387ساعت 7:50 توسط علی توضیح |
انواع عملگرها در وي بي اي اكسل VBA EXCEL OPERATOR
Arithmetic | Comparison | Logical
Exponentiation (^) | Equality (=) | Not
Negation (–) | Inequality (<>) | And
Multiplication and division (*, /) | Less than (<) | Or
Integer division (\) | Greater than (>) | Xor
Modulus arithmetic (Mod) | Less than or equal to (<=) | Eqv
Addition and subtraction (+, –) | Greater than or equal to (>=) | Imp
String concatenation (&) | Like Is |
نوشته شده در جمعه بیست و دوم آذر 1387ساعت 7:35 توسط علی توضیح |
توابع FUNCTIONS در وي بي اكسل
از آنجا كه ماكرو ها قادر به بازگرداندن يك مقدار به عنوان خروجي نيستند ، توابع نوع ديگري از ساختار تشكيل دهنده ماژول ها را معرفي مي كنيم:

ساختار يك تابع ( FUNCTION ) شبيه يك ماكرو است با اين تفاوت كه بجاي كلمه ي SUB از كلمه ي FUNCTION استفاده ميشود :

(اين تابع عدد اول را به توان عدد دوم مي رساند )

FUNCTION AVW()

DIM I AS SINGLE , J AS SINGLE

I= INPUTBOX(" I :")

J=INPUTBOX(" J: ")

AVW =I ^ J

END FUNCTION

نكته ي قابل توجه اينست كه جواب خروجي يك تابع هميشه بايد درون نام تابع ريخته شود.

نوشته شده در جمعه بیست و دوم آذر 1387ساعت 7:18 توسط علی توضیح |
صدا زدن ماكروها CALL
براي استفاده از يك ماكرو درون ماكرو هاي ديگر كافي است ابتدا ماكرو را تعريف كرده سپس درون يك ماكرو ديگر با استفاده از كلمه ي كليدي CALL آنرا صدا بزنيم :

SUB TEST3()

DIM S AS STRING * 5

S= INPUTBOX("YOUR NAME ")

END SUB

______________________________________

SUB TEST4()

CALL TEST3

END SUB

ماكرو TEST3 درون ماكرو TEST4 صدا زده شده است .

به اين نكته توجه كنيد كه هر گاه بخواهيم يك ماكرو فقط در همان ماژول تعريف شده ، شناخته شود كافي است قبل از كلمه ي كليدي SUB از كلمه ي كليدي PRIVATE استفاده شود .

* [image] ماكرو ها به صورت پيش فرض در تمام پروژه شناخته مي شوند.

نوشته شده در جمعه بیست و دوم آذر 1387ساعت 7:11 توسط علی توضیح |
انواع متغير ها در زبان VBA در اكسل 2007
همانطور كه در جلسات قبل ذكر كرديم متغير ها در زبان وي بي اكسل چند دسته اند :

1- عددي

2- غير عددي

3- ثابت ها

4- كاربر ساخته

كه محدوده ي هر كدام را در زير مشاهده ميكنيد ( راهنماي اكسل 2007 ) :

Data Type Summary

The following table shows the supported data types, including storage sizes and ranges.

Data type | Storage size | Range
Byte | 1 byte | 0 to 255
Boolean | 2 bytes | True or False
Integer | 2 bytes | -32,768 to 32,767
Long (long integer) | 4 bytes | -2,147,483,648 to 2,147,483,647
Single (single-precision floating-point) | 4 bytes | -3.402823E38 to -1.401298E-45 for negative values; 1.401298E-45 to 3.402823E38 for positive values
Double (double-precision floating-point) | 8 bytes | -1.79769313486231E308 to -4.94065645841247E-324 for negative values; 4.94065645841247E-324 to 1.79769313486232E308 for positive values
Currency (scaled integer) | 8 bytes | -922,337,203,685,477.5808 to 922,337,203,685,477.5807
Decimal | 14 bytes | +/-79,228,162,514,264,337,593,543,950,335 with no decimal point; +/-7.9228162514264337593543950335 with 28 places to the right of the decimal; smallest non-zero number is +/-0.0000000000000000000000000001
Date | 8 bytes | January 1, 100 to December 31, 9999
Object | 4 bytes | Any Object reference
String (variable-length) | 10 bytes + string length | 0 to approximately 2 billion
String (fixed-length) | Length of string | 1 to approximately 65,400
Variant (with numbers) | 16 bytes | Any numeric value up to the range of a Double
Variant (with characters) | 22 bytes + string length | Same range as for variable-length String
User-defined (using Type) | Number required by elements | The range of each element is the same as the range of its data type.

اين متغير هاكه با كلمه ي كليدي DIM معرفي مي شوند حيطه ي فعاليت ( اثر ) مشخصي دارند :

1- متغير هاي ماكرو

2- متغير هاي ما‍‍ژول

3- متغيرهاي پرو‍ژه ( سراسري)

1- متغير هايي كه در سطح ماكرو تعريف مي شوند تنها در همان ماكرو شناخته مي شوند.

SUB TEST1()

DIM A AS SINGLE

A=INPUTBOX(" ENTER A NUMBER :")

MSGBOX A

END SUB

2- اما نوع دوم متغير ها آنهايي هستند كه بايد درون تمام ماکروهای يك ماژول شناخته شوند ، براي اينكار كافي است متغير را در ابتداي ماژول قبل از تمام ماكروها ( قسمت اعلان يا DECLARATION) تعريف كرد و سپس در تمام ماکرو های آن ماژول میتوان از آن استفاده کرد:

۳- اما اگر بخواهیم این متغیر در تمام ماژول های یک پروژه شناخته شود کافی است در قسمت اعلان بجای کلمه ی dim از كلمه ي GLOBAL استفاده كنيم .در اين حالت متغير سراسري شده و در تمام ماكرو ها ي يك پروژه شناخته مي شود.

GLOBAL S AS STRING

در ضمن بايد بدانيم كه مجموعه ماكرو ها تشكيل يك ماژول داده و مجموعه ي ماژول ها تشكيل يك پروژه را مي دهد .

نكته 1 : اگر بخواهيم درون يك ماكرو پس از اتمام آن مقادير متغير هايش تهي نشود كافي است بجاي DIM از واژه كليدي STATIC استفاده كنيم . در اين حالت حتي پس از اتمام ماكرو مقادير متغير ايستا حفظ شده تا مقادير جديد به آن تعلق پيدا كند.

نوشته شده در پنجشنبه بیست و یکم آذر 1387ساعت 10:26 توسط علی توضیح |
ايجاد DEVELOPER TAB در اكسل 2007
براي كار با VBA و ماكروها كاربران نياز به ايجاد يك تب يا برگه دان جديد دارند به نام DEVELOPER که مراحل نصب آنرا در EXCEL 2007 ملاحظه مي نماييد:

نوشته شده در دوشنبه هجدهم آذر 1387ساعت 11:30 توسط علی توضیح |
استفاده از معتبر سازي در يك كاربرگ ديگر VALIDATION
استفاده از ليست هاي VALIDATION در تنها همان كاربرگ امكان پذير است براي انتقال از يك كاربرگ به كاربرگي ديگي كافي است محدوده ي مورد نظر را نامگذاري كرده سپس به ليست منتقل كنيد.

اين حالت تنها در همان كاربرگ قابل اجراست . اما اگر محدوده ي مورد نظر را نامگذاري نماييد اينكار امكان پذير خواهد شد.

حال اگر در يك كاربرگ ديگر بخواهيم مثلا در ستون A فقط همين اسامي ديده شوند ؛ كافي است در قسمت LIST ابزار VALIDATION بجاي محدوده آدرس از گزينه ali ( نام محدوده ) استفاده كنيد .

نوشته شده در یکشنبه هفدهم آذر 1387ساعت 10:12 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
حلقه ها در وي ب ي اي LOOPS IN VBA EXCEL 2007
FOR يكي از پر كاربردترين نوع حلقه در زبان هاي برنامه نويسي است و براي شمارش بكار ميرود. ساختارش چنين است :

FOR انتها تو ابتدا = شمارنده STEP گام

عمليات

NEXT

مثال : در ساختار زير سلول هاي ستون A تا A100 از 1 تا 100 پر مي شوند:

FOR I=1 TO 100

CELLS(I,1)=I

NEXT

مثال : جدولي در كاربرگ 1 طراحي كنيد كه شامل ستون نام و دريافتي و ماه دريافت باشد ، سپس اسامي چند نفر را در آن وارد نماييد ( تكراري هم داشته باشد ) آنگاه ماكرويي طراحي كنيد كه نام فرد را دريافت كرده سپس جمع كل دريافتي هاي وي را نمايش دهد .

نوشته شده در دوشنبه نهم دی 1387ساعت 9:40 توسط علی توضیح |
SELECT CASE IN VBA
يكي ديگر از ابزار هاي كنترلي در وي بي اي SELECT CASE است . اين ابزار مانند چند IF تو در تو است و شكل آن به صورت زير است :

SELECT CASE متغير

CASE محدوده 1

عمليات 1

CASE محدوده 2

عمليات 2

CASE ELSE

عمليات

END SELECT

به طور مثال ساختاري طراحي كنيد كه عددي را از كاربر گرفته و سپس رده ي آنرا مشخص كند:

1-اگر عدد 1 يا 2 يا 3 باشد رده A

2- اگر عدد بزرگتر از 3 و كوچكتر از 7 باشد رده ي B

3- اگر عدد بزرگتر از 7 باشد رده ي C

4- در غير اين صورت پيام خطا صادر كند.

نمايش داده شود:

SUB TEST()

DIM X!

X=INPUTBOX("X:")

SELECT CASE X

CASE 1,2,3

MSGBOX " A"

CASE 3 TO 7

MSGBOX " B"

CASE IS > 7

MSGBOX "C"

CASE ELSE

MSGBOX " ERROR"

END SELECT

END SUB

نوشته شده در دوشنبه نهم دی 1387ساعت 9:9 توسط علی توضیح |
استفاده از اكسل در امور حسابداري
برخي از دوستان درباره تهيه ي گزارش از ليست ها زياد مي پرسند به ويژه تابع VLOOKUP لازم است كه توضيحي مختصر درباره انواع ليست ها و گزارش هايي كه اكسل قادر است تهيه كند ارايه نمايم :

اكسل قادر است دو نوع گزارش كلي از ليستهايش تهيه كند:

1- ليست هايي كه آيتم هاي تكراراي دارند. مثل حقوق دستمزد كه يك نفر قادر است بارها پول دريافت كند .

2- ليست هايي كه اجازه ي تكرار ندارند. مثل مشخصات فردي درون اداره كه يكنفر نبايد دوبار ثبت شده باشد.

در مورد اول ابزار هايي چون

1-تابع SUBTOTAL

2- SUMIF, SUMIFS

3- تركيب آرايه اي SUM & IF

4- توابع پايگاه داده يا DSUM

5-PIVOTTABLE يا جداول محوري ( بسيار مهم )

6- ابزار SUBTOTAL

را مي توان استفاده كرد، كه تمامي آنها را در آرشيو مي توانيد بيابيد.

اما مورد دوم ليست هاي غير تكراري است كه ابزار هاي آن عبارتند از :

توابع INDEX و MATCH و VLOOKUP , HLOOKUP

اين توابع در ليست هاي تكراري استفاده ي چنداني ندارد

نوشته شده در چهارشنبه چهارم دی 1387ساعت 13:52 توسط علی توضیح |
استفاده از ساختارهای کنترلی در وی بی ای اکسل if , select case
if يكي از پر كاربرترين ابزارهاي وي بي اي در عمليات كنترلي است.

ساختار آن به شرح زير است:

if شرط then

عمليات

elseif شرط then

عمليات

else

عمليات

endif

مثال - دو عدد را از كاربر گرفته اگر مساوي باشند كلمه مساوي و درغير اين صورت نامساوي را نمايش دهد.

sub test1()

dim a!

dim b!

a=inputbox("a")

b=inputbox("b")

if a=b then

msgbox "equal"

else

msgbox " not equal"

endif

end sub

مثال 2- دو عدد درون a1 , b1 را مقايسه كند و هر كدام كه كوچكتر است را پاك كند .

مثال 3- اسامي و حقوق مبناي چند كارمند را دريافت كرده اگر حقوق بيش از 400$ باشد ماليات 10 درصد محاسبه شود در غير اين صورت 7 درصد محاسبه شود.

مثال ۴- میانگین اعداد درون ستون A از كاربرگ 1 را با همين ستون از كاربرگ 2 مقايسه كرده هر كدام كه بزرگتر بود نام آن كاربرگ به MAX تغيير يابد.

نكات اين تمرين :براي تغيير نام مثلا كابرگ 1 :

SHEETS(1).NAME="MAX"

براي استفاده از يك تابع درون وي بي اي از

APPLICATION.WORKSHEETFUNCTION. نام تابع

I = APPLICATION.WORKSHEETFUNCTION.AVERAGE(RANGE("A:A"))

(اين فرمول ميانگين تمام اعداد درون ستون A را به درون متغيير I مي ريزد.)

استفاده مي كنيم . توجه داشته باشيد كه توابع مشخص هستند و مقادير آنها بايد درون يك متغيير ريخته شود.

توجه كنيد براي انتخاب كاربرگ يك مي توان از دستور زير استفاده كرد :

SHEETS(1).SELECT

نوشته شده در چهارشنبه چهارم دی 1387ساعت 13:9 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
تمرین گزارش گیری

دانلود کنید :

با این تمرین به سوالات زیر در کاربرگ زیرپاسخ دهید :( تابع subtotal , autofilter)

در کاربرگ دریافتی :

۱- جمع دریافتی های علی چقدر است ؟

2- میانگین دریافتی های رضا چقدر است ؟

3- جمع دریافتی های امید در سال 82 چقدر است ؟

4- جمع کارکرد های علی در سال 83 از بانک melat چقدر است ؟

5- جمع دریافتی های علی در شش ماهه اول سال چقدر است ؟

نوشته شده در پنجشنبه بیست و هفتم تیر 1387ساعت 11:3 توسط علی توضیح |
فرم سازی در اکسل 2007

به دلیل از دست رفتن برخی از تصاویر این مبحث و اصرار دوستان آنرا مجددا با استفاده از اکسل 2007 برروی وبلاگ قرار می دهم :

برای نصب ابزار های فرم سازی در اکسل 2007 باید مسیر زیر را به ترتیب طی کنیم :

OFFICE BUTTON \ EXCEL OPTIONS \ CUSTOMIZE

گزینه DEVELOPER TAB را در ستون سمت چپ انتخاب کرده تا ابزار CONTROLS در فهرست ظاهر شود .

آنگاه آنرا به QAT انتقال داده ( ADD ) تا قادر به استفاده از آن باشیم.

حال ابزار CONTROLS قابل استفاده می باشد . آنرا باز کرده از امکانات آن استفاده می کنیم .

هر یک از این ابزار قابلیت خاصی دارند مثلا CHEKBOX برای تیک زدن یک گزینه استفاده می شود . اما کاربرگ چگونه این انتخاب را تشخیص می دهد ؟

هر کدام از این ابزار ها گزینه های به نام CELL LINK دارند که آنها را به کاربرگ متصل می کند و نتیجه را درون سلول انتخابی قرار می دهد .برای دستیابی به این بخش کافی است برروی ابزار راست کلیک کرده گزینه FORMAT CONTROL را انتخاب کنیم .

سایر ابزارها نیزاین گزینه را دارند به جز BUTTON که برای اجرای مستقیم ماکروها استفاده می شود.

ابزار های بخش CONTROLS عبارتند از :

1- CHECKBOX

2- OPTION BUTTON

3- COMBO BOX

که در زیر نمونه ای از طرز استفاده کمبو باکس نمایش داده شده است.عدد 2 در سل لینک شماره داده در آرایه مورد نظر است

4- LIST BOX

5- SCROLL

6- SPINNER

7- LABEL

8- BUTTON

نوشته شده در دوشنبه بیست و چهارم تیر 1387ساعت 11:29 توسط علی توضیح |
محافظت شدید از داده ها

: با استفاده از این روش دیگر گزینه های محافظت فعال نخواهند بود

مرجع :

http://support.microsoft.com/kb/309312

To disable password protection in Access, Excel, and Word by using the Microsoft Management Console:

1. | Click Start, point to Run, and then start the Microsoft Management Console (MMC),
2. | On the Console menu, click Add/Remove Snap-In.
3. | In the Add/Remove Snap-In dialog box, click Add (in the lower left area).
4. | In the list of snap-ins, double-click Group Policy, and then click Finish.
5. | Click Close and then click OK in the Add/Remove Snap-In dialog box.
6. | In the Console root under Local Computer Policy, expand User Configuration.
7. | Expand Administrative Templates, and then examine the templates that are currently installed.
8. | Right-click Administrative Templates, and then click Add/Remove Templates.
9. | Click Add and then double-click the Office program template (*.adm) that you want to modify.
10. | Click Close in the Add/Remove Templates dialog box.
11. | Expand the application template that you just added under Administrative Templates.
12. | Expand the Disable items in user interface item, and then click Predefined.
13. | Double-click Command bar buttons and menu items.
14. Click the Enabled button.
• For Access 2002, select the Tools | Security | Set Database Password check box.
• For Excel 2002, select the following check boxes:
• | Tools | Protection
• | Tools | Protection | Protect Sheet
• | Tools | Protection | Protect Workbook
• | Tools | Protection | Protect and Share Workbook
• For Word 2002, select the Tools | Protect Document check box.
15. | Click OK in the Properties dialog box.
16. | On the Console menu, click Save to save the modified policy.

موفق باشید

نوشته شده در دوشنبه بیست و چهارم تیر 1387ساعت 9:10 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
Excel Templates

مجموعه ای بی نظیر از قالب های آماده اکسل ( تمپلیت های ) در این سایت موجود است.

http://www.vertex42.com/ExcelTemplates/

نوشته شده در چهارشنبه هجدهم آذر 1388ساعت 12:6 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
کتاب های جدید و آموزشی اکسل 2003 و 2007
یکی از مشکلات بزرگ کسانی که با اکسل کار می کنند عدم وجود منابع غنی و پر محتوای است. کتب زیر که معرفی می گردند برخی از منابع موجود در بازار ایران است که از نظر محتوا قابل تقدیرند :

۱- راهنمای جامع اکسل ۲۰۰۰ ترجمه آقای مهدوی ( توجه کنید که راهنمای جامع باشد )

۲- راهنمای كاربردي تجاری اکسل ترجمه آقای مهدوی ( ویژه عملیات مالی و آماری anova)

۳- مدل سازی در اکسل ( توابع و فرمول ها ) تالیف مهندس مهدی شهناز

۴- آموزش تصویری اکسل ۲۰۰۷ ( ترجمه پرستو محمد پور - عالیه ) به همراه سی دی تمرین حدود ۵۰۰۰ تومان

۵- توابع و فرمول ها در اکسل ترجمه خانم فریبا معلمی ( ویژه کار تجاری و مالی )

6- ترفند هاي اكسل تاليف آقاي كيانوش حسني نژاد

7- خود آموز گام به گان اكسل 2007 ترجمه مهندس رامين مولانا پور ( تقريبا كامل )

8- سري كتاب هاي آموزش اكسل مهندس بهرام صمديان ( amar80.blogfa.com )

9- نمودارهاي اكسل ترجمه مهندس امير حسين رضوي ( در زمينه ي نمودار ها عاليه )

10 - كتاب جديد آموزش vba در اكسل تاليف مهندس مهدي شهناز

نوشته شده در شنبه هفدهم اسفند 1387ساعت 11:6 توسط علی توضیح |
جدا سازي يا TEXT TO COLUMNS
هر گاه كاربر قصد كند داده هاي درون سلول خود را بر اساس يك معيار خاص ( تعداد يا يك كاراكتر ) از هم جدا كرده آنها را در ستون هاي متفاوت بريزد بايد از اين ابزار استفاده كند .

در اكسل 2007 ( و همينطور 2003) از قسمت DATA گزينه TEXT TO COLUMNS را انتخاب مي كنيم .

توجه داشته باشيد كه بايد ابتدا متن مورد نظر را انتخاب كرده باشيد ، به طور مثال عبارت " I AM ALI TOZIH " را مي خواهيم در سلول هاي جدا قرار دهيم.

همانطور كه در شكل مشخص است عبارت " I AM ALI TOZIH " به كلمات جدا تبديل شده است ، جدا كننده SPACE است و هر كلمه در يك ستون مجاور قرار مي گيرد.

نوشته شده در شنبه هفدهم اسفند 1387ساعت 7:38 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
مثالی از فرم سازی در اکسل 2007- اکسل پیشرفته
مثال ساده ی زیر را دانود کنید و از قدرت و توانایی اکسل در این زمینه لذت ببرید

دانلود کنید

نوشته شده در پنجشنبه سوم دی 1388ساعت 9:19 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
اکسل 2010
جزوه ی زیبای آقای فرشید میدانی درباره امکانات جدید excel 2010 ملاحظه نمایید .

در ضمن سایت ایشان و گروه مبرزشان بسیاز زیبا و پر محتواست . این گروه برروی افیس تحقیق می کنند و مقالات و تالیفات زیادی دارند .

www.farsaran.ir

نوشته شده در سه شنبه بیست و ششم آبان 1388ساعت 12:55 توسط علی توضیح |
فرم سازی در اکسل 2007
ابزار بعدی combobox است

این ابزار فهرستی را از کاربر گرفته و سپس آنرا نمایش می دهد . این ابزار علاوه بر سلول اتصال دارای گزینه ی input range نیز هست که فهرست داده ها به آن تزریق می شود . سلول اتصال شماره ی سلول انتخاب شده در فهرست را نمایش می دهد .

تمرین : با استفاده از ابزار های ذکر شده یک فرم ساده فاکتور برای یک رستوران طراحی کنید که تا نام غذا انتخاب شود قیمت واحد نمایان شود و کاربر قادر باشد قیمت و تعداد را ملاحظه نماید مانند مثال زیر :

به نحوه ی استفاده از فرمول index دقت کنید این فرمول در یک ارایه به دنبال یک شماره ردیف گشته داده ی آن ردیف را نمایش می دهد. توجه کنید چون قیمت واحد مورد نظر ماست سلول اتصال کمبو باکس را به عنوان شماره ردیف داده به ایندکس می دهیم تا قیمت آنرا نمایش دهد .اما برای چک باکس سالاد کافی است از فرمول if استفاده کنیم . به این صورت که اگر سلول اتصال true باشد قیمت واحد مثلا 1000 باشد و در غیر این صورت 0 باشد .

تمرین را از اینجا دانلود کنید : http://www.divshare.com/download/9265677-3d3

نوشته شده در دوشنبه هجدهم آبان 1388ساعت 12:18 توسط علی توضیح |
فرم سازی در اکسل 2007
برای ساخت یک فرم در اکسل ۲۰۰۷ ابتدا باید تب developer را فعال كنيم تا علاوه بر ابزار هاي فرم سازي در محيط اكسل ؛ ابزار هاي ويژال بيسيك نيز نمايان گردند :

ابتدا برروي office button كليك كرده به سراغ انتهاي منو رفته سپس كليد excel ooption را فشرده در بخش popular گزينه ي show developer tab in the ribbon را فعال كنيم .

حال در تب developer به سراغ گزينه ي insert رفته ابزار هاي آنرا برروي كاربرگ قرار مي دهيم .به طور مثال ابزار check box را فعال كرده آنرا بروي صفحه كاربرگ قرار مي دهيم نام آنرا به " سالاد " تغيير مي دهيم . درحقيقت اين ابزار برروي كاربرگ مانند يك شي قرار مي گيرند و به آن متصل نيستند يعني هنگامي كه كاربر آنرا علامت زده انتخاب مي كند كاربرگ متوجه اين انتخاب نخواهد شد .

براي اتصال اين ابزار بايد برروي آنها راست كليك كرده و سپس براي گزينه ي cell link آنها يك سلول را انتخاب كرد تا نتيجه ي تغييراتشان در كاربرگ نمايان شود.

اين سلول نتيجه ي انتخاب و تغيير شما را نشان مي دهد .هنگام انتخاب چك باكس اين سلول مقدار true را نمايش داده و هنگام عدم انتخاب false را نمايش مي دهد.

حال كاربر قادر است بر اساس اين سلول عمليات فرمول نويسي و تصميم گيري را انجام دهد .

به طور مثال با استفاده از if مي تواند فرمولي نوشته كه اگر مقدار درست باشد عمليات مورد نظر انجام گيرد.

ابزار بعدي option button است كه كاربر هنگامي از آن استفاده مي كند كه يكي از گزينه ها را بايد الزاما انتخاب كند :

توجه كنيد كه اين ابزار يعني اپشن باتن يا كليد هاي راديويي تنها يك سلول اتصال ( cell link ) دارند يعني اگر چند تا از اينها كنار يكديگر يك گروه را تشكيل داده باشند ؛ تنها يك سلول انتخاب دارند كه نشان دهنده ي شماره آنست.

نوشته شده در یکشنبه هفدهم آبان 1388ساعت 10:51 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
سال نو قالب نو
سال نو همگی مبارک.

قالب جدید گذاشتم انشاالله که مورد پسند واقع شود....

نوشته شده در چهارشنبه بیست و ششم اسفند 1388ساعت 16:59 توسط علی توضیح |
دانلود تمرین گزارش گیری در اکسل پیشرفته- آنالیز داده ها
هرگاه بخواهیم از انبوهی از داده ها در اکسل گزارش تهیه کنیم کافی است تمرین زیر را دانلود کرده تا بیشتر به کارایی آن پی ببرید .

دانلود تمرین گزارش گیری

نوشته شده در چهارشنبه بیست و ششم اسفند 1388ساعت 14:2 توسط علی توضیح |
اتصال نقاط گسسته نمودار

برخی اوقات برای ترسیم یک نمودار نقاط مجهولی داریم که امکان یافتن آنها در دنیای واقعی نیست . برای اتصال نمودار و ایجاد یک جلوه ی بهتر ؛ می توان از تابع ()NA = استفاده کرد. کافی است این تابع را در جدول بجای نقاط مجهول قرار داد (بیضی های قرمز رنگ ).

لازم به ذکر است که این تابع درست شبیه آنچه در بالا نوشته شده بدون پارامتر و با علامت مساوی و پرانتزهای باز و بسته در سلول های خالی نوشته می شود.

نوشته شده در چهارشنبه بیست و ششم اسفند 1388ساعت 13:15 توسط علی توضیح |
حل تمرین ها data validation
تمرین ۱- ابتدا محدوده مورد نظر انتخاب شده :

مثلا ستون f

data \ data validation\ setting \ allow: \ custom \ formula \ =sum(f:f)>max(f:f)

تمرین 2 -

مثلا ستون e

data \ data validation\ setting \ allow: \ custom \ formula \ =countif(e:e,e1)<=1

نوشته شده در شنبه بیست و دوم اسفند 1388ساعت 9:28 توسط علی توضیح |
data validation
تمرین۱ : ساختاری طراحی کنید که همواره جمع داده هایش بیشتر از ماکزیمم آن باشد

با استفاده از data validation

تمرین۲ : ساختاری طراحی کنید که داده تکراری نپذیرد.( با استفاده از تابع countif)

نوشته شده در پنجشنبه ششم اسفند 1388ساعت 10:48 توسط علی توضیح |
تبدیل فایل های اکسل xls xlsx به exe
برخی از دوستان درباره تبدیل فایل های اکسل به exe پرسیدند :

یک سری سایت وجود داره که مدعی هستند فایل های اکسل xls xlsx را به exe تبدیل می کنند اما بنده تا به حال کار نکردم - موفق باشید.

نوشته شده در پنجشنبه ششم اسفند 1388ساعت 9:45 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
اکسل پیشرفته - نمودار های کیکی یا pie
یکی از نکات مهم در اکسل پیشرفته آشنایی با نمودار های پیشرفته pie است.این نمودارها تنها یک متغیر را با جزئیاتش ترسیم می کنند . یعنی کاربر مثلا درامد و زیرشاخه هایش را می تواند ترسیم کند و از مقایسه ی درآمد و هزینه با هم عاجز است . ( چون باید جمع جزئیات 100٪ شود - کل کیک )

این مدل از نمودار کیکی ؛ علاوه بر موارد مذکور قادر به دسته بندی نیز هست . یعنی می تواند دو یا تعدادی از پایین نمودار را با هم یک دسته قرار داده جدا ترسیم کند.

برای دسته بندی این نمودارها کافی است برروی یکی از بخش هی رنگی نمودار راست کلیک کرده گزینه ی

format data series را انتخاب کرده در بخش series option گزینه ی select plot contain the lasts عدد مورد نظر را انتخاب کنید .

مثلا اگر تهران دارای یک قسمت دیگر هم بود کافی است عدد 3 را وارد می کردیم.

نوشته شده در چهارشنبه بیست و هشتم بهمن 1388ساعت 11:56 توسط علی توضیح |
آموزش تصویری و مقدماتی اکسل
برای آموزش سریع و تصویری اکسل مقدماتی اینجا کلیک کنید

Microsoft Excel 2003 Tutorial - Excel Basics

نوشته شده در یکشنبه بیست و پنجم بهمن 1388ساعت 10:7 توسط علی توضیح |
Excel password - اکسل پیشرفته

برای مشاهده برنامه های رمز گذاری و رمز یابی در محیط اکسل و وی بی ای برروی لینک زیر کلیک کنید:

Excel password

نوشته شده در یکشنبه بیست و پنجم بهمن 1388ساعت 9:47 توسط علی توضیح |
تمرین توابع روند سازی trunc
با استفاده از توابع روند سازی ساختاری طراحی کنید که یک عدد حداکثر ۹ رقمی را رقم به رقم جدا کرده زیر هم قرار دهد

در ضمن این ساختار با استفاده از دو تابع متنی left , right نیز قابل طراحی می باشند.

نوشته شده در چهارشنبه هفتم بهمن 1388ساعت 9:27 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
ترسیم نمودار های دو ستونی در اکسل 2007 - اکسل پیشرفته
هرگاه دو مجموعه از داه های غیر همگون (یعنی اینکه داده های ترسیم شده با هم بسیار متفاوتند ) را برای ترسیم چارت داشته باشیم نمودار از شفافیت مناسبی برخوردار نخواهد شد .

همانطور که در تصویر ملاحظه می کنید جدول شامل سه ستون از داده هاست که اولین ستون x را برروی محور نشان داده و در دو ستون دیگر دو نوع مختلف داده ( یکی عددی و دیگری درصدی ) نمایش داده شده است . چون اختلاف عددی زیاد است نمودار آبی رنگ برروی کف محور قرار گرفته و شکل آن مشخص نیست . برای از بین بردن این مشکل کافی است هر نمودار را با یک محور عمودی مقایسه کرد.

برای ایجاد محور دوم کافی است نمودار مورد نظر را انتخاب کرده و سپس برروی آن راست کلیک نموده گزینه ی format data series را انتخاب کرده در series options گزینه ی second axies راانتخاب کنیم تا محور دوم ترسیم گردد.

حال می توان هر نمودار را با محور عمودی خودش مقایسه کرد .

نوشته شده در سه شنبه هفتم اردیبهشت 1389ساعت 9:0 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
تابع Trim - اکسل پیشرفته
برخی اوقات کاربران لیست هایی را تحویل می گیرند که از لحاظ کیفیت ورود داده در سطح پایینی قرار دارند و تحلیلگر باید زمان زیادی را برای تصحیح این لیست ها زمان صرف کند . یکی از موارد خطا در اینگونه لیست ها ورود یک داده به شکل های مختلف است . به طور مثال نام "علی توضیح" ممکن است با فاصله های مختلف در اطرافش نوشته شود : " علی توضیح " یا "علی توضیح" یا ... اینگونه ورود داده آنالیز لیست ها را خطا و اشتباه همراه می کند . لذا کاربر باید ابتدا داده های واحد را یکسان سازی کرده سپس آنالیز را آغاز کند .

یکی از بهترین توابعی که اکسل در اختیار کاربرانش قرار داده , تابع trim است . این تابع فواصل اضافی بین کلمات را حذف می کند . فواصل مجاز تنها بین هر کلمه یک space است .

=trim(" ali tozih ") => ali tozih

نوشته شده در پنجشنبه نوزدهم فروردین 1389ساعت 6:42 توسط علی توضیح |
فریز کردن در اکسل
یکی از مشکلاتی که بیشتر کاربران اکسل با آن برخورد می کنند ثابت کردن یا فریز کردن عناوین جداول است . این موضوع چه در کاربرگ و چه در چاپ مهم و پرکاربرد است .

الف - کاربرگ : هنگامی که یک کاربر با یک لیست طویل مواجه می شود زمان مشاهده ی انتهای لیست عناوین را از دست می دهد .

راه حل : کافی است سطری را که می خواهیم فریز کنیم در نظر گرفته سطر زیرین آنرا انتخاب کنیم سپس از مسیر زیر آنرا فریز کنیم :

excel 2007 : viwe\freeze panes \freeze panes

ب- چاپ : اگر بخواهیم این عناوین هنگام چاپ در بالای هر صفحه چاپ گردد از مسیر زیر حر کت می کنیم :

excel 2007 : page layout\print titles\rows to repaet at top

حال کافی است که سطر یا سطر های مورد نظر را انتخاب کنیم و کلید تایید را فشار دهیم .

نوشته شده در سه شنبه هفدهم فروردین 1389ساعت 8:24 توسط علی توضیح |
جستجوی سلول های رنگی در اکسل - find
برای یافتن سلول های رنگی همگون در اکسل می توان از مسیر مشخص شده در تصویر حرکت کرد :

Home/find & replace /find

درقسمت format دوگزینه مشاهده می شود یکی format که کاربر می تواند قالب مورد نظر را انتخاب کند و در حالت choose format from cell که کاربر تنها سلول رنگی مورد نظرش را با قطره چکان مکان نما انتخاب می کند .

حال کافی است کلید find all را فشار دهید تا تمام آنها را در کاربرگ sheet یا کارپوشه workbook بیابد .

نوشته شده در یکشنبه هشتم فروردین 1389ساعت 10:17 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
کلید های میانبر در اکسل 2007 SHORTCUT IN EXCEL 2007

Microsoft Excel 2007 shortcut and function keys

میانبرهایی که از ترکیب کلید کنترل اجرا می شوند

CTRL combination shortcut keys

Key

Description

CTRL+SHIFT+(

Unhides any hidden rows within the selection.آشکار سازی سطرهای پنهان شده در محدوده انتخاب شده

CTRL+SHIFT+)

Unhides any hidden columns within the selection.

CTRL+SHIFT+&

Applies the outline border to the selected cells.

CTRL+SHIFT_

Removes the outline border from the selected cells.

CTRL+SHIFT+~

Applies the General number format.

CTRL+SHIFT+$

Applies the Currency format with two decimal places (negative numbers in parentheses).

CTRL+SHIFT+%

Applies the Percentage format with no decimal places.

CTRL+SHIFT+^

Applies the Exponential number format with two decimal places.

CTRL+SHIFT+#

Applies the Date format with the day, month, and year.

CTRL+SHIFT+@

Applies the Time format with the hour and minute, and AM or PM.

CTRL+SHIFT+!

Applies the Number format with two decimal places, thousands separator, and minus sign (-) for negative values.

CTRL+SHIFT+*

Selects the current region around the active cell (the data area enclosed by blank rows and blank columns).

In a PivotTable, it selects the entire PivotTable report.

CTRL+SHIFT+:

Enters the current time.

CTRL+SHIFT+"

Copies the value from the cell above the active cell into the cell or the Formula Bar.

CTRL+SHIFT+Plus (+)

Displays the Insert dialog box to insert blank cells.

CTRL+Minus (-)

Displays the Delete dialog box to delete the selected cells.

CTRL+;

Enters the current date.

CTRL+`

Alternates between displaying cell values and displaying formulas in the worksheet.

CTRL+'

Copies a formula from the cell above the active cell into the cell or the Formula Bar.

CTRL+1

Displays the Format Cells dialog box.

CTRL+2

Applies or removes bold formatting.

CTRL+3

Applies or removes italic formatting.

CTRL+4

Applies or removes underlining.

CTRL+5

Applies or removes strikethrough.

CTRL+6

Alternates between hiding objects, displaying objects, and displaying placeholders for objects.

CTRL+8

Displays or hides the outline symbols.

CTRL+9

Hides the selected rows.

CTRL+0

Hides the selected columns.

CTRL+A

Selects the entire worksheet.

If the worksheet contains data, CTRL+A selects the current region. Pressing CTRL+A a second time selects the current region and its summary rows. Pressing CTRL+A a third time selects the entire worksheet.

When the insertion point is to the right of a function name in a formula, displays the Function Arguments dialog box.

CTRL+SHIFT+A inserts the argument names and parentheses when the insertion point is to the right of a function name in a formula.

CTRL+B

Applies or removes bold formatting.

CTRL+C

Copies the selected cells.

CTRL+C followed by another CTRL+C displays the Clipboard.

CTRL+D

Uses the Fill Down command to copy the contents and format of the topmost cell of a selected range into the cells below.

CTRL+F

Displays the Find and Replace dialog box, with the Find tab selected.

SHIFT+F5 also displays this tab, while SHIFT+F4 repeats the last Find action.

CTRL+SHIFT+F opens the Format Cells dialog box with the Font tab selected.

CTRL+G

Displays the Go To dialog box.

F5 also displays this dialog box.

CTRL+H

Displays the Find and Replace dialog box, with the Replace tab selected.

CTRL+I

Applies or removes italic formatting.

CTRL+K

Displays the Insert Hyperlink dialog box for new hyperlinks or the Edit Hyperlink dialog box for selected existing hyperlinks.

CTRL+N

Creates a new, blank workbook.

CTRL+O

Displays the Open dialog box to open or find a file.

CTRL+SHIFT+O selects all cells that contain comments.

CTRL+P

Displays the Print dialog box.

CTRL+SHIFT+P opens the Format Cells dialog box with the Font tab selected.

CTRL+R

Uses the Fill Right command to copy the contents and format of the leftmost cell of a selected range into the cells to the right.

CTRL+S

Saves the active file with its current file name, location, and file format.

CTRL+T

Displays the Create Table dialog box.

CTRL+U

Applies or removes underlining.

CTRL+SHIFT+U switches between expanding and collapsing of the formula bar.

CTRL+V

Inserts the contents of the Clipboard at the insertion point and replaces any selection. Available only after you have cut or copied an object, text, or cell contents.

CTRL+W

Closes the selected workbook window.

CTRL+X

Cuts the selected cells.

CTRL+Y

Repeats the last command or action, if possible.

CTRL+Z

Uses the Undo command to reverse the last command or to delete the last entry that you typed.

CTRL+SHIFT+Z uses the Undo or Redo command to reverse or restore the last automatic correction when AutoCorrect Smart Tags are displayed.

کلید های تابعی )F(

Function keys

Key

Description

F1

Displays the Microsoft Office Excel Help task pane.

CTRL+F1 displays or hides the ribbon.

ALT+F1 creates a chart of the data in the current range.

ALT+SHIFT+F1 inserts a new worksheet.

F2

Edits the active cell and positions the insertion point at the end of the cell contents. It also moves the insertion point into the Formula Bar when editing in a cell is turned off.

SHIFT+F2 adds or edits a cell comment.

CTRL+F2 displays the Print Preview window.

F3

Displays the Paste Name dialog box.

SHIFT+F3 displays the Insert Function dialog box.

F4

Repeats the last command or action, if possible.

CTRL+F4 closes the selected workbook window.

F5

Displays the Go To dialog box.

CTRL+F5 restores the window size of the selected workbook window.

F6

Switches between the worksheet, ribbon, task pane, and Zoom controls. In a worksheet that has been split (View menu, Manage This Window, Freeze Panes, Split Window command), F6 includes the split panes when switching between panes and the ribbon area.

SHIFT+F6 switches between the worksheet, Zoom controls, task pane, and ribbon.

CTRL+F6 switches to the next workbook window when more than one workbook window is open.

F7

Displays the Spelling dialog box to check spelling in the active worksheet or selected range.

CTRL+F7 performs the Move command on the workbook window when it is not maximized. Use the arrow keys to move the window, and when finished press ENTER, or ESC to cancel.

F8

Turns extend mode on or off. In extend mode, Extended Selection appears in the status line, and the arrow keys extend the selection.

SHIFT+F8 enables you to add a nonadjacent cell or range to a selection of cells by using the arrow keys.

CTRL+F8 performs the Size command (on the Control menu for the workbook window) when a workbook is not maximized.

ALT+F8 displays the Macro dialog box to create, run, edit, or delete a macro.

F9

Calculates all worksheets in all open workbooks.

SHIFT+F9 calculates the active worksheet.

CTRL+ALT+F9 calculates all worksheets in all open workbooks, regardless of whether they have changed since the last calculation.

CTRL+ALT+SHIFT+F9 rechecks dependent formulas, and then calculates all cells in all open workbooks, including cells not marked as needing to be calculated.

CTRL+F9 minimizes a workbook window to an icon.

F10

Turns key tips on or off.

SHIFT+F10 displays the shortcut menu for a selected item.

ALT+SHIFT+F10 displays the menu or message for a smart tag. If more than one smart tag is present, it switches to the next smart tag and displays its menu or message.

CTRL+F10 maximizes or restores the selected workbook window.

F11

Creates a chart of the data in the current range.

SHIFT+F11 inserts a new worksheet.

ALT+F11 opens the Microsoft Visual Basic Editor, in which you can create a macro by using Visual Basic for Applications (VBA).

F12

Displays the Save As dialog box.

سایر کلید ها در اکسل

Other useful shortcut keys

Key

Description

ARROW KEYS

Move one cell up, down, left, or right in a worksheet.

CTRL+ARROW KEY moves to the edge of the current data region (data region: A range of cells that contains data and that is bounded by empty cells or datasheet borders.) in a worksheet.

SHIFT+ARROW KEY extends the selection of cells by one cell.

CTRL+SHIFT+ARROW KEY extends the selection of cells to the last nonblank cell in the same column or row as the active cell, or if the next cell is blank, extends the selection to the next nonblank cell.

LEFT ARROW or RIGHT ARROW selects the tab to the left or right when the ribbon is selected. When a submenu is open or selected, these arrow keys switch between the main menu and the submenu. When a ribbon tab is selected, these keys navigate the tab buttons.

DOWN ARROW or UP ARROW selects the next or previous command when a menu or submenu is open. When a ribbon tab is selected, these keys navigate up or down the tab group.

In a dialog box, arrow keys move between options in an open drop-down list, or between options in a group of options.

DOWN ARROW or ALT+DOWN ARROW opens a selected drop-down list.

BACKSPACE

Deletes one character to the left in the Formula Bar.

Also clears the content of the active cell.

In cell editing mode, it deletes the character to the left of the insertion point.

DELETE

Removes the cell contents (data and formulas) from selected cells without affecting cell formats or comments.

In cell editing mode, it deletes the character to the right of the insertion point.

END

Moves to the cell in the lower-right corner of the window when SCROLL LOCK is turned on.

Also selects the last command on the menu when a menu or submenu is visible.

CTRL+END moves to the last cell on a worksheet, in the lowest used row of the rightmost used column. If the cursor is in the formula bar, CTRL+END moves the cursor to the end of the text.

CTRL+SHIFT+END extends the selection of cells to the last used cell on the worksheet (lower-right corner). If the cursor is in the formula bar, CTRL+SHIFT+END selects all text in the formula bar from the cursor position to the end—this does not affect the height of the formula bar.

ENTER

Completes a cell entry from the cell or the Formula Bar, and selects the cell below (by default).

In a data form, it moves to the first field in the next record.

Opens a selected menu (press F10 to activate the menu bar) or performs the action for a selected command.

In a dialog box, it performs the action for the default command button in the dialog box (the button with the bold outline, often the OK button).

ALT+ENTER starts a new line in the same cell.

CTRL+ENTER fills the selected cell range with the current entry.

SHIFT+ENTER completes a cell entry and selects the cell above.

ESC

Cancels an entry in the cell or Formula Bar.

Closes an open menu or submenu, dialog box, or message window.

It also closes full screen mode when this mode has been applied, and returns to normal screen mode to display the Ribbon and status bar again.

HOME

Moves to the beginning of a row in a worksheet.

Moves to the cell in the upper-left corner of the window when SCROLL LOCK is turned on.

Selects the first command on the menu when a menu or submenu is visible.

CTRL+HOME moves to the beginning of a worksheet.

CTRL+SHIFT+HOME extends the selection of cells to the beginning of the worksheet.

PAGE DOWN

Moves one screen down in a worksheet.

ALT+PAGE DOWN moves one screen to the right in a worksheet.

CTRL+PAGE DOWN moves to the next sheet in a workbook.

CTRL+SHIFT+PAGE DOWN selects the current and next sheet in a workbook.

PAGE UP

Moves one screen up in a worksheet.

ALT+PAGE UP moves one screen to the left in a worksheet.

CTRL+PAGE UP moves to the previous sheet in a workbook.

CTRL+SHIFT+PAGE UP selects the current and previous sheet in a workbook.

SPACEBAR

In a dialog box, performs the action for the selected button, or selects or clears a check box.

CTRL+SPACEBAR selects an entire column in a worksheet.

SHIFT+SPACEBAR selects an entire row in a worksheet.

CTRL+SHIFT+SPACEBAR selects the entire worksheet.

* If the worksheet contains data, CTRL+SHIFT+SPACEBAR selects the current region. Pressing CTRL+SHIFT+SPACEBAR a second time selects the current region and its summary rows. Pressing CTRL+SHIFT+SPACEBAR a third time selects the entire worksheet.

* When an object is selected, CTRL+SHIFT+SPACEBAR selects all objects on a worksheet.

ALT+SPACEBAR displays the Control menu for the Microsoft Office Excel window.

TAB

Moves one cell to the right in a worksheet.

Moves between unlocked cells in a protected worksheet.

Moves to the next option or option group in a dialog box.

SHIFT+TAB moves to the previous cell in a worksheet or the previous option in a dialog box.

CTRL+TAB switches to the next tab in dialog box.

CTRL+SHIFT+TAB switches to the previous tab in a dialog box.

منبع : راهنمای اکسل 2007

نوشته شده در یکشنبه هجدهم فروردین 1387ساعت 12:46 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
تکرار در اکسل 2010 - repeat all item labels
اگر در اکسل 2010 جدول محوری ترسیم کردید که یک گزارش خلاصه شده از داده های یک جدول را ارائه می کند . شما قادر خواهید بود داده های برچسب های آنرا در هر سطر تکرار کنید .این کار در اکسل 2010 ابراز مناسبی دارد به نام repeat all item labels در قسمتreport layout / design تب pivottable tools .

با استفاده از این شیوه شما قادرید جدول گزارشی ( محوری ) را به یک جدول دیگر داده تبدیل کرده و گزارشات مورد نیاز خود را با استفاده ار فیلترها و یا فرمول نویسی از آن استخراج کنید.

کافی است جدول را کپی کرده و عملیات فیلتر و یا فرمول نویسی را آغاز کنید .

نوشته شده در یکشنبه هجدهم مهر 1389ساعت 8:28 توسط علی توضیح |
پر کردن فضای خالی بین سلول های پر - ترفند 23
گاهی اوقات کاربران لیست هایی دریافت می کنند که داده های آن به صورت منظم پر نشده است .مثلا خروجی برخی از نرم افزار ها و جداول محوری از این گروهند . به تصویر زیر نگاه کنید :

سلول های خالی این بخش متعلق به سلول های پر بالای سرشان هستند . برای پر کردن آنها با سلول های بالایی مسیر زیر را به ترتیب طی می کنیم :

۱- ابتدا محدوه ی نام را انتخاب کرده

۲- سلول های خالی آنرا انتخاب می کنیم . ( برای اینکار کافی است کلید های ctrl +g را فشرده و سپس گزینه ی blanks را مطابق تصویر زیر انتخاب کنید )

۳- حال که سلول های خالی انتخاب شدند کافی است به اکسل بفهمانیم که ای سلول ها چگونه باید پر شوند. برای این منظور در همان حالی که سلول های خالی انتخاب شده اند علامت مساوی (=) را فشرده سلول بالایی را که حاوی داده (علی) است را انتخاب می کنیم .

۴- اکنون کافی است که با فشردن کلید ctrl+enterعملیات را تایید کنیم.

نوشته شده در یکشنبه چهارم مهر 1389ساعت 9:4 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
تابع پنهان datedif - اکسل پیشرفته
برخی از توابع اکسل در میان توابع تعریف شده ظاهر نمی شوند .از جمله ی این توابع ؛ تابع زیبای

datedif است که دو تاریخ را از کاربر گرفته و تفاوت های آنرا بر حسب روز ؛ ماه و سال نمایش می دهد.

=datedif( شاخص ; تاریخ بزرگتر ;تاریخ کوچکتر)

توجه کنید که هنگام تایپ این تابع ،راهنما برروی صفحه نمایش ظاهر نمی شود و کاربر باید نام تابع را به درستی تایپ کند

شاخص ها :

  • "Y": سال
  • "M" : ماه
  • "D" : روز

بین دو تاریخ را نشان می دهند

منبع : کتاب ترفند های اکسل - محمد حسن مهدوی

نوشته شده در دوشنبه سی و یکم خرداد 1389ساعت 8:59 توسط علی توضیح |
جمع بستن ساعات ها - اکسل پیشرفته
هر گاه چند سلول را که حاوی مقدار داده ای ساعت می باشد را با هم جمع کنیم اکسل به صورت پیش فرض آنها را دوباره با قالب ساعت نشان می دهد . به تصویر زیر دقت کنید . ستون جمع در حقیقت جمع ساعت های کارکرد سه ماه مهر و آبان و آذر است اما بجای اینکه جمع را نشان دهد ساعت را نشان می دهد .

برای رهایی از این مشکل کافی است سلول های حاوی جمع را با قالبی دیگر نمایش دهیم . برروی آنها راست کلیک کرده گزینه ی format cells و number و custom بخش hh:mm را انتخاب کرده ، در اطراف hh یک جفت علامت براکت قرار می دهیم ([hh])

منبع : کتاب ترفند های اکسل ( محمد حسن مهدوی )

نوشته شده در شنبه بیست و نهم خرداد 1389ساعت 14:4 توسط علی توضیح |
معرفی دو کتاب جدید از آقای مهدوی
معمولا کتاب های آقای مهدوی جزو بهترین کتاب های آموزشی اکسل و یا حتی اکسس محسوب می شوند . این دو کتاب جدید نیز از این قاعده مستثنی نیستند .

مدل سازی مالی در اکسل

ترجمه فصیح ومحتوای مناسب و غنی هر کاربری را به سمت خود جلب می کند. نشانی اینترنتی خرید کتابها :

http://www.adinebook.com/gp/product/9647826228/ref=sr_1_1000_17/982-9930533-8650635

http://www.adinebook.com/gp/product/9647826235/ref=sr_1_1000_18/982-9930533-8650635

نوشته شده در سه شنبه بیست و پنجم خرداد 1389ساعت 8:27 توسط علی توضیح |
تبدیل داده ها از افقی به عمودی
برای تبدیل حالت قرار گرفتن داده ها از افقی به عمودی یا برعکس دو روش را پیشنهاد می کنم:

۱- استفاده از paste special گزینه ی transpose. برای استفاده کافی است داده ها را کپی کرده و سپس بجای paste از paste special استفاده کنیم :

2- استفاده از تابع آرایه ای transpose . توجه داشته باشیم که برای اجرای این تابع الزاما باید کلید های

ctrl+shift+enter را با هم فشار دهید.

نوشته شده در سه شنبه بیست و پنجم خرداد 1389ساعت 8:13 توسط علی توضیح |
ایجاد علاقه برای کار با اکسل
گاهی لازم است برای ایجاد علاقه مندی بچه ها و دانش جویان از ابزارهای متفاوتی برای یادگیری اکسل استفاده کرد.برای مثال یک جدول ساده ی برنامه ی بازی های جام جهانی ۲۰۱۰ را برروی وبلاگ قرار دادم تا انگیزه ای باشد برای یادگیری بهتر و بیشتر اکسل توسط بچه ها.

دانلود فایل برنامه ها و پیش بینی باز یهای جام جهانی ۲۰۱۰ آفریقای جنوبی

نوشته شده در یکشنبه نهم خرداد 1389ساعت 12:30 توسط علی توضیح |
سایت فرساران آموزش تخصصی اکسل
آموزش Excel کتاب Excel توابع اکسل برنامه نویسی
نوشته شده در شنبه هشتم خرداد 1389ساعت 11:45 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
اکسل تحت وب یا google docs
شاید تا کنون این نیاز را داشته اید که یک کاربرگ اشتراکی با سایر همکاران و یا دوستانتان داشته باشید که هر نفر که شما مشخص می کنید قادر باشد داده ها را ببیند یا تغییر دهد.

گوگل متواضعانه این قابلیت را رایگان در اختیار کاربرانش قرار می دهد.ابتدا وارد اکانت مورد نظر در گوگل می شویم ( ترجیحا یک اکانت جدید و قابل اشتراک )سپس در قسمت more گزینه ی documents را انتخاب میکنیم.

در این بخش گوگل به شما اجازه می دهد تا یک صفحه گسترده یا spreadsheet ( شبیه اکسل - نه خود اکسل ) ایجاد کنید

اگر به تصاویر دقت کنید متوجه می شوید که این صفحه گسترده شباهت زیادی به اکسل دارد.البته همانطور که از آن انتظار می رود با شرایط تحت وب . مثلا شروع کارش با ۱۰۰ سطر است و ۲۰ ستون که این ارقام قابل افزایشند. اما مزیت این صفحه گسترده چیست؟

شما قادرید ایمیل دوستانتان را به گوگل دهید تا این پرونده را با آنها مشترک کند.

پس از ورود ایمیل دوستان و یا افرادی که قصد دارید آنها را دراین کاربرگ شریک کنید، گوگل تغیرات ثبت شده را بلافاصله به شما نشان خواهد داد.

لازم به ذکر است که دوستانتان پس از ورود به ایمیلشان ، دعوتنامه شما را مشاهده خواهند کرد و پس از ورود نام کاربری و کلمه ی عبور همان اکانت اشتراکی، به ویرایش کاربرگ مشغول خواهند شد.

این هم لینک راهنمای انگلیسی خود گوگل برای Google Docs

نوشته شده در دوشنبه بیست و نهم شهریور 1389ساعت 9:0 توسط علی توضیح |
استفاده از ابزار قدرتمند consolidate برای یکسان سازی داده ها
هرگاه در چند شیت یا کاربرگ جداولی با فیلد های مشابه داشته باشیم می توانیم از تمامی آنها در یک کاربرگ مجزا گزارش تهیه کنیم .

برای این منظور ابتدا وارد کاربرگ آخر ( گزارش ) می شویم که کاملا خالی است . حال از منوی data ابزار consolidate را فعال می کنیم.

ابتدا تابعی که قرار است برروی دادههای محاسباتی اعمال شود انتخاب می کنیم مثلا sum

حال محدوده ی داده ها مشخص می گردند و با کلید add به پنجره ی پایین منتقل میشوند.اگر جدول شما دارای عنوان است، گزینه های right column ,top row را علامت بزنید .

با فشردن کلید ok گزارشی از محدوده های انتخاب شده نمایش داده می شود.

نوشته شده در چهارشنبه هفدهم شهریور 1389ساعت 10:43 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
مطالب و کتاب های جدید
سایت پربار و زیبای فرساران مجددا به روز شده و بخش کتاب آن جزوات رنگی و زیبایی را برای دانلود قرار داده است.این سایت از گروهی متخصص استفاده می کند که شاید در بخش آفیس در کشور بینظیر باشند حتما این سایت را مشاهده کنید و از مطالبی که آقای مهندس میدانی و همکارن جوانشان در اختیار کاربران قرار می دهند استفاده کنید:

www.farsaran.ir

برای مشاهده کتب اینجا را کلیک کنید

با تشکر از این بچه ها و تمام کسانی که در راه تولید محتوا زحمت می کشند.

نوشته شده در سه شنبه سی ام آذر 1389ساعت 13:17 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
وبلاگ جدید اکسل

به سراغ وبلاگ زیر بروید نکات جالبی را برای یادگرفتن دارد .

http://exceluser.blogfa.com/

استفاده حرفه ای از اکسل

با آرزوی موفقیت برای نگارنده آن.

نوشته شده در شنبه چهاردهم اسفند 1389ساعت 8:54 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
دانلود کتاب تمام رنگی اکسل 2010
هنگام جستجو در اینترنت متوجه وجود یک ebook کامل و زیبا از اکسل 2010 شدم که در سایت پرتال دانلود قرار داشت .

لینک مستقیم دانلود این کتاب زیبا و کامل را از سایت پرتال دانلود برای تمام دوستان قرار می دهم تا این چند روز آخر هفته بدون منبع و کتاب نباشند :

دانلود کتاب اکسل 2010

excel 2010 - ebook

نوشته شده در پنجشنبه بیست و چهارم تیر 1389ساعت 11:11 توسط علی توضیح |
تبدیل واحدهای اندازه گیری در اکسل 2007 - توابع مهندسی

یکی از مزایای صفحه گسترده ی اکسل ، قابلیت تبدیل واحدهای اندازه گیری به یکدیگر است ، که در ساختار رشته های مهندسی بسیار پرکاربرد است .

تابع قدرتمند convert واحدهای ۱۰ گروه اندازه گیری را به یکدیگر تبدیل می کند. این گروه ها عبارتند از :

1- وزن و حجم

2- مسافت

3- زمان

4- فشار

5- نیرو

6- انرژی

7- توان

۸- جاذبه

۹- دما

۱۰- حجم مایعات

شکل این تابع به صورت زیر است :

=convert( واحد نهایی ; واحد اولیه ; مقدار )

مقدار مورد نظر را وارد کرده , واحد ها را با علامت گیوه و به ترتیب وارد می کنیم تا اکسل مقدار داده شده را از واحد اولیه بهواحد نهایی تبدیل کند.

مثال : فرض کنید می خواهیم بدانیم یک گرم چند پوند است ؟

به جدول راهنمای تابع نگاه کنید ، علامت اختصاری گرم "g" و پوند "lbm" است . این نکته مهم است که علامت های اختصاری انحصارا باید شبیه آنچه در راهنما ذکر شده است در تابع نوشته شوند ( کوچک و بزرگ بودن مهم است )

=convert(1;"g";"lbm") = 0.002205

  • microsoft excel help
CONVERT
Converts a number from one measurement system to another. For example, CONVERT can translate a table of distances in miles to a table of distances in kilometers.

Syntax

CONVERT(number,from_unit,to_unit)

Number is the value in from_units to convert.

From_unit is the units for number.

To_unit is the units for the result. CONVERT accepts the following text values (in quotation marks) for from_unit and to_unit.

1-Weight and mass | From_unit or to_unit
Gram | "g"
Slug | "sg"
Pound mass (avoirdupois) | "lbm"
U (atomic mass unit) | "u"
Ounce mass (avoirdupois) | "ozm"

2-Distance | From_unit or to_unit
Meter | "m"
Statute mile | "mi"
Nautical mile | "Nmi"
Inch | "in"
Foot | "ft"
Yard | "yd"
Angstrom | "ang"
Pica (1/72 in.) | "Pica"

3-Time | From_unit or to_unit
Year | "yr"
Day | "day"
Hour | "hr"
Minute | "mn"
Second | "sec"

4-Pressure | From_unit or to_unit
Pascal | "Pa" (or "p")
Atmosphere | "atm" (or "at")
mm of Mercury | "mmHg"

5-Force | From_unit or to_unit
Newton | "N"
Dyne | "dyn" (or "dy")
Pound force | "lbf"

6-Energy | From_unit or to_unit
Joule | "J"
Erg | "e"
Thermodynamic calorie | "c"
IT calorie | "cal"
Electron volt | "eV" (or "ev")
Horsepower-hour | "HPh" (or "hh")
Watt-hour | "Wh" (or "wh")
Foot-pound | "flb"
BTU | "BTU" (or "btu")

7-Power | From_unit or to_unit
Horsepower | "HP" (or "h")
Watt | "W" (or "w")

8-Magnetism | From_unit or to_unit
Tesla | "T"
Gauss | "ga"

9-Temperature | From_unit or to_unit
Degree Celsius | "C" (or "cel")
Degree Fahrenheit | "F" (or "fah")
Kelvin | "K" (or "kel")

10-Liquid measure | From_unit or to_unit
Teaspoon | "tsp"
Tablespoon | "tbs"
Fluid ounce | "oz"
Cup | "cup"
U.S. pint | "pt" (or "us_pt")
U.K. pint | "uk_pt"
Quart | "qt"
Gallon | "gal"
Liter | "l" (or "lt")

The following abbreviated unit prefixes can be prepended to any metric from_unit or to_unit.

Prefix | Multiplier | Abbreviation
exa | 1E+18 | "E"
peta | 1E+15 | "P"
tera | 1E+12 | "T"
giga | 1E+09 | "G"
mega | 1E+06 | "M"
kilo | 1E+03 | "k"
hecto | 1E+02 | "h"
dekao | 1E+01 | "e"
deci | 1E-01 | "d"
centi | 1E-02 | "c"
milli | 1E-03 | "m"
micro | 1E-06 | "u"
nano | 1E-09 | "n"
pico | 1E-12 | "p"
femto | 1E-15 | "f"
atto | 1E-18 | "a"

Remarks

  • If the input data types are incorrect, CONVERT returns the #VALUE! error value.
  • If the unit does not exist, CONVERT returns the #N/A error value.
  • If the unit does not support an abbreviated unit prefix, CONVERT returns the #N/A error value.
  • If the units are in different groups, CONVERT returns the #N/A error value.
  • Unit names and prefixes are case-sensitive.

Example

The example may be easier to understand if you copy it to a blank worksheet.

  1. Create a blank workbook or worksheet.
  2. Select the example in the Help topic.

    Note Do not select the row or column headers.

    Selecting an example from Help
  3. Press CTRL+C.
  4. In the worksheet, select cell A1, and press CTRL+V.
  5. To switch between viewing the results and viewing the formulas that return the results, press CTRL+` (grave accent), or on the Formulas tab, in the Formula Auditing group, click the Show Formulas button.
1
2
3
4
5
A | B
Formula | Description (Result)
=CONVERT(1.0, "lbm", "kg") | Converts 1 pound mass to kilograms (0.453592)
=CONVERT(68, "F", "C") | Converts 68 degrees Fahrenheit to Celsius (20)
=CONVERT(2.5, "ft", "sec") | Data types are not the same so an error is returned (#N/A)
=CONVERT(CONVERT(100,"ft","m"),"ft","m") | Converts 100 square feet into square meters (9.290304).

angstrom to yard calorie to volt celsius celsius to fahrenheit change from one pressure to another conversion tables conversion units convert convert celsius to fahrenheit convert distances convert energy measurements convert foot to inch convert from one time to another convert function convert gallons to liters convert KM to miles convert liquid measures convert minutes to seconds convert to a date convert to metric convert to other language convert to string convert weight and mass CONVERT WORKSHEET FUNCTION convert years to days date conversion dyne to pound force feet to meters fluid ounce to cup foot-pound to btu force conversion gallon to liter grams to ounce horsepower to watt hour to minute inch to foot inches to feet joule to erg kelvin to celsius kilometers to miles length units magnetism conversion meter to mile meter to pica metric conversion metric to English metric to english conversions METRIC TO IMPERIAL metric units newton to dyne pascal to atmosphere pascal to mm of mercury pint to quart pound to atomic mass unit teaspoon to tablespoon temperature equivalents tesla to gauss volume metric conversions what function can I use to convert from one unit of measure to another? xl

نوشته شده در چهارشنبه بیست و سوم تیر 1389ساعت 11:57 توسط علی توضیح |
تمرین - مرتب کردن اعداد درون یک ستون در ستونی دیگر به صورت خودکار
تمرین - فرض کنید درون ستون B اعدادی داریم که می خواهیم به صورت خودکار در ستون C مرتب شوند.

حل - ابتدا ستون A را به جدول اضافه کنید تا رتبه هر عدد در آن نوشته شود . حال از تابع large برای مرتب سازی بر اساس رتبه ها استفاده کرده آنها را مرتب می کنیم .

در مورد تابع large باید گفت که این تابع مجموعه ای از اعداد را از کاربر گرفته و سپس kامین عدد بزرگ آنرا نمایش می دهد.

شکل تابع :

=large( کاامین عنصر، مجموعه )

نکته مهم دیگر اینست که باید تمام مجموعه به صورت مطلق آدرس دهی شده باشد.

نوشته شده در پنجشنبه هفدهم تیر 1389ساعت 9:27 توسط علی توضیح |
حذف رکورد های تکراری در اکسل - remove duplicates
برای حذف رکورد های تکراری از یک جدول کافی است یک سلول از آنرا انتخاب کرده و از مسیر زیر حرکت کنیم :

data / data tools / remove duplicates

هنگام انتخاب این گزینه اکسل فرمی را نمایش می دهد که به کاربر امکان می دهد تا فیلدی از جدول را از مجموعه ی مقایسه حذف کند . به طور مثال اگر فیلد ردیف در میان جدول وجود داشت می توان آنرا حذف کرد.

یادمان باشد اکسل در این حالت به دنبال داده ی تکراری نمی گردد ، بلکه سعی می کند تا رکوردهای تکراری را یافته و حذف کند .

به تصویر زیر دقت کنید گرچه ما در لیست 2 نفر با نام های "علی توضیح" داریم، اما این دو با هم فرق دارند و دو نفر متفاوت هستند - به کد های شناسایی دقت کنید - بنابراین اکسل هیچ رکورد تکراری را یافت نمی کند.

اما اگر فیلد کد شناسایی را حذف کنیم ، هر دو "علی توضیح" حذف خواهند شد.

نوشته شده در پنجشنبه هفدهم تیر 1389ساعت 9:13 توسط علی توضیح |
نمایش اعداد منفی به صورت مثبت
برای نمایش اعداد منفی به صورت مثبت ( فقط نمایش) کافی است از مسیر زیر حرکت کنید :

format cells\number\currency\negative numbers

اما اگرخواهيم اين اعداد در باطن هم به شكل مثبت درآيند كافي است از تابع

=abs(num)

استفاده كنيم . اين تابع عدد منفي را به حالت مثبت منايش مي دهد

نوشته شده در شنبه دوازدهم تیر 1389ساعت 13:17 توسط علی توضیح |
پوزش
دوستان عزیز ظاهرا بخاطر فیلتر شدن سایت های میزبان ! تصاویر و قالب قابل مشاهده نیستند .به محض یافتن یک میزبان مطمئن تصاویر را بار گذاری خواهم کرد.

موفق باشید

نوشته شده در پنجشنبه دهم تیر 1389ساعت 8:38 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
ساخت یک گزارش پویا در اکسل 2010
بیشتر اوقات کاربران اکسل برای گزارش گیری از مجموعه ی عظیمی از داده ها در اکسل به مشکل برخورد می کنند. ابزار جداول محوری یا pivottables در اکسل این توانایی را در آنها ایجاد می کند.این ابزار به کاربران کمک می کند تا بر اساس فیلد ها گزارش تهیه کنند .

مثال- فرض کنید جدول شماره یک مجموعه ای از داده های مربوط به افراد یک کارگاه است که مرتب در حال دریافت و پرداخت میباشند . حال اگر بخواهیم گزارشی از تمام دریافتی ها ی همه کارکنان بیابیم به روش زیر اقدام می کنیم :

حل : ابتدا یک سلول از جدول داه را انتخاب کرده ، از منوی insert گزینه pivot tableرا انتخاب می کنیم .

با انتخاب محدوده جدول داده یا حتی بیشتر از آن ، اکسل متوجه فیلد ها و داده ها می گردد.

فیلد ها و منوی pivottable tools پدیدار می گردد و کاربر قادر است فیلدها را انتخاب کرده و عملیات محاسباتی خود را تغییر دهد.

هر جدول محوری دارای 4 بخش است .

1- ستون ها : که داده ها به صورت ستونی در جدول نمایش داده می شوند.

2- report : که اصلی ترین فیلد مجموعه محسوب می گردد و سایر فیلد ها زیر مجموعه ی آن محسوب می گردند.

3- سیگما : یا بخش محاسباتی جدول

4- ردیف ها : که داده ها به صورت سطری در جدول نمایش داده می شوند.

کافی است فیلد های مورد نظر را گرفته و به یکی از این چهار بخش بکشیم یا آنها را تیک بزنیم.

شکل جدول پدیدار می گردد و شما قادرید از گزارش ساخته شده اطلاعات بگیرید.

برخی اوقات به مشکل برخورد می کنیم . جدول محوری تفاوتی بین یک فیلد محاسباتی را با غیر آن به درستی درک نمی کند . در مثال زیر فیلد اتخاب شده سال به بخش محاسباتی منتقل شده است در حالیکه ما قصد جمع و ضرب آنرا نداریم و می خواهیم دریافتی افراد را طی سال های مختلف بررسی کنیم . بنابراین باید آنرا به بخش سطر ها کشید تا در کنار اسامی اطلاعات را شفافتر منتقل کنند.

خروجی جدول بیانگر دریافتی هر فرد طی سال های مورد نظر است .

لینک دانلود جدول و تمرین های بیشتر را در بخش تمرین جداول محوری در روز شانزدهم فروردین ۹۰ قرار داده ام. موفق باشید

نوشته شده در دوشنبه نهم خرداد 1390ساعت 9:2 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
توضیح بیشتر درباره تمرین قبل
در تمرین انبار از سه تابع match index , dsum استفاده شده است. همانطور که قبلا توضیح دادم دو تابع match , index برعکس یکدیگرند.

تایع index شماره ردیف داده را در یک مجموعه دریافت کرده خود داده را نمایش می دهد در حالیکه تابع match داده را دریافت کرده شماره ردیف آن در مجموعه را نمایش می دهد.

=index( شماره ردیف داده , مجموعه ) ====> data

=match ( data , مجموعه , type ) ======> data row

در این تمرین کافی است ابتدا با استفاده از تابع match شماره اولین ردیفی را که داده در آن نمایش داده شده را بیابید . با این کار شما قادر خواهید بود نام کالا را یافته و آنرا در سلولی دیگر نمایش دهید.

تابع dsum هم عملیات جمع را با شرط انجام می دهد . این تابع سه پارامتر دارد . ابتدا نشانی کل جدول را از کاربر گرفته ، شماره فیلدی را که قرار است عملیات جمع روی آن انجام گیرد را نیز دریافت می کند آنگاه با دریافت آدرس محدوده شرط ، عملیات جمع را انجام می دهد . نکته مهم آنست که آدرس محدوده ی شرط باید شامل عناوینی باشد که در آدرس کل جدول نیز وجود دارند. مثلا اگر شما می خواهید به دنبال جمع تعداد کالای خریداری شده بگردید ( فیلد شماره 6) باید محدوده شرط را طوری انتخاب کنید که کد کالا و شماره ی آن در محدوده ی شرط باشند ( m1 :m2 )

البته در تابع match پارامتر آخر دارای سه مقدار 0 و 1 و -1 است که بسته به نوع جستجو از آنها استفاده می کنیم :

1 برای جستجوی مقادیری کوچکتر از مقدار داده شده

0 برای جستجوی دقیق مقادیر داده شده

-1 برای جستجوی مقادیر بزرگتر از مقدار داده شده

نوشته شده در یکشنبه بیست و پنجم اردیبهشت 1390ساعت 14:7 توسط علی توضیح |
تمرین - یافتن داده ها روش استفاده از توابع match , dsum
در بسیاری از مواقع کاربران برای یافتن یک کالا یا شخص با استفاده از کد با مشکل روبرو می شوند و می خواهند بدون استفاده از vba نیز بر مشکل برطرف شود.

برای اینکار می توان از تابع match برای یافتن اولین ردیف از داده استفاده کرد و سپس نام داده را با استفاده از تابع index شناخت , بالاخره برای یافتن جمع ها از توابعی مانند dsum یا خانواده sumifs استفاده کرد. برای این منظور تمرین طراحی و با پاسخ در اختیار شما دوستان قرار می دهم تا بیشتر تمرین کنید.

تمرین - در جدول انبار ساختاری طراحی کنید که با نوشتن کد هر کالا شماره اولین ردیف ،نام کالا و سپس جمع خریداری شده و فروخته شده و مانده ی هر کالا را نمایش دهد.

دانلود فایل تمرین

نوشته شده در یکشنبه هجدهم اردیبهشت 1390ساعت 9:8 توسط علی توضیح |
طراحی جدول داده
توجه کاربران محترم اکسل را برای طراحی یک جدول به نکات زیر جلب می کنم:

۱- از گسستگی داده ها بپرهیزید . ( سطر یا ستون کاملا خالی در جدول نداشته باشید )

۲- از انجام عملیات merge بپرهیزید ( اینکار مانع از مرتب سازی و فیلترینگ صحیح داده ها در جدول می گردد)

3- تمام فیلد های مربوط به یک موضوع را در یک جدول قرار دهید تا قادر به دریافت اطلاعات صحیح تر باشید ( فیلدها همان ستون های جدولند )

4- فیلد های جدول حتما باید دارای عنوان باشند (هدر )

5- حتما سعی کنید از سمت ستون A جدول را طراحی کنید.

۶- از ورود داده های نامعتبر جلوگیری کنید ( validation).

7- از تخریب سلول هایی که نباید دستکاری شوند با protection جلوگیری کنید.

8- سعی کنید در بالای عناوین فیلدها محاسبات و سرجمع آنهارا نشان دهید( subtotal ) نه در پایین جدول

9- هر چه بیشتر فیلد در جدول شما باشد گزارشات شما دقیقتر و بنابراین اطلاعات شما صحیحتر خواهد بود (pivottable).

۱۰-منطق ورود داده را فراموش نکنید ( جایی که قرار است نام وارد شود فامیل وارد نکنیم )

نوشته شده در سه شنبه سیزدهم اردیبهشت 1390ساعت 13:48 توسط علی توضیح |
روز معلم مبارک
تقدیم به همه معلمان مربیان آموزگاران اساتید و...

روزگاری است که سودای بتان دین من است غم اینکار نشاط دل غمگین من است

دیدن روی تو را دیده ی جان بین باید وین کجا مرتبه چشم جهان بین من است

یار من باش که زیب فلک و زینت دهر از مه روی تو و اشک چو پروین من است

تا مرا عشق تو تعلیم سخن گفتن داد خلق را ورد زبان مدحت و تحسین من است

دولت فقر خدایا به من ارزانی دار کاین کرامت سبب حشمت و تمکین من است

یا رب آن کعبه مقصود تماشاگه کیست ؟ که مغیلان طریقش گل و نسرین من است

واعظ شحنه شناس این عظمت گو مفروش زانکه منزلگه سلطان دل مسکین من است

حافظ از حشمت پرویز دگر قصه مخوان که لبش جرعه کش خسرو و شیرین من است

نوشته شده در سه شنبه سیزدهم اردیبهشت 1390ساعت 13:0 توسط علی توضیح |
تمرین مدیریت داده -اکسل پیشرفته
تمرین - فرض کنید یک لیست از شماره های دانشجویی یک کلاس داریم و می خواهیم نمره ی هر دانشجو را در جلوی شماره اش وارد کنیم .فرمی لازم داریم تا با تایپ شماره دانشجویی آنرا در فهرست یافته و پس از ورود نمره آنرا در مقابلش ثبت کرده َ شماره دانشجویی بعدی را از کاربر بگیرد.

پاسخ: ابتدا یک سلول از جدول انتخاب شود.سپس ابزار form را از بخش ابزار های اکسل :

QAT\MORE COMMANDS \ ALL COMMANDS\FORM..

انتخاب می کنیم. حال با انتخاب این ابزار کاربر قادر است بسیاری از قابلیت های یک فرم ساده در ورود و نمایش داده ها را استفاده کند.

با فشردن کلید CRITERIA کاربر می تواند شرط مورد نظر را وارد کند . مثلا شماره دانشجویی. حال با فشردن کلید اینتر رکورد مورد نظر یافت شده می توانید داده متناظر آنرا وارد نمایید. اگر در حالت شرط ( CRITERIA ) باشید بجای این کلمه گزینه FORM فعال است.

با کلید NEW می توانید رکورد جدید وارد کنید و با کلید های NEXT , PREV هم به رکوردهای قبل و بعد وارد میشوید.

نوشته شده در پنجشنبه هشتم اردیبهشت 1390ساعت 9:38 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
نمودارهای اسپارک ( جرقه ای ) - sparklines excel 2010
گاهی اوقات لازم است کاربران همانطور که داده ها را مشاهده می کنند نمودارهای رشد و روند های آنها را نیز به صورت آنلاین شاهد باشند.

یکی از این ابزار که در اکسل ۲۰۱۰ طراحی شده است نمونه کوچک ( جرقه ای ) نمودارهای اصلی است که در بخش insert گزینه sparklines قرار داده شده است. برای ترسیم یک نمودار spark کافی است داده هایی که قرار است ترسیم شوند را انتخاب کرده یکی از انواع spark را کلیک کنیم . آنگاه محل قرار گیری جرقه را انتخاب کنیم تا نمودار در محل مورد نظر قرار گیرد.

ادامه مطلب
نوشته شده در دوشنبه بیست و چهارم آبان 1389ساعت 9:54 توسط علی توضیح |
آشنایی با تابع Indirect در اکسل - Excel
شهادت اما محمد باقر( ع ) شکافنده و مرزبان علوم نبوی بر دوستداران علم و اندیشه تسلیت باد:

چیزی با چیزی نیامیخته است که بهتر از حلم با علم باشد .

بحارالانوار ، دار احیاء الترا العربی ، ج 75، ص(172)

کار تابع indirect اینست که محتویات درونش را که یک آدرس است به تابع بعدی انتقال می دهد تا محتویات ادرس مذکور را نمایش دهد.درحقیقت به صورت غیر مستقیم مقدار یک سلول را انتقال می دهد.

مثلا فرض کنید در سلول g5 نشانی سلول a1 را نوشته اید، حال اگر در یک سلول دیگر فرمول زیر را بنویسید آن سلول محتویات a1 را نشان می دهد:

=indirect(g5)

به تصویر زیر دقت کنید

حل یک مثال با این تابع : محدود های از اعداد را در ستون a تا c داریم و می خواهیم با تغییر اعداد سطر محدوده جمع نیز تغییر کند . فرمول :

=SUM(INDIRECT("a"&G2&":c"&I2))

را می نویسیم تا تابع indirect سطر 2 تا 10 را در ستون های a تا c به تابع جمع ارسال کند.

نوشته شده در یکشنبه بیست و سوم آبان 1389ساعت 9:21 توسط علی توضیح |
کتاب جدید مجموعه کلید - کلید جدول، نمودار و ابزار گرافیکی در Excel همراه با CD
باز هم کتاب جدید مجموعه کلید کتابی زیبا غنی و پر از مطالب خواندنی است. این کتاب که در مباحث نمودارها و جداول و ساماندهی داهها و ... مطلب دارد توسط آقای مهندس محمد تقی مروج نگاشته شده است . همراه این کتاب سی دی آموزشی نیز ضمیمه شده است که تمارین درون کتاب به همراه تصاویر و فیلم نمایش داده شده است.

نکاتی که می توان در این کتاب یافت :

رسم نمودار درکل فراینده ساده ایست اما نکته های فراوانی در آن نهفته است که در این کتاب و در قالب پروژه ها و همچنین تمرین های مهم این نکته ها آموزش داده شده اند.

منظور از ابزار های گرافیکی چیست ؟
ابزار های متنوع و قدرتمندی در اکسل وجود دارند که برای بکار گیری آنها نه از فرمول نویسی، بلکه از دستورها و ابزار های موجود در نوار ابزار و با منوها استفاده می شود. ابزارهایی مانند مرتب سازی داده ها، پالایش داده ها، قالب بندی شرطی، حفاظت از داده ها، سنجش درستی داده های ورودی و بسیار موارد دیگر. از آنجا که استفاده از این ابزار به صورت گرافیکی انجام می شود نام عمومی ابزارد گرافیکی را برای آن انتخاب کرده ایم.

این کتاب برای چه کسانی مناسب است ؟
اگر یک آشنایی ابتدایی نیز با اکسل داشته باشید می توانید به خوبی از این کتاب برای بالا بردن سطح مهارتتان استفاده کنید. اما اگر مفاهیم پایه را یاد بگیرید (مانند مفهوم آدرس های نسبی و مطلق که در کتاب کلید اکسل 2007 آموزش داده شده اند) بی شک بهره بیشتری از مطالب خواهید برد. ولی برای تبددیل شدن به یک کاربر قدرتمند در اکسل، لازم است که در کنار این کتاب، فرمول نویسی را نیز به خوبی یاد بگیرید تا بتوانید با ترکیب آن با ابزار های گرافیکی به اوج قدرت در اکسل برسید و بتوانید انواع مسایل حرفه ای که با آنها روبرو می شوید را حل کنید. و آنگاه با ما هم عقیده خواهید شد که نرم افزار اکسل، یکی از بی نظیر ترین، قدرتمندترین و پرکاربردترین نرم افزار هاییست که تا کنون ساخته شده است.

برای مشاهده و مطرح کردن سوالات پیرامون موضوع این کتاب، روی این نوشته کلیک کنید.

مولف/مترجم :
محمد تقي مروج

تعداد صفحات :
152

قطع :
رقعي

خرید از سایت کلید آموزش : www.kelidshop.com

نوشته شده در شنبه بیست و دوم آبان 1389ساعت 14:40 توسط علی توضیح |
گزارش گیری از چند کاربرگ مختلف - muliple consolidation ranges in pivottable
فرض کنید در چند کاربرگ جداولی با فیلدهای شبیه هم داریم اما داده ها متفاوتند مثلا هر کاربرگ مربوط به عملیات مالی یک ماه از سال است و در هر جدول داده های افراد در آن ماه ها وارد شده است . حال قصد دارید که کز هر فرد طی ماه های مورد نظر گزارش تهیه کنید.

ابتدا باید یک سلول از یکی از جداول را انتخاب کرد و سپس از ویزار جداول محوری مرحله به مرحله جلو رفت .

Alt + D + P را باید فشرد تا پنجره ی ویزارد نمایان شود . ابتدا گزینه muliple consolidation ranges را انتخاب می کنیم

حال اگر مایلید فیلد ها را در جدول به صورت report مشاهده کنید می توانید آنها را انتخاب کنید

محدوده هایی از جداول که باید برای گزارش ارسال شوند را انتخاب و سپس add می کنیم.

توجه کنید که فیلدی که می خواهید بر اساس آن گزارش تهیه کنید باید ، اولین فیلد باشد .

با اتمام عملیات ویزارد گزارشی از دریافتی های تمتم پرسنل ماههای انتخاب شده به شما نشان داده می شود.

نوشته شده در چهارشنبه نوزدهم آبان 1389ساعت 9:15 توسط علی توضیح |
فایل تمرین گروه اکسل پیشرفته تابع subtotal
این فایل را از اینجا دانلود کنید و سپس تمرین های زیر را حل کنید : ( فایل فشرده شده است )

۱- بیشترین دریافتی های رضا در جدول شماره یک در نیمه اول سال ۸۲ چقدر است؟

۲- جمع تعداد چکش خریداری شده و فروخته شده در جدول شماره دو چقدر است ؟

۳- میانگین مبلغ فروش پاکن توسط فروشگاه کوچولو چقدر است ؟

تمرین های فوق از روش subtotal حل شوند .

نوشته شده در سه شنبه چهارم آبان 1389ساعت 9:34 توسط علی توضیح |
تزریق یک فایل اکسل به اوت لوک 2010
فرض کنید از شماره تلفن های موبایلتان یک نسخه کپی گرفته اید و می خواهید فایل اکسل آنرا به اوت لوک تزریق کنید تا با استفاده از امکانات آن با استفاده از یک خط تلفن و یک مودم َ با دوستانتان تماس حاصل کنید.

مراحل تزریق( import ) داده های اکسل به اوت لوک ( outlook ):

1- ابتدا اوت لوک 2010 را باز کرده : file / open / import

گزینه import from another program or file رااتنخاب می کنیم:

نوع فایل را اکسل انتخاب می کنیم ( در اوت لوک 2010 هنوز گزینه اکسل 2010 موجود نیست )

فایل مورد نظر را انتخاب می کنیم.در این مرحله نوع تکرار رکوردها را نیز تعیین می کنیم.

گزینه تماس ها contacts را انتخاب می کنیم تا داده ها به صورت دفترچه تلفن ذخیره شوند

حال باید نقشه ی اتصال را به درستی تهیه کرد . در این قسمت اوت لوک عناوین ستون ها در فایل اکسل را به فیلد های دفترچه تلفنش لینک می کند.

باید مثل اکسس آنها را درگ کرد.

حال دفترچه تلفن حاضر است . می توانید از آن برای تماس با شماره های آن بدون استفاده از دستگاه تلفن استفاده کرد.

فرد مورد نظر را جستجو کرده ، سپس شماره انرا از منوی home گزینه more یافته یا برروی آن دبل کلیک می کنیم.

برای جستجو هم کلید های ctrl + e را استفاده می کنیم.

نوشته شده در یکشنبه دوم آبان 1389ساعت 8:22 توسط علی توضیح |
جمع بستن ساعات ها - اکسل پیشرفته -( تکراری )
هر گاه چند سلول را که حاوی مقدار داده ای ساعت می باشد را با هم جمع کنیم اکسل به صورت پیش فرض آنها را دوباره با قالب ساعت نشان می دهد . به تصویر زیر دقت کنید . ستون جمع در حقیقت جمع ساعت های کارکرد سه ماه مهر و آبان و آذر است اما بجای اینکه جمع را نشان دهد ساعت را نشان می دهد .

برای رهایی از این مشکل کافی است سلول های حاوی جمع را با قالبی دیگر نمایش دهیم . برروی آنها راست کلیک کرده گزینه ی format cells و number و custom بخش hh:mm را انتخاب کرده ، در اطراف hh یک جفت علامت براکت قرار می دهیم ([hh])

منبع : کتاب ترفند های اکسل ( محمد حسن مهدوی )

نوشته شده در یکشنبه دوم آبان 1389ساعت 7:37 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
<-BlogAndPostTitle->
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ

POWERED BY ight="20">


تبليغات X
آشنایی بیشتر با format cells در اکسل 2007
حتما شما هم می دانید که با فشردن کلید های کنترل و عدد یک پنجره ی ابزار format cells در اکسل فعال می شود .یکی از توانایی های این بخش در قالب بندی اعداد، گزینه ی custom است که شما را قادر می سازد اعداد را با قالب بندی دلخواه نمایش دهید.

این بخش شامل 4 قسمت است که با علامت سیمی کالن ( ; ) از هم جدا می شوند و به ترتیب به اعداد مثبت - اعداد منفی - صفر و متن اختصاص دارند.تعدادی علامت در این بخش وجود دارد که با استفاده از آنها می توان قالب مورد نظر را صدا زد . در حقیقت نوعی کد نویسی با استفاده از این علائم. مثلا علامت # و علامت ؟ و عدد 0 و یا علامت اعشار (.) .

این علائم در بخش قالب بندی اعداد ما را یاری می کنند. مثلا کاربر می نویسد :

0.0;-0.0;;@

مفهوم این علائم اینست که ( از سمت چپ) اعداد مثبت را با یک اعشار بنویس ، اعداد منفی را نیز همینطور در ضمن علامت منفی را هم قرار بده ، صفر را اصلا نمایش نده ( بین دو سیمی کالن فضای خالی نیست ) ،و برای متن هم هرانچه نوشته شد نمایش بده.

مطالب زیر را از سایت مایکروسافت بخوانید نکات جالبی را مطرح کرده است :

Review guidelines for customizing a number format

To create a custom number format, you start by selecting one of the built-in number formats as a starting point. You can then change any one of the code sections of that format to create your own custom number format.

A number format can have up to four sections of code, separated by semicolons. These code sections define the format for positive numbers, negative numbers, zero values, and text, in that order.

>;;;

For example, you can use these code sections to create the following custom format:

[Blue]#,##0.00_);[Red](#,##0.00);0.00;"sales "@

You do not have to include all code sections in your custom number format. If you specify only two code sections for your custom number format, the first section is used for positive numbers and zeros, and the second section is used for negative numbers. If you specify only one code section, it is used for all numbers. If you want to skip a code section and include a code section that follows it, you must include the ending semicolon for the section that you skip.

The following guidelines should be helpful for customizing any of these number format code sections.

Guidelines for including text and adding spacing

  • Display both text and numbers To display both text and numbers in a cell, enclose the text characters in double quotation marks (" ") or precede a single character with a backslash (\). Include the characters in the appropriate section of the format codes. For example, type the format $0.00" Surplus";$-0.00" Shortage" to display a positive amount as "$125.74 Surplus" and a negative amount as "$-125.74 Shortage." Note that there is one space character before both "Surplus" and "Shortage" in each code section.

The following characters are displayed without the use of quotation marks.

$ | Dollar sign
+ | Plus sign
( | Left parenthesis
: | Colon
^ | Circumflex accent (caret)
' | Apostrophe
{ | Left curly bracket
< | Less-than sign
= | Equal sign
- | Minus sign
/ | Slash mark
) | Right parenthesis
! | Exclamation point
& | Ampersand
~ | Tilde
} | Right curly bracket
> | Greater-than sign
 | Space character
  • Include a section for text entry If included, a text section is always the last section in the number format. Include an "at" character (@) in the section where you want to display any text that you type in the cell. If the @ character is omitted from the text section, text that you type will not be displayed. If you want to always display specific text characters with the typed text, enclose the additional text in double quotation marks (" "). For example, "gross receipts for "@

If the format does not include a text section, any nonnumeric value that you type in a cell with that format applied is not affected by the format. In addition, the entire cell is converted to text.

  • Add spaces To create a space that is the width of a character in a number format, include an underscore character (_), followed by the character that you want to use. For example, when you follow an underscore with a right parenthesis, such as _), positive numbers line up correctly with negative numbers that are enclosed in parentheses.
  • Repeat characters To repeat the next character in the format to fill the column width, include an asterisk (*) in the number format. For example, type 0*- to include enough dashes after a number to fill the cell, or type *0 before any format to include leading zeros.

Guidelines for using decimal places, spaces, colors, and conditions

  • Include decimal places and significant digits To format fractions or numbers that contain decimal points, include the following digit placeholders, decimal points, and thousand separators in a section.
0 (zero) | This digit placeholder displays insignificant zeros if a number has fewer digits than there are zeros in the format. For example, if you type 8.9, and you want it to be displayed as 8.90, use the format #.00.
# | This digit placeholder follows the same rules as the 0 (zero). However, Excel does not display extra zeros when the number that you type has fewer digits on either side of the decimal than there are # symbols in the format. For example, if the custom format is #.##, and you type 8.9 in the cell, the number 8.9 is displayed.
? | This digit placeholder follows the same rules as the 0 (zero). However, Excel adds a space for insignificant zeros on either side of the decimal point so that decimal points are aligned in the column. For example, the custom format 0.0? aligns the decimal points for the numbers 8.9 and 88.99 in a column.
. (period) | This digit placeholder displays the decimal point in a number.
  • If a number has more digits to the right of the decimal point than there are placeholders in the format, the number rounds to as many decimal places as there are placeholders. If there are more digits to the left of the decimal point than there are placeholders, the extra digits are displayed. If the format contains only number signs (#) to the left of the decimal point, numbers less than 1 begin with a decimal point; for example, .47.
To display | As | Use this code
1234.59 | 1234.6 | ####.#
8.9 | 8.900 | #.000
.631 | 0.6 | 0.#
12 1234.568 | 12.0 1234.57 | #.0#
44.398 102.65 2.8 | 44.398 102.65 2.8 (with aligned decimals) | ???.???
5.25 5.3 | 5 1/4 5 3/10 (with aligned fractions) | # ???/???
  • Display a thousands separator To display a comma as a thousands separator or to scale a number by a multiple of 1,000, include the following separator in the number format.
, (comma) Displays the thousands separator in a number. Excel separates thousands by commas if the format contains a comma that is enclosed by number signs (#) or by zeros. A comma that follows a digit placeholder scales the number by 1,000. For example, if the format is #.0,, and you type 12,200,000 in the cell, the number 12.200.0 is displayed.
To display | As | Use this code
12000 | 12,000 | #,###
12000 | 12 | #,
12200000 | 12.2 | 0.0,,
  • Specify colors To specify the color for a section of the format, type the name of one of the following eight colors enclosed in square brackets in the section. The color code must be the first item in the section.
[Black]
[Green]
[White]
[Blue]
[Magenta]
[Yellow]
[Cyan]
[Red]
  • Specify conditions To specify number formats that will be applied only if a number meets a condition that you specify, enclose the condition in square brackets. The condition consists of a comparison operator (comparison operator: A sign that is used in comparison criteria to compare two values. Operators include: = Equal to, > Greater than, < Less than, >= Greater than or equal to, <= Less than or equal to, and <> Not equal to.) and a value. For example, the following format displays numbers that are less than or equal to 100 in a red font and numbers that are greater than 100 in a blue font.

[Red][<=100];[Blue][>100]

To apply conditional formats (conditional format: A format, such as cell shading or font color, that Excel automatically applies to cells if a specified condition is true.) to cells (for example, color shading that depends on the value of a cell), on the Home tab, in the Styles group, click Conditional Formatting.

Guidelines for currency, percentages, and scientific notation format

  • Include currency symbols To type one of the following currency symbols in a number format, press NUM LOCK and use the numeric keypad to type the ANSI code for the symbol.
To enter | Press this code
¢ | ALT+0162
£ | ALT+0163
¥ | ALT+0165
euro | ALT+0128

  • Note Custom formats are saved with the workbook. To have Excel always use a specific currency symbol, you must change the currency symbol that is selected in the Regional Options in Control Panel before you start Excel.

  • For information about how to change Regional Options, see Change the default date, time, number or measurement format..
  • Display percentages To display numbers as a percentage of 100 — for example, to display .08 as 8% or 2.8 as 280% — include the percent sign (%) in the number format.
  • Display scientific notations To display numbers in scientific (exponential) format, use the following exponent codes in a section.
E (E-, E+, e-, e+) Displays a number in scientific (exponential) format. Excel displays a number to the right of the "E" or "e" that corresponds to the number of places that the decimal point was moved. For example, if the format is 0.00E+00, and you type 12,200,000 in the cell, the number 1.22E+07 is displayed. If you change the number format to #0.0E+0, the number 12.2E+6 is displayed.

Guidelines for date and time formats

  • Display days, months, and years To display numbers as date formats (such as days, months, and years), use the following codes in a section.
m | Displays the month as a number without a leading zero.
mm | Displays the month as a number with a leading zero when appropriate.
mmm | Displays the month as an abbreviation (Jan to Dec).
mmmm | Displays the month as a full name (January to December).
mmmmm | Displays the month as a single letter (J to D).
d | Displays the day as a number without a leading zero.
dd | Displays the day as a number with a leading zero when appropriate.
ddd | Displays the day as an abbreviation (Sun to Sat).
dddd | Displays the day as a full name (Sunday to Saturday).
yy | Displays the year as a two-digit number.
yyyy | Displays the year as a four-digit number.
To display | As | Use this code
Months | 1–12 | m
Months | 01–12 | mm
Months | Jan–Dec | mmm
Months | January–December | mmmm
Months | J–D | mmmmm
Days | 1–31 | d
Days | 01–31 | dd
Days | Sun–Sat | ddd
Days | Sunday–Saturday | dddd
Years | 00–99 | yy
Years | 1900–9999 | yyyy
  • Display hours, minutes, and seconds To display time formats (such as hours, minutes, and seconds), use the following codes in a section.
h | Displays the hour as a number without a leading zero.
[h] | Displays elapsed time in hours. If you are working with a formula that returns a time in which the number of hours exceeds 24, use a number format that resembles [h]:mm:ss.
hh | Displays the hour as a number with a leading zero when appropriate. If the format contains AM or PM, the hour is based on the 12-hour clock. Otherwise, the hour is based on the 24-hour clock.
m | Displays the minute as a number without a leading zero. Note The m or mm code must appear immediately after the h or hh code or immediately before the ss code; otherwise, Excel displays the month instead of minutes.
[m] | Displays elapsed time in minutes. If you are working with a formula that returns a time in which the number of minutes exceeds 60, use a number format that resembles [mm]:ss.
mm | Displays the minute as a number with a leading zero when appropriate. Note The m or mm code must appear immediately after the h or hh code or immediately before the ss code; otherwise, Excel displays the month instead of minutes.
s | Displays the second as a number without a leading zero.
[s] | Displays elapsed time in seconds. If you are working with a formula that returns a time in which the number of seconds exceeds 60, use a number format that resembles [ss].
ss | Displays the second as a number with a leading zero when appropriate. If you want to display fractions of a second, use a number format that resembles h:mm:ss.00.
AM/PM, am/pm, A/P, a/p | Displays the hour using a 12-hour clock. Excel displays AM, am, A, or a for times from midnight until noon and PM, pm, P, or p for times from noon until midnight.
To display | As | Use this code
Hours | 0–23 | h
Hours | 00–23 | hh
Minutes | 0–59 | m
Minutes | 00–59 | mm
Seconds | 0–59 | s
Seconds | 00–59 | ss
Time | 4 AM | h AM/PM
Time | 4:36 PM | h:mm AM/PM
Time | 4:36:03 P | h:mm:ss A/P
Time | 4:36:03.75 | h:mm:ss.00
Elapsed time (hours and minutes) | 1:02 | [h]:mm
Elapsed time (minutes and seconds) | 62:16 | [mm]:ss
Elapsed time (seconds and hundredths) | 3735.80 | [ss].00

Top of Page Top of Page

Create a custom number format

  1. Open the workbook in which you want to create and store a custom number format.
  2. On the Home tab, click the Dialog Box Launcher Button image next to Number.

Excel Ribbon Image

  3. In the Category box, click Custom.
  4. In the Type list, select the number format that you want to customize.

The number format that you select appears in the Type box above the Type list.

Note When you select a built-in number format in the Type list, Excel creates a copy of that number format that you can then customize. The original number format in the Type list cannot be changed or deleted.

  5. In the Type box, make the necessary changes to the selected number format.

Tip For more information about the changes that you can make, see Review guidelines for customizing a number format in this article.

Note A custom number format is stored in the workbook in which it was created and will not be available in any other workbooks. To use a custom format in a new workbook, you can save the current workbook as an Excel template that you can use as the basis for the new workbook.

For more information, see Create and use an Excel template.

Top of Page Top of Page

Delete a custom number format

  1. Open the workbook that contains the custom number format that you want to delete.
  2. On the Home tab, click the Dialog Box Launcher Button image next to Number.

Excel Ribbon Image

  3. In the Category box, click Custom.
  4. In the Type list, select the custom number format that you want to delete.

Note Built-in number formats in the Type list cannot be deleted.

  5. Click Delete.

Note Any cells in the workbook that were formatted with the deleted custom format will be displayed in the default General format.

نوشته شده در یکشنبه بیست و ششم دی 1389ساعت 12:49 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
معرفی امکانات جدید اکسل 2012
گروه فعال سایت فرساران بازهم مطلبی جدید را درباره اکسل ۲۰۱۲ ارائه نموده که خواندن آنرا به همه توصیه می کنم.

این مطلب را می توانید از لینک زیر مشاهده کنید.

http://farsaran.ir/Excel%202012%20News

با عضویت در این سایت غنی مطالب جدید را به صورت مرتب با ایمیل دریافت کنید.

باز هم از زحمات گروه فعال فرساران و جناب آقای مهندس فرشید میدانی تشکر می کنیم .

www.farsaran.ir

نوشته شده در پنجشنبه سی ام تیر 1390ساعت 12:5 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
حل تمرین ها data validation
تمرین ۱- ابتدا محدوده مورد نظر انتخاب شده :

مثلا ستون f

data \ data validation\ setting \ allow: \ custom \ formula \ =sum(f:f)>max(f:f)

تمرین 2 -

مثلا ستون e

data \ data validation\ setting \ allow: \ custom \ formula \ =countif(e:e,e1)<=1

نوشته شده در شنبه بیست و دوم اسفند 1388ساعت 9:28 توسط علی توضیح |
data validation
تمرین۱ : ساختاری طراحی کنید که همواره جمع داده هایش بیشتر از ماکزیمم آن باشد

با استفاده از data validation

تمرین۲ : ساختاری طراحی کنید که داده تکراری نپذیرد.( با استفاده از تابع countif)

نوشته شده در پنجشنبه ششم اسفند 1388ساعت 10:48 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
تمرین مدیریت داده -اکسل پیشرفته
تمرین - فرض کنید یک لیست از شماره های دانشجویی یک کلاس داریم و می خواهیم نمره ی هر دانشجو را در جلوی شماره اش وارد کنیم .فرمی لازم داریم تا با تایپ شماره دانشجویی آنرا در فهرست یافته و پس از ورود نمره آنرا در مقابلش ثبت کرده َ شماره دانشجویی بعدی را از کاربر بگیرد.

پاسخ: ابتدا یک سلول از جدول انتخاب شود.سپس ابزار form را از بخش ابزار های اکسل :

QAT\MORE COMMANDS \ ALL COMMANDS\FORM..

انتخاب می کنیم. حال با انتخاب این ابزار کاربر قادر است بسیاری از قابلیت های یک فرم ساده در ورود و نمایش داده ها را استفاده کند.

با فشردن کلید CRITERIA کاربر می تواند شرط مورد نظر را وارد کند . مثلا شماره دانشجویی. حال با فشردن کلید اینتر رکورد مورد نظر یافت شده می توانید داده متناظر آنرا وارد نمایید. اگر در حالت شرط ( CRITERIA ) باشید بجای این کلمه گزینه FORM فعال است.

با کلید NEW می توانید رکورد جدید وارد کنید و با کلید های NEXT , PREV هم به رکوردهای قبل و بعد وارد میشوید.

نوشته شده در پنجشنبه هشتم اردیبهشت 1390ساعت 9:38 توسط علی توضیح |
نمودارهای اسپارک ( جرقه ای ) - sparklines excel 2010
گاهی اوقات لازم است کاربران همانطور که داده ها را مشاهده می کنند نمودارهای رشد و روند های آنها را نیز به صورت آنلاین شاهد باشند.

یکی از این ابزار که در اکسل ۲۰۱۰ طراحی شده است نمونه کوچک ( جرقه ای ) نمودارهای اصلی است که در بخش insert گزینه sparklines قرار داده شده است. برای ترسیم یک نمودار spark کافی است داده هایی که قرار است ترسیم شوند را انتخاب کرده یکی از انواع spark را کلیک کنیم . آنگاه محل قرار گیری جرقه را انتخاب کنیم تا نمودار در محل مورد نظر قرار گیرد.

ادامه مطلب
نوشته شده در دوشنبه بیست و چهارم آبان 1389ساعت 9:54 توسط علی توضیح |
استفاده از ابزار قدرتمند consolidate برای یکسان سازی داده ها
هرگاه در چند شیت یا کاربرگ جداولی با فیلد های مشابه داشته باشیم می توانیم از تمامی آنها در یک کاربرگ مجزا گزارش تهیه کنیم .

برای این منظور ابتدا وارد کاربرگ آخر ( گزارش ) می شویم که کاملا خالی است . حال از منوی data ابزار consolidate را فعال می کنیم.

ابتدا تابعی که قرار است برروی دادههای محاسباتی اعمال شود انتخاب می کنیم مثلا sum

حال محدوده ی داده ها مشخص می گردند و با کلید add به پنجره ی پایین منتقل میشوند.اگر جدول شما دارای عنوان است، گزینه های right column ,top row را علامت بزنید .

با فشردن کلید ok گزارشی از محدوده های انتخاب شده نمایش داده می شود.

نوشته شده در چهارشنبه هفدهم شهریور 1389ساعت 10:43 توسط علی توضیح |
حذف رکورد های تکراری در اکسل - remove duplicates
برای حذف رکورد های تکراری از یک جدول کافی است یک سلول از آنرا انتخاب کرده و از مسیر زیر حرکت کنیم :

data / data tools / remove duplicates

هنگام انتخاب این گزینه اکسل فرمی را نمایش می دهد که به کاربر امکان می دهد تا فیلدی از جدول را از مجموعه ی مقایسه حذف کند . به طور مثال اگر فیلد ردیف در میان جدول وجود داشت می توان آنرا حذف کرد.

یادمان باشد اکسل در این حالت به دنبال داده ی تکراری نمی گردد ، بلکه سعی می کند تا رکوردهای تکراری را یافته و حذف کند .

به تصویر زیر دقت کنید گرچه ما در لیست 2 نفر با نام های "علی توضیح" داریم، اما این دو با هم فرق دارند و دو نفر متفاوت هستند - به کد های شناسایی دقت کنید - بنابراین اکسل هیچ رکورد تکراری را یافت نمی کند.

اما اگر فیلد کد شناسایی را حذف کنیم ، هر دو "علی توضیح" حذف خواهند شد.

نوشته شده در پنجشنبه هفدهم تیر 1389ساعت 9:13 توسط علی توضیح |
جمع بستن ساعات ها - اکسل پیشرفته
هر گاه چند سلول را که حاوی مقدار داده ای ساعت می باشد را با هم جمع کنیم اکسل به صورت پیش فرض آنها را دوباره با قالب ساعت نشان می دهد . به تصویر زیر دقت کنید . ستون جمع در حقیقت جمع ساعت های کارکرد سه ماه مهر و آبان و آذر است اما بجای اینکه جمع را نشان دهد ساعت را نشان می دهد .

برای رهایی از این مشکل کافی است سلول های حاوی جمع را با قالبی دیگر نمایش دهیم . برروی آنها راست کلیک کرده گزینه ی format cells و number و custom بخش hh:mm را انتخاب کرده ، در اطراف hh یک جفت علامت براکت قرار می دهیم ([hh])

منبع : کتاب ترفند های اکسل ( محمد حسن مهدوی )

نوشته شده در شنبه بیست و نهم خرداد 1389ساعت 14:4 توسط علی توضیح |
جستجوی سلول های رنگی در اکسل - find
برای یافتن سلول های رنگی همگون در اکسل می توان از مسیر مشخص شده در تصویر حرکت کرد :

Home/find & replace /find

درقسمت format دوگزینه مشاهده می شود یکی format که کاربر می تواند قالب مورد نظر را انتخاب کند و در حالت choose format from cell که کاربر تنها سلول رنگی مورد نظرش را با قطره چکان مکان نما انتخاب می کند .

حال کافی است کلید find all را فشار دهید تا تمام آنها را در کاربرگ sheet یا کارپوشه workbook بیابد .

نوشته شده در یکشنبه هشتم فروردین 1389ساعت 10:17 توسط علی توضیح |
آموزش تصویری و مقدماتی اکسل
برای آموزش سریع و تصویری اکسل مقدماتی اینجا کلیک کنید

Microsoft Excel 2003 Tutorial - Excel Basics

نوشته شده در یکشنبه بیست و پنجم بهمن 1388ساعت 10:7 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
توابع آماری Statistical functions در excel 2007

Statistical functions

Function | Description
AVEDEV | Returns the average of the absolute deviations of data points from their mean انحراف متوسط داده ها- در این تابع ابتدا قدرمطلق فاصله هر متغییر از میانگین سنجیده سپس حاصل جمع به تعداد تقسیم می گردد .
AVERAGE | Returns the average of its arguments میانگین داده ها در این تابع سلول های خالی و داده های متنی محاسبه نمی شوند.
AVERAGEA | Returns the average of its arguments, including numbers, text, and logical values میانگین کل : انواع داده ها ی متنی و عددی در محاسبه منظور می گردند. TRUE 1 و FALSE 0
AVERAGEIF | Returns the average (arithmetic mean) of all the cells in a range that meet a given criteria محاسبه میانگین با احتساب یک شرط
AVERAGEIFS | Returns the average (arithmetic mean) of all cells that meet multiple criteria. میانگین محدوده با احتساب چند شرط
BETADIST | Returns the beta cumulative distribution function
BETAINV | Returns the inverse of the cumulative distribution function for a specified beta distribution
BINOMDIST | Returns the individual term binomial distribution probability
CHIDIST | Returns the one-tailed probability of the chi-squared distribution
CHIINV | Returns the inverse of the one-tailed probability of the chi-squared distribution
CHITEST | Returns the test for independence
CONFIDENCE | Returns the confidence interval for a population mean
CORREL | Returns the correlation coefficient between two data sets
COUNT | Counts how many numbers are in the list of arguments شمارش تعداد سلول های حاوی عدد
COUNTA | Counts how many values are in the list of arguments شمارش سلول های غیر خالی
COUNTBLANK | Counts the number of blank cells within a range شمارش سلول های خالی
COUNTIF | Counts the number of nonblank cells within a range that meet the given criteria شمارش تعداد سلول های حاوی شرط
COVAR | Returns covariance, the average of the products of paired deviations محاسبه کوواریانس
CRITBINOM | Returns the smallest value for which the cumulative binomial distribution is less than or equal to a criterion value
DEVSQ | Returns the sum of squares of deviations
EXPONDIST | Returns the exponential distribution
FDIST | Returns the F probability distribution
FINV | Returns the inverse of the F probability distribution
FISHER | Returns the Fisher transformation
FISHERINV | Returns the inverse of the Fisher transformation
FORECAST | Returns a value along a linear trend
FREQUENCY | Returns a frequency distribution as a vertical array
FTEST | Returns the result of an F-test
GAMMADIST | Returns the gamma distribution
GAMMAINV | Returns the inverse of the gamma cumulative distribution
GAMMALN | Returns the natural logarithm of the gamma function, Γ(x)
GEOMEAN | Returns the geometric mean
GROWTH | Returns values along an exponential trend
HARMEAN | Returns the harmonic mean
HYPGEOMDIST | Returns the hypergeometric distribution
INTERCEPT | Returns the intercept of the linear regression line
KURT | Returns the kurtosis of a data set محاسبه کشیدگی توزیع
LARGE | Returns the k-th largest value in a data set کا امین عدد بزرگ توزیع - اگر کا عدد یک باشد همان ماکس را نمایش می دهد
LINEST | Returns the parameters of a linear trend
LOGEST | Returns the parameters of an exponential trend
LOGINV | Returns the inverse of the lognormal distribution
LOGNORMDIST | Returns the cumulative lognormal distribution
MAX | Returns the maximum value in a list of arguments بزرگترین عدد محدوده
MAXA | Returns the maximum value in a list of arguments, including numbers, text, and logical values
MEDIAN | Returns the median of the given numbers
MIN | Returns the minimum value in a list of arguments
MINA | Returns the smallest value in a list of arguments, including numbers, text, and logical values
MODE | Returns the most common value in a data set
NEGBINOMDIST | Returns the negative binomial distribution
NORMDIST | Returns the normal cumulative distribution رتبه درصدی یک داده را در یک توزیع نرمال ،با میانگین و انحراف استاندارد مشخص نمایش می دهد
NORMINV | Returns the inverse of the normal cumulative distribution یافتن نمره خام یا استاندارد معادل با رتبه درصدی در یک توزیع نرمال( رتبه درصدی می گیرد ، داده را نمایش می دهد )
NORMSDIST | Returns the standard normal cumulative distribution رتبه درصدی یک داده را در یک توزیع نرمال استاندارد، نمایش می دهد
NORMSINV | Returns the inverse of the standard normal cumulative distribution یافتن نمره خام یا استاندارد معادل با رتبه درصدی در یک توزیع نرمال استاندارد
PEARSON | Returns the Pearson product moment correlation coefficient ضریب همبستگی پیرسون را نمایش می دهد این شاخص که ضریب معتبری برای تعیین رابطه بین متغییر هاست تنها جهت و شدت رابطه بین دو متغییر را نمایش می دهد و نباید تفسیر آن بر حسب درصد باشد.به عنوان مثال ضریب 70% ،هفتاد درصد از رابطه بین دو متغییر را تبیین نمی کند .0
PERCENTILE | Returns the k-th percentile of values in a range نقاط درصدی همانند رتبه های درصدی اندازه های ترتیبی هستند و با استفاده از آنها می توان تعیین کرد چه عددی توزیع را به درصدهای مختلف تقسیم می کند
PERCENTRANK | Returns the percentage rank of a value in a data set محاسبه رتبه درصدی یک داده در یک توزیع- این رتبه به ما میگوید که چند درصد نمره ها در توزیع در زیر آن قرار گرفته اند
PERMUT | Returns the number of permutations for a given number of objects
POISSON | Returns the Poisson distribution
PROB | Returns the probability that values in a range are between two limits
QUARTILE | Returns the quartile of a data set محاسبه چارک های توزیع
RANK | Returns the rank of a number in a list of numbers رتبه بندی داده های توزیع
RSQ | Returns the square of the Pearson product moment correlation coefficient
SKEW | Returns the skewness of a distribution میزان کجی منحنی توزیع را نمایش می دهد
SLOPE | Returns the slope of the linear regression line
SMALL | Returns the k-th smallest value in a data set کا امین عدد کوچک مجموعه را نمایش می دهد .0
STANDARDIZE | Returns a normalized value محاسبه نمره زی یا زد یا استاندارد سازی نمره فرض کنید در یک آزمون که میانگین و انحراف استاندارد آن به ترتیب 75 و 10 می باشد نمره شما 95 شده است .هنگامی که این نمره را به زد تبدیل می کنید ، تابع عدد 2 را نمایش می دهد که بیانگر عملکرد شما در آزمون با توجه به توزیع نمره هاست.یعنی نمره شما دو انحراف استاندارد بالاتر از میانگین کلاس قرار دارد. 0
STDEV | Estimates standard deviation based on a sample انحراف معیار نمونه
STDEVA | Estimates standard deviation based on a sample, including numbers, text, and logical values انحراف معیار نمونه با احتساب متن و عدد
STDEVP | Calculates standard deviation based on the entire population انحراف معیار کل جمعیت
STDEVPA | Calculates standard deviation based on the entire population, including numbers, text, and logical values انحراف معیار کل جمعیت با احتساب متن و عدد
STEYX | Returns the standard error of the predicted y-value for each x in the regression
TDIST | Returns the Student's t-distribution این تابع مقدار عددی ، درجه آزادی و دامنه را دریافت کرده و احتمال شانسی بودن اختلاف بین میانگین نمونه و جامعه را نشان می دهد
TINV | Returns the inverse of the Student's t-distribution عدد موجود در جدول t را بر اساس درجه آزادی و p یا احتمال شانسی بودن اختلاف بین میانگین نمونه و جامعه نمایش می دهد.در حقیقت این تابع بجای جدول t عمل می کند یعنی کاربر درجه آزادی وp را وارد کرده و سپس تابع عدد مورد نظر را نمایش میدهد.اگر عدد بدست آمده از t محاسبه شده کوچکتر باشد فرض صفر رد می شود .
TREND | Returns values along a linear trend
TRIMMEAN | Returns the mean of the interior of a data set
TTEST | Returns the probability associated with a Student's t-test
VAR | Estimates variance based on a sample محاسبه واریانس نمونه ای از مجموعه
VARA | Estimates variance based on a sample, including numbers, text, and logical values واریانس گیری از تمام عناصر ( متن و عدد)0
VARP | Calculates variance based on the entire population محاسبه واریانس کل مجموعه
VARPA | Calculates variance based on the entire population, including numbers, text, and logical values
WEIBULL | Returns the Weibull distribution
ZTEST | Returns the one-tailed probability-value of a z-test

منابع

  1. راهنمای اکسل ۲۰۰۷
  2. کتاب - احتمالات و آمار کاربردی در روانشناسی و علوم تربیتی - دکتر علی دلاور
  3. جزوه توابع آماری اکسل - بهرام صمدیان AMAR80.BLOGFA.COM

نوشته شده در دوشنبه بیست و هفتم اسفند 1386ساعت 13:49 توسط علی توضیح |
قالب بندی شرطی در اکسل 2007
برای ایجاد یک قالب بندی همراه با شرط در اکسل ۲۰۰۷ ابتدا محدوده مورد نظر را انتخاب کرده سپس از مسیر HOME > CONDITIONAL FORMATTING را فعال می کنیم . این ابزار دو بخش مجزای تعیین شرط را طراحی کرده است ؛ که اولی همان گزینه CUSTOM و دومی گزینه TOP 10 در نسخه 2003 می باشند . در حقیقت در اولی کاربران شرط خاصی را برای قالب بندی مشخص می کنند و در دومی درصد یا تعداد خاصی را مشاهده خواهند کرد .

1- HIGHLIGHT CELLS RULES

2- TOP/BUTTON RULES

Conditional formatting helps you to easily apply a format to each cell that depends on its value

در بخش اول شرط های بزرگتر ،کوچکتر، مساوی ، بین و ... و در بخش دوم درصد یا تعدادی از بالا یا پایین لیست را رنگی می کند . یکی از گزینه های جدید above , below average است که داده های بالاتر وپایین تر از شاخص میانگین را رنگی می کند.

یکی دیگر از ویژگی های جدید اکسل ۲۰۰۷، یافتن سلول های تکراری و غیر تکراری است.گزینه duplicate value این وظیفه را به خوبی انجام میدهد.جالب اینجاست که بدانید دیگر مانند اکسل ۲۰۰۳ تعداد شرط ها به ۳ محدود نمی شود و کاربران اکسل ۲۰۰۷ قادرند به صورت نامحدود ، محدوده خود را ، با قالب بندی های شرطی ، مشخص کنند .

نوشته شده در یکشنبه بیست و ششم اسفند 1386ساعت 12:33 توسط علی توضیح |
حذف داده های تکراری

قابلیت جدید اکسل 2007 در حذف داده های تکراری یکی از مزایای انکارناپذیر این صفحه گسترده است.

مسیر اجرا : انتخاب محدوده مورد نظر DATA>REMOVE DUPLICATES حال کلید SELECT ALL>OK

نوشته شده در شنبه بیست و پنجم اسفند 1386ساعت 12:45 توسط علی توضیح |
تغییرات اساسی اکسل 2007 و ویژگی های محاسباتی آن

Worksheet and workbook specifications and limits

ویژگی های محاسباتی اکسل 2007

تعداد کاربرگهای نامحدود یکی از ویپگی های خارق العاده اکسل 2007 محسوب می شود.

Feature | Maximum limit
Open workbooks | Limited by available memory and system resources
Worksheet size | 1,048,576 rows by 16,384 columns
Column width | 255 characters
Row height | 409 points
Page breaks | 1,026 horizontal and vertical تعداد کاراکترهای درون یک سلول
Total number of characters that a cell can contain | 32,767 characters
Characters in a header or footer | 255
Sheets in a workbook | Limited by available memory (default is 3 sheets) اکسل 2007 از 16 میلیون رنگ برای نمودارهایش استفاده می کند
Colors in a workbook | 16 million colors (32 bit with full access to 24 bit color spectrum)
Named views (view: A set of display and print settings that you can name and apply to a workbook. You can create more than one view of the same workbook without saving separate copies of the workbook.) in a workbook | Limited by available memory
Unique cell formats/cell styles | 64,000
Fill styles | 32
Line weight and styles | 16
Unique font types | 1,024 global fonts available for use; 512 per workbook
Number formats in a workbook | Between 200 and 250, depending on the language version of Excel that you have installed
Names in a workbook | Limited by available memory
Windows in a workbook | Limited by available memory
Panes in a window | 4
Linked sheets | Limited by available memory
Scenarios (scenario: A named set of input values that you can substitute in a worksheet model.) | Limited by available memory; a summary report shows only the first 251 scenarios
Changing cells in a scenario | 32
Adjustable cells in Solver | 200
Custom functions | Limited by available memory
Zoom range | 10 percent to 400 percent
Reports | Limited by available memory
Sort references | 64 in a single sort; unlimited when using sequential sorts
Undo levels | 100
Fields in a data form | 32
Workbook parameters | 255 parameters per workbook
Filter drop-down lists | 10,000

Calculation specifications and limits

Feature | Maximum limit
Number precision | 15 digits
Largest number allowed to be typed into a cell | 9.99999999999999E+307
Largest allowed positive number | 1.79769313486231E+308
Smallest allowed negative number | -2.2251E-308
Smallest allowed positive number | 2.229E-308
Largest allowed negative number | -1E-307
Length of formula contents | 8,192 characters
Internal length of formula | 16,384 bytes
Iterations | 32,767
Worksheet arrays | Limited by available memory
Selected ranges | 2,048
Arguments in a function | 255
Nested levels of functions | 64
User defined function categories | 255
Number of available worksheet functions | 341
Size of the operand stack | 1,024
Cross-worksheet dependency | 64,000 worksheets that can refer to other sheets
Cross-worksheet array formula dependency | Limited by available memory
Area dependency | Limited by available memory
Area dependency per worksheet | Limited by available memory
Dependency on a single cell | 4 billion formulas that can depend on a single cell
Linked cell content length from closed workbooks | 32,767
Earliest date allowed for calculation | January 1, 1900 (January 1, 1904, if 1904 date system is used)
Latest date allowed for calculation | December 31, 9999
Largest amount of time that can be entered | 9999:59:59

Charting specifications and limits

Feature | Maximum limit
Charts linked to a worksheet | Limited by available memory
Worksheets referred to by a chart | 255
Data series (data series: Related data points that are plotted in a chart. Each data series in a chart has a unique color or pattern and is represented in the chart legend. You can plot one or more data series in a chart. Pie charts have only one data series.) in one chart | 255
Data points (data points: Individual values that are plotted in a chart. Related data points make up a data series. Data points are represented by bars, columns, lines, slices, dots, and other shapes. These shapes are called data markers.) in a data series for 2-D charts | 32,000
Data points in a data series for 3-D charts | 4,000
Data points for all data series in one chart | 256,000

PivotTable and PivotChart report specifications and limits

Feature | Maximum limit
PivotTable reports (PivotTable report: An interactive, crosstabulated Excel report that summarizes and analyzes data, such as database records, from various sources, including ones that are external to Excel.) on a sheet | Limited by available memory
Unique items per field | 1,048,576
Row (row field: A field that's assigned a row orientation in a PivotTable report. Items associated with a row field are displayed as row labels.) or column fields (column field: A field that's assigned a column orientation in a PivotTable report. Items associated with a column field are displayed as column labels.) in a PivotTable report | Limited by available memory
Report filters in a PivotTable report | 256 (may be limited by available memory)
Value fields in a PivotTable report | 256
Calculated item (calculated item: An item within a PivotTable field or PivotChart field that uses a formula you create. Calculated items can perform calculations by using the contents of other items within the same field of the PivotTable report or PivotChart report.) formulas in a PivotTable report | Limited by available memory
Report filters in a PivotChart report (PivotChart report: A chart that provides interactive analysis of data, like a PivotTable report. You can change views of data, see different levels of detail, or reorganize the chart layout by dragging fields and by showing or hiding items in fields.) | 256 (may be limited by available memory)
Value fields in a PivotChart report | 256
Calculated item formulas in a PivotChart report | Limited by available memory
Length of the MDX name for a PivotTable item | 32,767
Length for a relational PivotTable string | 32,767

Shared workbook specifications and limits

Feature | Maximum limit
Users who can open and share a shared workbook (shared workbook: A workbook set up to allow multiple users on a network to view and make changes at the same time. Each user who saves the workbook sees the changes made by other users.) at the same time | 256
Personal views (view: A set of display and print settings that you can name and apply to a workbook. You can create more than one view of the same workbook without saving separate copies of the workbook.) in a shared workbook | Limited by available memory
Days that change history (change history: In a shared workbook, information that is maintained about changes made in past editing sessions. The information includes the name of the person who made each change, when the change was made, and what data was changed.) is maintained | 32,767 (default is 30 days)
Workbooks that can be merged at one time | Limited by available memory
Cells that can be highlighted in a shared workbook | 32,767
Colors used to identify changes made by different users when change highlighting is turned on | 32 (each user is identified by a separate color; changes made by the current user are highlighted with navy blue)

نوشته شده در شنبه بیست و پنجم اسفند 1386ساعت 12:10 توسط علی توضیح |
اکسل 2007 EXCEL 2007

What's new in Microsoft Office Excel 2007

یکی از شاهکار های جدید مایکروسافت را به جرات می توان اکسل ۲۰۰۷ از سری آفیس ۱۲ دانست. در این سری جدید تعداد سطرها از 65536 به 1048576 و تعداد ستون ها از 256 به 16384 تغییر یافته است.

این افزایش قابلیت های فراوانی را در اکسل ۲۰۰۷ برای کاربران مهیا می کند .محیط اکسل ۲۰۰۷ را در زیر مشاهده می کنید.

Parts of the Excel 2007 Screen

سه آیتم به محیط 2007 اضافه شده است که به ترتیب :

1- OFFICE BUTTON که بخش فایل را پوشش می دهد :

Microsoft Office Excel 2007 - Office Button

کلید EXCEL OPTIONS هم در این بخش قرار دارد:

۲- QAT که تصویر فلاپی در آن مشاهده می شود و عملیات ذخیره سازی و یا آندو و ردو را انجام می دهد. کاربران قادرند موارد مورد نیاز را با آن اضافه کنند یا از آن حذف نمایند .

۳- نوار ابزار ریبون RIBBON :

Microsoft Office 2007 Ribbon Excel Live Preview

این نوار ابزار ساختار، نتیجه محوری (RESULTS ORIENTED) داشته که بجای موضوع محوری در 2003 ،سرعت دسترسی به ابزارها را بیشتر می کند .

نوشته شده در پنجشنبه بیست و سوم اسفند 1386ساعت 9:9 توسط علی توضیح |
جزوه اکسل پیشرفته
دوستان برای گزارش گیری و تحلیل داده های لیست ها، در این جزوه چند روش ارائه شده است:

۱- استفاده از تابع SUBTOTAL فیلتر ها

2- تابع SUMIF , COUNTIF

3- توابع پایگاه داده DATABASE FUNCTIONS

DSUM DMAX DMIN ,...

4- استفاده از توابع آرایه ای مثل FREQUENCY , TRANSPOSE, SUM & IF

5- استفاده از جداول محوری PIVOT TABLE

استفاده از ابزار DATA VALIDATION , TEXT TO COLUMN,...

توابع روند سازی ROUND , ROUNDDOWN,ROUNDUP,ODD,EVEN,FLOOR,CEILING,TRUNC.,INT

دانلود جزوه اکسل پیشرفته

قبلا بخاطر اشتباهات جزوه از تمام دوستان عذر خواهی می کنم. موفق باشید

علی توضیح اسفند ۸۶

نوشته شده در سه شنبه بیست و یکم اسفند 1386ساعت 10:43 توسط علی توضیح |
ابزاری برای انتخاب ک محدوده از سلول ها VBA
برای انتخاب یک محدوده از سلول ها می توان از ابزاری بنام REFEDIT استفاده کرد.

مثال : در یک فرم سه شیء TEXTBOX , REFEDIT, COMMANDBUTTON قرار دارند فرض کنید قصد داریم آدرس انتخاب شده توسط REFEDIT را با فشار دادن کلید در TEXTBOX نمایش دهیم در بخش کد مربوط به کلید متن زیر را وارد می کنیم :

()Private Sub CommandButton1_Click

TextBox1 = RefEdit1.Value
End Sub

راهنمای اکسل

RefEdit Control

On a user form, this control displays the address of a range of cells that you've entered or selected on one or more worksheets. To select a range, click the button in the control to collapse the user form, select the range, and then click the button in the control again to expand the user form.

If the RefEdit control is embedded on a worksheet, you can link the contents of the control to a cell on any worksheet in that workbook.

Remarks

The default property for a RefEdit control is Value.

The default event for a RefEdit control is BeforeDragOver.

You cannot use a RefEdit control on a modeless user form. You can use the ShowModal property to set a user form to modal.

Example

This example sets the control tip text for the RefEdit1 control in UserForm1, and then it displays the user form.

UserForm1.RefEdit1.ControlTipText = _
    "The selected range of data in the worksheet"
UserForm1.Show

Later, the user clicks CommandButton1 in UserForm1. This example of an event-handling procedure displays the address of the selected worksheet range and then ends the program.

Private Sub CommandButton1_Click
    MsgBox RefEdit1.Value
    End
End Sub

نوشته شده در چهارشنبه یکم اسفند 1386ساعت 9:37 توسط علی توضیح |
تمرین جداول محوری - گزارش گیری و ساخت گزارش
با توجه به فایل زیر به سوالات زیر پاسخ دهید :

تمرین

کاربرگ دریافتی :

۱- جمع دریافتی های هر فرد چقدر است ؟

۲- جمع دریافتی های هر فرد در هر ماه چقدر است ؟

۳- میانگین دریافتی های هر فرد در هر ماه در هر بانک چقدر است ؟

کاربرگ انبار :

۱- از هر کالا به هر اندازه و جنس چقدر وارد انبار شده و چقدر خارج شده است؟

۲- هر وارد کننده از هر کالا چه میزانی وارد کرده است؟

کاربرگ لوازم التحریر

۱- هر فروشگاه از هر کالا چقدر فروخته است ؟

۲- هر فروشگاه در هر شهر از هر کالا چقدر فروخته است ؟

نوشته شده در چهارشنبه یکم اسفند 1386ساعت 7:43 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
تمرین جداول محوری - pivottable
در فایل زیر که شامل سه کاربرگ است ، تمرین های زیر را حل کنید:

1- در جدول یک مطلوبست جمع دریافتی هر نفر؟

2- میانگین دریافتی هر نفر از هر بانک ؟

3- بیشترین دریافتی هر نفر در هر سال ؟

4- کمترین مقداری که هر بانک به عنوان دریافتی ، در هر سال به هر فرد داده است ؟

5- در جدول شماره دو ، مقدار خریداری شده و فروخته شده هر کالا را نمایش داده و سپس مانده ی هر کدام را نمایش دهید.

6- در جدول شماره سه هر فروشگاه در هر شهر از هر کالا چه مبلغی ( جمع کل ) فروش داشته است.

7- نمودار فروش پاکن را در تمام فروشگاه ها مقایسه کنید.

دانلود تمرین

موفق باشید

نوشته شده در سه شنبه شانزدهم فروردین 1390ساعت 11:17 توسط علی توضیح |
توابع مالی - بخش دوم

تابع RATE

این تابع درصد نرخ سود سالانه را محاسبه می کند.

=RATE( تعداد اقساط ; مبلغ هر قسط ; مبلغ وام )

مثال 3 : فرض کنید وامی به مبلغ سی میلیون ریال به مدت هفت سال باید بازپرداخت شود اگر مبلغ هر قسط

سالیانه ی آن 5,184,594.55 ریال باشد نرخ سود سالیانه ی آن چقدر است ؟

=RATE( 7 ; 5,184,594.55 ; 30000000) = 5%

تابع NPER

این تابع تعداد اقساط یک وام را مشخص می کند.

=NPER( سالانه نرخ سود ; مبلغ هر قسط ; مبلغ وام )

مثال 4 : فرض کنید وامی به مبلغ سی میلیون ریال با نرخ سود سالانه پنج درصد و با مبلغ هر قسط 5,184,594.55 ریال را از بانک دریافت کرده ایم . چند قسط سالیانه باید بپردازیم؟

=NPER( 5% ; 5,184,594.55 ; 30000000) = 7

نوشته شده در دوشنبه پانزدهم فروردین 1390ساعت 11:23 توسط علی توضیح |
برخی توابع مالی در اکسل - اکسل 2007 پیشرفته

برخی توابع مالی در اکسل

برخی از توابع مالی استفاده های زیادی در اکسل دارند ، که به طور خلاصه به شرح 4 مورد از آنها خواهیم پرداخت:

تابع PMT

این تابع برای محاسبه مبلغ اقساط سالیانه یک وام با بهره ثابت بکار می رود.

=PMT( نرخ بهره سالانه; تعداد اقساط سالانه ; مبلغ کل وام )

در مورد توابع مالی این نکته ضروری است که اگر تمام مواردمثبت باشد اکسل به صورت خودکار جواب را منفی نمایش می دهد ( شما را بدهکار می کند ) برای جلوگیری از این کار ، معمولا مبلغ وام را منفی نمایش می دهند تا سایر جواب ها مثبت نشان داده شود.

این نکته هم ضروری است که بدانیم ساختار ها باید همگون باشند یعنی اگر کاربر بهره سالانه استفاده می کند مبلغ قسط هم سالانه نمایش داده می شود ، تعداد اقساط هم همان تعداد سال های پرداخت وام تلقی می گردد.

مثال 1 : فرض کنید وامی را به مبلغ سی میلیون ریال ( سه میلیون تومان ) با بهره سالانه پنج درصد طی هفت سال می خواهیم بازپس دهیم ، آیا می توان مبلغ اقساط سالانه آنرا محاسبه کرد؟

=PMT( 5% ; 7 ; 30000000) = ريال 5,184,594.55

در حقیقت شما باید سالانه مبلغ ريال 5,184,594.55 را بابت اقساط بپردازید .

نرخ بهره سالانه | تعداد اقساط ( سال ) | مبلغ وام | مبلغ هر قسط ( سالانه ) | مبلغ هر قسط (ماهانه ) | جمع کل اقساط | جمع کل سود پرداختی
5% | 7 | 30,000,000- | ريال 5,184,594.55 | ريال 432,049.55 | ريال 36,292,161.87 | ريال 6,292,161.87

تابع IPMT

این تابع برای محاسبه مبلغ سود هر قسط سالیانه یک وام با بهره ثابت بکار می رود.

=IPMT( نرخ بهره سالانه;شماره قسط ; تعداد اقساط سالانه ; مبلغ کل وام )

این تابع که شبیه تابع PMT است ، مبلغ سود هر قسط را محاسبه می کند.

مثال 2: در مثال شماره یک مبلغ سود هر قسط را محاسبه کنید، مثلا برای قسط سال اول :

=IPMT(5% ; 1 ; 7 ; 30000000)

نرخ بهره سالانه | شماره قسط | تعداد اقساط ( سال ) | مبلغ وام | مبلغ سود ه قسط
5% | 1 | 7 | 30,000,000- | 1,500,000.00
5% | 2 | 7 | 30,000,000- | 1,315,770.27
5% | 3 | 7 | 30,000,000- | 1,122,329.06
5% | 4 | 7 | 30,000,000- | 919,215.78
5% | 5 | 7 | 30,000,000- | 705,946.85
5% | 6 | 7 | 30,000,000- | 482,014.46
5% | 7 | 7 | 30,000,000- | 246,885.45

نرخ بهره سالانه | شماره قسط | تعداد اقساط ( سال ) | مبلغ وام | مبلغ سود هر قسط
5% | 1 | 7 | 30,000,000- | ريال 1,500,000.00
5% | 2 | 7 | 30,000,000- | ريال 1,315,770.27
5% | 3 | 7 | 30,000,000- | ريال 1,122,329.06
5% | 4 | 7 | 30,000,000- | ريال 919,215.78
5% | 5 | 7 | 30,000,000- | ريال 705,946.85
5% | 6 | 7 | 30,000,000- | ريال 482,014.46
5% | 7 | 7 | 30,000,000- | ريال 246,885.45

نوشته شده در دوشنبه پانزدهم فروردین 1390ساعت 10:21 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
استفاده از اكسل در امور حسابداري
برخي از دوستان درباره تهيه ي گزارش از ليست ها زياد مي پرسند به ويژه تابع VLOOKUP لازم است كه توضيحي مختصر درباره انواع ليست ها و گزارش هايي كه اكسل قادر است تهيه كند ارايه نمايم :

اكسل قادر است دو نوع گزارش كلي از ليستهايش تهيه كند:

1- ليست هايي كه آيتم هاي تكراراي دارند. مثل حقوق دستمزد كه يك نفر قادر است بارها پول دريافت كند .

2- ليست هايي كه اجازه ي تكرار ندارند. مثل مشخصات فردي درون اداره كه يكنفر نبايد دوبار ثبت شده باشد.

در مورد اول ابزار هايي چون

1-تابع SUBTOTAL

2- SUMIF, SUMIFS

3- تركيب آرايه اي SUM & IF

4- توابع پايگاه داده يا DSUM

5-PIVOTTABLE يا جداول محوري ( بسيار مهم )

6- ابزار SUBTOTAL

را مي توان استفاده كرد، كه تمامي آنها را در آرشيو مي توانيد بيابيد.

اما مورد دوم ليست هاي غير تكراري است كه ابزار هاي آن عبارتند از :

توابع INDEX و MATCH و VLOOKUP , HLOOKUP

اين توابع در ليست هاي تكراري استفاده ي چنداني ندارد

نوشته شده در چهارشنبه چهارم دی 1387ساعت 13:52 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
معرفی امکانات جدید اکسل 2012
گروه فعال سایت فرساران بازهم مطلبی جدید را درباره اکسل ۲۰۱۲ ارائه نموده که خواندن آنرا به همه توصیه می کنم.

این مطلب را می توانید از لینک زیر مشاهده کنید.

http://farsaran.ir/Excel%202012%20News

با عضویت در این سایت غنی مطالب جدید را به صورت مرتب با ایمیل دریافت کنید.

باز هم از زحمات گروه فعال فرساران و جناب آقای مهندس فرشید میدانی تشکر می کنیم .

www.farsaran.ir

نوشته شده در پنجشنبه سی ام تیر 1390ساعت 12:5 توسط علی توضیح |
وبلاگ جدید اکسل

به سراغ وبلاگ زیر بروید نکات جالبی را برای یادگرفتن دارد .

http://exceluser.blogfa.com/

استفاده حرفه ای از اکسل

با آرزوی موفقیت برای نگارنده آن.

نوشته شده در شنبه چهاردهم اسفند 1389ساعت 8:54 توسط علی توضیح |
مطالب و کتاب های جدید
سایت پربار و زیبای فرساران مجددا به روز شده و بخش کتاب آن جزوات رنگی و زیبایی را برای دانلود قرار داده است.این سایت از گروهی متخصص استفاده می کند که شاید در بخش آفیس در کشور بینظیر باشند حتما این سایت را مشاهده کنید و از مطالبی که آقای مهندس میدانی و همکارن جوانشان در اختیار کاربران قرار می دهند استفاده کنید:

www.farsaran.ir

برای مشاهده کتب اینجا را کلیک کنید

با تشکر از این بچه ها و تمام کسانی که در راه تولید محتوا زحمت می کشند.

نوشته شده در سه شنبه سی ام آذر 1389ساعت 13:17 توسط علی توضیح |
کتاب جدید مجموعه کلید - کلید جدول، نمودار و ابزار گرافیکی در Excel همراه با CD
باز هم کتاب جدید مجموعه کلید کتابی زیبا غنی و پر از مطالب خواندنی است. این کتاب که در مباحث نمودارها و جداول و ساماندهی داهها و ... مطلب دارد توسط آقای مهندس محمد تقی مروج نگاشته شده است . همراه این کتاب سی دی آموزشی نیز ضمیمه شده است که تمارین درون کتاب به همراه تصاویر و فیلم نمایش داده شده است.

نکاتی که می توان در این کتاب یافت :

رسم نمودار درکل فراینده ساده ایست اما نکته های فراوانی در آن نهفته است که در این کتاب و در قالب پروژه ها و همچنین تمرین های مهم این نکته ها آموزش داده شده اند.

منظور از ابزار های گرافیکی چیست ؟
ابزار های متنوع و قدرتمندی در اکسل وجود دارند که برای بکار گیری آنها نه از فرمول نویسی، بلکه از دستورها و ابزار های موجود در نوار ابزار و با منوها استفاده می شود. ابزارهایی مانند مرتب سازی داده ها، پالایش داده ها، قالب بندی شرطی، حفاظت از داده ها، سنجش درستی داده های ورودی و بسیار موارد دیگر. از آنجا که استفاده از این ابزار به صورت گرافیکی انجام می شود نام عمومی ابزارد گرافیکی را برای آن انتخاب کرده ایم.

این کتاب برای چه کسانی مناسب است ؟
اگر یک آشنایی ابتدایی نیز با اکسل داشته باشید می توانید به خوبی از این کتاب برای بالا بردن سطح مهارتتان استفاده کنید. اما اگر مفاهیم پایه را یاد بگیرید (مانند مفهوم آدرس های نسبی و مطلق که در کتاب کلید اکسل 2007 آموزش داده شده اند) بی شک بهره بیشتری از مطالب خواهید برد. ولی برای تبددیل شدن به یک کاربر قدرتمند در اکسل، لازم است که در کنار این کتاب، فرمول نویسی را نیز به خوبی یاد بگیرید تا بتوانید با ترکیب آن با ابزار های گرافیکی به اوج قدرت در اکسل برسید و بتوانید انواع مسایل حرفه ای که با آنها روبرو می شوید را حل کنید. و آنگاه با ما هم عقیده خواهید شد که نرم افزار اکسل، یکی از بی نظیر ترین، قدرتمندترین و پرکاربردترین نرم افزار هاییست که تا کنون ساخته شده است.

برای مشاهده و مطرح کردن سوالات پیرامون موضوع این کتاب، روی این نوشته کلیک کنید.

مولف/مترجم :
محمد تقي مروج

تعداد صفحات :
152

قطع :
رقعي

خرید از سایت کلید آموزش : www.kelidshop.com

نوشته شده در شنبه بیست و دوم آبان 1389ساعت 14:40 توسط علی توضیح |
دانلود کتاب تمام رنگی اکسل 2010
هنگام جستجو در اینترنت متوجه وجود یک ebook کامل و زیبا از اکسل 2010 شدم که در سایت پرتال دانلود قرار داشت .

لینک مستقیم دانلود این کتاب زیبا و کامل را از سایت پرتال دانلود برای تمام دوستان قرار می دهم تا این چند روز آخر هفته بدون منبع و کتاب نباشند :

دانلود کتاب اکسل 2010

excel 2010 - ebook

نوشته شده در پنجشنبه بیست و چهارم تیر 1389ساعت 11:11 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
توضیح بیشتر درباره تمرین قبل
در تمرین انبار از سه تابع match index , dsum استفاده شده است. همانطور که قبلا توضیح دادم دو تابع match , index برعکس یکدیگرند.

تایع index شماره ردیف داده را در یک مجموعه دریافت کرده خود داده را نمایش می دهد در حالیکه تابع match داده را دریافت کرده شماره ردیف آن در مجموعه را نمایش می دهد.

=index( شماره ردیف داده , مجموعه ) ====> data

=match ( data , مجموعه , type ) ======> data row

در این تمرین کافی است ابتدا با استفاده از تابع match شماره اولین ردیفی را که داده در آن نمایش داده شده را بیابید . با این کار شما قادر خواهید بود نام کالا را یافته و آنرا در سلولی دیگر نمایش دهید.

تابع dsum هم عملیات جمع را با شرط انجام می دهد . این تابع سه پارامتر دارد . ابتدا نشانی کل جدول را از کاربر گرفته ، شماره فیلدی را که قرار است عملیات جمع روی آن انجام گیرد را نیز دریافت می کند آنگاه با دریافت آدرس محدوده شرط ، عملیات جمع را انجام می دهد . نکته مهم آنست که آدرس محدوده ی شرط باید شامل عناوینی باشد که در آدرس کل جدول نیز وجود دارند. مثلا اگر شما می خواهید به دنبال جمع تعداد کالای خریداری شده بگردید ( فیلد شماره 6) باید محدوده شرط را طوری انتخاب کنید که کد کالا و شماره ی آن در محدوده ی شرط باشند ( m1 :m2 )

البته در تابع match پارامتر آخر دارای سه مقدار 0 و 1 و -1 است که بسته به نوع جستجو از آنها استفاده می کنیم :

1 برای جستجوی مقادیری کوچکتر از مقدار داده شده

0 برای جستجوی دقیق مقادیر داده شده

-1 برای جستجوی مقادیر بزرگتر از مقدار داده شده

نوشته شده در یکشنبه بیست و پنجم اردیبهشت 1390ساعت 14:7 توسط علی توضیح |
تمرین - یافتن داده ها روش استفاده از توابع match , dsum
در بسیاری از مواقع کاربران برای یافتن یک کالا یا شخص با استفاده از کد با مشکل روبرو می شوند و می خواهند بدون استفاده از vba نیز بر مشکل برطرف شود.

برای اینکار می توان از تابع match برای یافتن اولین ردیف از داده استفاده کرد و سپس نام داده را با استفاده از تابع index شناخت , بالاخره برای یافتن جمع ها از توابعی مانند dsum یا خانواده sumifs استفاده کرد. برای این منظور تمرین طراحی و با پاسخ در اختیار شما دوستان قرار می دهم تا بیشتر تمرین کنید.

تمرین - در جدول انبار ساختاری طراحی کنید که با نوشتن کد هر کالا شماره اولین ردیف ،نام کالا و سپس جمع خریداری شده و فروخته شده و مانده ی هر کالا را نمایش دهد.

دانلود فایل تمرین

نوشته شده در یکشنبه هجدهم اردیبهشت 1390ساعت 9:8 توسط علی توضیح |
طراحی جدول داده
توجه کاربران محترم اکسل را برای طراحی یک جدول به نکات زیر جلب می کنم:

۱- از گسستگی داده ها بپرهیزید . ( سطر یا ستون کاملا خالی در جدول نداشته باشید )

۲- از انجام عملیات merge بپرهیزید ( اینکار مانع از مرتب سازی و فیلترینگ صحیح داده ها در جدول می گردد)

3- تمام فیلد های مربوط به یک موضوع را در یک جدول قرار دهید تا قادر به دریافت اطلاعات صحیح تر باشید ( فیلدها همان ستون های جدولند )

4- فیلد های جدول حتما باید دارای عنوان باشند (هدر )

5- حتما سعی کنید از سمت ستون A جدول را طراحی کنید.

۶- از ورود داده های نامعتبر جلوگیری کنید ( validation).

7- از تخریب سلول هایی که نباید دستکاری شوند با protection جلوگیری کنید.

8- سعی کنید در بالای عناوین فیلدها محاسبات و سرجمع آنهارا نشان دهید( subtotal ) نه در پایین جدول

9- هر چه بیشتر فیلد در جدول شما باشد گزارشات شما دقیقتر و بنابراین اطلاعات شما صحیحتر خواهد بود (pivottable).

۱۰-منطق ورود داده را فراموش نکنید ( جایی که قرار است نام وارد شود فامیل وارد نکنیم )

نوشته شده در سه شنبه سیزدهم اردیبهشت 1390ساعت 13:48 توسط علی توضیح |
تمرین مدیریت داده -اکسل پیشرفته
تمرین - فرض کنید یک لیست از شماره های دانشجویی یک کلاس داریم و می خواهیم نمره ی هر دانشجو را در جلوی شماره اش وارد کنیم .فرمی لازم داریم تا با تایپ شماره دانشجویی آنرا در فهرست یافته و پس از ورود نمره آنرا در مقابلش ثبت کرده َ شماره دانشجویی بعدی را از کاربر بگیرد.

پاسخ: ابتدا یک سلول از جدول انتخاب شود.سپس ابزار form را از بخش ابزار های اکسل :

QAT\MORE COMMANDS \ ALL COMMANDS\FORM..

انتخاب می کنیم. حال با انتخاب این ابزار کاربر قادر است بسیاری از قابلیت های یک فرم ساده در ورود و نمایش داده ها را استفاده کند.

با فشردن کلید CRITERIA کاربر می تواند شرط مورد نظر را وارد کند . مثلا شماره دانشجویی. حال با فشردن کلید اینتر رکورد مورد نظر یافت شده می توانید داده متناظر آنرا وارد نمایید. اگر در حالت شرط ( CRITERIA ) باشید بجای این کلمه گزینه FORM فعال است.

با کلید NEW می توانید رکورد جدید وارد کنید و با کلید های NEXT , PREV هم به رکوردهای قبل و بعد وارد میشوید.

نوشته شده در پنجشنبه هشتم اردیبهشت 1390ساعت 9:38 توسط علی توضیح |
آشنایی با تابع Indirect در اکسل - Excel
شهادت اما محمد باقر( ع ) شکافنده و مرزبان علوم نبوی بر دوستداران علم و اندیشه تسلیت باد:

چیزی با چیزی نیامیخته است که بهتر از حلم با علم باشد .

بحارالانوار ، دار احیاء الترا العربی ، ج 75، ص(172)

کار تابع indirect اینست که محتویات درونش را که یک آدرس است به تابع بعدی انتقال می دهد تا محتویات ادرس مذکور را نمایش دهد.درحقیقت به صورت غیر مستقیم مقدار یک سلول را انتقال می دهد.

مثلا فرض کنید در سلول g5 نشانی سلول a1 را نوشته اید، حال اگر در یک سلول دیگر فرمول زیر را بنویسید آن سلول محتویات a1 را نشان می دهد:

=indirect(g5)

به تصویر زیر دقت کنید

حل یک مثال با این تابع : محدود های از اعداد را در ستون a تا c داریم و می خواهیم با تغییر اعداد سطر محدوده جمع نیز تغییر کند . فرمول :

=SUM(INDIRECT("a"&G2&":c"&I2))

را می نویسیم تا تابع indirect سطر 2 تا 10 را در ستون های a تا c به تابع جمع ارسال کند.

نوشته شده در یکشنبه بیست و سوم آبان 1389ساعت 9:21 توسط علی توضیح |
تزریق یک فایل اکسل به اوت لوک 2010
فرض کنید از شماره تلفن های موبایلتان یک نسخه کپی گرفته اید و می خواهید فایل اکسل آنرا به اوت لوک تزریق کنید تا با استفاده از امکانات آن با استفاده از یک خط تلفن و یک مودم َ با دوستانتان تماس حاصل کنید.

مراحل تزریق( import ) داده های اکسل به اوت لوک ( outlook ):

1- ابتدا اوت لوک 2010 را باز کرده : file / open / import

گزینه import from another program or file رااتنخاب می کنیم:

نوع فایل را اکسل انتخاب می کنیم ( در اوت لوک 2010 هنوز گزینه اکسل 2010 موجود نیست )

فایل مورد نظر را انتخاب می کنیم.در این مرحله نوع تکرار رکوردها را نیز تعیین می کنیم.

گزینه تماس ها contacts را انتخاب می کنیم تا داده ها به صورت دفترچه تلفن ذخیره شوند

حال باید نقشه ی اتصال را به درستی تهیه کرد . در این قسمت اوت لوک عناوین ستون ها در فایل اکسل را به فیلد های دفترچه تلفنش لینک می کند.

باید مثل اکسس آنها را درگ کرد.

حال دفترچه تلفن حاضر است . می توانید از آن برای تماس با شماره های آن بدون استفاده از دستگاه تلفن استفاده کرد.

فرد مورد نظر را جستجو کرده ، سپس شماره انرا از منوی home گزینه more یافته یا برروی آن دبل کلیک می کنیم.

برای جستجو هم کلید های ctrl + e را استفاده می کنیم.

نوشته شده در یکشنبه دوم آبان 1389ساعت 8:22 توسط علی توضیح |
جمع بستن ساعات ها - اکسل پیشرفته -( تکراری )
هر گاه چند سلول را که حاوی مقدار داده ای ساعت می باشد را با هم جمع کنیم اکسل به صورت پیش فرض آنها را دوباره با قالب ساعت نشان می دهد . به تصویر زیر دقت کنید . ستون جمع در حقیقت جمع ساعت های کارکرد سه ماه مهر و آبان و آذر است اما بجای اینکه جمع را نشان دهد ساعت را نشان می دهد .

برای رهایی از این مشکل کافی است سلول های حاوی جمع را با قالبی دیگر نمایش دهیم . برروی آنها راست کلیک کرده گزینه ی format cells و number و custom بخش hh:mm را انتخاب کرده ، در اطراف hh یک جفت علامت براکت قرار می دهیم ([hh])

منبع : کتاب ترفند های اکسل ( محمد حسن مهدوی )

نوشته شده در یکشنبه دوم آبان 1389ساعت 7:37 توسط علی توضیح |
تکرار در اکسل 2010 - repeat all item labels
اگر در اکسل 2010 جدول محوری ترسیم کردید که یک گزارش خلاصه شده از داده های یک جدول را ارائه می کند . شما قادر خواهید بود داده های برچسب های آنرا در هر سطر تکرار کنید .این کار در اکسل 2010 ابراز مناسبی دارد به نام repeat all item labels در قسمتreport layout / design تب pivottable tools .

با استفاده از این شیوه شما قادرید جدول گزارشی ( محوری ) را به یک جدول دیگر داده تبدیل کرده و گزارشات مورد نیاز خود را با استفاده ار فیلترها و یا فرمول نویسی از آن استخراج کنید.

کافی است جدول را کپی کرده و عملیات فیلتر و یا فرمول نویسی را آغاز کنید .

نوشته شده در یکشنبه هجدهم مهر 1389ساعت 8:28 توسط علی توضیح |
پر کردن فضای خالی بین سلول های پر - ترفند 23
گاهی اوقات کاربران لیست هایی دریافت می کنند که داده های آن به صورت منظم پر نشده است .مثلا خروجی برخی از نرم افزار ها و جداول محوری از این گروهند . به تصویر زیر نگاه کنید :

سلول های خالی این بخش متعلق به سلول های پر بالای سرشان هستند . برای پر کردن آنها با سلول های بالایی مسیر زیر را به ترتیب طی می کنیم :

۱- ابتدا محدوه ی نام را انتخاب کرده

۲- سلول های خالی آنرا انتخاب می کنیم . ( برای اینکار کافی است کلید های ctrl +g را فشرده و سپس گزینه ی blanks را مطابق تصویر زیر انتخاب کنید )

۳- حال که سلول های خالی انتخاب شدند کافی است به اکسل بفهمانیم که ای سلول ها چگونه باید پر شوند. برای این منظور در همان حالی که سلول های خالی انتخاب شده اند علامت مساوی (=) را فشرده سلول بالایی را که حاوی داده (علی) است را انتخاب می کنیم .

۴- اکنون کافی است که با فشردن کلید ctrl+enterعملیات را تایید کنیم.

نوشته شده در یکشنبه چهارم مهر 1389ساعت 9:4 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
فرم سازی در اکسل 2007
ابزار بعدی combobox است

این ابزار فهرستی را از کاربر گرفته و سپس آنرا نمایش می دهد . این ابزار علاوه بر سلول اتصال دارای گزینه ی input range نیز هست که فهرست داده ها به آن تزریق می شود . سلول اتصال شماره ی سلول انتخاب شده در فهرست را نمایش می دهد .

تمرین : با استفاده از ابزار های ذکر شده یک فرم ساده فاکتور برای یک رستوران طراحی کنید که تا نام غذا انتخاب شود قیمت واحد نمایان شود و کاربر قادر باشد قیمت و تعداد را ملاحظه نماید مانند مثال زیر :

به نحوه ی استفاده از فرمول index دقت کنید این فرمول در یک ارایه به دنبال یک شماره ردیف گشته داده ی آن ردیف را نمایش می دهد. توجه کنید چون قیمت واحد مورد نظر ماست سلول اتصال کمبو باکس را به عنوان شماره ردیف داده به ایندکس می دهیم تا قیمت آنرا نمایش دهد .اما برای چک باکس سالاد کافی است از فرمول if استفاده کنیم . به این صورت که اگر سلول اتصال true باشد قیمت واحد مثلا 1000 باشد و در غیر این صورت 0 باشد .

تمرین را از اینجا دانلود کنید : http://www.divshare.com/download/9265677-3d3

نوشته شده در دوشنبه هجدهم آبان 1388ساعت 12:18 توسط علی توضیح |
فرم سازی در اکسل 2007
برای ساخت یک فرم در اکسل ۲۰۰۷ ابتدا باید تب developer را فعال كنيم تا علاوه بر ابزار هاي فرم سازي در محيط اكسل ؛ ابزار هاي ويژال بيسيك نيز نمايان گردند :

ابتدا برروي office button كليك كرده به سراغ انتهاي منو رفته سپس كليد excel ooption را فشرده در بخش popular گزينه ي show developer tab in the ribbon را فعال كنيم .

حال در تب developer به سراغ گزينه ي insert رفته ابزار هاي آنرا برروي كاربرگ قرار مي دهيم .به طور مثال ابزار check box را فعال كرده آنرا بروي صفحه كاربرگ قرار مي دهيم نام آنرا به " سالاد " تغيير مي دهيم . درحقيقت اين ابزار برروي كاربرگ مانند يك شي قرار مي گيرند و به آن متصل نيستند يعني هنگامي كه كاربر آنرا علامت زده انتخاب مي كند كاربرگ متوجه اين انتخاب نخواهد شد .

براي اتصال اين ابزار بايد برروي آنها راست كليك كرده و سپس براي گزينه ي cell link آنها يك سلول را انتخاب كرد تا نتيجه ي تغييراتشان در كاربرگ نمايان شود.

اين سلول نتيجه ي انتخاب و تغيير شما را نشان مي دهد .هنگام انتخاب چك باكس اين سلول مقدار true را نمايش داده و هنگام عدم انتخاب false را نمايش مي دهد.

حال كاربر قادر است بر اساس اين سلول عمليات فرمول نويسي و تصميم گيري را انجام دهد .

به طور مثال با استفاده از if مي تواند فرمولي نوشته كه اگر مقدار درست باشد عمليات مورد نظر انجام گيرد.

ابزار بعدي option button است كه كاربر هنگامي از آن استفاده مي كند كه يكي از گزينه ها را بايد الزاما انتخاب كند :

توجه كنيد كه اين ابزار يعني اپشن باتن يا كليد هاي راديويي تنها يك سلول اتصال ( cell link ) دارند يعني اگر چند تا از اينها كنار يكديگر يك گروه را تشكيل داده باشند ؛ تنها يك سلول انتخاب دارند كه نشان دهنده ي شماره آنست.

نوشته شده در یکشنبه هفدهم آبان 1388ساعت 10:51 توسط علی توضیح |
تمرین 2- فرم سازی
تمرین1 : فرض کنید اسامی تعدادی کارمند را در یک کاربرگ ،به همراه مشخصات فردی آنها ذخیره کرده ایم . حال قصد داریم با استفاده از یک کمبوباکس و ابزار های فرم سازی در اکسل ، فرمی را طراحی کنیم که با انتخاب نام یک کارمند ، مشخصات فردی وی پدیدار گردد و سپس قادر باشید تمام محاسبات را بر روی داده ها انجام دهیم .

دانلود تمرین

تمرین 2: فرم ساده ای را ایجاد کنید که بتوان با آن در یک رستوران، یک نوع غذا همراه با چند نوع دسر و نوشیدنی سفارش داده و سپس درصد سرویس و تخفیف را محاسبه کرده و سپس مبلغ کل فاکتور ثبت شود .

توجه کنید که با انتخاب نوع غذا ،قیمت واحد با استفاده از تابع index نمایش داده شده و پس از انتخاب تعداد ، جمع هر غذا نمایش داده شود .

دانلود تمرین رستوران

نوشته شده در سه شنبه بیست و یکم شهریور 1385ساعت 11:57 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


نظرات وبلاگ

پستی با شماره درخواستی در وبلاگ به ثبت نرسیده یا حذف شده است

بستن پنجره


تبليغات X
ساخت یک گزارش پویا در اکسل 2010
بیشتر اوقات کاربران اکسل برای گزارش گیری از مجموعه ی عظیمی از داده ها در اکسل به مشکل برخورد می کنند. ابزار جداول محوری یا pivottables در اکسل این توانایی را در آنها ایجاد می کند.این ابزار به کاربران کمک می کند تا بر اساس فیلد ها گزارش تهیه کنند .

مثال- فرض کنید جدول شماره یک مجموعه ای از داده های مربوط به افراد یک کارگاه است که مرتب در حال دریافت و پرداخت میباشند . حال اگر بخواهیم گزارشی از تمام دریافتی ها ی همه کارکنان بیابیم به روش زیر اقدام می کنیم :

حل : ابتدا یک سلول از جدول داه را انتخاب کرده ، از منوی insert گزینه pivot tableرا انتخاب می کنیم .

با انتخاب محدوده جدول داده یا حتی بیشتر از آن ، اکسل متوجه فیلد ها و داده ها می گردد.

فیلد ها و منوی pivottable tools پدیدار می گردد و کاربر قادر است فیلدها را انتخاب کرده و عملیات محاسباتی خود را تغییر دهد.

هر جدول محوری دارای 4 بخش است .

1- ستون ها : که داده ها به صورت ستونی در جدول نمایش داده می شوند.

2- report : که اصلی ترین فیلد مجموعه محسوب می گردد و سایر فیلد ها زیر مجموعه ی آن محسوب می گردند.

3- سیگما : یا بخش محاسباتی جدول

4- ردیف ها : که داده ها به صورت سطری در جدول نمایش داده می شوند.

کافی است فیلد های مورد نظر را گرفته و به یکی از این چهار بخش بکشیم یا آنها را تیک بزنیم.

شکل جدول پدیدار می گردد و شما قادرید از گزارش ساخته شده اطلاعات بگیرید.

برخی اوقات به مشکل برخورد می کنیم . جدول محوری تفاوتی بین یک فیلد محاسباتی را با غیر آن به درستی درک نمی کند . در مثال زیر فیلد اتخاب شده سال به بخش محاسباتی منتقل شده است در حالیکه ما قصد جمع و ضرب آنرا نداریم و می خواهیم دریافتی افراد را طی سال های مختلف بررسی کنیم . بنابراین باید آنرا به بخش سطر ها کشید تا در کنار اسامی اطلاعات را شفافتر منتقل کنند.

خروجی جدول بیانگر دریافتی هر فرد طی سال های مورد نظر است .

لینک دانلود جدول و تمرین های بیشتر را در بخش تمرین جداول محوری در روز شانزدهم فروردین ۹۰ قرار داده ام. موفق باشید

نوشته شده در دوشنبه نهم خرداد 1390ساعت 9:2 توسط علی توضیح |
تمرین جداول محوری - pivottable
در فایل زیر که شامل سه کاربرگ است ، تمرین های زیر را حل کنید:

1- در جدول یک مطلوبست جمع دریافتی هر نفر؟

2- میانگین دریافتی هر نفر از هر بانک ؟

3- بیشترین دریافتی هر نفر در هر سال ؟

4- کمترین مقداری که هر بانک به عنوان دریافتی ، در هر سال به هر فرد داده است ؟

5- در جدول شماره دو ، مقدار خریداری شده و فروخته شده هر کالا را نمایش داده و سپس مانده ی هر کدام را نمایش دهید.

6- در جدول شماره سه هر فروشگاه در هر شهر از هر کالا چه مبلغی ( جمع کل ) فروش داشته است.

7- نمودار فروش پاکن را در تمام فروشگاه ها مقایسه کنید.

دانلود تمرین

موفق باشید

نوشته شده در سه شنبه شانزدهم فروردین 1390ساعت 11:17 توسط علی توضیح |
گزارش گیری از چند کاربرگ مختلف - muliple consolidation ranges in pivottable
فرض کنید در چند کاربرگ جداولی با فیلدهای شبیه هم داریم اما داده ها متفاوتند مثلا هر کاربرگ مربوط به عملیات مالی یک ماه از سال است و در هر جدول داده های افراد در آن ماه ها وارد شده است . حال قصد دارید که کز هر فرد طی ماه های مورد نظر گزارش تهیه کنید.

ابتدا باید یک سلول از یکی از جداول را انتخاب کرد و سپس از ویزار جداول محوری مرحله به مرحله جلو رفت .

Alt + D + P را باید فشرد تا پنجره ی ویزارد نمایان شود . ابتدا گزینه muliple consolidation ranges را انتخاب می کنیم

حال اگر مایلید فیلد ها را در جدول به صورت report مشاهده کنید می توانید آنها را انتخاب کنید

محدوده هایی از جداول که باید برای گزارش ارسال شوند را انتخاب و سپس add می کنیم.

توجه کنید که فیلدی که می خواهید بر اساس آن گزارش تهیه کنید باید ، اولین فیلد باشد .

با اتمام عملیات ویزارد گزارشی از دریافتی های تمتم پرسنل ماههای انتخاب شده به شما نشان داده می شود.

نوشته شده در چهارشنبه نوزدهم آبان 1389ساعت 9:15 توسط علی توضیح |
تکرار در اکسل 2010 - repeat all item labels
اگر در اکسل 2010 جدول محوری ترسیم کردید که یک گزارش خلاصه شده از داده های یک جدول را ارائه می کند . شما قادر خواهید بود داده های برچسب های آنرا در هر سطر تکرار کنید .این کار در اکسل 2010 ابراز مناسبی دارد به نام repeat all item labels در قسمتreport layout / design تب pivottable tools .

با استفاده از این شیوه شما قادرید جدول گزارشی ( محوری ) را به یک جدول دیگر داده تبدیل کرده و گزارشات مورد نیاز خود را با استفاده ار فیلترها و یا فرمول نویسی از آن استخراج کنید.

کافی است جدول را کپی کرده و عملیات فیلتر و یا فرمول نویسی را آغاز کنید .

نوشته شده در یکشنبه هجدهم مهر 1389ساعت 8:28 توسط علی توضیح |
روش ساخت جدول محوری pivot table - ابزاری مناسب برای گزارش گیری و تحلیل داده
جدول محوری چیست؟ هرگاه لیستی از داد ه های تکرار شده داشته باشیم و بخواهیم از این داد ه ها گزارش گرفته و اطلاعات خارج کنیم ، از این ابزار استفاده می کنیم . اطلاعات حول محور یکی از فیلد های لیست ارائه می شود .

به طور مثال ، فرض کنید لیست تعدادی فروشگاه که لوازم التحریر می فروشند ، همراه نوع کالا ، تعداد و مبلغ فروش هر کالا و اسامی شهرهای هر فروشگاه موجود است . در این لیست هرگاه فروشگاهی کالایی را فروخته باشد مثل یک دفتر روزنامه ثبت شده است .

مساله : می خواهیم بدانیم هر فروشگاه از هر کالا چقدر فروخته است ؟

یعنی محوریت جدول با اسامی فروشگاه هاست .

روش ساخت جدول محوری

برای ایجاد یک گزارش یا جدول محوری از یک لیست ، کافی است مراحل زیر را به ترتیب انجام دهیم :

  1. انتخاب یکی از سلول های لیست
  2. data | pivottable and pivotchart report
  3. next
  4. next
  5. layout
  6. انتخاب ساختار جدول
  7. انتخاب قالب جدول
  8. finish

مراحل تصویری:

انتخاب یک سلول از لیست و سپس منوی DATA ....

این گزینه ها برای انتخاب جدول یا ترسیم نمودار آن و یا انتخاب نوع لیست داده هاست . منظور از نوع لیست ، لیست داده های درون یا بیرون از اکسل و یا ترکیبی از لیست های متفاوت از داده های یکسان ( مثلا دریافتی و پرداختی افراد در دو شیت متفاوت باشد ) و یا ترکیب دو جدول محوری

انتخاب محدوده لیست ( بهتر است بیشتر انتخاب کنید )

جدول محوری در همان کاربرگ یا یک کاربرگ جدید و کلید LAYOUT

هر فیلدی به جای مورد نظر کشیده می شود . ( ROW به صورت ردیفی COLUMN به صورت ستونی و DATA داده های محاسباتی و بخش PAGE به عنوان محور تمام جدول )

فیلد های کالا ، فروشگاه و جمع کل همگی زیر مجموعه فیلد شهر می باشند . با دبل کلیک برروی جمع کل میتوانید توابع دیگری غیر از SUM را انتخاب کنید .

جدول به صورت فوق نمایش داده می شود . مبلغ فروش هر کالا در هر فروشگاه و در تمام شهر ها نمایش داده شده است . ( PAGE = ALL )

انتخاب یک قالب زیبا برای جدول محوری

جدول آماده استخراج اطلاعات و اتخاذ تصمیم نهایی است . سطر و ستون آخر جمع نهایی است .

مثال ها در بخش تمرین آماده دانلود است .

نوشته شده در دوشنبه ششم شهریور 1385ساعت 11:55 توسط علی توضیح |
دانلود تمرین ها PIVOT TABLE AND PIVOT CHART REPORT
قابل توجه دانشجویان اکسل پیشرفته تمرین های زیر را دانلود کرده ، آنها را حل و به آدرس ایمیل من ارسال نمایید . مهلت ارسال 6 شهریور 85

DOWNLOAD PIVOTTABLE

برای دانلود تمرین ها ابتدا برروی آنها کلیک کرده سپس کلید FREE را در پایین صفحه فشار داده آنگاه عناصر داده شده را در بخش PLEASE ENTER وارد کرده سپس کلید DOWNLOAD FROM را می فشارید:

تمرین جدول محوری 1

  1. جمع دریافتی های هر فرد چقدر است ؟
  2. جمع دریافتی های هر فرد در هر ماه چقدر است ؟
  3. میانگین دریافتی های هر فرد از هر بانک چقدر است ؟

تمرین جدول محوری 2

  1. نمودار مبلغ فروش هر کالا در هر فروشگاه
  2. نمودار مبلغ فروش هر کالا در هر شهر
  3. مقایسه تعداد فروش هر کالا در فروشگاه
  4. مقایسه تاریخ های فروش

تمرین جدول محوری 3

  1. ایجاد یک فرم کنترل انبار
  2. حسابداری انبار
  3. گزارش تعداد مانده های هر کالا در انبار

نحوه ایجاد جداول محوری ....

نوشته شده در دوشنبه سی ام مرداد 1385ساعت 12:41 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
دانلود تمرین ها PIVOT TABLE AND PIVOT CHART REPORT
قابل توجه دانشجویان اکسل پیشرفته تمرین های زیر را دانلود کرده ، آنها را حل و به آدرس ایمیل من ارسال نمایید . مهلت ارسال 6 شهریور 85

DOWNLOAD PIVOTTABLE

برای دانلود تمرین ها ابتدا برروی آنها کلیک کرده سپس کلید FREE را در پایین صفحه فشار داده آنگاه عناصر داده شده را در بخش PLEASE ENTER وارد کرده سپس کلید DOWNLOAD FROM را می فشارید:

تمرین جدول محوری 1

  1. جمع دریافتی های هر فرد چقدر است ؟
  2. جمع دریافتی های هر فرد در هر ماه چقدر است ؟
  3. میانگین دریافتی های هر فرد از هر بانک چقدر است ؟

تمرین جدول محوری 2

  1. نمودار مبلغ فروش هر کالا در هر فروشگاه
  2. نمودار مبلغ فروش هر کالا در هر شهر
  3. مقایسه تعداد فروش هر کالا در فروشگاه
  4. مقایسه تاریخ های فروش

تمرین جدول محوری 3

  1. ایجاد یک فرم کنترل انبار
  2. حسابداری انبار
  3. گزارش تعداد مانده های هر کالا در انبار

نحوه ایجاد جداول محوری ....

نوشته شده در دوشنبه سی ام مرداد 1385ساعت 12:41 توسط علی توضیح |
معرفی یک وبلاگ جدید درباره اکسل
این وبلاگ توسط آقای فرشید میدانی تهیه شده است و مطالب جالب و کاملی را درباره نرم افزار اکسل مورد بحث قرار داده است . برای کسب اطلاعات بیشتر درباره ابزار زیر به وبلاگ ایشان مراجعه نمایید :

  1. شرح فارسی توابع ریاضی و مثلثاتی
  2. تاریخ شمسی در اکسل (توابع جدید برای تاریخ و تبدیل عدد به حروف در اکسل تاریخ هجری شمسی ( تاریخ جلالی در اکسل)
  3. تبدیل عدد به حروف در اکسل

  4. آشنایی با Solver

  5. نمونه سوالات ICDL مهات چهارم

با تشکر از ایشان

نوشته شده در شنبه بیست و هشتم مرداد 1385ساعت 10:56 توسط علی توضیح |
مطالب جدید اکسل EXCEL
برای کسب اطلاعات بیشتر درباره ابزار زیر به وبلاگ آقای بهرام صمدیان مراجعه نمایید :

  1. GOTO
  2. SENARIO
  3. GOAL SEEK
  4. SOLVER
  5. Excel Custom Format Cell
  6. ماکرو نویسی در اکسل

جناب صمدیان مطالب حرفه ای اکسل را با جزئیات و دقت فراوان و به شیوایی همراه با مثال ارائه کرده اند

نوشته شده در شنبه بیست و هشتم مرداد 1385ساعت 10:24 توسط علی توضیح |
متن کتاب اکسل 2002

متن کتاب اکسل 2002 شاخه کار و دانش : رایانه کار درجه ۲

نوشته شده در پنجشنبه بیست و ششم مرداد 1385ساعت 12:25 توسط علی توضیح |
توابع آدرس و جستجو 4

rows(محدوده)

این تابع تعداد سطرهای محدوه را نمایش می دهد .

columns(محدوده)

این تابع تعداد ستون های محدوه را نمایش می دهد .

ADDRESS(row_num,column_num,abs_num,a1,sheet_text)

این تابع شماره سطر و شماره ستون را دریافت کرده آدرس سلول را نمایش می دهد .

پارامترهای این تابع عبارتند از :

Row_num شماره سطر

Column_num شماره ستون

Abs_num شماره نوع آدرس

A1 اگر صحیح باشد آدرس دهی با فرم حروفی و اگر نادرست باشد آدرس دهی با فرم عددی است .

نام کاربرگ برای آدرس دهی Sheet_text

شماره | نوع آدرس
1 or omitted | مطلق
2 | سطر مطلق و ستون نسبی
3 | سطر نسبی و ستون مطلق
4 | نسبی

نوشته شده در پنجشنبه بیست و ششم مرداد 1385ساعت 10:32 توسط علی توضیح |
توابع اکسل5
Financial functions | توابع مالی
Function | Description
ACCRINT | Returns the accrued interest for a security that pays periodic interest
ACCRINTM | Returns the accrued interest for a security that pays interest at maturity
AMORDEGRC | Returns the depreciation for each accounting period by using a depreciation coefficient
AMORLINC | Returns the depreciation for each accounting period
COUPDAYBS | Returns the number of days from the beginning of the coupon period to the settlement date
COUPDAYS | Returns the number of days in the coupon period that contains the settlement date
COUPDAYSNC | Returns the number of days from the settlement date to the next coupon date
COUPNCD | Returns the next coupon date after the settlement date
COUPNUM | Returns the number of coupons payable between the settlement date and maturity date
COUPPCD | Returns the previous coupon date before the settlement date
CUMIPMT | Returns the cumulative interest paid between two periods
CUMPRINC | Returns the cumulative principal paid on a loan between two periods
DB | Returns the depreciation of an asset for a specified period by using the fixed-declining balance method
DDB | Returns the depreciation of an asset for a specified period by using the double-declining balance method or some other method that you specify
DISC | Returns the discount rate for a security
DOLLARDE | Converts a dollar price, expressed as a fraction, into a dollar price, expressed as a decimal number
DOLLARFR | Converts a dollar price, expressed as a decimal number, into a dollar price, expressed as a fraction
DURATION | Returns the annual duration of a security with periodic interest payments
EFFECT | Returns the effective annual interest rate
FV | Returns the future value of an investment
FVSCHEDULE | Returns the future value of an initial principal after applying a series of compound interest rates
INTRATE | Returns the interest rate for a fully invested security
IPMT | Returns the interest payment for an investment for a given period
IRR | Returns the internal rate of return for a series of cash flows
ISPMT | Calculates the interest paid during a specific period of an investment
MDURATION | Returns the Macauley modified duration for a security with an assumed par value of $100
MIRR | Returns the internal rate of return where positive and negative cash flows are financed at different rates
NOMINAL | Returns the annual nominal interest rate
NPER | Returns the number of periods for an investment
NPV | Returns the net present value of an investment based on a series of periodic cash flows and a discount rate
ODDFPRICE | Returns the price per $100 face value of a security with an odd first period
ODDFYIELD | Returns the yield of a security with an odd first period
ODDLPRICE | Returns the price per $100 face value of a security with an odd last period
ODDLYIELD | Returns the yield of a security with an odd last period
PMT | Returns the periodic payment for an annuity
PPMT | Returns the payment on the principal for an investment for a given period
PRICE | Returns the price per $100 face value of a security that pays periodic interest
PRICEDISC | Returns the price per $100 face value of a discounted security
PRICEMAT | Returns the price per $100 face value of a security that pays interest at maturity
PV | Returns the present value of an investment
RATE | Returns the interest rate per period of an annuity
RECEIVED | Returns the amount received at maturity for a fully invested security
SLN | Returns the straight-line depreciation of an asset for one period
SYD | Returns the sum-of-years' digits depreciation of an asset for a specified period
TBILLEQ | Returns the bond-equivalent yield for a Treasury bill
TBILLPRICE | Returns the price per $100 face value for a Treasury bill
TBILLYIELD | Returns the yield for a Treasury bill
VDB | Returns the depreciation of an asset for a specified or partial period by using a declining balance method
XIRR | Returns the internal rate of return for a schedule of cash flows that is not necessarily periodic
XNPV | Returns the net present value for a schedule of cash flows that is not necessarily periodic
YIELD | Returns the yield on a security that pays periodic interest
YIELDDISC | Returns the annual yield for a discounted security; for example, a Treasury bill
YIELDMAT | Returns the annual yield of a security that pays interest at maturity
Information functions | توابع اطلاعاتی
Function | Description
CELL | Returns information about the formatting, location, or contents of a cell
ERROR.TYPE | Returns a number corresponding to an error type
INFO | Returns information about the current operating environment
ISBLANK | Returns TRUE if the value is blank
ISERR | Returns TRUE if the value is any error value except #N/A
ISERROR | Returns TRUE if the value is any error value
ISEVEN | Returns TRUE if the number is even
ISLOGICAL | Returns TRUE if the value is a logical value
ISNA | Returns TRUE if the value is the #N/A error value
ISNONTEXT | Returns TRUE if the value is not text
ISNUMBER | Returns TRUE if the value is a number
ISODD | Returns TRUE if the number is odd
ISREF | Returns TRUE if the value is a reference
ISTEXT | Returns TRUE if the value is text
N | Returns a value converted to a number
NA | Returns the error value #N/A
TYPE | Returns a number indicating the data type of a value
Top of Page |
Logical functions | توابع منطقی
Function | Description
AND | Returns TRUE if all of its arguments are TRUE
FALSE | Returns the logical value FALSE
IF | Specifies a logical test to perform
NOT | Reverses the logic of its argument
OR | Returns TRUE if any argument is TRUE
TRUE | Returns the logical value TRUE
Lookup and reference functions | توابع جستجو و آدرس
Function | Description
ADDRESS | Returns a reference as text to a single cell in a worksheet
AREAS | Returns the number of areas in a reference
CHOOSE | Chooses a value from a list of values
COLUMN | Returns the column number of a reference
COLUMNS | Returns the number of columns in a reference
GETPIVOTDATA | Returns data stored in a PivotTable
HLOOKUP | Looks in the top row of an array and returns the value of the indicated cell
HYPERLINK | Creates a shortcut or jump that opens a document stored on a network server, an intranet, or the Internet
INDEX | Uses an index to choose a value from a reference or array
INDIRECT | Returns a reference indicated by a text value
LOOKUP | Looks up values in a vector or array
MATCH | Looks up values in a reference or array
OFFSET | Returns a reference offset from a given reference
ROW | Returns the row number of a reference
ROWS | Returns the number of rows in a reference
RTD | Retrieves real-time data from a program that supports COM automation (Automation: A way to work with an application's objects from another application or development tool. Formerly called OLE Automation, Automation is an industry standard and a feature of the Component Object Model (COM).)
TRANSPOSE | Returns the transpose of an array
VLOOKUP | Looks in the first column of an array and moves across the row to return the value of a cell
Math and trigonometry functions | توابع ریاضیات و مثلثات
Function | Description
ABS | Returns the absolute value of a number
ACOS | Returns the arccosine of a number
ACOSH | Returns the inverse hyperbolic cosine of a number
ASIN | Returns the arcsine of a number
ASINH | Returns the inverse hyperbolic sine of a number
ATAN | Returns the arctangent of a number
ATAN2 | Returns the arctangent from x- and y-coordinates
ATANH | Returns the inverse hyperbolic tangent of a number
CEILING | Rounds a number to the nearest integer or to the nearest multiple of significance
COMBIN | Returns the number of combinations for a given number of objects
COS | Returns the cosine of a number
COSH | Returns the hyperbolic cosine of a number
DEGREES | Converts radians to degrees
EVEN | Rounds a number up to the nearest even integer
EXP | Returns e raised to the power of a given number
FACT | Returns the factorial of a number
FACTDOUBLE | Returns the double factorial of a number
FLOOR | Rounds a number down, toward zero
GCD | Returns the greatest common divisor
INT | Rounds a number down to the nearest integer
LCM | Returns the least common multiple
LN | Returns the natural logarithm of a number
LOG | Returns the logarithm of a number to a specified base
LOG10 | Returns the base-10 logarithm of a number
MDETERM | Returns the matrix determinant of an array
MINVERSE | Returns the matrix inverse of an array
MMULT | Returns the matrix product of two arrays
MOD | Returns the remainder from division
MROUND | Returns a number rounded to the desired multiple
MULTINOMIAL | Returns the multinomial of a set of numbers
ODD | Rounds a number up to the nearest odd integer
PI | Returns the value of pi
POWER | Returns the result of a number raised to a power
PRODUCT | Multiplies its arguments
QUOTIENT | Returns the integer portion of a division
RADIANS | Converts degrees to radians
نوشته شده در پنجشنبه بیست و ششم مرداد 1385ساعت 9:7 توسط علی توضیح |
توابع اکسل 4

Engineering functions | توابع مهندسی
Function | Description
BESSELI | Returns the modified Bessel function In(x)
BESSELJ | Returns the Bessel function Jn(x)
BESSELK | Returns the modified Bessel function Kn(x)
BESSELY | Returns the Bessel function Yn(x)
BIN2DEC | Converts a binary number to decimal
BIN2HEX | Converts a binary number to hexadecimal
BIN2OCT | Converts a binary number to octal
COMPLEX | Converts real and imaginary coefficients into a complex number
CONVERT | Converts a number from one measurement system to another
DEC2BIN | Converts a decimal number to binary
DEC2HEX | Converts a decimal number to hexadecimal
DEC2OCT | Converts a decimal number to octal
DELTA | Tests whether two values are equal
ERF | Returns the error function
ERFC | Returns the complementary error function
GESTEP | Tests whether a number is greater than a threshold value
HEX2BIN | Converts a hexadecimal number to binary
HEX2DEC | Converts a hexadecimal number to decimal
HEX2OCT | Converts a hexadecimal number to octal
IMABS | Returns the absolute value (modulus) of a complex number
IMAGINARY | Returns the imaginary coefficient of a complex number
IMARGUMENT | Returns the argument theta, an angle expressed in radians
IMCONJUGATE | Returns the complex conjugate of a complex number
IMCOS | Returns the cosine of a complex number
IMDIV | Returns the quotient of two complex numbers
IMEXP | Returns the exponential of a complex number
IMLN | Returns the natural logarithm of a complex number
IMLOG10 | Returns the base-10 logarithm of a complex number
IMLOG2 | Returns the base-2 logarithm of a complex number
IMPOWER | Returns a complex number raised to an integer power
IMPRODUCT | Returns the product of from 2 to 29 complex numbers
IMREAL | Returns the real coefficient of a complex number
IMSIN | Returns the sine of a complex number
IMSQRT | Returns the square root of a complex number
IMSUB | Returns the difference between two complex numbers
IMSUM | Returns the sum of complex numbers
OCT2BIN | Converts an octal number to binary
OCT2DEC | Converts an octal number to decimal
OCT2HEX | Converts an octal number to hexadecimal

excel help

نوشته شده در پنجشنبه بیست و ششم مرداد 1385ساعت 8:32 توسط علی توضیح |
توابع اکسل 3
Date and time functions | توابع تاریخ و زمان
Function | Description
DATE | Returns the serial number of a particular date
DATEVALUE | Converts a date in the form of text to a serial number
DAY | Converts a serial number to a day of the month
DAYS360 | Calculates the number of days between two dates based on a 360-day year
EDATE | Returns the serial number of the date that is the indicated number of months before or after the start date
EOMONTH | Returns the serial number of the last day of the month before or after a specified number of months
HOUR | Converts a serial number to an hour
MINUTE | Converts a serial number to a minute
MONTH | Converts a serial number to a month
NETWORKDAYS | Returns the number of whole workdays between two dates
NOW | Returns the serial number of the current date and time
SECOND | Converts a serial number to a second
TIME | Returns the serial number of a particular time
TIMEVALUE | Converts a time in the form of text to a serial number
TODAY | Returns the serial number of today's date
WEEKDAY | Converts a serial number to a day of the week
WEEKNUM | Converts a serial number to a number representing where the week falls numerically with a year
WORKDAY | Returns the serial number of the date before or after a specified number of workdays
YEAR | Converts a serial number to a year
YEARFRAC | Returns the year fraction representing the number of whole days between start_date and end_date
نوشته شده در چهارشنبه بیست و پنجم مرداد 1385ساعت 13:7 توسط علی توضیح |
توابع اکسل 2

Database functions |
Function | Description
DAVERAGE | Returns the average of selected database entries
DCOUNT | Counts the cells that contain numbers in a database
DCOUNTA | Counts nonblank cells in a database
DGET | Extracts from a database a single record that matches the specified criteria
DMAX | Returns the maximum value from selected database entries
DMIN | Returns the minimum value from selected database entries
DPRODUCT | Multiplies the values in a particular field of records that match the criteria in a database
DSTDEV | Estimates the standard deviation based on a sample of selected database entries
DSTDEVP | Calculates the standard deviation based on the entire population of selected database entries
DSUM | Adds the numbers in the field column of records in the database that match the criteria
DVAR | Estimates variance based on a sample from selected database entries
DVARP | Calculates variance based on the entire population of selected database entries

این توابع از راهنمای اکسل 2003 گردآوری شده اند .

نوشته شده در چهارشنبه بیست و پنجم مرداد 1385ساعت 12:29 توسط علی توضیح |
توابع اکسل 1

 | فهرست تمام توابع اکسل مقدماتی و پیشرفته و آماری و ... دسته بندی شده
Database functions | توابع پایگاه داده
Date and time functions | توابع تاریخ و زمان
Engineering functions | توابع مهندسی
Financial functions | توابع مالی
Information functions | توابع اطلاعاتی
Logical functions | توابع منطقی
Lookup and reference functions | توابع جستجو و آدرس
Math and trigonometry functions | توابع ریاضیات و مثلثات
Statistical functions | توابع آماری
Text functions | توابع متن
External functions | توابع خارجی

ادامه مطلب
نوشته شده در چهارشنبه بیست و پنجم مرداد 1385ساعت 12:11 توسط علی توضیح |
توابع جستجو 3
تابع VLOOKUP

این تابع داده ای را در اولین ستون یک لیست جستجو کرده سپس مقدار متناظر آنرا در ستون مورد نظر نمایش می دهد .

=VLOOKUP(lookup_value,table_array,col_index_num,range_lookup)

پارامترها به ترتیب عبارتند از :

  1. مقدار جستجو
  2. آدرس کل جدول
  3. شماره ستونی که قصد داریم مقدار آنرا بیابیم .
  4. عدد یک برای لیست صعودی ، عدد -1 برای لیست نزولی ، عدد صفر برای لیست نامنظم

شرح کامل این ساختار به زبان اصلی از راهنمای اکسل :

EXCEL HELP VLOOKUP:

Lookup_value is the value to be found in the first column of the array. Lookup_value can be a value, a reference, or a text string.

Table_array is the table of information in which data is looked up. Use a reference to a range or a range name, such as Database or List.

  • If range_lookup is TRUE, the values in the first column of table_array must be placed in ascending order: ..., -2, -1, 0, 1, 2, ..., A-Z, FALSE, TRUE; otherwise VLOOKUP may not give the correct value. If range_lookup is FALSE, table_array does not need to be sorted.

  • You can put the values in ascending order by choosing the Sort command from the Data menu and selecting Ascending.

  • The values in the first column of table_array can be text, numbers, or logical values.

  • Uppercase and lowercase text are equivalent.

Col_index_num is the column number in table_array from which the matching value must be returned. A col_index_num of 1 returns the value in the first column in table_array; a col_index_num of 2 returns the value in the second column in table_array, and so on. If col_index_num is less than 1, VLOOKUP returns the #VALUE! error value; if col_index_num is greater than the number of columns in table_array, VLOOKUP returns the #REF! error value.

Range_lookup is a logical value that specifies whether you want VLOOKUP to find an exact match or an approximate match. If TRUE or omitted, an approximate match is returned. In other words, if an exact match is not found, the next largest value that is less than lookup_value is returned. If FALSE, VLOOKUP will find an exact match. If one is not found, the error value #N/A is returned.

مثال : برای جدول زیر فرمولی طراحی نمایید که اگر نام شخص نوشته شود در مقابل آن حقوق مبنا نمایش داده شود. ( به نحوه آدرس دهی جدول و شماره ستون انتخاب شده دقت نمایید .)

نوشته شده در چهارشنبه بیست و پنجم مرداد 1385ساعت 10:43 توسط علی توضیح |
ترکیب دو تابع MATCH , INDEX
مثال : در جدول داده شده مثال قبل ، فرمولی طراحی نمایید که هرگاه نام شخص نوشته شود ، شماره پرسنلی نمایش داده شود . ( ترکیب دو تابع MATCH , INDEX )

نوشته شده در چهارشنبه بیست و پنجم مرداد 1385ساعت 10:4 توسط علی توضیح |
توابع آدرس و جستجو 2
برای جستجو در لیست های غیر تکراری در اکسل از توابع مختلفی استفاده می شود که مهمترین آنها عبارتند از :

۱- تابع index

شکل این تابع به این صورت است :

=index( شماره ردیف داده در آرایه ; آدرس آرایه مورد جستجو )

این تابع در آرایه ( یک محدوده تک ستونی)جستجو ، به شماره ردیف داده شده وارد می شود و سپس داده را که در آن ردیف قرار گرفته نمایش می دهد .مثال در فرمول زیر b6 تا b11 محدوده ای از نام هاست که نام شماره 4 در لیست ( توضیح علی ) مورد نظر ماست .

=INDEX(B6:B11;4 )

۲- تابع match

شکل این تابع به این صورت است :

=match( آرایه جستجو ; داده مورد جستجو; match type )

این تابع برعکس تابع فوق ابتدا داده را در آرایه جستجو کرده و سپس شماره ردیف آنرا ، نمایش می دهد .

match type : برای حالتی که آرایه نزولی است عدد -1 برای حالتی که صعودی است عدد یک و برای حالتی که آرایه نامنظم پر شده است عدد صفر است .

مثال : در مثال زیر اگر نام نوشته شود - شماره ردیف آن نمایش داده شود و اگر شماره ردیف نوشته شود نام نمایش داده شود .

نوشته شده در سه شنبه بیست و چهارم مرداد 1385ساعت 9:51 توسط علی توضیح |
فرم سازی 3

نحوه ساخت فرم ها

فرم زیر را طوری طراحی کنید ، که با انتخاب اسم فرد تمام مشخصات او نمایش داده شود :

نوشته شده در سه شنبه بیست و چهارم مرداد 1385ساعت 8:14 توسط علی توضیح |
ابزار گزارش گیری 2

مطالبی درباره

شیوه استفاده از توابع sumif , countif

در گزارش گیری از انبوه داده ها

نوشته شده در دوشنبه شانزدهم مرداد 1385ساعت 12:6 توسط علی توضیح |
تمرین تابع subtotal
این تابع دارای ۱۱ تابع درونی است و هر کدام ازاین توابع با یک عدد از یک تا یازده مشخص شده و سپس در محدوده داده شده عمل می کنند .

این یازده تابع عبارتند از :

Function_num (includes hidden values) | Function_num (ignores hidden values) | Function
1 | 101 | AVERAGE
2 | 102 | COUNT
3 | 103 | COUNTA
4 | 104 | MAX
5 | 105 | MIN
6 | 106 | PRODUCT
7 | 107 | STDEV
8 | 108 | STDEVP
9 | 109 | SUM
10 | 110 | VAR
11 | 111 | VARP

ویژگی قابل ذکر این تابع حساسیت نسبت به فیلتر هاست . یعنی در زمانی که فیلتر ها فعال هستند عملیات را فقط برای محدوده نمایش داده شده انجام میدهد .

به طور مثال در جدول زیر جمع دریافتی های علی در ماه مهر چقدر است ؟

ابتدا تابع را به شکلی که در تصویر قرار دارد بالای جدول قرار می دهیم آنگاه فیلتر ها را فعال کرده ، علی و ماه مهر را انتخاب می کنیم ، تابع مجموع داده های فیلتر شده را نمایش می دهد .

هرگاه بخواهیم سطرهای پنهان شده در محاسبات دخیل نشوند از اعداد با پیش شماره 100 استفاده می کنیم . ( XP 2003 )

در فایل زیر مطلوبست:

  1. جمع کل دریافتی های علی ؟
  2. میانگین کل دریافتی های رضا؟
  3. جمع کل دریافتی های علی در ماه مهر؟
  4. جمع کل دریافتی های علی در مها مهر از بانک ملی؟
  5. جمع کل درافتی های علی و رضا با هم ؟
  6. جمع کل درافتی هایی که از بانک سپه انجام شده ؟

دانلود تمرین تابع subtotal

نوشته شده در چهارشنبه چهارم مرداد 1385ساعت 5:20 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
آشنایی بیشتر با format cells در اکسل 2007
حتما شما هم می دانید که با فشردن کلید های کنترل و عدد یک پنجره ی ابزار format cells در اکسل فعال می شود .یکی از توانایی های این بخش در قالب بندی اعداد، گزینه ی custom است که شما را قادر می سازد اعداد را با قالب بندی دلخواه نمایش دهید.

این بخش شامل 4 قسمت است که با علامت سیمی کالن ( ; ) از هم جدا می شوند و به ترتیب به اعداد مثبت - اعداد منفی - صفر و متن اختصاص دارند.تعدادی علامت در این بخش وجود دارد که با استفاده از آنها می توان قالب مورد نظر را صدا زد . در حقیقت نوعی کد نویسی با استفاده از این علائم. مثلا علامت # و علامت ؟ و عدد 0 و یا علامت اعشار (.) .

این علائم در بخش قالب بندی اعداد ما را یاری می کنند. مثلا کاربر می نویسد :

0.0;-0.0;;@

مفهوم این علائم اینست که ( از سمت چپ) اعداد مثبت را با یک اعشار بنویس ، اعداد منفی را نیز همینطور در ضمن علامت منفی را هم قرار بده ، صفر را اصلا نمایش نده ( بین دو سیمی کالن فضای خالی نیست ) ،و برای متن هم هرانچه نوشته شد نمایش بده.

مطالب زیر را از سایت مایکروسافت بخوانید نکات جالبی را مطرح کرده است :

Review guidelines for customizing a number format

To create a custom number format, you start by selecting one of the built-in number formats as a starting point. You can then change any one of the code sections of that format to create your own custom number format.

A number format can have up to four sections of code, separated by semicolons. These code sections define the format for positive numbers, negative numbers, zero values, and text, in that order.

>;;;

For example, you can use these code sections to create the following custom format:

[Blue]#,##0.00_);[Red](#,##0.00);0.00;"sales "@

You do not have to include all code sections in your custom number format. If you specify only two code sections for your custom number format, the first section is used for positive numbers and zeros, and the second section is used for negative numbers. If you specify only one code section, it is used for all numbers. If you want to skip a code section and include a code section that follows it, you must include the ending semicolon for the section that you skip.

The following guidelines should be helpful for customizing any of these number format code sections.

Guidelines for including text and adding spacing

  • Display both text and numbers To display both text and numbers in a cell, enclose the text characters in double quotation marks (" ") or precede a single character with a backslash (\). Include the characters in the appropriate section of the format codes. For example, type the format $0.00" Surplus";$-0.00" Shortage" to display a positive amount as "$125.74 Surplus" and a negative amount as "$-125.74 Shortage." Note that there is one space character before both "Surplus" and "Shortage" in each code section.

The following characters are displayed without the use of quotation marks.

$ | Dollar sign
+ | Plus sign
( | Left parenthesis
: | Colon
^ | Circumflex accent (caret)
' | Apostrophe
{ | Left curly bracket
< | Less-than sign
= | Equal sign
- | Minus sign
/ | Slash mark
) | Right parenthesis
! | Exclamation point
& | Ampersand
~ | Tilde
} | Right curly bracket
> | Greater-than sign
 | Space character
  • Include a section for text entry If included, a text section is always the last section in the number format. Include an "at" character (@) in the section where you want to display any text that you type in the cell. If the @ character is omitted from the text section, text that you type will not be displayed. If you want to always display specific text characters with the typed text, enclose the additional text in double quotation marks (" "). For example, "gross receipts for "@

If the format does not include a text section, any nonnumeric value that you type in a cell with that format applied is not affected by the format. In addition, the entire cell is converted to text.

  • Add spaces To create a space that is the width of a character in a number format, include an underscore character (_), followed by the character that you want to use. For example, when you follow an underscore with a right parenthesis, such as _), positive numbers line up correctly with negative numbers that are enclosed in parentheses.
  • Repeat characters To repeat the next character in the format to fill the column width, include an asterisk (*) in the number format. For example, type 0*- to include enough dashes after a number to fill the cell, or type *0 before any format to include leading zeros.

Guidelines for using decimal places, spaces, colors, and conditions

  • Include decimal places and significant digits To format fractions or numbers that contain decimal points, include the following digit placeholders, decimal points, and thousand separators in a section.
0 (zero) | This digit placeholder displays insignificant zeros if a number has fewer digits than there are zeros in the format. For example, if you type 8.9, and you want it to be displayed as 8.90, use the format #.00.
# | This digit placeholder follows the same rules as the 0 (zero). However, Excel does not display extra zeros when the number that you type has fewer digits on either side of the decimal than there are # symbols in the format. For example, if the custom format is #.##, and you type 8.9 in the cell, the number 8.9 is displayed.
? | This digit placeholder follows the same rules as the 0 (zero). However, Excel adds a space for insignificant zeros on either side of the decimal point so that decimal points are aligned in the column. For example, the custom format 0.0? aligns the decimal points for the numbers 8.9 and 88.99 in a column.
. (period) | This digit placeholder displays the decimal point in a number.
  • If a number has more digits to the right of the decimal point than there are placeholders in the format, the number rounds to as many decimal places as there are placeholders. If there are more digits to the left of the decimal point than there are placeholders, the extra digits are displayed. If the format contains only number signs (#) to the left of the decimal point, numbers less than 1 begin with a decimal point; for example, .47.
To display | As | Use this code
1234.59 | 1234.6 | ####.#
8.9 | 8.900 | #.000
.631 | 0.6 | 0.#
12 1234.568 | 12.0 1234.57 | #.0#
44.398 102.65 2.8 | 44.398 102.65 2.8 (with aligned decimals) | ???.???
5.25 5.3 | 5 1/4 5 3/10 (with aligned fractions) | # ???/???
  • Display a thousands separator To display a comma as a thousands separator or to scale a number by a multiple of 1,000, include the following separator in the number format.
, (comma) Displays the thousands separator in a number. Excel separates thousands by commas if the format contains a comma that is enclosed by number signs (#) or by zeros. A comma that follows a digit placeholder scales the number by 1,000. For example, if the format is #.0,, and you type 12,200,000 in the cell, the number 12.200.0 is displayed.
To display | As | Use this code
12000 | 12,000 | #,###
12000 | 12 | #,
12200000 | 12.2 | 0.0,,
  • Specify colors To specify the color for a section of the format, type the name of one of the following eight colors enclosed in square brackets in the section. The color code must be the first item in the section.
[Black]
[Green]
[White]
[Blue]
[Magenta]
[Yellow]
[Cyan]
[Red]
  • Specify conditions To specify number formats that will be applied only if a number meets a condition that you specify, enclose the condition in square brackets. The condition consists of a comparison operator (comparison operator: A sign that is used in comparison criteria to compare two values. Operators include: = Equal to, > Greater than, < Less than, >= Greater than or equal to, <= Less than or equal to, and <> Not equal to.) and a value. For example, the following format displays numbers that are less than or equal to 100 in a red font and numbers that are greater than 100 in a blue font.

[Red][<=100];[Blue][>100]

To apply conditional formats (conditional format: A format, such as cell shading or font color, that Excel automatically applies to cells if a specified condition is true.) to cells (for example, color shading that depends on the value of a cell), on the Home tab, in the Styles group, click Conditional Formatting.

Guidelines for currency, percentages, and scientific notation format

  • Include currency symbols To type one of the following currency symbols in a number format, press NUM LOCK and use the numeric keypad to type the ANSI code for the symbol.
To enter | Press this code
¢ | ALT+0162
£ | ALT+0163
¥ | ALT+0165
euro | ALT+0128

  • Note Custom formats are saved with the workbook. To have Excel always use a specific currency symbol, you must change the currency symbol that is selected in the Regional Options in Control Panel before you start Excel.

  • For information about how to change Regional Options, see Change the default date, time, number or measurement format..
  • Display percentages To display numbers as a percentage of 100 — for example, to display .08 as 8% or 2.8 as 280% — include the percent sign (%) in the number format.
  • Display scientific notations To display numbers in scientific (exponential) format, use the following exponent codes in a section.
E (E-, E+, e-, e+) Displays a number in scientific (exponential) format. Excel displays a number to the right of the "E" or "e" that corresponds to the number of places that the decimal point was moved. For example, if the format is 0.00E+00, and you type 12,200,000 in the cell, the number 1.22E+07 is displayed. If you change the number format to #0.0E+0, the number 12.2E+6 is displayed.

Guidelines for date and time formats

  • Display days, months, and years To display numbers as date formats (such as days, months, and years), use the following codes in a section.
m | Displays the month as a number without a leading zero.
mm | Displays the month as a number with a leading zero when appropriate.
mmm | Displays the month as an abbreviation (Jan to Dec).
mmmm | Displays the month as a full name (January to December).
mmmmm | Displays the month as a single letter (J to D).
d | Displays the day as a number without a leading zero.
dd | Displays the day as a number with a leading zero when appropriate.
ddd | Displays the day as an abbreviation (Sun to Sat).
dddd | Displays the day as a full name (Sunday to Saturday).
yy | Displays the year as a two-digit number.
yyyy | Displays the year as a four-digit number.
To display | As | Use this code
Months | 1–12 | m
Months | 01–12 | mm
Months | Jan–Dec | mmm
Months | January–December | mmmm
Months | J–D | mmmmm
Days | 1–31 | d
Days | 01–31 | dd
Days | Sun–Sat | ddd
Days | Sunday–Saturday | dddd
Years | 00–99 | yy
Years | 1900–9999 | yyyy
  • Display hours, minutes, and seconds To display time formats (such as hours, minutes, and seconds), use the following codes in a section.
h | Displays the hour as a number without a leading zero.
[h] | Displays elapsed time in hours. If you are working with a formula that returns a time in which the number of hours exceeds 24, use a number format that resembles [h]:mm:ss.
hh | Displays the hour as a number with a leading zero when appropriate. If the format contains AM or PM, the hour is based on the 12-hour clock. Otherwise, the hour is based on the 24-hour clock.
m | Displays the minute as a number without a leading zero. Note The m or mm code must appear immediately after the h or hh code or immediately before the ss code; otherwise, Excel displays the month instead of minutes.
[m] | Displays elapsed time in minutes. If you are working with a formula that returns a time in which the number of minutes exceeds 60, use a number format that resembles [mm]:ss.
mm | Displays the minute as a number with a leading zero when appropriate. Note The m or mm code must appear immediately after the h or hh code or immediately before the ss code; otherwise, Excel displays the month instead of minutes.
s | Displays the second as a number without a leading zero.
[s] | Displays elapsed time in seconds. If you are working with a formula that returns a time in which the number of seconds exceeds 60, use a number format that resembles [ss].
ss | Displays the second as a number with a leading zero when appropriate. If you want to display fractions of a second, use a number format that resembles h:mm:ss.00.
AM/PM, am/pm, A/P, a/p | Displays the hour using a 12-hour clock. Excel displays AM, am, A, or a for times from midnight until noon and PM, pm, P, or p for times from noon until midnight.
To display | As | Use this code
Hours | 0–23 | h
Hours | 00–23 | hh
Minutes | 0–59 | m
Minutes | 00–59 | mm
Seconds | 0–59 | s
Seconds | 00–59 | ss
Time | 4 AM | h AM/PM
Time | 4:36 PM | h:mm AM/PM
Time | 4:36:03 P | h:mm:ss A/P
Time | 4:36:03.75 | h:mm:ss.00
Elapsed time (hours and minutes) | 1:02 | [h]:mm
Elapsed time (minutes and seconds) | 62:16 | [mm]:ss
Elapsed time (seconds and hundredths) | 3735.80 | [ss].00

Top of Page Top of Page

Create a custom number format

  1. Open the workbook in which you want to create and store a custom number format.
  2. On the Home tab, click the Dialog Box Launcher Button image next to Number.

Excel Ribbon Image

  3. In the Category box, click Custom.
  4. In the Type list, select the number format that you want to customize.

The number format that you select appears in the Type box above the Type list.

Note When you select a built-in number format in the Type list, Excel creates a copy of that number format that you can then customize. The original number format in the Type list cannot be changed or deleted.

  5. In the Type box, make the necessary changes to the selected number format.

Tip For more information about the changes that you can make, see Review guidelines for customizing a number format in this article.

Note A custom number format is stored in the workbook in which it was created and will not be available in any other workbooks. To use a custom format in a new workbook, you can save the current workbook as an Excel template that you can use as the basis for the new workbook.

For more information, see Create and use an Excel template.

Top of Page Top of Page

Delete a custom number format

  1. Open the workbook that contains the custom number format that you want to delete.
  2. On the Home tab, click the Dialog Box Launcher Button image next to Number.

Excel Ribbon Image

  3. In the Category box, click Custom.
  4. In the Type list, select the custom number format that you want to delete.

Note Built-in number formats in the Type list cannot be deleted.

  5. Click Delete.

Note Any cells in the workbook that were formatted with the deleted custom format will be displayed in the default General format.

نوشته شده در یکشنبه بیست و ششم دی 1389ساعت 12:49 توسط علی توضیح |
معرفی دو کتاب جدید از آقای مهدوی
معمولا کتاب های آقای مهدوی جزو بهترین کتاب های آموزشی اکسل و یا حتی اکسس محسوب می شوند . این دو کتاب جدید نیز از این قاعده مستثنی نیستند .

مدل سازی مالی در اکسل

ترجمه فصیح ومحتوای مناسب و غنی هر کاربری را به سمت خود جلب می کند. نشانی اینترنتی خرید کتابها :

http://www.adinebook.com/gp/product/9647826228/ref=sr_1_1000_17/982-9930533-8650635

http://www.adinebook.com/gp/product/9647826235/ref=sr_1_1000_18/982-9930533-8650635

نوشته شده در سه شنبه بیست و پنجم خرداد 1389ساعت 8:27 توسط علی توضیح |
تبدیل داده ها از افقی به عمودی
برای تبدیل حالت قرار گرفتن داده ها از افقی به عمودی یا برعکس دو روش را پیشنهاد می کنم:

۱- استفاده از paste special گزینه ی transpose. برای استفاده کافی است داده ها را کپی کرده و سپس بجای paste از paste special استفاده کنیم :

2- استفاده از تابع آرایه ای transpose . توجه داشته باشیم که برای اجرای این تابع الزاما باید کلید های

ctrl+shift+enter را با هم فشار دهید.

نوشته شده در سه شنبه بیست و پنجم خرداد 1389ساعت 8:13 توسط علی توضیح |
فریز کردن در اکسل
یکی از مشکلاتی که بیشتر کاربران اکسل با آن برخورد می کنند ثابت کردن یا فریز کردن عناوین جداول است . این موضوع چه در کاربرگ و چه در چاپ مهم و پرکاربرد است .

الف - کاربرگ : هنگامی که یک کاربر با یک لیست طویل مواجه می شود زمان مشاهده ی انتهای لیست عناوین را از دست می دهد .

راه حل : کافی است سطری را که می خواهیم فریز کنیم در نظر گرفته سطر زیرین آنرا انتخاب کنیم سپس از مسیر زیر آنرا فریز کنیم :

excel 2007 : viwe\freeze panes \freeze panes

ب- چاپ : اگر بخواهیم این عناوین هنگام چاپ در بالای هر صفحه چاپ گردد از مسیر زیر حر کت می کنیم :

excel 2007 : page layout\print titles\rows to repaet at top

حال کافی است که سطر یا سطر های مورد نظر را انتخاب کنیم و کلید تایید را فشار دهیم .

نوشته شده در سه شنبه هفدهم فروردین 1389ساعت 8:24 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


Link Dump

آرشیو پیوندهای روزانه


تبليغات X
اکسل تحت وب یا google docs
شاید تا کنون این نیاز را داشته اید که یک کاربرگ اشتراکی با سایر همکاران و یا دوستانتان داشته باشید که هر نفر که شما مشخص می کنید قادر باشد داده ها را ببیند یا تغییر دهد.

گوگل متواضعانه این قابلیت را رایگان در اختیار کاربرانش قرار می دهد.ابتدا وارد اکانت مورد نظر در گوگل می شویم ( ترجیحا یک اکانت جدید و قابل اشتراک )سپس در قسمت more گزینه ی documents را انتخاب میکنیم.

در این بخش گوگل به شما اجازه می دهد تا یک صفحه گسترده یا spreadsheet ( شبیه اکسل - نه خود اکسل ) ایجاد کنید

اگر به تصاویر دقت کنید متوجه می شوید که این صفحه گسترده شباهت زیادی به اکسل دارد.البته همانطور که از آن انتظار می رود با شرایط تحت وب . مثلا شروع کارش با ۱۰۰ سطر است و ۲۰ ستون که این ارقام قابل افزایشند. اما مزیت این صفحه گسترده چیست؟

شما قادرید ایمیل دوستانتان را به گوگل دهید تا این پرونده را با آنها مشترک کند.

پس از ورود ایمیل دوستان و یا افرادی که قصد دارید آنها را دراین کاربرگ شریک کنید، گوگل تغیرات ثبت شده را بلافاصله به شما نشان خواهد داد.

لازم به ذکر است که دوستانتان پس از ورود به ایمیلشان ، دعوتنامه شما را مشاهده خواهند کرد و پس از ورود نام کاربری و کلمه ی عبور همان اکانت اشتراکی، به ویرایش کاربرگ مشغول خواهند شد.

این هم لینک راهنمای انگلیسی خود گوگل برای Google Docs

نوشته شده در دوشنبه بیست و نهم شهریور 1389ساعت 9:0 توسط علی توضیح |
وبلاگ معادل
یک وبلاگ شبیه وبلاگ بنده وجود دارد .شاید برخی از صفحات در آن فعال شود :

www.excelxp.mihanblog.com

اگر وبلاگ فعال نشد ، از وبلاگ بالا استفاده کنید .

نوشته شده در یکشنبه بیست و نهم بهمن 1385ساعت 13:11 توسط علی توضیح |
پاسخ به یک پرسش: تبدیل گراد و رادیان و درجه به یکدیگر
توابع مثلثاتی در اکسل زاوایا را به صورت پیش فرض بر اساس رادیان محاسبه می کنند .

به طور مثال :

=sin( 90 )

سینوس 90 رادیان را محاسبه و نمایش می دهد . برای گریز از این مشکل توابعی مثل radians , degrees شما را یاری می دهد .

radians درجه را به رادیان و degrees رادیان را به درجه تبدیل می کنند .

به طور مثال سینوس زاویه 90 درجه را به شکل زیر نمایش می دهند :

=sin(radians(90))

اما برای گراد تابع مستقلی نداریم و برای تبدیل آنها کافی است از فرمول تبدیل استفاده کنیم

d/180=g/200=r/pi

یعنی برای محاسبه سینوس ۱۰۰ رادیان به روش زیر عمل می کنیم

1=sin(radians(100*180/200))

برخی دیگر از توابع مثلثاتی عبارتند از :

cos , tan , asin , acos , sinh , cosh, tanh, pi , ...

مثال: ارک سینوس زیر برای تبدیل بر اساس درجه طراحی شده است .

=ASIN(-0.5)*180/PI()

نوشته شده در سه شنبه چهاردهم شهریور 1385ساعت 9:35 توسط علی توضیح |
پاسخ به یک پرسش : در جدول زیر اسامی دانش آموزان برتر در هر درس چگونه نمایش داده می شود ؟
منظور از دانش آموز برتر ، بالاترین نمره در هر درس است . دو روش برای اینکار ارائه می شود :

۱- تابع dget یکی از توابع پایگاه اطلاعاتی اکسل است که به همراه تابع max قادر است این مشکل را برطرف نماید.

=DGET( database , field , criteria )

این تابع در فیلد مورد نظر از پایگاه ( آدرس جدول ) داده شده ، آدرس محدوه شرط را دریافت کرده، داده مورد نظر را نمایش می دهد .

۲- ترکیب توابع index , match , max

dget , match , index

نوشته شده در دوشنبه سیزدهم شهریور 1385ساعت 11:3 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
حلقه ها در وي ب ي اي LOOPS IN VBA EXCEL 2007
FOR يكي از پر كاربردترين نوع حلقه در زبان هاي برنامه نويسي است و براي شمارش بكار ميرود. ساختارش چنين است :

FOR انتها تو ابتدا = شمارنده STEP گام

عمليات

NEXT

مثال : در ساختار زير سلول هاي ستون A تا A100 از 1 تا 100 پر مي شوند:

FOR I=1 TO 100

CELLS(I,1)=I

NEXT

مثال : جدولي در كاربرگ 1 طراحي كنيد كه شامل ستون نام و دريافتي و ماه دريافت باشد ، سپس اسامي چند نفر را در آن وارد نماييد ( تكراري هم داشته باشد ) آنگاه ماكرويي طراحي كنيد كه نام فرد را دريافت كرده سپس جمع كل دريافتي هاي وي را نمايش دهد .

نوشته شده در دوشنبه نهم دی 1387ساعت 9:40 توسط علی توضیح |
SELECT CASE IN VBA
يكي ديگر از ابزار هاي كنترلي در وي بي اي SELECT CASE است . اين ابزار مانند چند IF تو در تو است و شكل آن به صورت زير است :

SELECT CASE متغير

CASE محدوده 1

عمليات 1

CASE محدوده 2

عمليات 2

CASE ELSE

عمليات

END SELECT

به طور مثال ساختاري طراحي كنيد كه عددي را از كاربر گرفته و سپس رده ي آنرا مشخص كند:

1-اگر عدد 1 يا 2 يا 3 باشد رده A

2- اگر عدد بزرگتر از 3 و كوچكتر از 7 باشد رده ي B

3- اگر عدد بزرگتر از 7 باشد رده ي C

4- در غير اين صورت پيام خطا صادر كند.

نمايش داده شود:

SUB TEST()

DIM X!

X=INPUTBOX("X:")

SELECT CASE X

CASE 1,2,3

MSGBOX " A"

CASE 3 TO 7

MSGBOX " B"

CASE IS > 7

MSGBOX "C"

CASE ELSE

MSGBOX " ERROR"

END SELECT

END SUB

نوشته شده در دوشنبه نهم دی 1387ساعت 9:9 توسط علی توضیح |
استفاده از ساختارهای کنترلی در وی بی ای اکسل if , select case
if يكي از پر كاربرترين ابزارهاي وي بي اي در عمليات كنترلي است.

ساختار آن به شرح زير است:

if شرط then

عمليات

elseif شرط then

عمليات

else

عمليات

endif

مثال - دو عدد را از كاربر گرفته اگر مساوي باشند كلمه مساوي و درغير اين صورت نامساوي را نمايش دهد.

sub test1()

dim a!

dim b!

a=inputbox("a")

b=inputbox("b")

if a=b then

msgbox "equal"

else

msgbox " not equal"

endif

end sub

مثال 2- دو عدد درون a1 , b1 را مقايسه كند و هر كدام كه كوچكتر است را پاك كند .

مثال 3- اسامي و حقوق مبناي چند كارمند را دريافت كرده اگر حقوق بيش از 400$ باشد ماليات 10 درصد محاسبه شود در غير اين صورت 7 درصد محاسبه شود.

مثال ۴- میانگین اعداد درون ستون A از كاربرگ 1 را با همين ستون از كاربرگ 2 مقايسه كرده هر كدام كه بزرگتر بود نام آن كاربرگ به MAX تغيير يابد.

نكات اين تمرين :براي تغيير نام مثلا كابرگ 1 :

SHEETS(1).NAME="MAX"

براي استفاده از يك تابع درون وي بي اي از

APPLICATION.WORKSHEETFUNCTION. نام تابع

I = APPLICATION.WORKSHEETFUNCTION.AVERAGE(RANGE("A:A"))

(اين فرمول ميانگين تمام اعداد درون ستون A را به درون متغيير I مي ريزد.)

استفاده مي كنيم . توجه داشته باشيد كه توابع مشخص هستند و مقادير آنها بايد درون يك متغيير ريخته شود.

توجه كنيد براي انتخاب كاربرگ يك مي توان از دستور زير استفاده كرد :

SHEETS(1).SELECT

نوشته شده در چهارشنبه چهارم دی 1387ساعت 13:9 توسط علی توضیح |
آرايه ها در و ي بي اي اكسل ARRAY IN VBA EXCEL
آرايه مجموعه اي از داده هاست كه به ترتيب در كنار يكديگر قرار مي گيرند به طور مثال A يك آرايه با 5 عضو است كه چهار تاي آن عددي و يكي از آنها متني است.

A={ 1 , 2.57 , 17 , "ALI" , 122 }

آرايه ها يا يك بعدي هستند يا چند بعدي

تعريف يك آرايه يك بعدي در وي بي اي مانند تعريف يك متغير انجام مي پذيرد :مثال

DIM A(5) AS STRING

كه در آن پس از كلمه ديم نام آرايه و انتهاي آن ذكر مي گردد و در انتها نوع داده هاي آن

آرايه ها هميشه از ابتداي صفر آغاز مي كنند به تصاوير زير دقت كنيد

توجه كنيد كه دو عنصري از آرايه كه مقدار دهي نشده اند صفر در نظر گرفته شده اند .

براي اينكه يك آرايه يك بعدي از ابتداي يك آغاز كند مي توان در تعريف آن به روش زير اقدام كرد

DIM ALIARR(1 TO 7) AS SINGLE

كه 7 عنصر از جنس سينگل دارد با ابتداي يك aliarr يك آرايه يك بعدي با نام

براي پر كردن يك آرايه كافي است عناصر آنرا پر كنيم

A(1)="ALI"

A(2)=22

A(3)="ALI TOZIH"

A(6)="REZA"

نوشته شده در پنجشنبه بیست و هشتم آذر 1387ساعت 7:45 توسط علی توضیح |
تمرين وي بي اي VBA EXCEL

تمرين - فرض كنيد ليستي داريد به شكل زير ، كه از سلول A2 آغاز شده است . حال قصد داريم تابعي طراحي كنيم كه با ارسال سلول آغازين ليست به آن تعداد سطر هاي ليست محاسبه شود .

نوشته شده در شنبه بیست و سوم آذر 1387ساعت 11:26 توسط علی توضیح |
ارسال يك متغير به يك ماكرو يا تابع در وي بي اي اكسل
براي جلو گيري از استفاده ي تكراري از تابع inputbox كافي است متغيرهاي مورد استفاده را به صورت پارامتر يا آرگومان به تابع يا ماكرو ارسال كنيم ،براي اين منظور كافي است متغير ها را درون پرانتز جلوي نام تعريف كنيم :

function ali_link(a as string, b as string)

ali_link = a & " " & b

end function

اين تابع دو رشته را از كاربر دريافت كرده آنها را با يك فاصله در كنار هم قرار داده و به خروجي تابع ارسال مي كند. براي استفاده از آن كافي است آنرا به همراه دو متغيرش درون يك ماكرو صدا بزنيم :

sub ali_text()

msgbox ali_link("ali","tozih")

end sub

نوشته شده در جمعه بیست و دوم آذر 1387ساعت 8:0 توسط علی توضیح |
مثال هاي توابع و ماكرو ها در VBA EXCEL
مثال ۱- ماكرويي طراحي كنيد كه نام و نام خانوادگي را از كاربر گرفته سپس آنها را در كنار هم در يك جعبه پیام نشان دهد .

مثال 2 - در مثال بالا نام و نام خانوادگي زير هم در يك جعبه نام قرار گيرند ( VBCR)

مثال 3 - ماكرويي طراحي كنيد كه شعاع يك دايره را گرفته محيط و مساحت آنرا نمايش دهد.

مثال 4 - مثال بالا را با استفاده از يك ماكرو و دو تابع محيط و مساحت انجام دهيد .

مثال 5 - تابعي طراحي كنيد كه ميانگين وزني اعداد داده شده را محاسبه نمايد:

عدد : 10 31 15 5

ضريب :2 4 7 9

توجه كنيد كه تابع بايد هر 8 عدد را دريافت كند.

مثال 6 - تابعي طراحي كنيد كه قادر باشد با دريافت ضرايب عددي معادله درجه اول ax+b=0 آنرا حل كرده جوابش را بازگرداند.

نوشته شده در جمعه بیست و دوم آذر 1387ساعت 7:50 توسط علی توضیح |
انواع عملگرها در وي بي اي اكسل VBA EXCEL OPERATOR
Arithmetic | Comparison | Logical
Exponentiation (^) | Equality (=) | Not
Negation (–) | Inequality (<>) | And
Multiplication and division (*, /) | Less than (<) | Or
Integer division (\) | Greater than (>) | Xor
Modulus arithmetic (Mod) | Less than or equal to (<=) | Eqv
Addition and subtraction (+, –) | Greater than or equal to (>=) | Imp
String concatenation (&) | Like Is |
نوشته شده در جمعه بیست و دوم آذر 1387ساعت 7:35 توسط علی توضیح |
توابع FUNCTIONS در وي بي اكسل
از آنجا كه ماكرو ها قادر به بازگرداندن يك مقدار به عنوان خروجي نيستند ، توابع نوع ديگري از ساختار تشكيل دهنده ماژول ها را معرفي مي كنيم:

ساختار يك تابع ( FUNCTION ) شبيه يك ماكرو است با اين تفاوت كه بجاي كلمه ي SUB از كلمه ي FUNCTION استفاده ميشود :

(اين تابع عدد اول را به توان عدد دوم مي رساند )

FUNCTION AVW()

DIM I AS SINGLE , J AS SINGLE

I= INPUTBOX(" I :")

J=INPUTBOX(" J: ")

AVW =I ^ J

END FUNCTION

نكته ي قابل توجه اينست كه جواب خروجي يك تابع هميشه بايد درون نام تابع ريخته شود.

نوشته شده در جمعه بیست و دوم آذر 1387ساعت 7:18 توسط علی توضیح |
صدا زدن ماكروها CALL
براي استفاده از يك ماكرو درون ماكرو هاي ديگر كافي است ابتدا ماكرو را تعريف كرده سپس درون يك ماكرو ديگر با استفاده از كلمه ي كليدي CALL آنرا صدا بزنيم :

SUB TEST3()

DIM S AS STRING * 5

S= INPUTBOX("YOUR NAME ")

END SUB

______________________________________

SUB TEST4()

CALL TEST3

END SUB

ماكرو TEST3 درون ماكرو TEST4 صدا زده شده است .

به اين نكته توجه كنيد كه هر گاه بخواهيم يك ماكرو فقط در همان ماژول تعريف شده ، شناخته شود كافي است قبل از كلمه ي كليدي SUB از كلمه ي كليدي PRIVATE استفاده شود .

* [image] ماكرو ها به صورت پيش فرض در تمام پروژه شناخته مي شوند.

نوشته شده در جمعه بیست و دوم آذر 1387ساعت 7:11 توسط علی توضیح |
انواع متغير ها در زبان VBA در اكسل 2007
همانطور كه در جلسات قبل ذكر كرديم متغير ها در زبان وي بي اكسل چند دسته اند :

1- عددي

2- غير عددي

3- ثابت ها

4- كاربر ساخته

كه محدوده ي هر كدام را در زير مشاهده ميكنيد ( راهنماي اكسل 2007 ) :

Data Type Summary

The following table shows the supported data types, including storage sizes and ranges.

Data type | Storage size | Range
Byte | 1 byte | 0 to 255
Boolean | 2 bytes | True or False
Integer | 2 bytes | -32,768 to 32,767
Long (long integer) | 4 bytes | -2,147,483,648 to 2,147,483,647
Single (single-precision floating-point) | 4 bytes | -3.402823E38 to -1.401298E-45 for negative values; 1.401298E-45 to 3.402823E38 for positive values
Double (double-precision floating-point) | 8 bytes | -1.79769313486231E308 to -4.94065645841247E-324 for negative values; 4.94065645841247E-324 to 1.79769313486232E308 for positive values
Currency (scaled integer) | 8 bytes | -922,337,203,685,477.5808 to 922,337,203,685,477.5807
Decimal | 14 bytes | +/-79,228,162,514,264,337,593,543,950,335 with no decimal point; +/-7.9228162514264337593543950335 with 28 places to the right of the decimal; smallest non-zero number is +/-0.0000000000000000000000000001
Date | 8 bytes | January 1, 100 to December 31, 9999
Object | 4 bytes | Any Object reference
String (variable-length) | 10 bytes + string length | 0 to approximately 2 billion
String (fixed-length) | Length of string | 1 to approximately 65,400
Variant (with numbers) | 16 bytes | Any numeric value up to the range of a Double
Variant (with characters) | 22 bytes + string length | Same range as for variable-length String
User-defined (using Type) | Number required by elements | The range of each element is the same as the range of its data type.

اين متغير هاكه با كلمه ي كليدي DIM معرفي مي شوند حيطه ي فعاليت ( اثر ) مشخصي دارند :

1- متغير هاي ماكرو

2- متغير هاي ما‍‍ژول

3- متغيرهاي پرو‍ژه ( سراسري)

1- متغير هايي كه در سطح ماكرو تعريف مي شوند تنها در همان ماكرو شناخته مي شوند.

SUB TEST1()

DIM A AS SINGLE

A=INPUTBOX(" ENTER A NUMBER :")

MSGBOX A

END SUB

2- اما نوع دوم متغير ها آنهايي هستند كه بايد درون تمام ماکروهای يك ماژول شناخته شوند ، براي اينكار كافي است متغير را در ابتداي ماژول قبل از تمام ماكروها ( قسمت اعلان يا DECLARATION) تعريف كرد و سپس در تمام ماکرو های آن ماژول میتوان از آن استفاده کرد:

۳- اما اگر بخواهیم این متغیر در تمام ماژول های یک پروژه شناخته شود کافی است در قسمت اعلان بجای کلمه ی dim از كلمه ي GLOBAL استفاده كنيم .در اين حالت متغير سراسري شده و در تمام ماكرو ها ي يك پروژه شناخته مي شود.

GLOBAL S AS STRING

در ضمن بايد بدانيم كه مجموعه ماكرو ها تشكيل يك ماژول داده و مجموعه ي ماژول ها تشكيل يك پروژه را مي دهد .

نكته 1 : اگر بخواهيم درون يك ماكرو پس از اتمام آن مقادير متغير هايش تهي نشود كافي است بجاي DIM از واژه كليدي STATIC استفاده كنيم . در اين حالت حتي پس از اتمام ماكرو مقادير متغير ايستا حفظ شده تا مقادير جديد به آن تعلق پيدا كند.

نوشته شده در پنجشنبه بیست و یکم آذر 1387ساعت 10:26 توسط علی توضیح |
ايجاد DEVELOPER TAB در اكسل 2007
براي كار با VBA و ماكروها كاربران نياز به ايجاد يك تب يا برگه دان جديد دارند به نام DEVELOPER که مراحل نصب آنرا در EXCEL 2007 ملاحظه مي نماييد:

نوشته شده در دوشنبه هجدهم آذر 1387ساعت 11:30 توسط علی توضیح |
تمرین IF
تمرین IF : ماکرویی طراحی کنید که نمره ی دانش آموزی را از کاربر گرفته اگر

0=<نمره =<7 ضعیف

7<نمره =<14 متوسط

14<نمره =<20 خوب

پیام های مقابل آنها را چاپ نماید .

Sub NOMREH()

Dim NOM As Single

NOM = InputBox(" نمره را وارد کنید")

If NOM >= 0 And NOM <= 7 Then MsgBox "BAD"

If NOM > 7 And NOM <= 14 Then MsgBox " NOT BAD"

If NOM > 14 And NOM <= 20 Then MsgBox "GOOD"

End Sub

به این نکته توجه داشته باشید که اگر فرامین IF فقط یک دستور باشند دیگر نیازی به END IF نیست البته دستور مورد نظر را باید در پشت سر THEN نوشت .

نوشته شده در سه شنبه نوزدهم تیر 1386ساعت 9:53 توسط علی توضیح |
راهنمای استفاده از دستور شرطی IF

If...Then...Else Statement

*برگرفته از راهنمای اکسل*

Conditionally executes a group of statements, depending on the value of an expression.

Syntax

If condition Then [statements] [Else elsestatements]

Or, you can use the block form syntax:

If condition Then
[statements]

[ElseIf condition-n Then
[elseifstatements] ...

[Else
[elsestatements]]

End If

The If...Then...Else statement syntax has these parts:

Part | Description
condition | Required. One or more of the following two types of expressions:
 | A numeric expression or string expression that evaluates to True or False. If condition is Null, condition is treated as False.
 | An expression of the form TypeOf objectname Is objecttype. The objectname is any object reference and objecttype is any valid object type. The expression is True if objectname is of the object type specified by objecttype; otherwise it is False.
statements | Optional in block form; required in single-line form that has no Else clause. One or more statements separated by colons; executed if condition is True.
condition-n | Optional. Same as condition.
elseifstatements | Optional. One or more statements executed if associated condition-n is True.
elsestatements | Optional. One or more statements executed if no previous condition or condition-n expression is True.

Remarks

You can use the single-line form (first syntax) for short, simple tests. However, the block form (second syntax) provides more structure and flexibility than the single-line form and is usually easier to read, maintain, and debug.

Note With the single-line form, it is possible to have multiple statements executed as the result of an If...Then decision. All statements must be on the same line and separated by colons, as in the following statement:

If A > 10 Then A = A + 1 : B = B + A : C = C + B

A block form If statement must be the first statement on a line. The Else, ElseIf, and End If parts of the statement can have only a line number or line label preceding them. The block If must end with an End If statement.

To determine whether or not a statement is a block If, examine what follows the Then keyword. If anything other than a comment appears after Then on the same line, the statement is treated as a single-line If statement.

The Else and ElseIf clauses are both optional. You can have as many ElseIf clauses as you want in a block If, but none can appear after an Else clause. Block If statements can be nested; that is, contained within one another.

When executing a block If (second syntax), condition is tested. If condition is True, the statements following Then are executed. If condition is False, each ElseIf condition (if any) is evaluated in turn. When a True condition is found, the statements immediately following the associated Then are executed. If none of the ElseIf conditions are True (or if there are no ElseIf clauses), the statements following Else are executed. After executing the statements following Then or Else, execution continues with the statement following End If.

Tip Select Case may be more useful when evaluating a single expression that has several possible actions. However, the TypeOf objectname Is objecttype clause can't be used with the Select Case statement.

Note TypeOf cannot be used with hard data types such as Long, Integer, and so forth other than Object.

نوشته شده در سه شنبه نوزدهم تیر 1386ساعت 9:41 توسط علی توضیح |
شرط ها و ساختار های تصمیم گیری در وی بی ای IF IN VBA
یکی از مهمترین بخش های هر زبان برنامه نویسی ساختار های تصمیمگیری در آنهاست .

IF یکی از پرکاربرد ترین دستورات VBA می باشد ، ساختار آن عبارت است از :

IF شرط THEN

عملیات مورد نظر

END IF

مثال : می خواهیم ساختار شرطی ایجاد کنیم که اگر محتویات سلول A1 از عدد 10 کوچکتر بود یک پیام مردودی نمایش دهد . ( فقط ساختار IF را نمایش می دهیم )

IF RANGE("A1")<10 THEN

MSGBOX" مردود"

END IF

نوشته شده در سه شنبه نوزدهم تیر 1386ساعت 9:30 توسط علی توضیح |
تمرین 2
تمرین 2 - ماکرویی طراحی کنید که نام و نام خانوادگی را از کاربر دریافت کرده سپس آنها را در کنار یکدیگر نمایش دهد .

SUB NAM()

DIM N AS STRING

DIM F AS STRING

N= INPUTBOX("ENTER NAME :")

F=INPUTBOX("ENTER FAMILY :")

MSGBOX N&" "&F

END SUB

نوشته شده در سه شنبه نوزدهم تیر 1386ساعت 9:15 توسط علی توضیح |
تمرین
تمرین : ماکرویی بنویسید که دو عدد را از کاربر گرفته و سپس ضرب آنها را نمایش دهد :

SUB ZARB()

DIM I AS SINGLE

DIM J AS SINGLE

DIM K AS SINGLE

I= INPUTBOX(" ENTER I :")

J= INPUTBOX(" ENTER J :")

K=I*J

MSGBOX " I*J = " &K

END SUB

نوشته شده در سه شنبه نوزدهم تیر 1386ساعت 9:9 توسط علی توضیح |
معرفی متغیر ها در وی بی ای
برای استفاده از متغیر ها در وی بی ای VBA بهتر است که آنها را تعریف کنیم ، دو نوع متغیر عددی و غیر عددی وجود دارد که عددی ها عبارتند از :

  1. BYTE
  2. INTEGER
  3. LONG
  4. SINGLE
  5. DOUBLE
  6. CURRENCY
  7. DECIMAL

و غیر عددی عا عبارتند از:

  1. BOOLEAN
  2. OBJECT
  3. STRING
  4. VARIANT
  5. DATE

روش معرفی متغیر ها استفاده از کلمه ی کلیدی DIM بعد از نام ماکروست . به مثال زیر توجه کنید:

I به عنوان یک عدد صحیح ( متغیر) معرفی شده است .

SUB ALI()

DIM I AS INTEGER ' I به عنوان یک عدد صحیح معرفی

I = INPUTBOX (" ENTER A NUMBER INTEGER:")

END SUB

Data Type Summary

The following table shows the supported data types, including storage sizes and ranges.

Data type | Storage size | Range
Byte | 1 byte | 0 to 255
Boolean | 2 bytes | True or False
Integer | 2 bytes | -32,768 to 32,767
Long (long integer) | 4 bytes | -2,147,483,648 to 2,147,483,647
Single (single-precision floating-point) | 4 bytes | -3.402823E38 to -1.401298E-45 for negative values; 1.401298E-45 to 3.402823E38 for positive values
Double (double-precision floating-point) | 8 bytes | -1.79769313486231E308 to -4.94065645841247E-324 for negative values; 4.94065645841247E-324 to 1.79769313486232E308 for positive values
Currency (scaled integer) | 8 bytes | -922,337,203,685,477.5808 to 922,337,203,685,477.5807
Decimal | 14 bytes | +/-79,228,162,514,264,337,593,543,950,335 with no decimal point; +/-7.9228162514264337593543950335 with 28 places to the right of the decimal; smallest non-zero number is +/-0.0000000000000000000000000001
Date | 8 bytes | January 1, 100 to December 31, 9999
Object | 4 bytes | Any Object reference
String (variable-length) | 10 bytes + string length | 0 to approximately 2 billion
String (fixed-length) | Length of string | 1 to approximately 65,400
Variant (with numbers) | 16 bytes | Any numeric value up to the range of a Double
Variant (with characters) | 22 bytes + string length | Same range as for variable-length String
User-defined (using Type) | Number required by elements | The range of each element is the same as the range of its data type.

Note Arrays of any data type require 20 bytes of memory plus 4 bytes for each array dimension plus the number of bytes occupied by the data itself. The memory occupied by the data can be calculated by multiplying the number of data elements by the size of each element. For example, the data in a single-dimension array consisting of 4 Integer data elements of 2 bytes each occupies 8 bytes. The 8 bytes required for the data plus the 24 bytes of overhead brings the total memory requirement for the array to 32 bytes.

A Variant containing an array requires 12 bytes more than the array alone.

Note Use the StrConv function to convert one type of string data to another.

نوشته شده در سه شنبه پنجم تیر 1386ساعت 13:16 توسط علی توضیح |
INPUTBOX جعبه دریافت داده
هر گاه کاربر قصد دریافت داده ها را از کاربرگ نداشته باشد و بخواهد آنها را مستقیما دریافت کند از این ابزار استفاده می کند :

Sub ALI()
I = InputBox(" عدد مورد نظر را وارد کنيد ")
End Sub

در مثال فوق ماکرو ساده ای را مشاهده می کنید که پیام " عدد مورد نظر را وارد کنید " را نمایش داده و عدد یا متن کاربر را دریافت کرده و در متغییر I می ریزد .

شکل این تابع به صورت زیر است :

InputBox Function

Displays a prompt in a dialog box, waits for the user to input text or click a button, and returns a String containing the contents of the text box.

Syntax

InputBox(prompt[, title] [, default] [, xpos] [, ypos] [, helpfile, context])

The InputBox function syntax has these named arguments:

Part | Description
prompt | Required. String expression displayed as the message in the dialog box. The maximum length of prompt is approximately 1024 characters, depending on the width of the characters used. If prompt consists of more than one line, you can separate the lines using a carriage return character (Chr(13)), a linefeed character (Chr(10)), or carriage return–linefeed character combination (Chr(13) & Chr(10)) between each line.
title | Optional. String expression displayed in the title bar of the dialog box. If you omit title, the application name is placed in the title bar.
default | Optional. String expression displayed in the text box as the default response if no other input is provided. If you omit default, the text box is displayed empty.
xpos | Optional. Numeric expression that specifies, in twips, the horizontal distance of the left edge of the dialog box from the left edge of the screen. If xpos is omitted, the dialog box is horizontally centered.
ypos | Optional. Numeric expression that specifies, in twips, the vertical distance of the upper edge of the dialog box from the top of the screen. If ypos is omitted, the dialog box is vertically positioned approximately one-third of the way down the screen.
helpfile | Optional. String expression that identifies the Help file to use to provide context-sensitive Help for the dialog box. If helpfile is provided, context must also be provided.
context | Optional. Numeric expression that is the Help context number assigned to the appropriate Help topic by the Help author. If context is provided, helpfile must also be provided.

Remarks

When both helpfile and context are provided, the user can press F1 (Windows) or HELP (Macintosh) to view the Help topic corresponding to the context. Some host applications, for example, Microsoft Excel, also automatically add a Help button to the dialog box. If the user clicks OK or presses ENTER , the InputBox function returns whatever is in the text box. If the user clicks Cancel, the function returns a zero-length string ("").

Note To specify more than the first named argument, you must use InputBox in an expression. To omit some positional arguments, you must include the corresponding comma delimiter.

مثال :

Sub proInput()

J = InputBox("For what year do you need this report?")

End Sub

نوشته شده در سه شنبه پنجم تیر 1386ساعت 10:3 توسط علی توضیح |
دانلود تمرین وی بی for & if

برای دانلود

تمرین وی بی کلیک کنید.

ابتدا تمرین را دانلود کرده و سپس سعی کنید آنرا بدون ااستفاده از راهنما حل کنید:

صورت مسله : ماکرویی بنویسید که اعداد ستون اول را در در ستون دوم جستجو کرده و تکراری های آنرا یافته با رنگ سرخ و پررنگ نمایش دهد .

نوشته شده در دوشنبه چهارم تیر 1386ساعت 14:6 توسط علی توضیح |
معرفی برخی از اشیا و خصوصیات آنها
برای ایجاد محیطی که بتوان ماکرو را در آن نوشت ابتدا باید وارد محیط vbe شد سپس از منوی insert گزینه module را انتخاب می کنیم تا محیط کد نویسی فعال شود . ماکرو ها ، ماژول ها را می سازند و ماژول ها ، پروژه ها را . در حقیقت پروژه از تعدادی شی و ماژول تشکیل شده است .

اشیا یی مانند range دارای تعدای خصوصیت به شرح زیر می باشند :

  1. value
  2. font . name
  3. font . size
  4. font . bold
  5. font . italic
  6. font . underline
  7. font . colorindex
  8. interior.colorindex
  9. formula

تمرین 1 - ماکرویی بنویسید که اندازه فونت محتویات سلول d3 را به 25 و حالت پررنگ تغییر دهد و نوع فونت را به titr .

sub ali23()

range("d3").font.name ="titr"

range("d3").font.size = 25

range("d3").font.bold = true

end sub

نوشته شده در شنبه پنجم خرداد 1386ساعت 14:58 توسط علی توضیح |
نوشتن چند ماکرو ساده
برای تسلط به VBA یا همان زبان برنامه نویسی آفیس ، چند تمرین ساده را مرور می کنیم و بعد به سراغ معرفی اشیاء درون وی بی ای خواهیم رفت تا برخی از خصوصیات و متد های آنها را معرفی کنیم .

تمرین 1 - ماکروییی بنام EDITB1 بنویسید که محتویات سلول A1 را در درون سلول B1 قرار دهد .

SUB EDITB1()

RANGE("B1") = range("a1")

END SUB

تمرین 2- ماکرویی بنویسید که عدد 14 را درون c1 و عدد ۱۴- را درون c2 قرار دهد .

SUB ali22()

RANGE("c1") = 14

RANGE("c2") = -14

END SUB

نوشته شده در شنبه پنجم خرداد 1386ساعت 12:0 توسط علی توضیح |
ماکرو نویسی استفاده از زبان وی بی ای VBA

بنام خدا

ماکرو نویسی در اکسل VBA

برای انجام عملیات تکراری و جستجو ی داده های مورد نظر می توان از ابزار قدرتمند ماکروها در اکسل استفاده کرد. ورود به ساختار برنامه نویسی ویژال بیسیک در اکسل که با عنوان VBA یا VISUAL BASIC FOR APPLICATION در اکسل و یا آفیس از آن یاد می گردد ، از مسیر زیر انجام می گیرد :

TOOLS | MACRO | VISAUL BASIC EDITOR

در حقیقت ماکرو ها، همان کدهایی هستد که توسط کاربر یا ماشین تولید می شوند. اگر شما یک ماکرو را با استفاده از ابزار ماکرو سازی طراحی و اجرا کنید آنرا توسط ماشین ساخته اید ولی اگر بخواهید انعطاف بیشتری به آن بدهید باید آنرا بنویسید( کد نویسی ). زبان وب بی ای در حقیقت معماری درونی اکسل و ابزاری قدرتمند برای نوشتن برنامه های پیشرفته و حلقوی است . این زبان که یک زبان شئ گراست ، اجزای درونی خود را به شکل اشیائی در نظر می گیرد که نرم افزار اکسل را تشکیل می دهند، مثل فایل ( کارپوشه WORKBOOK ) ، کاربرگ یا WORKSHEET و یا سلول RANGE .در حقیقت کارپوشه ها از اشیاء کاربرگ تشکیل شده اند و کاربرگ ها با اشیاء سلول کامل می شوند . هر شیء دارای یک سری خاصیت است . مثلا شما یک سنگ را در نظر بگیرید ، رنگ ، وزن ، شکل و... خواص سنگ محسوب می شوند .در وی بی ای VBA نیز همینطور است ، مثلا یک سلول دارای خواصی مثل محتویات ، اندازه فونت ، نام فونت ، رنگ ، فرمول ، کادر و .... می باشد. کاربران در برنامه نویسی در حقیقت این خواص را تغییر می دهند .

بیایید یک تمرین را باهم انجام دهیم :

ابتدا نوار ابزار ویژال بیسیک را فعال کنید ، سپس ماکرویی را طراحی کنید که در سلول A1 از کاربرگ 2 وارد شود .

مراحل ساخت ماکرو :

ابتدا کلید RECORD MACRO را می فشاریم و سپس به کاربرگ 2 و سلول A1 وارد می شویم و در آخر کلید STOP را می فشاریم .

حال برای دیدن کد ماکرو مسیر زیر را دنبال کنید :

کلید RUN را فشرده تا اسامی ماکرو ها ظاهر شود سپس ماکروی مورد نظر را انتخاب کرده کلید EDIT را می فشاریم تا متن ماکرو ( کد ) نمایش داده شود .

همانطور که مشاهده می کنید ماکرو با SUB و نام ماکرو ،شروع و با END SUB تمام می شود و در بین آنها عبارات برنامه نویسی نوشته شده است . سه رنگ در بدنه ی ماکرو بکار رفته 1- سبز: که معرف توضیحات برنامه است و هیچ تاثیری بر عملکرد ماکرو ندارد 2- آبی : کلمات کلیدی 3- سیاه : دستورات

Sub Macro1()

' Macro1 Macro

' Macro recorded 2007/04/23 by tozih

Sheets("Sheet2").Select

Range("A1").Select

End Sub

همانطور که از کد ها مشخص است ماکرویی بنام MACRO1 به کاربرگ 2 رفته و سلول A1 را در آن انتخاب می کند . در ساختار برنامه نویسی VBA تغییر خواص به صورت توارثی انجام می پذیرد ، یعنی هر خاصیت باید به شئ مورد نظر، با یک نقطه متصل باشد .

Range("A1").Select

در حقیقت برای تغییر خاصیت اشیاء باید ابتدا نام شئ را ذکر کرده سپس نقطه را قرار داده و آنگاه خاصیت مورد نظر را ذکر کنیم و مقادیر آنرا تغییر دهیم . مثلا :

RANGE("A2:A10").FONT.SIZE = 16

اندازه فونت محتویات سلول های A1 تا A10 را به 16 تغییر می دهد .

مثال دیگر ، محتویات سلول D2 از کاربرگ 3 را عبارت ALI TOZIH قرار دهید .

SHEETS("SHEET3").RANGE("D5").VALUE = "ALI TOZIH"

در ضمن خاصیت VALUE پیش فرض است و می توان آنرا حذف کرد :

SHEETS("SHEET3").RANGE("D5") = "ALI TOZIH"

نوشته شده در دوشنبه سوم اردیبهشت 1386ساعت 12:11 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
توابع مالی - بخش دوم

تابع RATE

این تابع درصد نرخ سود سالانه را محاسبه می کند.

=RATE( تعداد اقساط ; مبلغ هر قسط ; مبلغ وام )

مثال 3 : فرض کنید وامی به مبلغ سی میلیون ریال به مدت هفت سال باید بازپرداخت شود اگر مبلغ هر قسط

سالیانه ی آن 5,184,594.55 ریال باشد نرخ سود سالیانه ی آن چقدر است ؟

=RATE( 7 ; 5,184,594.55 ; 30000000) = 5%

تابع NPER

این تابع تعداد اقساط یک وام را مشخص می کند.

=NPER( سالانه نرخ سود ; مبلغ هر قسط ; مبلغ وام )

مثال 4 : فرض کنید وامی به مبلغ سی میلیون ریال با نرخ سود سالانه پنج درصد و با مبلغ هر قسط 5,184,594.55 ریال را از بانک دریافت کرده ایم . چند قسط سالیانه باید بپردازیم؟

=NPER( 5% ; 5,184,594.55 ; 30000000) = 7

نوشته شده در دوشنبه پانزدهم فروردین 1390ساعت 11:23 توسط علی توضیح |
برخی توابع مالی در اکسل - اکسل 2007 پیشرفته

برخی توابع مالی در اکسل

برخی از توابع مالی استفاده های زیادی در اکسل دارند ، که به طور خلاصه به شرح 4 مورد از آنها خواهیم پرداخت:

تابع PMT

این تابع برای محاسبه مبلغ اقساط سالیانه یک وام با بهره ثابت بکار می رود.

=PMT( نرخ بهره سالانه; تعداد اقساط سالانه ; مبلغ کل وام )

در مورد توابع مالی این نکته ضروری است که اگر تمام مواردمثبت باشد اکسل به صورت خودکار جواب را منفی نمایش می دهد ( شما را بدهکار می کند ) برای جلوگیری از این کار ، معمولا مبلغ وام را منفی نمایش می دهند تا سایر جواب ها مثبت نشان داده شود.

این نکته هم ضروری است که بدانیم ساختار ها باید همگون باشند یعنی اگر کاربر بهره سالانه استفاده می کند مبلغ قسط هم سالانه نمایش داده می شود ، تعداد اقساط هم همان تعداد سال های پرداخت وام تلقی می گردد.

مثال 1 : فرض کنید وامی را به مبلغ سی میلیون ریال ( سه میلیون تومان ) با بهره سالانه پنج درصد طی هفت سال می خواهیم بازپس دهیم ، آیا می توان مبلغ اقساط سالانه آنرا محاسبه کرد؟

=PMT( 5% ; 7 ; 30000000) = ريال 5,184,594.55

در حقیقت شما باید سالانه مبلغ ريال 5,184,594.55 را بابت اقساط بپردازید .

نرخ بهره سالانه | تعداد اقساط ( سال ) | مبلغ وام | مبلغ هر قسط ( سالانه ) | مبلغ هر قسط (ماهانه ) | جمع کل اقساط | جمع کل سود پرداختی
5% | 7 | 30,000,000- | ريال 5,184,594.55 | ريال 432,049.55 | ريال 36,292,161.87 | ريال 6,292,161.87

تابع IPMT

این تابع برای محاسبه مبلغ سود هر قسط سالیانه یک وام با بهره ثابت بکار می رود.

=IPMT( نرخ بهره سالانه;شماره قسط ; تعداد اقساط سالانه ; مبلغ کل وام )

این تابع که شبیه تابع PMT است ، مبلغ سود هر قسط را محاسبه می کند.

مثال 2: در مثال شماره یک مبلغ سود هر قسط را محاسبه کنید، مثلا برای قسط سال اول :

=IPMT(5% ; 1 ; 7 ; 30000000)

نرخ بهره سالانه | شماره قسط | تعداد اقساط ( سال ) | مبلغ وام | مبلغ سود ه قسط
5% | 1 | 7 | 30,000,000- | 1,500,000.00
5% | 2 | 7 | 30,000,000- | 1,315,770.27
5% | 3 | 7 | 30,000,000- | 1,122,329.06
5% | 4 | 7 | 30,000,000- | 919,215.78
5% | 5 | 7 | 30,000,000- | 705,946.85
5% | 6 | 7 | 30,000,000- | 482,014.46
5% | 7 | 7 | 30,000,000- | 246,885.45

نرخ بهره سالانه | شماره قسط | تعداد اقساط ( سال ) | مبلغ وام | مبلغ سود هر قسط
5% | 1 | 7 | 30,000,000- | ريال 1,500,000.00
5% | 2 | 7 | 30,000,000- | ريال 1,315,770.27
5% | 3 | 7 | 30,000,000- | ريال 1,122,329.06
5% | 4 | 7 | 30,000,000- | ريال 919,215.78
5% | 5 | 7 | 30,000,000- | ريال 705,946.85
5% | 6 | 7 | 30,000,000- | ريال 482,014.46
5% | 7 | 7 | 30,000,000- | ريال 246,885.45

نوشته شده در دوشنبه پانزدهم فروردین 1390ساعت 10:21 توسط علی توضیح |
آشنایی با تابع Indirect در اکسل - Excel
شهادت اما محمد باقر( ع ) شکافنده و مرزبان علوم نبوی بر دوستداران علم و اندیشه تسلیت باد:

چیزی با چیزی نیامیخته است که بهتر از حلم با علم باشد .

بحارالانوار ، دار احیاء الترا العربی ، ج 75، ص(172)

کار تابع indirect اینست که محتویات درونش را که یک آدرس است به تابع بعدی انتقال می دهد تا محتویات ادرس مذکور را نمایش دهد.درحقیقت به صورت غیر مستقیم مقدار یک سلول را انتقال می دهد.

مثلا فرض کنید در سلول g5 نشانی سلول a1 را نوشته اید، حال اگر در یک سلول دیگر فرمول زیر را بنویسید آن سلول محتویات a1 را نشان می دهد:

=indirect(g5)

به تصویر زیر دقت کنید

حل یک مثال با این تابع : محدود های از اعداد را در ستون a تا c داریم و می خواهیم با تغییر اعداد سطر محدوده جمع نیز تغییر کند . فرمول :

=SUM(INDIRECT("a"&G2&":c"&I2))

را می نویسیم تا تابع indirect سطر 2 تا 10 را در ستون های a تا c به تابع جمع ارسال کند.

نوشته شده در یکشنبه بیست و سوم آبان 1389ساعت 9:21 توسط علی توضیح |
فایل تمرین گروه اکسل پیشرفته تابع subtotal
این فایل را از اینجا دانلود کنید و سپس تمرین های زیر را حل کنید : ( فایل فشرده شده است )

۱- بیشترین دریافتی های رضا در جدول شماره یک در نیمه اول سال ۸۲ چقدر است؟

۲- جمع تعداد چکش خریداری شده و فروخته شده در جدول شماره دو چقدر است ؟

۳- میانگین مبلغ فروش پاکن توسط فروشگاه کوچولو چقدر است ؟

تمرین های فوق از روش subtotal حل شوند .

نوشته شده در سه شنبه چهارم آبان 1389ساعت 9:34 توسط علی توضیح |
تبدیل واحدهای اندازه گیری در اکسل 2007 - توابع مهندسی

یکی از مزایای صفحه گسترده ی اکسل ، قابلیت تبدیل واحدهای اندازه گیری به یکدیگر است ، که در ساختار رشته های مهندسی بسیار پرکاربرد است .

تابع قدرتمند convert واحدهای ۱۰ گروه اندازه گیری را به یکدیگر تبدیل می کند. این گروه ها عبارتند از :

1- وزن و حجم

2- مسافت

3- زمان

4- فشار

5- نیرو

6- انرژی

7- توان

۸- جاذبه

۹- دما

۱۰- حجم مایعات

شکل این تابع به صورت زیر است :

=convert( واحد نهایی ; واحد اولیه ; مقدار )

مقدار مورد نظر را وارد کرده , واحد ها را با علامت گیوه و به ترتیب وارد می کنیم تا اکسل مقدار داده شده را از واحد اولیه بهواحد نهایی تبدیل کند.

مثال : فرض کنید می خواهیم بدانیم یک گرم چند پوند است ؟

به جدول راهنمای تابع نگاه کنید ، علامت اختصاری گرم "g" و پوند "lbm" است . این نکته مهم است که علامت های اختصاری انحصارا باید شبیه آنچه در راهنما ذکر شده است در تابع نوشته شوند ( کوچک و بزرگ بودن مهم است )

=convert(1;"g";"lbm") = 0.002205

  • microsoft excel help
CONVERT
Converts a number from one measurement system to another. For example, CONVERT can translate a table of distances in miles to a table of distances in kilometers.

Syntax

CONVERT(number,from_unit,to_unit)

Number is the value in from_units to convert.

From_unit is the units for number.

To_unit is the units for the result. CONVERT accepts the following text values (in quotation marks) for from_unit and to_unit.

1-Weight and mass | From_unit or to_unit
Gram | "g"
Slug | "sg"
Pound mass (avoirdupois) | "lbm"
U (atomic mass unit) | "u"
Ounce mass (avoirdupois) | "ozm"

2-Distance | From_unit or to_unit
Meter | "m"
Statute mile | "mi"
Nautical mile | "Nmi"
Inch | "in"
Foot | "ft"
Yard | "yd"
Angstrom | "ang"
Pica (1/72 in.) | "Pica"

3-Time | From_unit or to_unit
Year | "yr"
Day | "day"
Hour | "hr"
Minute | "mn"
Second | "sec"

4-Pressure | From_unit or to_unit
Pascal | "Pa" (or "p")
Atmosphere | "atm" (or "at")
mm of Mercury | "mmHg"

5-Force | From_unit or to_unit
Newton | "N"
Dyne | "dyn" (or "dy")
Pound force | "lbf"

6-Energy | From_unit or to_unit
Joule | "J"
Erg | "e"
Thermodynamic calorie | "c"
IT calorie | "cal"
Electron volt | "eV" (or "ev")
Horsepower-hour | "HPh" (or "hh")
Watt-hour | "Wh" (or "wh")
Foot-pound | "flb"
BTU | "BTU" (or "btu")

7-Power | From_unit or to_unit
Horsepower | "HP" (or "h")
Watt | "W" (or "w")

8-Magnetism | From_unit or to_unit
Tesla | "T"
Gauss | "ga"

9-Temperature | From_unit or to_unit
Degree Celsius | "C" (or "cel")
Degree Fahrenheit | "F" (or "fah")
Kelvin | "K" (or "kel")

10-Liquid measure | From_unit or to_unit
Teaspoon | "tsp"
Tablespoon | "tbs"
Fluid ounce | "oz"
Cup | "cup"
U.S. pint | "pt" (or "us_pt")
U.K. pint | "uk_pt"
Quart | "qt"
Gallon | "gal"
Liter | "l" (or "lt")

The following abbreviated unit prefixes can be prepended to any metric from_unit or to_unit.

Prefix | Multiplier | Abbreviation
exa | 1E+18 | "E"
peta | 1E+15 | "P"
tera | 1E+12 | "T"
giga | 1E+09 | "G"
mega | 1E+06 | "M"
kilo | 1E+03 | "k"
hecto | 1E+02 | "h"
dekao | 1E+01 | "e"
deci | 1E-01 | "d"
centi | 1E-02 | "c"
milli | 1E-03 | "m"
micro | 1E-06 | "u"
nano | 1E-09 | "n"
pico | 1E-12 | "p"
femto | 1E-15 | "f"
atto | 1E-18 | "a"

Remarks

  • If the input data types are incorrect, CONVERT returns the #VALUE! error value.
  • If the unit does not exist, CONVERT returns the #N/A error value.
  • If the unit does not support an abbreviated unit prefix, CONVERT returns the #N/A error value.
  • If the units are in different groups, CONVERT returns the #N/A error value.
  • Unit names and prefixes are case-sensitive.

Example

The example may be easier to understand if you copy it to a blank worksheet.

  1. Create a blank workbook or worksheet.
  2. Select the example in the Help topic.

    Note Do not select the row or column headers.

    Selecting an example from Help
  3. Press CTRL+C.
  4. In the worksheet, select cell A1, and press CTRL+V.
  5. To switch between viewing the results and viewing the formulas that return the results, press CTRL+` (grave accent), or on the Formulas tab, in the Formula Auditing group, click the Show Formulas button.
1
2
3
4
5
A | B
Formula | Description (Result)
=CONVERT(1.0, "lbm", "kg") | Converts 1 pound mass to kilograms (0.453592)
=CONVERT(68, "F", "C") | Converts 68 degrees Fahrenheit to Celsius (20)
=CONVERT(2.5, "ft", "sec") | Data types are not the same so an error is returned (#N/A)
=CONVERT(CONVERT(100,"ft","m"),"ft","m") | Converts 100 square feet into square meters (9.290304).

angstrom to yard calorie to volt celsius celsius to fahrenheit change from one pressure to another conversion tables conversion units convert convert celsius to fahrenheit convert distances convert energy measurements convert foot to inch convert from one time to another convert function convert gallons to liters convert KM to miles convert liquid measures convert minutes to seconds convert to a date convert to metric convert to other language convert to string convert weight and mass CONVERT WORKSHEET FUNCTION convert years to days date conversion dyne to pound force feet to meters fluid ounce to cup foot-pound to btu force conversion gallon to liter grams to ounce horsepower to watt hour to minute inch to foot inches to feet joule to erg kelvin to celsius kilometers to miles length units magnetism conversion meter to mile meter to pica metric conversion metric to English metric to english conversions METRIC TO IMPERIAL metric units newton to dyne pascal to atmosphere pascal to mm of mercury pint to quart pound to atomic mass unit teaspoon to tablespoon temperature equivalents tesla to gauss volume metric conversions what function can I use to convert from one unit of measure to another? xl

نوشته شده در چهارشنبه بیست و سوم تیر 1389ساعت 11:57 توسط علی توضیح |
تمرین - مرتب کردن اعداد درون یک ستون در ستونی دیگر به صورت خودکار
تمرین - فرض کنید درون ستون B اعدادی داریم که می خواهیم به صورت خودکار در ستون C مرتب شوند.

حل - ابتدا ستون A را به جدول اضافه کنید تا رتبه هر عدد در آن نوشته شود . حال از تابع large برای مرتب سازی بر اساس رتبه ها استفاده کرده آنها را مرتب می کنیم .

در مورد تابع large باید گفت که این تابع مجموعه ای از اعداد را از کاربر گرفته و سپس kامین عدد بزرگ آنرا نمایش می دهد.

شکل تابع :

=large( کاامین عنصر، مجموعه )

نکته مهم دیگر اینست که باید تمام مجموعه به صورت مطلق آدرس دهی شده باشد.

نوشته شده در پنجشنبه هفدهم تیر 1389ساعت 9:27 توسط علی توضیح |
تابع پنهان datedif - اکسل پیشرفته
برخی از توابع اکسل در میان توابع تعریف شده ظاهر نمی شوند .از جمله ی این توابع ؛ تابع زیبای

datedif است که دو تاریخ را از کاربر گرفته و تفاوت های آنرا بر حسب روز ؛ ماه و سال نمایش می دهد.

=datedif( شاخص ; تاریخ بزرگتر ;تاریخ کوچکتر)

توجه کنید که هنگام تایپ این تابع ،راهنما برروی صفحه نمایش ظاهر نمی شود و کاربر باید نام تابع را به درستی تایپ کند

شاخص ها :

  • "Y": سال
  • "M" : ماه
  • "D" : روز

بین دو تاریخ را نشان می دهند

منبع : کتاب ترفند های اکسل - محمد حسن مهدوی

نوشته شده در دوشنبه سی و یکم خرداد 1389ساعت 8:59 توسط علی توضیح |
تبدیل داده ها از افقی به عمودی
برای تبدیل حالت قرار گرفتن داده ها از افقی به عمودی یا برعکس دو روش را پیشنهاد می کنم:

۱- استفاده از paste special گزینه ی transpose. برای استفاده کافی است داده ها را کپی کرده و سپس بجای paste از paste special استفاده کنیم :

2- استفاده از تابع آرایه ای transpose . توجه داشته باشیم که برای اجرای این تابع الزاما باید کلید های

ctrl+shift+enter را با هم فشار دهید.

نوشته شده در سه شنبه بیست و پنجم خرداد 1389ساعت 8:13 توسط علی توضیح |
تابع Trim - اکسل پیشرفته
برخی اوقات کاربران لیست هایی را تحویل می گیرند که از لحاظ کیفیت ورود داده در سطح پایینی قرار دارند و تحلیلگر باید زمان زیادی را برای تصحیح این لیست ها زمان صرف کند . یکی از موارد خطا در اینگونه لیست ها ورود یک داده به شکل های مختلف است . به طور مثال نام "علی توضیح" ممکن است با فاصله های مختلف در اطرافش نوشته شود : " علی توضیح " یا "علی توضیح" یا ... اینگونه ورود داده آنالیز لیست ها را خطا و اشتباه همراه می کند . لذا کاربر باید ابتدا داده های واحد را یکسان سازی کرده سپس آنالیز را آغاز کند .

یکی از بهترین توابعی که اکسل در اختیار کاربرانش قرار داده , تابع trim است . این تابع فواصل اضافی بین کلمات را حذف می کند . فواصل مجاز تنها بین هر کلمه یک space است .

=trim(" ali tozih ") => ali tozih

نوشته شده در پنجشنبه نوزدهم فروردین 1389ساعت 6:42 توسط علی توضیح |
تمرین توابع روند سازی trunc
با استفاده از توابع روند سازی ساختاری طراحی کنید که یک عدد حداکثر ۹ رقمی را رقم به رقم جدا کرده زیر هم قرار دهد

در ضمن این ساختار با استفاده از دو تابع متنی left , right نیز قابل طراحی می باشند.

نوشته شده در چهارشنبه هفتم بهمن 1388ساعت 9:27 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


آموزش جامع نرم افزار اکسل 2007 EXCEL - توابع مالی - بخش دوم

تبليغات X
آموزش جامع نرم افزار اکسل 2007 EXCEL - توابع مالی - بخش دوم
آموزش جامع نرم افزار اکسل 2007 EXCEL
آموزش محیط و توانایی های صفحه گسترده اکسل 2007 توابع ، نمودارها، روش های تحلیل داده - اکسل پیشرفته
توابع مالی - بخش دوم

تابع RATE

این تابع درصد نرخ سود سالانه را محاسبه می کند.

=RATE( تعداد اقساط ; مبلغ هر قسط ; مبلغ وام )

مثال 3 : فرض کنید وامی به مبلغ سی میلیون ریال به مدت هفت سال باید بازپرداخت شود اگر مبلغ هر قسط

سالیانه ی آن 5,184,594.55 ریال باشد نرخ سود سالیانه ی آن چقدر است ؟

=RATE( 7 ; 5,184,594.55 ; 30000000) = 5%

تابع NPER

این تابع تعداد اقساط یک وام را مشخص می کند.

=NPER( سالانه نرخ سود ; مبلغ هر قسط ; مبلغ وام )

مثال 4 : فرض کنید وامی به مبلغ سی میلیون ریال با نرخ سود سالانه پنج درصد و با مبلغ هر قسط 5,184,594.55 ریال را از بانک دریافت کرده ایم . چند قسط سالیانه باید بپردازیم؟

=NPER( 5% ; 5,184,594.55 ; 30000000) = 7

نوشته شده در دوشنبه پانزدهم فروردین 1390ساعت 11:23 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


آموزش جامع نرم افزار اکسل 2007 EXCEL - تمرین جداول محوری - pivottable

تبليغات X
آموزش جامع نرم افزار اکسل 2007 EXCEL - تمرین جداول محوری - pivottable
آموزش جامع نرم افزار اکسل 2007 EXCEL
آموزش محیط و توانایی های صفحه گسترده اکسل 2007 توابع ، نمودارها، روش های تحلیل داده - اکسل پیشرفته
تمرین جداول محوری - pivottable
در فایل زیر که شامل سه کاربرگ است ، تمرین های زیر را حل کنید:

1- در جدول یک مطلوبست جمع دریافتی هر نفر؟

2- میانگین دریافتی هر نفر از هر بانک ؟

3- بیشترین دریافتی هر نفر در هر سال ؟

4- کمترین مقداری که هر بانک به عنوان دریافتی ، در هر سال به هر فرد داده است ؟

5- در جدول شماره دو ، مقدار خریداری شده و فروخته شده هر کالا را نمایش داده و سپس مانده ی هر کدام را نمایش دهید.

6- در جدول شماره سه هر فروشگاه در هر شهر از هر کالا چه مبلغی ( جمع کل ) فروش داشته است.

7- نمودار فروش پاکن را در تمام فروشگاه ها مقایسه کنید.

دانلود تمرین

موفق باشید

نوشته شده در سه شنبه شانزدهم فروردین 1390ساعت 11:17 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
اموزش و راهنمای استفاده از برخی توابع آماری در تحلیل داده های علوم تربیتی و کلاس و مدرسه
یک مثال ساده برای استفاده از اکسل در طراحی و تجزیه و تحلیل نمرات دانش آموزان و دروس آنها با استفاده از این توابع مدیران آموزشی ، حتی مدرسین گرامی قادرند کلاس و یا مدرسه را ارزیابی آموزشی کنند .

مثال : فرض کنید نمرات تعدادی دانش آموز در یک کلاس را در اکسل به فرم زیر وارد می کنیم . حال قصد بررسی و تجزیه و تحلیل نمرات هر دانش آموز( سطری) و هر درس ( ستون) را در جدول طراحی شده داریم .میخواهیم بدانیم جایگاه هر دانش آموز و کیفیت آموزش هر درس کجاست ؟

توابعی که در مثال فوق استفاده شده اند عبارتند از :

جمع | SUM
مد | MODE
میانه کلاس | MEDIAN
میانگین کلاس | AVERAGE
کمترین نمره | MIN
بیشترین نمره | MAX
دامنه تغییرات | MAX-MIN
چارک اول | QUQRTILE 1
چارک سوم | QUQRTILE 3
انحراف چارکی | (Q3-Q1)/2
واریانس کلاس | VAR
انحراف از معیار | STDEV
کشیدگی یا کجی | SKEW
نقطه اوج توزیع | KURT

نوشته شده در پنجشنبه نهم شهریور 1385ساعت 8:30 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


آموزش جامع نرم افزار اکسل 2007 EXCEL - تمرین مدیریت داده -اکسل پیشرفته

تبليغات X
آموزش جامع نرم افزار اکسل 2007 EXCEL - تمرین مدیریت داده -اکسل پیشرفته
آموزش جامع نرم افزار اکسل 2007 EXCEL
آموزش محیط و توانایی های صفحه گسترده اکسل 2007 توابع ، نمودارها، روش های تحلیل داده - اکسل پیشرفته
تمرین مدیریت داده -اکسل پیشرفته
تمرین - فرض کنید یک لیست از شماره های دانشجویی یک کلاس داریم و می خواهیم نمره ی هر دانشجو را در جلوی شماره اش وارد کنیم .فرمی لازم داریم تا با تایپ شماره دانشجویی آنرا در فهرست یافته و پس از ورود نمره آنرا در مقابلش ثبت کرده َ شماره دانشجویی بعدی را از کاربر بگیرد.

پاسخ: ابتدا یک سلول از جدول انتخاب شود.سپس ابزار form را از بخش ابزار های اکسل :

QAT\MORE COMMANDS \ ALL COMMANDS\FORM..

انتخاب می کنیم. حال با انتخاب این ابزار کاربر قادر است بسیاری از قابلیت های یک فرم ساده در ورود و نمایش داده ها را استفاده کند.

با فشردن کلید CRITERIA کاربر می تواند شرط مورد نظر را وارد کند . مثلا شماره دانشجویی. حال با فشردن کلید اینتر رکورد مورد نظر یافت شده می توانید داده متناظر آنرا وارد نمایید. اگر در حالت شرط ( CRITERIA ) باشید بجای این کلمه گزینه FORM فعال است.

با کلید NEW می توانید رکورد جدید وارد کنید و با کلید های NEXT , PREV هم به رکوردهای قبل و بعد وارد میشوید.

نوشته شده در پنجشنبه هشتم اردیبهشت 1390ساعت 9:38 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


آموزش جامع نرم افزار اکسل 2007 EXCEL - طراحی جدول داده

تبليغات X
آموزش جامع نرم افزار اکسل 2007 EXCEL - طراحی جدول داده
آموزش جامع نرم افزار اکسل 2007 EXCEL
آموزش محیط و توانایی های صفحه گسترده اکسل 2007 توابع ، نمودارها، روش های تحلیل داده - اکسل پیشرفته
طراحی جدول داده
توجه کاربران محترم اکسل را برای طراحی یک جدول به نکات زیر جلب می کنم:

۱- از گسستگی داده ها بپرهیزید . ( سطر یا ستون کاملا خالی در جدول نداشته باشید )

۲- از انجام عملیات merge بپرهیزید ( اینکار مانع از مرتب سازی و فیلترینگ صحیح داده ها در جدول می گردد)

3- تمام فیلد های مربوط به یک موضوع را در یک جدول قرار دهید تا قادر به دریافت اطلاعات صحیح تر باشید ( فیلدها همان ستون های جدولند )

4- فیلد های جدول حتما باید دارای عنوان باشند (هدر )

5- حتما سعی کنید از سمت ستون A جدول را طراحی کنید.

۶- از ورود داده های نامعتبر جلوگیری کنید ( validation).

7- از تخریب سلول هایی که نباید دستکاری شوند با protection جلوگیری کنید.

8- سعی کنید در بالای عناوین فیلدها محاسبات و سرجمع آنهارا نشان دهید( subtotal ) نه در پایین جدول

9- هر چه بیشتر فیلد در جدول شما باشد گزارشات شما دقیقتر و بنابراین اطلاعات شما صحیحتر خواهد بود (pivottable).

۱۰-منطق ورود داده را فراموش نکنید ( جایی که قرار است نام وارد شود فامیل وارد نکنیم )

نوشته شده در سه شنبه سیزدهم اردیبهشت 1390ساعت 13:48 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


معرفی امکانات جدید اکسل 2012 - پنجشنبه سی ام تیر 1390
ساخت یک گزارش پویا در اکسل 2010 - دوشنبه نهم خرداد 1390
توضیح بیشتر درباره تمرین قبل - یکشنبه بیست و پنجم اردیبهشت 1390
تمرین - یافتن داده ها روش استفاده از توابع match , dsum - یکشنبه هجدهم اردیبهشت 1390
طراحی جدول داده - سه شنبه سیزدهم اردیبهشت 1390
روز معلم مبارک - سه شنبه سیزدهم اردیبهشت 1390
تمرین مدیریت داده -اکسل پیشرفته - پنجشنبه هشتم اردیبهشت 1390
تمرین جداول محوری - pivottable - سه شنبه شانزدهم فروردین 1390
توابع مالی - بخش دوم - دوشنبه پانزدهم فروردین 1390
برخی توابع مالی در اکسل - اکسل 2007 پیشرفته - دوشنبه پانزدهم فروردین 1390
وبلاگ جدید اکسل - شنبه چهاردهم اسفند 1389
آشنایی بیشتر با format cells در اکسل 2007 - یکشنبه بیست و ششم دی 1389
مطالب و کتاب های جدید - سه شنبه سی ام آذر 1389
نمودارهای اسپارک ( جرقه ای ) - sparklines excel 2010 - دوشنبه بیست و چهارم آبان 1389
آشنایی با تابع Indirect در اکسل - Excel - یکشنبه بیست و سوم آبان 1389
کتاب جدید مجموعه کلید - کلید جدول، نمودار و ابزار گرافیکی در Excel همراه با CD - شنبه بیست و دوم آبان 1389
گزارش گیری از چند کاربرگ مختلف - muliple consolidation ranges in pivottable - چهارشنبه نوزدهم آبان 1389
فایل تمرین گروه اکسل پیشرفته تابع subtotal - سه شنبه چهارم آبان 1389
تزریق یک فایل اکسل به اوت لوک 2010 - یکشنبه دوم آبان 1389
جمع بستن ساعات ها - اکسل پیشرفته -( تکراری ) - یکشنبه دوم آبان 1389
تکرار در اکسل 2010 - repeat all item labels - یکشنبه هجدهم مهر 1389
پر کردن فضای خالی بین سلول های پر - ترفند 23 - یکشنبه چهارم مهر 1389
اکسل تحت وب یا google docs - دوشنبه بیست و نهم شهریور 1389
استفاده از ابزار قدرتمند consolidate برای یکسان سازی داده ها - چهارشنبه هفدهم شهریور 1389
دانلود کتاب تمام رنگی اکسل 2010 - پنجشنبه بیست و چهارم تیر 1389
تبدیل واحدهای اندازه گیری در اکسل 2007 - توابع مهندسی - چهارشنبه بیست و سوم تیر 1389
تمرین - مرتب کردن اعداد درون یک ستون در ستونی دیگر به صورت خودکار - پنجشنبه هفدهم تیر 1389
حذف رکورد های تکراری در اکسل - remove duplicates - پنجشنبه هفدهم تیر 1389
نمایش اعداد منفی به صورت مثبت - شنبه دوازدهم تیر 1389
پوزش - پنجشنبه دهم تیر 1389
تابع پنهان datedif - اکسل پیشرفته - دوشنبه سی و یکم خرداد 1389
جمع بستن ساعات ها - اکسل پیشرفته - شنبه بیست و نهم خرداد 1389
معرفی دو کتاب جدید از آقای مهدوی - سه شنبه بیست و پنجم خرداد 1389
تبدیل داده ها از افقی به عمودی - سه شنبه بیست و پنجم خرداد 1389
ایجاد علاقه برای کار با اکسل - یکشنبه نهم خرداد 1389
سایت فرساران آموزش تخصصی اکسل - شنبه هشتم خرداد 1389
ترسیم نمودار های دو ستونی در اکسل 2007 - اکسل پیشرفته - سه شنبه هفتم اردیبهشت 1389
تابع Trim - اکسل پیشرفته - پنجشنبه نوزدهم فروردین 1389
فریز کردن در اکسل - سه شنبه هفدهم فروردین 1389
جستجوی سلول های رنگی در اکسل - find - یکشنبه هشتم فروردین 1389
سال نو قالب نو - چهارشنبه بیست و ششم اسفند 1388
دانلود تمرین گزارش گیری در اکسل پیشرفته- آنالیز داده ها - چهارشنبه بیست و ششم اسفند 1388
اتصال نقاط گسسته نمودار - چهارشنبه بیست و ششم اسفند 1388
حل تمرین ها data validation - شنبه بیست و دوم اسفند 1388
data validation - پنجشنبه ششم اسفند 1388
تبدیل فایل های اکسل xls xlsx به exe - پنجشنبه ششم اسفند 1388
اکسل پیشرفته - نمودار های کیکی یا pie - چهارشنبه بیست و هشتم بهمن 1388
آموزش تصویری و مقدماتی اکسل - یکشنبه بیست و پنجم بهمن 1388
Excel password - اکسل پیشرفته - یکشنبه بیست و پنجم بهمن 1388
تمرین توابع روند سازی trunc - چهارشنبه هفتم بهمن 1388
۱ ۲ ۳ ۴ >>
Powered by BLOGFA.COM


آموزش جامع نرم افزار اکسل 2007 EXCEL - توضیح بیشتر درباره تمرین قبل

تبليغات X
آموزش جامع نرم افزار اکسل 2007 EXCEL - توضیح بیشتر درباره تمرین قبل
آموزش جامع نرم افزار اکسل 2007 EXCEL
آموزش محیط و توانایی های صفحه گسترده اکسل 2007 توابع ، نمودارها، روش های تحلیل داده - اکسل پیشرفته
توضیح بیشتر درباره تمرین قبل
در تمرین انبار از سه تابع match index , dsum استفاده شده است. همانطور که قبلا توضیح دادم دو تابع match , index برعکس یکدیگرند.

تایع index شماره ردیف داده را در یک مجموعه دریافت کرده خود داده را نمایش می دهد در حالیکه تابع match داده را دریافت کرده شماره ردیف آن در مجموعه را نمایش می دهد.

=index( شماره ردیف داده , مجموعه ) ====> data

=match ( data , مجموعه , type ) ======> data row

در این تمرین کافی است ابتدا با استفاده از تابع match شماره اولین ردیفی را که داده در آن نمایش داده شده را بیابید . با این کار شما قادر خواهید بود نام کالا را یافته و آنرا در سلولی دیگر نمایش دهید.

تابع dsum هم عملیات جمع را با شرط انجام می دهد . این تابع سه پارامتر دارد . ابتدا نشانی کل جدول را از کاربر گرفته ، شماره فیلدی را که قرار است عملیات جمع روی آن انجام گیرد را نیز دریافت می کند آنگاه با دریافت آدرس محدوده شرط ، عملیات جمع را انجام می دهد . نکته مهم آنست که آدرس محدوده ی شرط باید شامل عناوینی باشد که در آدرس کل جدول نیز وجود دارند. مثلا اگر شما می خواهید به دنبال جمع تعداد کالای خریداری شده بگردید ( فیلد شماره 6) باید محدوده شرط را طوری انتخاب کنید که کد کالا و شماره ی آن در محدوده ی شرط باشند ( m1 :m2 )

البته در تابع match پارامتر آخر دارای سه مقدار 0 و 1 و -1 است که بسته به نوع جستجو از آنها استفاده می کنیم :

1 برای جستجوی مقادیری کوچکتر از مقدار داده شده

0 برای جستجوی دقیق مقادیر داده شده

-1 برای جستجوی مقادیر بزرگتر از مقدار داده شده

نوشته شده در یکشنبه بیست و پنجم اردیبهشت 1390ساعت 14:7 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


آموزش جامع نرم افزار اکسل 2007 EXCEL - روز معلم مبارک

تبليغات X
آموزش جامع نرم افزار اکسل 2007 EXCEL - روز معلم مبارک
آموزش جامع نرم افزار اکسل 2007 EXCEL
آموزش محیط و توانایی های صفحه گسترده اکسل 2007 توابع ، نمودارها، روش های تحلیل داده - اکسل پیشرفته
روز معلم مبارک
تقدیم به همه معلمان مربیان آموزگاران اساتید و...

روزگاری است که سودای بتان دین من است غم اینکار نشاط دل غمگین من است

دیدن روی تو را دیده ی جان بین باید وین کجا مرتبه چشم جهان بین من است

یار من باش که زیب فلک و زینت دهر از مه روی تو و اشک چو پروین من است

تا مرا عشق تو تعلیم سخن گفتن داد خلق را ورد زبان مدحت و تحسین من است

دولت فقر خدایا به من ارزانی دار کاین کرامت سبب حشمت و تمکین من است

یا رب آن کعبه مقصود تماشاگه کیست ؟ که مغیلان طریقش گل و نسرین من است

واعظ شحنه شناس این عظمت گو مفروش زانکه منزلگه سلطان دل مسکین من است

حافظ از حشمت پرویز دگر قصه مخوان که لبش جرعه کش خسرو و شیرین من است

نوشته شده در سه شنبه سیزدهم اردیبهشت 1390ساعت 13:0 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


آموزش جامع نرم افزار اکسل 2007 EXCEL - تمرین - یافتن داده ها روش استفاده از توابع match , dsum

تبليغات X
آموزش جامع نرم افزار اکسل 2007 EXCEL - تمرین - یافتن داده ها روش استفاده از توابع match , dsum
آموزش جامع نرم افزار اکسل 2007 EXCEL
آموزش محیط و توانایی های صفحه گسترده اکسل 2007 توابع ، نمودارها، روش های تحلیل داده - اکسل پیشرفته
تمرین - یافتن داده ها روش استفاده از توابع match , dsum
در بسیاری از مواقع کاربران برای یافتن یک کالا یا شخص با استفاده از کد با مشکل روبرو می شوند و می خواهند بدون استفاده از vba نیز بر مشکل برطرف شود.

برای اینکار می توان از تابع match برای یافتن اولین ردیف از داده استفاده کرد و سپس نام داده را با استفاده از تابع index شناخت , بالاخره برای یافتن جمع ها از توابعی مانند dsum یا خانواده sumifs استفاده کرد. برای این منظور تمرین طراحی و با پاسخ در اختیار شما دوستان قرار می دهم تا بیشتر تمرین کنید.

تمرین - در جدول انبار ساختاری طراحی کنید که با نوشتن کد هر کالا شماره اولین ردیف ،نام کالا و سپس جمع خریداری شده و فروخته شده و مانده ی هر کالا را نمایش دهد.

دانلود فایل تمرین

نوشته شده در یکشنبه هجدهم اردیبهشت 1390ساعت 9:8 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


آموزش جامع نرم افزار اکسل 2007 EXCEL - ساخت یک گزارش پویا در اکسل 2010

تبليغات X
آموزش جامع نرم افزار اکسل 2007 EXCEL - ساخت یک گزارش پویا در اکسل 2010
آموزش جامع نرم افزار اکسل 2007 EXCEL
آموزش محیط و توانایی های صفحه گسترده اکسل 2007 توابع ، نمودارها، روش های تحلیل داده - اکسل پیشرفته
ساخت یک گزارش پویا در اکسل 2010
بیشتر اوقات کاربران اکسل برای گزارش گیری از مجموعه ی عظیمی از داده ها در اکسل به مشکل برخورد می کنند. ابزار جداول محوری یا pivottables در اکسل این توانایی را در آنها ایجاد می کند.این ابزار به کاربران کمک می کند تا بر اساس فیلد ها گزارش تهیه کنند .

مثال- فرض کنید جدول شماره یک مجموعه ای از داده های مربوط به افراد یک کارگاه است که مرتب در حال دریافت و پرداخت میباشند . حال اگر بخواهیم گزارشی از تمام دریافتی ها ی همه کارکنان بیابیم به روش زیر اقدام می کنیم :

حل : ابتدا یک سلول از جدول داه را انتخاب کرده ، از منوی insert گزینه pivot tableرا انتخاب می کنیم .

با انتخاب محدوده جدول داده یا حتی بیشتر از آن ، اکسل متوجه فیلد ها و داده ها می گردد.

فیلد ها و منوی pivottable tools پدیدار می گردد و کاربر قادر است فیلدها را انتخاب کرده و عملیات محاسباتی خود را تغییر دهد.

هر جدول محوری دارای 4 بخش است .

1- ستون ها : که داده ها به صورت ستونی در جدول نمایش داده می شوند.

2- report : که اصلی ترین فیلد مجموعه محسوب می گردد و سایر فیلد ها زیر مجموعه ی آن محسوب می گردند.

3- سیگما : یا بخش محاسباتی جدول

4- ردیف ها : که داده ها به صورت سطری در جدول نمایش داده می شوند.

کافی است فیلد های مورد نظر را گرفته و به یکی از این چهار بخش بکشیم یا آنها را تیک بزنیم.

شکل جدول پدیدار می گردد و شما قادرید از گزارش ساخته شده اطلاعات بگیرید.

برخی اوقات به مشکل برخورد می کنیم . جدول محوری تفاوتی بین یک فیلد محاسباتی را با غیر آن به درستی درک نمی کند . در مثال زیر فیلد اتخاب شده سال به بخش محاسباتی منتقل شده است در حالیکه ما قصد جمع و ضرب آنرا نداریم و می خواهیم دریافتی افراد را طی سال های مختلف بررسی کنیم . بنابراین باید آنرا به بخش سطر ها کشید تا در کنار اسامی اطلاعات را شفافتر منتقل کنند.

خروجی جدول بیانگر دریافتی هر فرد طی سال های مورد نظر است .

لینک دانلود جدول و تمرین های بیشتر را در بخش تمرین جداول محوری در روز شانزدهم فروردین ۹۰ قرار داده ام. موفق باشید

نوشته شده در دوشنبه نهم خرداد 1390ساعت 9:2 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


آموزش جامع نرم افزار اکسل 2007 EXCEL - معرفی امکانات جدید اکسل 2012

تبليغات X
آموزش جامع نرم افزار اکسل 2007 EXCEL - معرفی امکانات جدید اکسل 2012
آموزش جامع نرم افزار اکسل 2007 EXCEL
آموزش محیط و توانایی های صفحه گسترده اکسل 2007 توابع ، نمودارها، روش های تحلیل داده - اکسل پیشرفته
معرفی امکانات جدید اکسل 2012
گروه فعال سایت فرساران بازهم مطلبی جدید را درباره اکسل ۲۰۱۲ ارائه نموده که خواندن آنرا به همه توصیه می کنم.

این مطلب را می توانید از لینک زیر مشاهده کنید.

http://farsaran.ir/Excel%202012%20News

با عضویت در این سایت غنی مطالب جدید را به صورت مرتب با ایمیل دریافت کنید.

باز هم از زحمات گروه فعال فرساران و جناب آقای مهندس فرشید میدانی تشکر می کنیم .

www.farsaran.ir

نوشته شده در پنجشنبه سی ام تیر 1390ساعت 12:5 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


آموزش جامع نرم افزار اکسل 2007 EXCEL - برخی توابع مالی در اکسل - اکسل 2007 پیشرفته

تبليغات X
آموزش جامع نرم افزار اکسل 2007 EXCEL - برخی توابع مالی در اکسل - اکسل 2007 پیشرفته
آموزش جامع نرم افزار اکسل 2007 EXCEL
آموزش محیط و توانایی های صفحه گسترده اکسل 2007 توابع ، نمودارها، روش های تحلیل داده - اکسل پیشرفته
برخی توابع مالی در اکسل - اکسل 2007 پیشرفته

برخی توابع مالی در اکسل

برخی از توابع مالی استفاده های زیادی در اکسل دارند ، که به طور خلاصه به شرح 4 مورد از آنها خواهیم پرداخت:

تابع PMT

این تابع برای محاسبه مبلغ اقساط سالیانه یک وام با بهره ثابت بکار می رود.

=PMT( نرخ بهره سالانه; تعداد اقساط سالانه ; مبلغ کل وام )

در مورد توابع مالی این نکته ضروری است که اگر تمام مواردمثبت باشد اکسل به صورت خودکار جواب را منفی نمایش می دهد ( شما را بدهکار می کند ) برای جلوگیری از این کار ، معمولا مبلغ وام را منفی نمایش می دهند تا سایر جواب ها مثبت نشان داده شود.

این نکته هم ضروری است که بدانیم ساختار ها باید همگون باشند یعنی اگر کاربر بهره سالانه استفاده می کند مبلغ قسط هم سالانه نمایش داده می شود ، تعداد اقساط هم همان تعداد سال های پرداخت وام تلقی می گردد.

مثال 1 : فرض کنید وامی را به مبلغ سی میلیون ریال ( سه میلیون تومان ) با بهره سالانه پنج درصد طی هفت سال می خواهیم بازپس دهیم ، آیا می توان مبلغ اقساط سالانه آنرا محاسبه کرد؟

=PMT( 5% ; 7 ; 30000000) = ريال 5,184,594.55

در حقیقت شما باید سالانه مبلغ ريال 5,184,594.55 را بابت اقساط بپردازید .

نرخ بهره سالانه | تعداد اقساط ( سال ) | مبلغ وام | مبلغ هر قسط ( سالانه ) | مبلغ هر قسط (ماهانه ) | جمع کل اقساط | جمع کل سود پرداختی
5% | 7 | 30,000,000- | ريال 5,184,594.55 | ريال 432,049.55 | ريال 36,292,161.87 | ريال 6,292,161.87

تابع IPMT

این تابع برای محاسبه مبلغ سود هر قسط سالیانه یک وام با بهره ثابت بکار می رود.

=IPMT( نرخ بهره سالانه;شماره قسط ; تعداد اقساط سالانه ; مبلغ کل وام )

این تابع که شبیه تابع PMT است ، مبلغ سود هر قسط را محاسبه می کند.

مثال 2: در مثال شماره یک مبلغ سود هر قسط را محاسبه کنید، مثلا برای قسط سال اول :

=IPMT(5% ; 1 ; 7 ; 30000000)

نرخ بهره سالانه | شماره قسط | تعداد اقساط ( سال ) | مبلغ وام | مبلغ سود ه قسط
5% | 1 | 7 | 30,000,000- | 1,500,000.00
5% | 2 | 7 | 30,000,000- | 1,315,770.27
5% | 3 | 7 | 30,000,000- | 1,122,329.06
5% | 4 | 7 | 30,000,000- | 919,215.78
5% | 5 | 7 | 30,000,000- | 705,946.85
5% | 6 | 7 | 30,000,000- | 482,014.46
5% | 7 | 7 | 30,000,000- | 246,885.45

نرخ بهره سالانه | شماره قسط | تعداد اقساط ( سال ) | مبلغ وام | مبلغ سود هر قسط
5% | 1 | 7 | 30,000,000- | ريال 1,500,000.00
5% | 2 | 7 | 30,000,000- | ريال 1,315,770.27
5% | 3 | 7 | 30,000,000- | ريال 1,122,329.06
5% | 4 | 7 | 30,000,000- | ريال 919,215.78
5% | 5 | 7 | 30,000,000- | ريال 705,946.85
5% | 6 | 7 | 30,000,000- | ريال 482,014.46
5% | 7 | 7 | 30,000,000- | ريال 246,885.45

نوشته شده در دوشنبه پانزدهم فروردین 1390ساعت 10:21 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


تبليغات X
نمودار ها در اکسل

نمودارها در اكسل

يكي از بهترين ابزارها جهت نمايش دادها در اكسل نمودارها يا Chart مي‏باشد . اگربخواهيم ليستی ازداده ها را به وسيله نمودار تحليل وبرسي كنيم ابتدا يك سلول از ليست را انتخاب كرده سپس از ابزار CHART WIZARD جهت رسم نمودار استفاده ميكنيم .

انواع نمودار‏ها در اكسل

1- : COLUMN نمودار ستوني :اين نمودار تاكيد بيشتري بر زمان دارد و برای داده های گسسته بکار می رود .

2- BAR : نمودار افقي :اين نمودار شبيه نمودار ستوني است با اين تفاوت تاكيد كمتري بر زمان دارد.

3- : LINE نمودار خطي :اين نمودار براي مقايسه تعداد زيادي متغير پيوسته با تاکيد بر زمان است.

4-PIE : نمودار كلوچه‏اي: اين نمودار براي برسي تنها يك متغييركه مجموع آن به 100%مي رسد , استفاده مي شود.

5- XY(SCATTRE):اين نمودار شبيه نمودار خطي ميباشد با اين تفاوت كه نمودارمتغيير وابسته را ترسيم مي كند. توجه داشته باشيد که ستون اول جدول داده های عددی دارد .

6-: AREA نمودار سطحي : اندازه سطر هر نمودار بيانگر اندازه متغيراست در اين نمودار مقايسه بيش از 3 متغير توصيه نمي شود .

7-DOUGHNUT : نمودار حلقوي :اين نمودار شبيه نمودار كلوچه‏اي است با اين تفاوت كه قادر به مقايسه بيشتر از يك متغيير است

8-: RADARنمودار رادار:در اين نمودار براي مقايسه چند متغير در حيطه مجاز استفاده مي شود

9- :SURFACE نمودار صفحه‏‏اي برای مقايسه تاثير چند متغيير بر روی يک متغيير بکار می رود .

10- : BUBBLE نمودار حبابي :اين نمودار با بررسي 3 متغير هم زمان با توجه به مكان حباب ها واندازه آنها احتمال حادثه مورد نظر را پيش‏بيني مي كند

11-STOCK : اين نمودار جهت تحليل و بررسي اوراق يك شركت در بازار سهام استفاده مي شود

12- CYLINDER: شبيه نمودار ستوني با فرمتی متفاوت

13- :CONE شبيه نمودار ستوني با فرمتی متفاوت

14- PYRAMID: شبيه نمودار ستوني با فرمتی متفاوت

مراحل رسم يك نمودار

مرحله اول :

جهت رسم يك نمودار از ليستي از داده ها , ابتدا يكي از سلولها يا مجموعه مورد نظر را انتخاب كرده سپس با استفاده از كليد CHART WIZARDنوع نمودار را انتخاب كرده به مرحله بعد مي رويم .

مرحله دوم :

CHART SOURCE DATA : در اين مرحله داده‏هاي مورد نظررا به نمودار تزريق مي كنيم . با استفاده از پنجره DATA RANGE كار‏بر قادر است حيطه ترسيم داده‏ها را تغيير دهد .دو كليد ROWSوCOLUMNSجهت انتخاب دادهها سطري يا ستون براي ترسيم ميباشد .

مرحله سوم :

CHART OPTIONS : تغيرات مربوط به وضع ظاهري نمودار در اين قسمت كاربر قادر است عناوين نمودار عناوين مربوط به محورها تغيير اندازه ورنگ نمودار برچسبهاي بر روي نمودار, تغيير مكان راهنما‏ي نمودار را انجام دهد .

مرحله چهارم :

CHART LOCATION : گام آخر در ترسيم نمودار تعيين محل نمودار ميباشد دو حالت در اين قسمت موجود است .

حالت اول : ايجاد يك كاربرگ جدا .

حلت دوم :ترسيم نمودار در همان كار برگ

در انتها كليد FINISH را فشار مي دهيم ونمودار رسم مي شود .

نوشته شده در سه شنبه بیست و هفتم دی 1384ساعت 10:27 توسط علی توضیح |
توابع پر کاربرد اکسل

معرفی

توابعپرکاربرد در اكسل

تابع SUM

شكل تابع (محدوده)=SUM

شرح تابع :

اين تابع پارامترهاي موجود (محدود ‏ه هاي موجود )رابايكديگر جمع ميكند

مثال: =Sum(C10:C231) اين فرمول مجموعه‏اي از سلولهاي C10تا C231رابا يكديگر جمع ميكند .

محدوده C10 تا C231 محدوده‏اي از آدرسها مي باشد كه با علامت (:) مشخص شده است .

تابع AVERAGE

شكل تابع (محدوده)=Average

شرح تابع :

ميانگين دادههاي موجود در محدوده را محاسبه ميكند .

مثال: (=Average(F5:G11 ميانگين سلولهاي F5تا G11را محاسبه ميكند .

تابع MAX

شكل تابع :(محدوده)=MAX

شرح تابع : بيشترين مقدار محدوده را باز مي گرداند.

تابع MIN

شكل تابع :(محدوده)=MIN

شرح تابع :

كوچكترين مقدار محدوده را باز مي گرداند .

تابع MEDIAN

شكل تابع :(محدوده)=MEDIAN

شرح تابع :

ميانه محدوده را نمايش ميدهد .

تابع MODE

شكل تابع (محدوده)=MODE

شرح تابع :

داده با بيشترين فراواني را در محدوده نمايش ميدهد .

مثال: فرمولي را بنويسيد كه اگر كاربر درسلول (K4) كلمه TEST1را نوشت معدل TEST1و اگر TEST2 معدل TEST2را محاسبه کند.

تابع IF

شكل تابع ( ;T ;Fشرط)=IF

شرح تابع :

IFيك تابع شرطي ومنطقي است و ابتدا شرط راچك كرده اگرشرط صحيح باشد عمليات Tانجام مي‏پذيرد واگر شرط نادرست باشد عمليات F .

مثال: اگر مقدار درسلول A1بزرگتر يامساوي با 10باشد كلمه WINودرغير اين صورت كلمه FILLدر سلو D3 چاپ كنيد :

=IF(A1>=10;"WIN";"FILL"’)

اين فرمول درسلول D3 نوشته ميشود.

مثال:اگر در سلول A10كلمه TEST1 نوشته شود در A11ميانگين TEST1نمايش داده شود :

= IF (A10=B1;AVERAGE(B2:B6);0)

مثال :اگردرسلول A10كلمه TEST1نوشته شود ميانگين TEST1 در A11 نشان داده شود .

اگردرسلول A10كلمه TEST2نوشته شود ميانگين TEST2در A11 نشان داده شود .

اگردرسلول A10 كلمه TEST3 نوشته شود ميانگين TEST3در A11 نشان داده شود .

=IF(A10=B1;AAVERAGE(B2:B6);IF(A10=C1;AVERAGE(C2:C6);IF(A10=D1;AVERAGE(D2:D6);0)))

توابع AND و OR

تابع ANDو OR دوتابع منطقي مي باشند كه خروجي آنها هميشه دو حالت درست يانادرست ميباشد .

تابع AND

شكل تابع (شرط1و2)=AND

شرح تابع :اين تابع حد‏اقل دوشرط1و2رابرسي ميكند واگر هر دو صحيح باشند جواب صحيح را نمايش مي‏دهدواگر حتي يكي ازشرطها نادرست باشد جواب نادرست

مثال3:اگر ميانگين TEST1و TEST2هردو از12بيشتر كلمه GOODرا در B11 چاپ كند ودر غير اين صورت کلمه . BAD

=IF(AND(AVERAGE(B2:B6)>12;AVERAGE(C2:C6)>12);’GOOD’;’BAD’)

تابع OR

شكل تابع (شرط1و2)=OR

شرح تابع :

اين تابع حد‏اقل دوشرط رابرسي كرده واگر دوشرط نادرست باشند ،نادرست را نمايش مي دهد اگر حتي يكي از شرطها صحيح باشد خروجي تابع صحيح است .

مثال: اگر حد‏اقل ميانگين يكي از سه آزمون از 17بيشتر باشد كلمه GOODودر غير اين صورت BAD

=IF(OR(AVERAGE(B2:B6)>17;AVERAGE(C2:C6)>17);AVERAGE(D2:D6)>17);’GOOD’;’BAD’)

تابع COUNT

شكل تابع (محدوده )=COUNT

شرح تابع :

تعداد اعداد موجود در محدوده را نمايش مي‏دهد (سلولهاي را كه شامل اعداد )

مثال:

=COUNT(B2:B12)

تابع COUNTA

شكل تابع (محدوده )=COUNA

شرح تابع :

سلولهاي شامل اعداد ومتن را شمارش ميكند .

تابع NOW

شكل تابع ()=NOW

شرح تابع :

تاريخ وساعت جاري نمايش ميدهد .

تابع TODAY

شكل تابع ()=TODAY

شرح تابع :

تاريخ جاري نمايش ميدهد

تابع HOUR

شكل تابع (پارامتر زمان )=HOUR

شرح تابع :

اين تابع پارامتر زمان را دريافت كرده وساعت آن را بعنوان خروجي نمايش ميدهد

تابع YEAR

شكل تابع (تاريخ)=YEAR

شرح تابع :

سال را از تاريخ جدا كرده ونمايش ميدهد

تابع ABS

شكل تابع (عدد)=ABS

شرح تابع :

اين تابع قدر مطلق عددمورد نظر را نمايش ميدهد (بدون علامت)

مثال:

=ABS(-9.5) که حاصل این فرمول عدد 9.5 است .

تابع POWER

شكل تابع =POWER(A,B)

شرح تابع :

اين تابع عدد A را به توان Bمي‏رساند .

تابع SQRT

شكل تابع =SQRT(A)

شرح تابع :

جذر يا ريشه دوم عددمثبت Aرا نمايش مي‏دهد .

تابع PI

شكل تابع =PI()

شرح تابع :

اين تابع عدد پی را نمايش مي‏دهد .

مثال : اگر دايره‏اي به شعاع 7.3 داشته باشيم مساحت دايره چقدر است ؟ ( مساحت دایره شعاع به توان 2 درعدد پی ) .

=PI()*POWER(7.3;2)

تابع MOD

شكل تابع =MOD(A,B)

شرح تابع :

باقيمانده تقسيم عدد A بر Bرا نمايش ميدهد .

تابع RADIANS

شكل تابع (زاويه )=RADIANS

شرح تابع :

تبديل زاويه مورد نظر از رادیان به درجه

مثال:

=SIN(RADIANS(90))

تابع SIN

شكل تابع (زاويه )=SIN

شرح تابع :

اين تابع SINزاويه مورد نظر را نمايش ميدهد .

تابع LEN

شكل تابع :(عبارت)=LEN

شرح تابع :

تعداد كاركترهاي يك سلول يا عبارت را مي‏شمارد .

تابع UPPER

شكل تابع =UPPER(A1)

شرح تابع :

خروجي حرف بزرگ (عبارت را تما‏ما با حرف بزرگ نمايش ميدهد )

تابع LOWER

شكل تابع =LOWER(A1)

شرح تابع :

خروجي حرف كوچك

تابع COUNTIF

شكل تابع (شرط;محدوده)=COUNTIF

شرح تابع :

اين تابع محدوده مورد نظر را با شرط گروه وتعداد سلولهايي را كه با شرط مطابقت دارند نمايش ميدهد

مثال:

=COUNTIF(A1:G10,">30")

تابع SUMIF

شكل تابع (محدوده جمع;شرط;محدوده شرط)=SUMIF

شرح تابع :

اين تابع داراي سه پارامتر است شرط را در محدوده شرط كنترل كرده واگر شرط صحيح موجود در محدوده جمع سلول متناظررا جمع مي‏كند اين عمليات تا انتها‏ي ليست خود كار انجام ميشود .

اين توابع را ميتوان از طريق INSERT FUNCTION از منوی INSERT

استفاده کرد .

نوشته شده در سه شنبه بیست و هفتم دی 1384ساعت 8:30 توسط علی توضیح |
توابع

توابع در اكسل

جهت انجام عمليات تكراري وپيچيده از توابع تعريف شده دراكسل استفاده ميكنيم.

قسمتهاي مختلف يك تابع :

هر تابع از سه جزء اساسي تشكيل شده است

1-علامت مساوی 2- نام تابع 3- پارامتر تابع

مثال : تابع =SUM(A3:B10)

که در آن کلمه SUM نام تابع و A3:B10 پارامتر تابع است . این پارامتر محدوده عملیات تابع را مشخص می کند و مفهوم آن اینست که اعداد موجود در محدوده A3 تا B10 را با هم جمع می کند .

مثال : جدول زير را کامل کنيد :

مفهوم علامت دو نقطه در تابع کلمه تا می باشد .

دسته بندی توابع در اکسل

در اكسل توابع به يازده دسته مختلف تقسيم ميشوند .

اين يازده گروه عبارتند از :

Most Recently used | توابعي كه اخيراٌمورد استفاده قرار گرفته‏اند
All | تمامي توابع موجود در اكسل
Financial | ما لي
Date & time | تاريخ وزمان
Math & Trig | رياضي ومثلثات
Statistical | آماري
Lookup & reference | آدرسها وجستجو
Database | بانك اطلاعاتي
Text | متن
Logical | منطقي
Information | اطلاعات

اين دسته بندی يافتن توابع را آسان تر می نمايد . هر تابع در دسته کاری مورد نظر قرار دارد , بطور مثال توابع

مثلثاتی در گروه مثلثات و رياضيات و توابع آماری مثل ميانگين و ميانه و بيشينه و کمينه در گروه توابع آماری

قرار دارند.

دسته بندی توابع

نوشته شده در شنبه بیست و چهارم دی 1384ساعت 15:12 توسط علی توضیح |
مثال های فرمول نویسی
مثال های فرمول نویسی و استفاده از آدرس دهی های مختلف

۱- جدول زیر را کامل کنید :

در جدول زير اگر سود هر كالا 25 درصد قيمت خريد آن باشد مطلوبست محاسبه مبلغ سود و قیمت فروش و مبلغ فروش كل هر كالا با استفاده از آدرس دهي مطلق
 | الف - فروش = سود + خريد |  |  | ب- مبلغ كل = تعداد × فروش |  |  |
 |  |  |  | 25% |  |  |
 | رديف | كالا | خريد | سود | فروش | تعداد | مبلغ كل
 | 1 | كيف كوچك | 1200 |  |  | 10 |
 | 2 | كيف بزرگ | 1500 |  |  | 11 |
 | 3 | كفش ورزشي | 850 |  |  | 5 |
 | 4 | توپ | 120 |  |  | 0 |
 | 5 | اسكيت | 4500 |  |  | 7 |

۲- جدول فوق را با استفاده از آدرس دهی مطلق حل کنید : ) یعنی ۲۵ ٪ را بالای ستون فروش ثابت نگه داشته و همه محاسبات با سلول فوق انجام شود .

نوشته شده در سه شنبه بیستم دی 1384ساعت 12:34 توسط علی توضیح |
آدرس دهی سلول ها در فرمول نویسی

14-انواع آدرسها

1-آدرس نسبي :

اين آدرس همان آدرس معمولي در اكسل مي باشد كه با انجام عمليات Copyو Pasteو Autofillآدرس درون فرمول ها تغيير كرده وبه نسبت مكان مورد نظر تغير شكل مي دهد

مثال: اگر در سلول A5 فرمول روبرو نوشته شود و سپس آنرا به سلول A6 کپی کنيم ,

=G1*5

نتيجه چنين خواهد شد

=G2*5

ويا اگر اين فرمول را كپي كرده وبه 4خانه پايين ترببريم و Paste را کليک كنيم فرمول به شكل زير تغيير ماهيت ميدهد: =G5*5

2- آدرسهاي مطلق :

براي جلوگيري از تغييرات در فرمولها از نوع دوم آدرس استفاده ميكنيم اين آدرسها آدرسهاي مطلق ناميده ميشوند ودليل آن اين است كه با تغييردر كاربرگ وسلولها‏ آدرسها‏ي مطلق تغيير نمي‏يابد جهت ايجاد يك آدرس مطلق از علامت $ (دلار )استفاده ميكنيم كافي است كه پشت نام ستون وشماره سطر علائم $بگذاريم .

مثال: =$F$2+A5

اگر آدرس فوق را در چهار سلول پايين‏تر كپي كنيم به شكل زير تغيير مي كند :

=$F$2+A9

3- آدرسهای تركيبي :

هرگاه كاربر بخواهد سطريا ستون را ثابت نگه دارد از آدرسهاي مخلوط يا تركيبي استفاده مينمايد براي ايجاد يك آدرس تركيبي يا مخلوط باز از علامت $استفاده ميكنيم براي ثابت نگه‏داشتن ستون علامت $رادر پشت حرف ستون قرار ميدهيم وبراي ثابت نگه‏داشتن سطر علامت$ را در پشت شماره سطر

مثال: =$H2 به مفهوم ثابت بودن ستون Hاست با قابليت تغيير رديفها

و=H$2 به معناي قابليت تغيير ستونها وثابت بودن شماره سطر 2 است

تمرين: يك جدول ضرب 10×10 را با استفاده از آدرس دهی ترکيبی بسازيد :

نوشته شده در سه شنبه بیستم دی 1384ساعت 12:10 توسط علی توضیح |
فرمول نویسی در اکسل

13-محاسبات در اكسل

الف : فرمولها ب : توابع

الف: فرمول ها :براي انجام محاسبات ساده در اكسل از فرمولها استفاده ميكنيم هر فرمول از قسمتهاي زير تشكيل شده است

1- علامت مساوي

2- متغيرها

3- عملگرهاي رياضي

=3+2

=(-4)^8 * 19 – 13.23

=77.02 / 14.9

انواع عملگرهای رياضی

+ : جمع - : تفريق

/ : تقسيم * : ضرب

^ : توان % : درصد

& ( به هم پيوستن دو کلمه يا دو رقم )

مثال: عمليات سمت چپ در سلول نوشته شده و حاصل پس از فشردن کليد Enter مشاهده می شود .

حاصل | عمليات
3 | =1+2
-1 | =1-2
5 | =10/2
10 | =5*2
8 | =2^3 عدد دو به توان عدد سه
1 | =5%*20 پنج درصد عدد 20
ali hosein | =”ali”&”hosein”

متغيرها ميتواند آدرس نيز باشند .

مثال1: اگر در سلول A1 عدد 10 و در سلول A2عدد 5 را نوشته شده باشند و در سلول A3 معادله زير را بنويسيم =A1+A2 جواب 15 در A3 نمايان خواهد شد .

مثال2 :در جدول فوق براي انجام محاسبات جمع ومعدل گيري بايد در ستونها‏ي مورد نظر فرمولهاي صحيح را ياداشت کرد.

لازم به ذکر است که فقط سلول اول فرمول نویسی شده و با استفاده از Autofill بقیه سلول ها پر می شوند.

نوشته شده در سه شنبه بیستم دی 1384ساعت 12:0 توسط علی توضیح |
فیلتر سازی لیست ها

12-فيلتر سازي ليست ها :

جهت فيلتر سازي ليست ها ابتدا سر ستونهاي ليست را انتخاب كرده سپس مسير

Data | Filters | Autofilter را انتخاب كرده ,علائم فيلتر در سر ستون ها نمايش داده مي شوند .

براي فيلتر كردن يك داده در يک فيلد, فيلتر ستون مورد نظر را باز كرده وداده مورد نظر را از ليست انتخاب می کنيم . ليست, تمامي رديف ها ( رکورد ها ) را به جز رديف مورد نظر پنهان مي كند .براي خنثي سازي فيلتر, فيلدي كه مورد عمليات فيلتر سازي قرار گرفته را (فلش آبي رنگ ) باز كرده گزينه All را انتخاب مي كنيم .

فيلتر سازي پيشرفته :

الف- گزينه Custom : براي انجام عمليات فيلتر سازي همراه با شرط از گزينه Custom استفاده مي كنيم .

اين گزينه دارای شرط های زير است :

شرط ها :

مساوي با | Equals
نا مساوي با | Does not equal
بزرگتر | is greater than
بزرگتر يا مساوي | is greater than or equal to
كوچكتر | is less than
كوچكتر يا مساوي | is less than or equal to
شروع شود با | begins with
شروع نشود با | does not begin with
تمام شود با | ends with
تمام نشود با | does not end with
شامل شود | contains
شامل نشود | does not contain

با استفاده از شرطهاي فوق كار‏بر قادر است در هر محيط محاسباتي ومقايسه‏اي فيلتر سازي پيشرفته را انجام دهد .

مثال : اگر شرط زير را بخواهيم با استفاده از فيلتر بسازيم :

7 <= x < ۲۶

is greater than or equal to 7

And

is less than 26

مثال 2: x > 15 يا x < 8 را با فيلترها مشخص کنيد .

is less than 8

or

is greater than 15

ب- Top 10 : از اين گزينه در فيلتر سازي ميتوان براي يافتن درصد خاص يا تعدادي از دادهاي درون سلولها را كه در بالا ويا در پايين ليست قرار دارند استفاده کرد .

نوشته شده در سه شنبه بیستم دی 1384ساعت 11:7 توسط علی توضیح |
روش های تحلیل داده

بخش دوم

آشنايي با روش هاي

تحليل داده در

EXCEL

ليست List

در شروع کار با اکسل , ساختن يک پايگاه داده برای تبديل آنها به اطلاعات و انجام عمليات تجزيه و تحليل مهمترين کار به نظر می رسد . ليست: مجموعه ای از داده هاست که به طور منطقی در کنار يکديگر قرار گرفته اند .

11-مرتب سازي ليستها :

جهت مرتب سازي يك ليست برحسب يك فيلد ,ابتدا يكي از سلول ها ي فيلد مورد نظر را انتخاب كرده سپس ازكليدهاي مرتب سازي استفاده مي كنيم:

Sort Descending : مرتب سازي نزولی يعني از بزرگ به کوچک .

Sort Ascending : مرتب سازي صعودی يعنی از كوچك به بزرگ.

لازم به ذكر است كه اكسل تمامي رکورد های ليست را مرتب مي كند. در حقيقت نرم افزار كليه ركوردها رابر اساس فيلد انتخاب شده مرتب مي كند .

توجه : اگر در يك ليست يك ستون را انتخاب كرده وسپس مرتب سازي را انجام دهيم , داده ها تنها درون ستون مرتب مي شود اما ليست مرتب نمي گردد .

روشهاي مرتب سازي پيشرفته:

براي استفاده از روشهاي پيچيده‏تر در مرتب سازي, يا همزمان مرتب كردن چند فيلد متفاوت ابتدا يك سلول از ليست را انتخاب كرده سپس از منو Data | Sort پنجره اي باز شده وبه كاربر اجازه ميدهد تا 3 فيلد را همزمان مرتب سازی نمايد . مرتب سازي همزمان ويژه فيلدهايي است كه داده تكراري دارند .

مثال : جدول فوق را ابتدا بر حسب فيلد نام خانوادگی و سپس بر اساس فيلد نام مرتب نماييد .

Header row: (پيش فرض) هنگام مرتب سازي سرستون ها ی ليست را جزء مرتب سازي حساب نمي كند.

No Header row: هنگام مرتب سازي سرستون ها را نيز در عمليات مرتب سازي شركت مي دهد.(نامطلوب).

مرتب سازي به صورت دلخواه :

در ليست ها براي مرتب سازي فيلدهاي ويژه مثلاٌ ايام هفته يا ماه ها يا ليستي كه به صورت غير معمول بخواهيم مرتب كنيم ابتدا يكي از سلول هاي آن فيلد را انتخاب كرده سپس از منو Data | sort | Option پنجره فعال شده وكاربر قادر است نوع مرتب سازي را انتخاب كند .

Case sensitive: حساسيت به حروف كوچك و بزرگ مثال: ALI, ali

Sort top to bottom: از بالا به پايين مرتب ميكند مرتب سازي به صورت ستون

Sort left to right : مرتب سازي به صورت سطري

نوشته شده در یکشنبه هجدهم دی 1384ساعت 14:17 توسط علی توضیح |
یافتن سلول هايي با قالب بندی خاص
یافتن سلول هايي با فرمت تعریف شده

برای یافتن یک کلمه یا یک سلول خاص با قالب بندی تعریف شده ، کافی است از ترکیب کلید های

Ctrl + F )find) استفاده کنيم . این ابزار قادر است داده ها و قالببندی ها را یافته و به کاربر نمایش

دهد .

مثال :در جدول زیر سلول های رنگی را بیابید :

نوشته شده در یکشنبه هجدهم دی 1384ساعت 11:2 توسط علی توضیح |
یافتن سلول های خاص

10-يافتن سلولهاي خاص

براي يافتن سلولهاي خاص اكسل با شرايط خاص مثلاٌ سلول هايي كه با توضيحات مي باشند يا محتويات سلول های آنها مقادير خاصی می باشد ، از منوی Go to | Special Edit | را انتخاب می کنيم .

برخی گزينه هاي اين پنجره عبارتند از :

Comment: سلولهايي را كه داراي توضيحات مي باشد انتخاب مي كند.

Constants: سلولهاي غير خالي را در محدوده جاری انتخاب مي كند که محتويات آنهاشامل:

  1. numbers : اعداد باشد.
  2. text : متن باشد .
  3. logical : داده های منطقی باشد .
  4. error : شامل خطا باشد .

formula : سلولهاي غير خالي را در محدوده جاری انتخاب مي كند که فرمول آنهاشاملموارد فوق گردد .

Blanks: سلولهاي خالي محدوده جاری را انتخاب مي كند.

: Current Region کل سلول های محدوده جاری را انتخاب می کند.

Current array: محدوده سلول هاي آرايه ای را انتخاب مي كند.

Objects: اشياء و اشكال را برروي صفحه انتخاب ميكند.

Row differences: تمام سلول هايي را كه محتويات آنها با سلول مقايسه متفاوت مي باشد را در يک رديف, انتخاب مي كند.

Column differences: تمام سلول هايي را كه محتويات آنها با سلول مقايسه متفاوت مي باشد را در يک ستون, انتخاب مي كند.

precedent: تمام سلول هايي را كه در فرمول اين سلول بکار رفته اند رامشخص می کند .

dependent: فرمول هايي را که اين سلول در آنها بکار رفته است را مشخص می کند ..

Last cell: آخرين سلول را در محدوده جاری انتخاب می کند.

Visible cells only : فقط سلولهاي قابل مشاهده را انتخاب ميكند (تغيرات شامل سلولهاي پنهان نمي شود) .

Data Validation: معتبر سازی با شرط:

All: تمام سلولهايي كه داراي قالبندي شرطي باشند انتخاب مي كند.

Same: تمام سلول هايي كه قالبندي آنها شبيه قالبندي سلول ها انتخاب شده است را انتخاب مي كند.

نوشته شده در یکشنبه هجدهم دی 1384ساعت 9:55 توسط علی توضیح |
ایجاد یک الگو

-ايجاد يك قالبندي دائمي ( الگو ) : Style

براي تعريف كردن يك قالبندي يا فرمت دايمی ، ابتدا سلول مورد نظر را انتخاب کرده سپس از منوی Format گزينه Style را انتخاب كرده، ابتدا يك نام جديد را بجای کلمه normal مي نويسيم سپس كليد Modify را فشار مي دهيم . براي قالبندي مورد نظر فونت، رنگها وكادرهاي دلخواه را انتخاب مي كنيم .سپس كليد Add را مي فشاريم درپايان ok را کليک می کنيم تا الگو ذخيره گردد . اين الگو در تمام کاربرگ اکسل قابل استفاده است . کافی است سلول های مورد نظر را انتخاب کرده و سپس از مسير ذکر شده ، الگوی دلخواه را انتخاب می کنيم .

نوشته شده در یکشنبه هجدهم دی 1384ساعت 9:13 توسط علی توضیح |
ساخت نوار ابزار جدید

ابزار Format painter

جهت كپي كردن وانتقال يك قالبندي به سلول مورد نظر از ابزار Format painter استفاده مي كنيم ( ابزاری شبيه برس که فقط قالب بندی را انتقال می دهد ) .

8-توسعه نوار ابزار

براي گسترش نوار ابزار اكسل كافي است در قسمت خالي نوار ابزار يا نوار منو راست كليك كرده گزينه Customize را انتخاب كرده واز برگه دان Commandsرا چپ كليك كنيد , ابزار دلخواه را انتخاب كرده و با عمل drag كردن آن را به نوار ابزار دلخواه می کشانيم پنجره Close را بسته وكار بر قادر به استفاده از ابزار جديد ميشود .

ساخت نوار ابزار دلخواه

ابتدا برروي قسمت خالي نوار منو راست كليك كرده گزينه Customize را انتخاب كرده در برگه دان Toollbarكليد New را فشرده , اكسل از كار‎‏‏بر يك نام را ميخواهد كه نوار ابزار با آن نام نوشته شود سپس به برگدان Commands رفته ابزار مورد نيازرا به وسيله drag (کشيدن )كردن به نوار ابزار جديد ضميمه کنيد .

نوشته شده در یکشنبه هجدهم دی 1384ساعت 8:57 توسط علی توضیح |
قالب بندی شرطی

قالب بندي شرطي يا Conditional Formatting

هر گاه كاربر بخواهد در مجموعه اي از سلولها يا حتي يك سلول قالب بندي با يك شرط خاص ايجاد كند از گزينه Conditional Formatting استفاده ميكند .

مثال: اگر بخواهيم در يك ستون اعدادي كه بين 9 و صفر قرار ميگيرند به رنگ قرمز نمايش دهد ابتداء ستون مورد نظر را انتخاب كرده سپس قالب بندی شرطی را کليک کرده , پنجره زير فعال مي شود .

شرطها

بين |  | between
بين اين دو عدد نباشد |  | not between
مساوي با |  | equal to
نامساوي با |  | grater than
بزرگتر با |  | less than
 | بزرگتر و مساوي | grater than or equal to
 | كوچكتر و مساوي | less than or equal to

پس از انتخاب شرط مورد نظر اعداد مربوط به شرط را در جعبه هاي روبروي شرط وارد ميكنيم سپس با استفاده از كليد Format قالب بندي مورد نظر را معمولا رنگ انتخاب كرده سپس كليد Ok را مي فشاريم. براي ايجاد شرط دوم كليد Add را مي فشاريم اكسل تا 3 شرط را به صورت قالبندي شرطي مي پذيرد .

براي حذف شرط هاي ايجاد شده از كليد Delete استفاده ميكنيم در اين حالت پنجره اي باز شده از کاربر شماره شرط را ميخواهد سپس ok را مي فشاريم تا شرط مورد نظر حذف شود .

ابزار Format painter

جهت كپي كردن وانتقال يك قالبندي به سلول مورد نظر از نوار ابزار Format painter استفاده ميكنيم .

نوشته شده در دوشنبه دوازدهم دی 1384ساعت 14:18 توسط علی توضیح |
قالب بندی خودکار

پنهان سازي سطر ياستون

براي پنهان سازي يك ستون( يا سطر) ، برروي سرستون مورد نظررفته راست كليك كرده گزينه Hide را انتخاب کرده تا ستون مورد نظر از چشم پنهان شود (ترتيب الفبايي ستون ها به هم مي خورد) .

براي آشكار كردن يك ستون پنهان شده دوستون مجاور را انتخاب كرده برروي آنها راست كليك وگزينه Unhide را انتخاب مي كنيم ستونهاي پنهان شده نمايان ميشوند .

استفاده از قالبندي خودكار (Auto format )

جهت ايجاد يك قالبندي به صورت خودكار برروي ليستي از دادهها يكي از سلولهاي ليست راانتخاب كرده از منو Format |Auto format يكي از جدولها را انتخاب كرده كليد okرامي فشاريم , جدول قالب مورد نظر را پيدا ميكند .

نوشته شده در دوشنبه دوازدهم دی 1384ساعت 13:53 توسط علی توضیح |
ابزار Paste Special و ساختار کاربرگ

ابزار Paste Special

استفاده از Paste special : اگر كاربر بخواهد داده ها را با شرط كپي نمايد از گزينه Paste specialاستفاده مي كند. به طور مثال كاربرقادر است داده هاي كپي شده را به داده هاي جديد اضافه كند يا اگر داده ها به صورت افقي كپي شده باشند آنها را به صورت عمودي كپي نمايد، يا حتي داده ها ر ابا اتصال به مبدا در جاي خود قراردهد . اين گزينه در منوی Edit و يا در راست کليک مشاهده می شود .

برخي از گزينه هاي اين پنجره عبارتند از :

Add: اضافه كردن مقصد به مبدا : Multiply ضرب مقصد در مبدا

Subtract: تفريق مقصد از مبدا Divide: تقسيم مقصد بر مبدا

Transpose: تبديل ازحالت افقي به عمودي يا ازحالت عمودي به افقي

Paste link: با استفاده از اين گزينه مقصد به مبدا وابسته می گردد و هر نوع تغيير در مبدا, مقصد را نيز تغيير می دهد.

7-تغييرساختاركاربرگ

افزودن سطر وستون براي اضافه كردن يك سطر و يك ستون دريك كاربرگ كافي است ستون بعد آن را انتخاب كرده برروي سرستون راست كليك كرده گزينه Insert را کليک کرده , ستون جديد درج ميشود براي سطر نيز با همين روش .

براي حذف يك ستون ويك سطر ستون مورد نظر را انتخاب راست كليك گزينه Delete را انتخاب ميكنيم , ستون مورد نظر حذف ميشود .

نوشته شده در دوشنبه دوازدهم دی 1384ساعت 10:42 توسط علی توضیح |
استفاده از AUTOFILL

ابزار AutoFill

Autofillيا پركننده خود كار : هنگامي كه به پايين يك سلول نزديك ميشويم يک مربع کوچک سياه رنگ ديده می شود که اگر ماوس را به آن نزديک کنيم , اشاره گر ماوس به صورت يك صليب نازك سياه رنگ ملاحظه ميشود , در اين حالت اگر چپ كليك ماوس را پايين نگه داشته وبه سمت اطراف حركت كنيم Autofillفعال گشته , دو نوع عمليات انجام ميدهد

الف- كپي ب- توسعه

در حالت اول داده ها تكرار ميشود و در حالت دوم عمليات توسعه داده ها صورت مي پذيرد .

مثال : اگر در يك سلول عدد 1 نوشته شود وكاربر Autofill آن سلول همراه با كليد Ctrl را فعال ساخته و به سمت پايين حركت كند عمليات توسعه زير صورت مي پذيرد :

در حالتي كه Ctrl پايين فشرده شود , يك علامت + در بالاي Autofillملاحظه ميگردد .

مثال2: اگر دردوسلول پياپي اعداد 1 و 3 نوشته شوند سپس هردوسلول انتخاب شده Autofill آن را پايين نگه داريم وبه سمت پايين حركت كنيم سري زير حاصل ميشود :

از Autofilllمي توان براي كپي روزهاي هفته ،ماههاي سال وتاريخ نيز استفاده كرد.

جهت ايجاد يك ليست خود كار Autofillاز منوی Optiosn | Custom list Tools |را انتخاب كرده , در پنجره خالي سمت راست ليست مورد نظر را تايپ كرده وسپس كليد Add را مي فشاريم , Okرا فشرده از پنجره خارج ميشويم .حال اگر يكي ازاعضاي ليست رادر يك سلول ياداشت كنيم و Autofillرا فعال سازيم به صورت چرخشی اعضاي ديگر تكرار مي شود .

نوشته شده در دوشنبه دوازدهم دی 1384ساعت 9:43 توسط علی توضیح |
روش های نقل و انتقال داده ها

6-نقل و انتقال داده ها در اکسل

روشهاي كپي داده ها در اكسل

به چند روش ميتوان داده ها را درون اكسل كپي كرد :

روش اول ابتدا سلولهاي مبداء را انتخاب كرده سپس با استفاده از راست كليك گزينه Copy را نتخاب كرده به مقصد مي رويم و در انتها گزينه Paste را انتخاب ميكنيم .

روش دوم استفاد ه ازنوار منوی Edit : ابتداء سلولهاي مبدا را انتخاب كرده از منوی Edit ,گزينه Copy را برمی گزينيم و در آخر به مقصد رفته گزينه Paste را می فشاريم .

روش سوم استفاد ه از نوار ابزار : سلولهاي مبداء را انتخاب کرده با استفاد ه از كليد كپي آنها را به حافظه مي سپاريم و سپس به مقصد رفته كليد Pasteرا فشار مي دهيم .

روش چهارم استفاد ه از چپ كليك مآوس يا Drag: ابتداء سلولهاي مبدا را انتخاب كرده , با ماوس به حاشيه آن نزديك شده تا يك فلاش سفيد رنگ به همراه يك صليب آشكار گردد . در اين حالت كليد Ctrl و چپ كليك ماوس ر ا پايين نگه داشته و به مقصد حركت ميكنيم , سپس چپ كليك موس و Ctrlرا رها مي كنيم .تمام مراحل فوق جهت انجام عمليات انتقال نيز صادق است , تنها در اين حالت كليد Ctrl لازم نيست .

۱- انتخاب پیوسته (ماوس) : حرکت با چپ کلیک

۲- انتخاب پیوسته ( صفحه کلید) : SHIFT + کلید های جهتی

۳- انتخاب گسسته (ماوس) : چپ کلیک + کلید کنترل

۴- اتخاب گسسته ( صفحه کلید) : SHIFT + F8

براي انتخاب يك ستون يا يك سطر كافي است برروي سر ستون يا سر سطر , چپ كليك كرده و براي انتخاب يك كاربرگ (Sheet ) برروي سلول كاربرگ [image] چپ كليك ميكنيم (A Ctrl +) .

نوشته شده در دوشنبه دوازدهم دی 1384ساعت 8:49 توسط علی توضیح |
فایل ها در اکسل

5-ساختار فايل ها در اكسل

در اكسل نيز مانند هر برنامه اي تحت ويندوز كليدهايي جهت ذخيره سازي فايلها وباز كردن فايلهاي موجود است . براي ذخيره فايل موجود ,كافي است از كليد Save استفاده کنيد که براي اولين بار از كاربر نام مورد نظر را خواسته وفايل را با نام داده شده ذخيره ميكند و براي تغيير نام ومكان فايل از گزينه Save as استفاده ميكنيم .

رمزگذاری فايل

براي ذخيره يك فايل با رمز كافي است كه فايل مورد نظر را فعال كرده سپس از

File | Save As.. | tools | General options چهارگزينه نمايش داده ميشود .

1- Always Backup: ايجاد يك فايل پشتيبان از فايل موجود .

2-Open Password to: براي باز كردن يك فايل Passwordمورد نظر را وارد كنيد .

3- Password To Modify: براي ايجاد تغيير برروی فايل جاری از كاربر رمز مي خواهد .

4-Read Only Recommended : در ابتداي بازکردن فايل از كاربر مي پرسد كه آن را به صورت فقط خواندني باز نمايد , در صورت پاسخ مثبت , كاربر اطلاعات جديد را وارد كرده اما ذخيره با نام قبلي ميسر نيست .

برخی اصطلاحات مربوط به ذخيره اطلاعات در اکسل

فيلد : در اکسل معمولاستون ها را فيلد می نامند .

رکورد : در اکسل سطر ها را رکورد می نامند .

کاربرگ : يا همان SHEET مجموعه ای از رکورد هاست.

فايل : يا همان WORKBOOK مجموعه از کاربرگ هاست .

نوشته شده در دوشنبه دوازدهم دی 1384ساعت 8:30 توسط علی توضیح |
ویرایش داده ها

-ويرايش داده ها

براي حذف يا ويرايش دادهها در سلول به چهار روش اقدام ميكنيم :

1- سلول مورد نظر را انتخاب كرده كليد Deleteرا فشار مي دهيم تا داده فعلي حذف شده و سپس داده جديد را تايپ ميكنيم .

2- برروي سلول مورد نظر رفته , داده جديد را تايپ مي كنيم .

3- با استفاده از كليد F2, مكان نما در سلول فعال شده وكاربرقادر به ويرايش داده ها در سلول ميباشد .

4- با استفاد ه از كليك ماوس بروي سلول مورد نظر رفته عمليات دوبار كليك را انجام داده مكان نما فعال ميگردد وشبيه عمليات کليد F2 ,كاربر قادر به ويرايش داده ها در سلول ميباشد .

حذف قالب بندي سلول

به طور كلي براي حذف داده ها در يك سلول از كليد Delete استفاده مي كنيم , اما اين كليد قادر به حذف قالبندي سلول نمي باشد (منظور از قالببندي : رنگها , قالبندي عمومي وعددي است)براي حذف قالبندي ها, سلول مورد نظر را انتخاب كرده , سپس از منوی Edit گزينه Clear را انتخاب می کنيم که گزينه های آن به شرح زير عمليات پاکسازی را انجام می دهند :

ALL: : اين گزينه باعث حذف محتويات سلول وهمچنين قالب بندي آن ميگر دد.

Formats : قالب بندي حذف شده و داده برجا مي ماند .

Contents: حذف داده تغيير قالب بندي سلول.

Comments: حذف توضيحات سلول .

نوشته شده در یکشنبه یازدهم دی 1384ساعت 14:41 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


 Title Required
RSS Channel: آموزش جامع نرم افزار اکسل 2007 EXCEL
آموزش محيط و توانايي هاي صفحه گسترده اکسل 2007 توابع ، نمودارها، روش هاي تحليل داده - اکسل پيشرفته
Generator: | blogfa.com
Docs: | http://blogs.law.harvard.edu/tech/rss
معرفي امکانات جديد اکسل 2012
گروه فعال سايت فرساران بازهم مطلبي جديد را درباره اکسل ???? ارائه نموده که خواندن آنرا به همه توصيه مي کنم.

اين مطلب را مي توانيد از لينک زير مشاهده کنيد.

http://farsaran.ir/Excel%202012%20News

با عضويت در اين سايت غني مطالب جديد را به صورت مرتب با ايميل دريافت کنيد.

باز هم از زحمات گروه فعال فرساران و جناب آقاي مهندس فرشيد ميداني تشکر مي کنيم .

www.farsaran.ir

http://commenting.blogfa.com/?blogid=excel&postid=195
ساخت يک گزارش پويا در اکسل 2010
بيشتر اوقات کاربران اکسل براي گزارش گيري از مجموعه ي عظيمي از داده ها در اکسل به مشکل برخورد مي کنند. ابزار جداول محوري يا pivottables در اکسل اين توانايي را در آنها ايجاد مي کند.اين ابزار به کاربران کمک مي کند تا بر اساس فيلد ها گزارش تهيه کنند .

مثال- فرض کنيد جدول شماره يک مجموعه اي از داده هاي مربوط به افراد يک کارگاه است که مرتب در حال دريافت و پرداخت ميباشند . حال اگر بخواهيم گزارشي از تمام دريافتي ها ي همه کارکنان بيابيم به روش زير اقدام مي کنيم :

حل : ابتدا يک سلول از جدول داه را انتخاب کرده ، از منوي insert گزينه pivot tableرا انتخاب مي کنيم .

با انتخاب محدوده جدول داده يا حتي بيشتر از آن ، اکسل متوجه فيلد ها و داده ها مي گردد.

فيلد ها و منوي pivottable tools پديدار مي گردد و کاربر قادر است فيلدها را انتخاب کرده و عمليات محاسباتي خود را تغيير دهد.

هر جدول محوري داراي 4 بخش است .

1- ستون ها : که داده ها به صورت ستوني در جدول نمايش داده مي شوند.

2- report : که اصلي ترين فيلد مجموعه محسوب مي گردد و ساير فيلد ها زير مجموعه ي آن محسوب مي گردند.

3- سيگما : يا بخش محاسباتي جدول

4- رديف ها : که داده ها به صورت سطري در جدول نمايش داده مي شوند.

کافي است فيلد هاي مورد نظر را گرفته و به يکي از اين چهار بخش بکشيم يا آنها را تيک بزنيم.

شکل جدول پديدار مي گردد و شما قادريد از گزارش ساخته شده اطلاعات بگيريد.

برخي اوقات به مشکل برخورد مي کنيم . جدول محوري تفاوتي بين يک فيلد محاسباتي را با غير آن به درستي درک نمي کند . در مثال زير فيلد اتخاب شده سال به بخش محاسباتي منتقل شده است در حاليکه ما قصد جمع و ضرب آنرا نداريم و مي خواهيم دريافتي افراد را طي سال هاي مختلف بررسي کنيم . بنابراين بايد آنرا به بخش سطر ها کشيد تا در کنار اسامي اطلاعات را شفافتر منتقل کنند.

خروجي جدول بيانگر دريافتي هر فرد طي سال هاي مورد نظر است .

لينک دانلود جدول و تمرين هاي بيشتر را در بخش تمرين جداول محوري در روز شانزدهم فروردين ?? قرار داده ام. موفق باشيد

http://commenting.blogfa.com/?blogid=excel&postid=194
توضيح بيشتر درباره تمرين قبل
در تمرين انبار از سه تابع match index , dsum استفاده شده است. همانطور که قبلا توضيح دادم دو تابع match , index برعکس يکديگرند.

تايع index شماره رديف داده را در يک مجموعه دريافت کرده خود داده را نمايش مي دهد در حاليکه تابع match داده را دريافت کرده شماره رديف آن در مجموعه را نمايش مي دهد.

=index( شماره رديف داده , مجموعه ) ====> data

=match ( data , مجموعه , type ) ======> data row

در اين تمرين کافي است ابتدا با استفاده از تابع match شماره اولين رديفي را که داده در آن نمايش داده شده را بيابيد . با اين کار شما قادر خواهيد بود نام کالا را يافته و آنرا در سلولي ديگر نمايش دهيد.

تابع dsum هم عمليات جمع را با شرط انجام مي دهد . اين تابع سه پارامتر دارد . ابتدا نشاني کل جدول را از کاربر گرفته ، شماره فيلدي را که قرار است عمليات جمع روي آن انجام گيرد را نيز دريافت مي کند آنگاه با دريافت آدرس محدوده شرط ، عمليات جمع را انجام مي دهد . نکته مهم آنست که آدرس محدوده ي شرط بايد شامل عناويني باشد که در آدرس کل جدول نيز وجود دارند. مثلا اگر شما مي خواهيد به دنبال جمع تعداد کالاي خريداري شده بگرديد ( فيلد شماره 6) بايد محدوده شرط را طوري انتخاب کنيد که کد کالا و شماره ي آن در محدوده ي شرط باشند ( m1 :m2 )

البته در تابع match پارامتر آخر داراي سه مقدار 0 و 1 و -1 است که بسته به نوع جستجو از آنها استفاده مي کنيم :

1 براي جستجوي مقاديري کوچکتر از مقدار داده شده

0 براي جستجوي دقيق مقادير داده شده

-1 براي جستجوي مقادير بزرگتر از مقدار داده شده

http://commenting.blogfa.com/?blogid=excel&postid=193
تمرين - يافتن داده ها روش استفاده از توابع match , dsum
در بسياري از مواقع کاربران براي يافتن يک کالا يا شخص با استفاده از کد با مشکل روبرو مي شوند و مي خواهند بدون استفاده از vba نيز بر مشکل برطرف شود.

براي اينکار مي توان از تابع match براي يافتن اولين رديف از داده استفاده کرد و سپس نام داده را با استفاده از تابع index شناخت , بالاخره براي يافتن جمع ها از توابعي مانند dsum يا خانواده sumifs استفاده کرد. براي اين منظور تمرين طراحي و با پاسخ در اختيار شما دوستان قرار مي دهم تا بيشتر تمرين کنيد.

تمرين - در جدول انبار ساختاري طراحي کنيد که با نوشتن کد هر کالا شماره اولين رديف ،نام کالا و سپس جمع خريداري شده و فروخته شده و مانده ي هر کالا را نمايش دهد.

دانلود فايل تمرين

http://commenting.blogfa.com/?blogid=excel&postid=192
طراحي جدول داده
توجه کاربران محترم اکسل را براي طراحي يک جدول به نکات زير جلب مي کنم:

?- از گسستگي داده ها بپرهيزيد . ( سطر يا ستون کاملا خالي در جدول نداشته باشيد )

?- از انجام عمليات merge بپرهيزيد ( اينکار مانع از مرتب سازي و فيلترينگ صحيح داده ها در جدول مي گردد)

3- تمام فيلد هاي مربوط به يک موضوع را در يک جدول قرار دهيد تا قادر به دريافت اطلاعات صحيح تر باشيد ( فيلدها همان ستون هاي جدولند )

4- فيلد هاي جدول حتما بايد داراي عنوان باشند (هدر )

5- حتما سعي کنيد از سمت ستون A جدول را طراحي کنيد.

?- از ورود داده هاي نامعتبر جلوگيري کنيد ( validation).

7- از تخريب سلول هايي که نبايد دستکاري شوند با protection جلوگيري کنيد.

8- سعي کنيد در بالاي عناوين فيلدها محاسبات و سرجمع آنهارا نشان دهيد( subtotal ) نه در پايين جدول

9- هر چه بيشتر فيلد در جدول شما باشد گزارشات شما دقيقتر و بنابراين اطلاعات شما صحيحتر خواهد بود (pivottable).

??-منطق ورود داده را فراموش نکنيد ( جايي که قرار است نام وارد شود فاميل وارد نکنيم )

http://commenting.blogfa.com/?blogid=excel&postid=191
روز معلم مبارک
تقديم به همه معلمان مربيان آموزگاران اساتيد و...

روزگاري است که سوداي بتان دين من است غم اينکار نشاط دل غمگين من است

ديدن روي تو را ديده ي جان بين بايد وين کجا مرتبه چشم جهان بين من است

يار من باش که زيب فلک و زينت دهر از مه روي تو و اشک چو پروين من است

تا مرا عشق تو تعليم سخن گفتن داد خلق را ورد زبان مدحت و تحسين من است

دولت فقر خدايا به من ارزاني دار کاين کرامت سبب حشمت و تمکين من است

يا رب آن کعبه مقصود تماشاگه کيست ؟ که مغيلان طريقش گل و نسرين من است

واعظ شحنه شناس اين عظمت گو مفروش زانکه منزلگه سلطان دل مسکين من است

حافظ از حشمت پرويز دگر قصه مخوان که لبش جرعه کش خسرو و شيرين من است

http://commenting.blogfa.com/?blogid=excel&postid=190
تمرين مديريت داده -اکسل پيشرفته
تمرين - فرض کنيد يک ليست از شماره هاي دانشجويي يک کلاس داريم و مي خواهيم نمره ي هر دانشجو را در جلوي شماره اش وارد کنيم .فرمي لازم داريم تا با تايپ شماره دانشجويي آنرا در فهرست يافته و پس از ورود نمره آنرا در مقابلش ثبت کرده َ شماره دانشجويي بعدي را از کاربر بگيرد.

پاسخ: ابتدا يک سلول از جدول انتخاب شود.سپس ابزار form را از بخش ابزار هاي اکسل :

QAT\MORE COMMANDS \ ALL COMMANDS\FORM..

انتخاب مي کنيم. حال با انتخاب اين ابزار کاربر قادر است بسياري از قابليت هاي يک فرم ساده در ورود و نمايش داده ها را استفاده کند.

با فشردن کليد CRITERIA کاربر مي تواند شرط مورد نظر را وارد کند . مثلا شماره دانشجويي. حال با فشردن کليد اينتر رکورد مورد نظر يافت شده مي توانيد داده متناظر آنرا وارد نماييد. اگر در حالت شرط ( CRITERIA ) باشيد بجاي اين کلمه گزينه FORM فعال است.

با کليد NEW مي توانيد رکورد جديد وارد کنيد و با کليد هاي NEXT , PREV هم به رکوردهاي قبل و بعد وارد ميشويد.

http://commenting.blogfa.com/?blogid=excel&postid=189
تمرين جداول محوري - pivottable
در فايل زير که شامل سه کاربرگ است ، تمرين هاي زير را حل کنيد:

1- در جدول يک مطلوبست جمع دريافتي هر نفر؟

2- ميانگين دريافتي هر نفر از هر بانک ؟

3- بيشترين دريافتي هر نفر در هر سال ؟

4- کمترين مقداري که هر بانک به عنوان دريافتي ، در هر سال به هر فرد داده است ؟

5- در جدول شماره دو ، مقدار خريداري شده و فروخته شده هر کالا را نمايش داده و سپس مانده ي هر کدام را نمايش دهيد.

6- در جدول شماره سه هر فروشگاه در هر شهر از هر کالا چه مبلغي ( جمع کل ) فروش داشته است.

7- نمودار فروش پاکن را در تمام فروشگاه ها مقايسه کنيد.

دانلود تمرين

موفق باشيد

http://commenting.blogfa.com/?blogid=excel&postid=188
توابع مالي - بخش دوم

تابع RATE

اين تابع درصد نرخ سود سالانه را محاسبه مي کند.

=RATE( تعداد اقساط ; مبلغ هر قسط ; مبلغ وام )

مثال 3 : فرض کنيد وامي به مبلغ سي ميليون ريال به مدت هفت سال بايد بازپرداخت شود اگر مبلغ هر قسط

ساليانه ي آن 5,184,594.55 ريال باشد نرخ سود ساليانه ي آن چقدر است ؟

=RATE( 7 ; 5,184,594.55 ; 30000000) = 5%

تابع NPER

اين تابع تعداد اقساط يک وام را مشخص مي کند.

=NPER( سالانه نرخ سود ; مبلغ هر قسط ; مبلغ وام )

مثال 4 : فرض کنيد وامي به مبلغ سي ميليون ريال با نرخ سود سالانه پنج درصد و با مبلغ هر قسط 5,184,594.55 ريال را از بانک دريافت کرده ايم . چند قسط ساليانه بايد بپردازيم؟

=NPER( 5% ; 5,184,594.55 ; 30000000) = 7

http://commenting.blogfa.com/?blogid=excel&postid=187
برخي توابع مالي در اکسل - اکسل 2007 پيشرفته

برخي توابع مالي در اکسل

برخي از توابع مالي استفاده هاي زيادي در اکسل دارند ، که به طور خلاصه به شرح 4 مورد از آنها خواهيم پرداخت:

تابع PMT

اين تابع براي محاسبه مبلغ اقساط ساليانه يک وام با بهره ثابت بکار مي رود.

=PMT( نرخ بهره سالانه; تعداد اقساط سالانه ; مبلغ کل وام )

در مورد توابع مالي اين نکته ضروري است که اگر تمام مواردمثبت باشد اکسل به صورت خودکار جواب را منفي نمايش مي دهد ( شما را بدهکار مي کند ) براي جلوگيري از اين کار ، معمولا مبلغ وام را منفي نمايش مي دهند تا ساير جواب ها مثبت نشان داده شود.

اين نکته هم ضروري است که بدانيم ساختار ها بايد همگون باشند يعني اگر کاربر بهره سالانه استفاده مي کند مبلغ قسط هم سالانه نمايش داده مي شود ، تعداد اقساط هم همان تعداد سال هاي پرداخت وام تلقي مي گردد.

مثال 1 : فرض کنيد وامي را به مبلغ سي ميليون ريال ( سه ميليون تومان ) با بهره سالانه پنج درصد طي هفت سال مي خواهيم بازپس دهيم ، آيا مي توان مبلغ اقساط سالانه آنرا محاسبه کرد؟

=PMT( 5% ; 7 ; 30000000) = ريال 5,184,594.55

در حقيقت شما بايد سالانه مبلغ ريال 5,184,594.55 را بابت اقساط بپردازيد .

نرخ بهره سالانه | تعداد اقساط ( سال ) | مبلغ وام | مبلغ هر قسط ( سالانه ) | مبلغ هر قسط (ماهانه ) | جمع کل اقساط | جمع کل سود پرداختي
5% | 7 | 30,000,000- | ريال 5,184,594.55 | ريال 432,049.55 | ريال 36,292,161.87 | ريال 6,292,161.87

تابع IPMT

اين تابع براي محاسبه مبلغ سود هر قسط ساليانه يک وام با بهره ثابت بکار مي رود.

=IPMT( نرخ بهره سالانه;شماره قسط ; تعداد اقساط سالانه ; مبلغ کل وام )

اين تابع که شبيه تابع PMT است ، مبلغ سود هر قسط را محاسبه مي کند.

مثال 2: در مثال شماره يک مبلغ سود هر قسط را محاسبه کنيد، مثلا براي قسط سال اول :

=IPMT(5% ; 1 ; 7 ; 30000000)

نرخ بهره سالانه | شماره قسط | تعداد اقساط ( سال ) | مبلغ وام | مبلغ سود ه قسط
5% | 1 | 7 | 30,000,000- | 1,500,000.00
5% | 2 | 7 | 30,000,000- | 1,315,770.27
5% | 3 | 7 | 30,000,000- | 1,122,329.06
5% | 4 | 7 | 30,000,000- | 919,215.78
5% | 5 | 7 | 30,000,000- | 705,946.85
5% | 6 | 7 | 30,000,000- | 482,014.46
5% | 7 | 7 | 30,000,000- | 246,885.45

نرخ بهره سالانه | شماره قسط | تعداد اقساط ( سال ) | مبلغ وام | مبلغ سود هر قسط
5% | 1 | 7 | 30,000,000- | ريال 1,500,000.00
5% | 2 | 7 | 30,000,000- | ريال 1,315,770.27
5% | 3 | 7 | 30,000,000- | ريال 1,122,329.06
5% | 4 | 7 | 30,000,000- | ريال 919,215.78
5% | 5 | 7 | 30,000,000- | ريال 705,946.85
5% | 6 | 7 | 30,000,000- | ريال 482,014.46
5% | 7 | 7 | 30,000,000- | ريال 246,885.45

http://commenting.blogfa.com/?blogid=excel&postid=186


آموزش جامع نرم افزار اکسل 2007 EXCEL - استفاده از توابع SUMIF , COUNTIF

تبليغات X
آموزش جامع نرم افزار اکسل 2007 EXCEL - استفاده از توابع SUMIF , COUNTIF
آموزش جامع نرم افزار اکسل 2007 EXCEL
آموزش محیط و توانایی های صفحه گسترده اکسل 2007 توابع ، نمودارها، روش های تحلیل داده - اکسل پیشرفته
استفاده از توابع SUMIF , COUNTIF
تابع SUMIF

شکل تابع

= SUMIF(محدوده جمع , شرط , محدوده شرط )

این تابع در محدوده شرط به دنبال شرط گشته و سپس سلول های متناظر آنرا در محدوده جمع با هم جمع می کند .

مثال :جمع دریافتی های علی چقدر است ؟

سلول های متناظر علی در قسمت دریافتی

تابع COUNTIF

اما تابع COUNTIF تعداد سلول های شرط را شمارش می کند .

=COUNTIF( شرط , محدوده شرط)

مثال : در جدول فوق تعداد دریافتی های علی چقدر است ؟

نوشته شده در شنبه بیستم اسفند 1384ساعت 14:55 توسط علی توضیح |
درباره وبلاگ
بنام خدا
این وبلاگ آموزشی سعی دارد با ایجاد یک کلاس آموزشی مجازی و تعاملی در حد امکان به نیاز های روزمره کاربران نرم افزار صفحه گسترده اکسل اعم از شناخت محیط ،قالب بندی ها ،ترسیم جداول ، رنگها ، شرطها ، محاسبات ، فرمول نویسی ، استفاده از توابع ، نمودار ها ، چاپ ، تحلیل داده ها توابع آرایه ای فیلتر سازی و جداول محوری و ماکرو نوسی ...
منوی اصلی
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ
نوشته های پیشین
تیر 1390
خرداد 1390
اردیبهشت 1390
فروردین 1390
اسفند 1389
دی 1389
آذر 1389
آبان 1389
مهر 1389
شهریور 1389
تیر 1389
خرداد 1389
اردیبهشت 1389
فروردین 1389
اسفند 1388
بهمن 1388
دی 1388
آذر 1388
آبان 1388
اسفند 1387
دی 1387
آذر 1387
مهر 1387
تیر 1387
اردیبهشت 1387
فروردین 1387
اسفند 1386
بهمن 1386
شهریور 1386
مرداد 1386
تیر 1386
خرداد 1386
اردیبهشت 1386
فروردین 1386
اسفند 1385
بهمن 1385
شهریور 1385
مرداد 1385
تیر 1385
خرداد 1385
اردیبهشت 1385
فروردین 1385
اسفند 1384
بهمن 1384
دی 1384
آذر 1384
آرشیو موضوعی
کتابها و منابع آموزشی اکسل
ترفندها
توابع
نمودارها
آشنایی با محیط اکسل
جداول محوری
توابع گزارش گیری
فرمول ها و توابع آرایه ای
مطالب گوناگون
فرم سازی
آمار
VBA
معتبر سازي داده ها VALIDATION
ابزارهاي اكسل
پیوندها
آمار 80
آموزش مقدماتی اکسل
ماکس ایران
آموزش گام به گام اکسل
آموزش اکسل 2000
آموزش تصویری اکسل
تکنولوژی های آموزشی
سایت های آموزش کامپیوتر
معرفی کتب کامپیوتر
آموزش icdl قوه قضاییه
آموزش منوهای اکسل
یک وبلاگ بسیار زیبا
پژوهش های آماری
تاریخ شمسی با اکسل
ترفند های ویندوز - وبلاگی زیبا
پایگاه کتب الکترونیکی تخصصی
آموزش طراحی صفحات وب سایت
cpearson
contextures
EXCEL HOME PAGE
آموزش spss
یک وبلاگ جالب
نكات آفيس
آموزش جامع حسابداري ( جالب)
آموزش اکسس
ترفندهای رایانه
دایره المعارف آموزشی
مهندسی شبکه های انتقال و توزیع برق
ترفند های اکسل
وبلاگ ساختمان ( عالی )


 Please visit this link since your browser does not support frames.


gahnevesht.com

 Click here to go to gahnevesht.com .


Excel Macros Tutorial

Microsoft Excel Macros

Excel Macros Table of Contents

The Tutorial on Excel Macros (VBA)
For beginners, intermediate and advanced users

When I decided to learn about Excel macros I had been working as a Business Data Analyst (accounting, finance, sales, production...) for more than 20 years and I had no background in programming.

Even if I had an MBA and was recognized as a competent analyst by my clients (Fortune 500), a lot of books, websites and courses on macros (VBA) developed by professional computer programmers made me feel inadequate.

I discovered rapidly that there were complex and simple ways to do things in VBA. I chose the simple ways to make myself useful and efficient. I was 45 years old then and I started a new very rewarding career as a Consultant in Excel (with a very solid background in business data analysis and reporting). The rewards were both financial and intellectual.

I share these simple ways in my tutorial. It will help you achieve your goals whatever your background
and it will NOT make you feel inadequate.

If you are good at what you do, you will become even better, you will do things that you thought were impossible with Excel and you will work a lot faster.

The Tutorial on Excel Macros (VBA)
In a single, easy and quick download

Download this tutorial on your own computer
And learn at your own pace

Reviewed and improved each year
Covering Excel 1997 to 2011

33 Complete Lessons
Many more Tips, Ideas, Examples and Exercises
Read them on screen or print them
For beginners, intermediate and advanced users
plus
25 Excel Spreadsheets
with useful macros
Templates and examples
with step by step instructions
Nothing hidden nothing protected

Only $65

Click on the button below to download the tutorial IMMEDIATELY


Access

Access

Filter

فیلتر کردن چندین مقدار

جهت فیلتر کردن چندین مقدار می توانیم از دکمه Filter که روی برگه Datasheet واقع شده است استفاده کنید. در این صورت صفحه ای باز می شود که شامل کادرهای بررسی برای هر مقدار در فیلد می باشد و شما می توانید چندین مقدار را جهت فیلتر کردن انتخاب کنید.

فیلتر کردن چندین مقدار

1. روی ستون فیلد مورد نظر کلیک کنید.

2. روی Filter کلیک کنید.

قاب Filter پایین فیلد انتخاب شده نمایان می شود.

3. مقادیری را نمی خواهید انتخاب شوند، تیک آنها را بردارید.

4. روی OK کلیک کنید.

5. هنگامی که فیلتر کردن به پایان رسید روی Toggle Filter کلیک کنید.

لیست به گونه ای فیلتر شده است که تنها مقادیری که ما انتخاب کرده ایم نمایش داده می شوند.

+ نوشته شده در پنجشنبه هفدهم دی 1388ساعت 15:36 توسط NiLooFaR |

Primary Key

درک مفاهیم کلید های اصلی و ترکیبی

کلید اصلی فیلدی است که به وسیله آن هر رکورد به صورت یکتا مشخص می شود و رابطه ها بین جداول به وسیله آنها می توانند به وجود بیایند.

هنگامی که بیشتر از یک فیلد برای کلید اصلی در نظر گرفته شده باشد، به آن کلید ترکیبی می گویند.

کدام فیلد؟!

از قدیم، اولین فیلد در جدول کلید اصلی می باشد. به وسیله این قرارداد، مرور و مرتب سازی رکوردها به وسیله فیلد کلید اصلی آنها آسان تر می شود. به هرحال می توانیم هر فیلد دلخواهی را برای این منظور درنظر بگیریم، می توانید فیلدی AutoNumber را استفاده کنیم و اجازه دهیم تا Access شماره گذاری را برای ما انجام دهد یا فیلد Number ویا Text را استفاده کنیم.

کلیدهای ترکیبی

در مواقع نادری، ممکن است یک فیلد به تنهایی نتواند به طور یکتا رکوردها را مشخص کند. برای مثال فرض کنید جدولی داریم که داده های مربوط به این که چه دانشجویی چه کلاس هایی را انتخاب کرده را ذخیره می کند. این جدول دو فیلد دارد: StudentID و ClassID. هیچکدام از این فیلدها برای هر رکورد یکتا نیستند. اما ترکیب آن دو برای هر رکورد یکتاست.

در آن مواقع، ممکن است نیاز داشته باشیم به این که کلید اصلی چند فیلدی تنظیم کنیم(که همان کلید ترکیبی نیز نامیده میشود)، که در آن هر رکورد باید ترکیبی یکتا از مقادیر درون آن فیلدها را داشته باشد.

تنظیم کلید اصلی یا ترکیبی

تنظیم کلید اصلی یا ترکیبی واقعا ساده است.کلید اصلی یا ترکیبی برای هر جدولی الزامی نیست، اما به شدت توصیه می شود!

اگر سعی کنیم جدولی را بدون کلید اصلی یا ترکیبی ببندیم یا ذخیره کنیم، Access پیغام اخطاری را نمایش می دهد.

تنظیم کلید اصلی تکی

1. در نمای Table Design، درون سطر مربوط به فیلدی که قصد دارید به عنوان کلید اصلی تنظیم کنید کلیک کنید.

2. روی Primary Key کلیک کنید.

نمای کلید در سمت چپ فیلد ظاهر می شود.

تنظیم کلید چند فیلدی(ترکیبی)

1. در نمای Table Design، در سمت چپ اولین فیلدی که می خواهید شامل شود کلیک کنید.

2. کلید Ctrl را پایین نگه داشته و در سمت چپ فیلدهای دیگری که می خواهید شامل شوند کلیک کنید.

3. روی Primary Key کلیک کنید.

نمای کلید در سمت چپ هریک از فیلدهای انتخاب شده ظاهر می شود.

+ نوشته شده در چهارشنبه شانزدهم دی 1388ساعت 21:47 توسط NiLooFaR |

Relationships

درک روابط

می توانیم جداول را به وسیله ایجاد روابط بین آنها و بر اساس فیلدی که به اشتراک دارند به هم متصل کنیم.این روابط ایجاد فرم ها، پرس و جوها و گزارشاتی که شامل فیلدهایی از چندین جدول می شوند را ممکن می کنند.

فیلدهای مشترک

برای وجود ارتباط بین دو جدول، آن ها باید دارای فیلدهای مشترک باشند. به عنوان مثال، جدول Customers ممکن است دارای فیلد CustomerID باشد و جذول Orders نیز ممکن است دارای فیلد CustomerID باشد. این دو جدول توسط این فیلد می توانند به هم مرتبط شوند. جهت ایجاد ارتباط در هر دو جدول، نوع نوع فیلد باید مشابه باشد.

(استثنا: فیلد AutoNumber می تواند با فیلد Number ارتباط برقرار کند.)

کلید اصلی و کلید خارجی

در اکثر روابط فیلد کلید اصلی در یک جدول در جدولی دیگر که کلید اصلی آن نمی باشد، مرتبط می شود. در یک جدول فیلد شامل ارزش های یکتایی است که در جدول دیگر به اینصورت نمی باشد. فیلد ارتباطی در جدول دیگر کلید خارجی نامیده می شود. به عنوان مثال در جدول Customers هر رکورد دارای فیلد CustomersID یکتایی می باشد. اما در جدول Orders ممکن است دو سفارش مختلف دارای CustomerId مشابه باشند.

ایجاد ارتباط بین دو جدول

روابط بین جداول در پنجره ای به نام Relationships ایجاد و مدیریت می شوند. می توانیم به وسیله کشیدن یک فیلد از یک جدول به فیلدی از جدول دیگر، روابط بین دو جدول را ایجاد کنیم.

نمای Relationships را باز کنید

1. روی Database Tools کلیک کنید.

2. روی Relationships کلیک کنید.

کادر محاوره ای Show Table باز می شود.

اضافه کردن جدول ها به پنجره Relationships

1. اگر هنوز کادر محاوره ای Show Table باز نشده، روی Show Table کلیک کنید.

2. برای افزودن به پنجره Relationships روی یک جدول کلیک کنید.

3. روی Add کلیک کنید.

4. مراحل 2و 3 را برای افزودن جدول های بیشتر تکرار کنید.

روی Close کلیک کنید.

ساخت یک رابطه

1. روی فیلد کلید اصلی که باید با فیلدی در جدول دیگر مرتبط شود کلیک کنید.

2. فیلد کلید اولیه را به سمت فیلد مرتبط در جدول دیگر بکشید و رها کنید.

+ نوشته شده در سه شنبه پانزدهم دی 1388ساعت 22:55 توسط NiLooFaR |

چگونگی ذخیره کردن فایل با فرمت Access 2002-2003

اگر بخواهیم فایل ایجاد شده در نرم افزار اکسس 2007 در ورژن های قبلی این نرم افزارهم باز شود، باید آن را به فرمت اکسس 2002-2003 ذخیره کنیم.

1. روی دکمه Office کلیک کنید.

2. در پنجره باز شده روی Save As کلیک کنید.

3. روی قسمت مشخص شده در تصویر زیر کلیک کنید.

با انجام این مراحل فایل انتخابی با فرمت Access 2002-2003 ذخیره می شود .

+ نوشته شده در سه شنبه پانزدهم دی 1388ساعت 18:32 توسط NiLooFaR |

تعارف اولیه

جداول، رکوردها و فیلدها

در Access دادها در جداول ذخیره می شوند و هر سطر خاص از جدول یک رکورد نامیده می شود. برای مثال در جدول Customers، اطلاعات مربوط به هر مشتری رکوردی مجزا است. هر رکورد ترکیبی از یک یا چند فیلد می باشد که شامل داده های خاص می باشد. برای مثال فیلدهای مشتریان ممکن است شامل نام، آدرس، شهر، ایالت و کد پستی باشد.

فرم ها و Datasheetها

به طور پیش فرض هر جدول به صورت شبکه ای گسترده نمایان می شود که به آن Datasheet می گویند. می توانیم به طور مستقیم در Datasheet چیزی را تایپ کنیم. برای آسان تر کردن ورود داده ها، برخی ساخت فرم های نمایشی را انتخاب می کنند که شبیه به کادرهای محاوره ای می باشند که برای ورود مقادیر فیلدها ظاهر می شوند. استفاده از فرمی که به صورت جذاب فرمت بندی شده، راحت تر و دلچسب تر از ورود رکوردها در یک Datasheet تخت می باشد.

فیلترها و پرس و جوها

اغلب نمایش جداول در نمایش فیلتر شده کارآمد می باشد. می توانیم برای نمایش رکوردهایی خاص، فیلدهایی خاص و یا هر دو، جدول را فیلتر کنیم. می توانیم فیلترهای یک بار مصرف را اجرا کنیم و یا پرس و جوهایی بسازیم که مانند فیلترهای ذخیره شده عمل کنند. پرس و جوها همچنین به ما این امکان را می دهند تا داده ها از چندین جدول به هم مرتبط را باهم ترکیب کرده و نتیجه را به صورت Datasheet نمایش دهیم.

گزارش ها

جدول ها و پرس و جوهایی که به شکل Datasheet تخت نمایش داده می شوند، هنگام چاپ بر روی کاغذ، زیاد جذاب نیستند. گزارش ها، داده های جدول و پرس و جوها را با فرمتی جذاب به همراه تیترها، سربرگ ها، پانویس ها و حتی آرم ها و دیگر عناصر گرافیکی ارائه می کنند.

+ نوشته شده در سه شنبه پانزدهم دی 1388ساعت 14:10 توسط NiLooFaR |

آشنایی با Access

ذخیره سازی و پردازش حجم انبوهی از داده ها!

این جمله کوتاه، توصیف کننده کار بسیار حیاتی و بزرگی در دنیای امروز می باشد که توسط یکی از مهم ترین برنامه های موجود در Office یعنی Access انجام میگیرد. به کمک این نرم افزار می توانیم حجم بالایی از اطلاعات را درون جداول ذخیره سازی کنیم و با استفاده از امکانات موجود در برنامه روی آنها پردازش های لازم را صورت داده و نتایج دلخواه را استخراج کنیم.

محیط ساده و کاربرپسند، ویزاردها و امکانات متعدد و قابلیت برنامه نویسی، به افراد مبتدی تا کاربران حرفه ای این امکان را داده تا اطلاعات مورد نظر خود را با سهولت تمام، ذخیره و بازیابی کنند.

داده های درون یک دفترچه تلفن، اطلاعات مربوط به دانش آموزان یک مدرسه، سیستم خرید و فروش یک شرکت یا کارخانه و هر نوع اطلاعات دیگری را می توان با خیال راحت به Access سپرد و با پرسیدن سوالات متنوع، نتایج مورد نظر را به آسانی استخراج نمود.

به بین دیگر Microsoft Access 2007 برنامه ای برای ساخت پایگاه های داده است تا بتوان اطلاعات تجاری و یا شخصی را در آنها ذخیره کرد. می توانیم از Access برای ساخت، بازیابی و مدیریت مجموعه های بزرگ و کوچک اطلاعات استفاده کنیم.

+ نوشته شده در سه شنبه پانزدهم دی 1388ساعت 10:19 توسط NiLooFaR |
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ

نوشته های پیشین

دی 1388

پیوندها

ویکی پدیا
وبلاگ تخصصی کامپیوتر و نرم افزار
وبلاگ تخصصی کامپیوتر
مهندسی نرم افزار
RSS

POWERED BY
BLOGFA.COM


استفاده حرفه ای از Excel

استفاده حرفه ای از Excel

Excel Profetional Tips and Tricks

طریقه اضافه کردن footer و header

سلام دوستان عزیز
بابت تاخیر در نوشتن وبلاگ عذر میخوام خیلی سرم شلوغ بود و نتونستم به وعده وفا کنم و به خیلی از سوالات پاسخ بدم.راستش در حال تغییر شغل بودم و.... به هرحال از امروز قول میدم که دیگه شاهد چنین تاخیری نباشید و نکته های خوب و آموزنده ای اینجا ببینید.

سوالی که چند تا از دوستان پرسیده بودند طریقه اضافه کردن footer و header سربرگ و پانوشت؟ به شیت اکسل است که در ادامه روش آن را توضیح میدم. استفاده از footer و header باعث زیبایی و شکیل شدن صفحه اکسل بعد از پرینت شدن میشود و در ثانی موجب میشود نمودار یا جدول پرینت گرفته شده هویت پیدا کند.

1) در اکسل 2007 ابتدا روی تب insert کلیک میکنیم.

2) در تب مربوطه و در قسمت Text روی header & footer کلیک میکنیم.

3) بعد از آن خود اکسل به صورت اتوماتیک صفحه کاغذ را نشان داده و میشود به راحتی footer و header را اضافه کرد.

امیدوارم این نکته پاسخ دوستان عزیز را بدهد. لطفاً سوالات خود را در قسمت کامنت همین پست مطرح کنید.

+ نوشته شده در شنبه نوزدهم شهریور 1390ساعت 14:43 توسط پانته آ |

پاسخ به سوالات (2)

با سلام مجدد در این پست قصد دارم سوال دوستمون مجدید رو پاسخ بدم:

من لیستی از تاریخها دارم میخوام اتومات این ستون به ترتیب تاریخ مرتب بشه نمیخواهم هر دفعه که تاریخی عوض از طریق SORT مرتب کنم

دوست خوبم میتونین از ماکرونویسی استفاده کنید برای اینکار Alt +F11 را بزنیند تا وارد editor شوید

سپس کد زیر را وارد کنید:

Private Sub Worksheet_Change(ByVal Target As Range)
If Not (Application.Intersect(Worksheets(1).Range("E9:F32"), Target) Is Nothing) Then
DoSort
End If
End Sub

Private Sub DoSort()
Worksheets(3).Range("E3:M7").Sort Key1:=Worksheets(3).Range("M3"), Order1:=xlDescending, _
Key2:=Worksheets(3).Range("L3"), Order2:=xlDescending, Header:=xlYes
Worksheets(3).Range("E10:M14").Sort Key1:=Worksheets(3).Range("M10"), Order1:=xlDescending, _
Key2:=Worksheets(3).Range("L10"), Order2:=xlDescending, Header:=xlYes
Worksheets(3).Range("E17:M21").Sort Key1:=Worksheets(3).Range("M17"), Order1:=xlDescending, _
Key2:=Worksheets(3).Range("L17"), Order2:=xlDescending, Header:=xlYes
Worksheets(3).Range("E24:M28").Sort Key1:=Worksheets(3).Range("M24"), Order1:=xlDescending, _
Key2:=Worksheets(3).Range("L24"), Order2:=xlDescending, Header:=xlYes
End Sub

فقط باید در کد بالا بازه E9:F32 در شیت اول را با توجه به ویژگی های فایل خود تغییر دهید.

امیدوارم مفید بوده باشد.

+ نوشته شده در پنجشنبه نوزدهم اسفند 1389ساعت 12:26 توسط پانته آ |

پاسخ به سوالات (1)

سلام، خانم صدف در پست قبلی این سوال رو پرسیدن:

آیا میتوان در اکسل یه تعداد روز را به یک تاریخی اضافه کرد و تاریخ جدید به دست آورد؟

بله دوست خوبم. ابتدا باید تاریخ را در یک سل با فرمت date وارد کنیم. سپس عددی که قرار است به آن اضافه گردد را در یک سل دیگر و یک سل را به عنوان سل نتیجه با فرمت date ایجاد کرد و دو سل مذکور یعنی تاریخ اولیه و سل عدد را در آن سل جمع زد.

فقط نکته اینجاست که سل تاریخ مبداً و سل تاریخ نتیجه هردو باید فرمت تاریخ داشته باشند. برای تعیین فرمت سل، روی سل کلیک راست کنین و format cell را انتخاب کنین و در قسمت Category گزینه date را انتخاب کنین.

امیدوارم جواب سوال خود را گرفته باشید. در مورد فرمت پرینت هم در آینده نزدیک یک پست تخصیص میدهم.

+ نوشته شده در سه شنبه هفدهم اسفند 1389ساعت 11:59 توسط پانته آ |

میانبرهای تاریخ و زمان

سلام دوستان خیلی ممنون از کامنت ها و ایمیل هایی که ارسال فرمودید. از پست بعدی به نوبت به سوالات دوستان پاسخ میدم.

فعلاْ به نکته زیر توجه کنید:

خیلی وقت ها نیاز داریم که تاریخ روز رو در انتهای شیت اکسل وارد کنیم یا مثلاْ رکورد یک تماس تلفنی رو وارد کنیم و جلوش ساعت و تاریخ اون روز رو بزنیم. برای اینکار میتوانیم از دوتا short cut و یا میانبر زیر استفاده کنیم:

برای وارد کردن زمان کامپیوتر:

Ctrl + Shift + : ( یعنی همزمان کنترل، شیفت و دونقطه را میگیریم)

برای وارد کردن تاریخ روز:

Ctrl + ; ( یعنی همزمان کنترل و سمی کالون را میگیریم)

این دو میانبر سرعت ورود داده ها را افزایش میدهد.

+ نوشته شده در سه شنبه هفدهم اسفند 1389ساعت 11:51 توسط پانته آ |

conditional drop-down lists

خیلی وقت ها ما احتیاج داریم که برای ورودی های یک سل در اکسل محدودیت های خاصی ایجاد کنیم. همانطور که در مطالب قبلی گفتیم یک راه استفاده از dropdown لیست ها است.

حالا یک صورت مسئله پیچیده تر مطرح میکنیم. فرض کنیم شما میخواهید وقتی که کاربر رشته تحصیلی خود را صنایع انتخاب کرد در سل گرایش فقط بتواند از بین دو گرایش صنایع یعنی تولید و تحلیل سیستم انتخاب کند و اگر رشته خود را مکانیک انتخاب کرد فقط بتواند از بین سیالات و جامدات انتخاب کند. اگر تعداد رشته ها و گرایش ها خیلی زیاد باشد استفاده از تابع IF غیر ممکن است.

مثال زیر را عیناْ در اکسل پیاده سازی کنید تا این روش را بیاموزید. (در این مثال ما دنبال این هستیم که وقتی کاربر کشور خود را انتخاب میکند در ستون شهر فقط بتواند شهرایی را انتخاب کند که متعلق به همان کشور است و بعد از انتخاب شهر فقط بتواند از بین خیابان های آن شهر برای قسمت خیابان استفاده کند.)

ابتدا این جدول را درست کنید:

سپس در سل F1 تایپ کنید Netherlands
سپس در سل G1 تایپ کنید Britain
سپس در سل H1 تایپ کنید Germany

سپس با توجه جدول زیر داده ها را وارد کنید:

(البته شماره سل را وارد نکنید. بلکه به عنوان مثال در سل H2 وارد کنید Bonn)

Cell F2: Amsterdam | Cell G2: London | Cell H2: Bonn
Cell F3: Rotterdam | Cell G3: Canterbury | Cell H3: Berlin
Cell F4: Eindhoven | Cell G4: Manchester | Cell H4: Munich

وقنی تمام اطلاعات بالا را وارد کردیم صفحه اکسل به شکل زیر در میاید: (ما فعلاً از وارد کردن نام خیابان ها صرف نظر میکنیم، یعنی از سطر 7 به بعد را وارد نمیکنیم.)

سل F2 تا F4 را انتخاب کنید روی آن right click کنید و بزنید Name a Range و در قسمت Name وارد کنید: Netherlands (فقط به املای صحیح آن دقت کنید.)

سل G2 تا G4 را انتخاب کنید روی آن right click کنید و بزنید Name a Range و در قسمت Name وارد کنید: Britain (فقط به املای صحیح آن دقت کنید.)

سل H2 تا H4 را انتخاب کنید روی آن right click کنید و بزنید Name a Range و در قسمت Name وارد کنید: Germany (فقط به املای صحیح آن دقت کنید.)

حال وارد سل B2 میشویم و یک drop down list از نام کشورها(F1 تا H1) وارد میکنیم و drag میکنیم تا سل B4

سپس در سل C2 یک drop down list ایجاد کنید و در قسمت Source بنویسید :

=INDIRECT($B2)

حال وقتی یک کشور انتخاب شود، در سل روبرویی که شهر باشد، تابع Indirect دنبال Range ای که به این نام گذاشته شده میگردد و drop down list جدید تشکیل میشود. سپس سل C2 را تا C4 میکشیم. (drag میکنیم.)

برای آموختن این روش کل تمرین بالا را انجام دهید تا مطلب به خوبی جا بیفتد.

همچنین میتوانید برای تمرین در ستون D نام خیابان ها را شرطی کنید.

این مطلب از وبلاگ مایکروسافت نقل شده لذا در صورت وجود ابهام میتوانید به منبع اصلی مراجعه کنید.

+ نوشته شده در یکشنبه پانزدهم اسفند 1389ساعت 9:29 توسط پانته آ |

نحوه استفاده از بولت در یک سل bulleted list

برای ایجاد bulleted list در یک سل excel باید از روش زیر استفاده کنیم:

  • روشن کردن Num Lock
  • انتخاب سل مورد نظر و Double click بر روی آن
  • Alt + 7 (عدد 7 حتماً باید از روی قسمت Numeric کیبورد انتخاب شود.)
  • تایپ مطلب مورد نیاز
  • استفاده از Alt + Enter برای رفتن به خط بعد
  • استفاده مجدد از Alt +7 جهت ایجاد بولت

+ نوشته شده در چهارشنبه یازدهم اسفند 1389ساعت 11:49 توسط پانته آ |

تایپ کردن چند خط در یک سل

برای تایپ کردن دو خط مختلف در یک سل Excel می توانیم از Alt + Enter استفاده کنیم. چون استفاده از Enter موجب میشه که نشانگر ما به سل بعدی انتقال پیدا کنه. لذا استفاده از Alt + Enter برای نوشتن دو خط مجزا در یک سل اکسل خیلی کاربردی و مفید هستش.

+ نوشته شده در چهارشنبه یازدهم اسفند 1389ساعت 11:42 توسط پانته آ |

تهیه drop down list در اکسل

تهیه لیست های drop down در اکسل فواید خیلی زیادی داره.اول از همه اینکه کاربر میتواند داده هایی که به سل ها وارد میشود را کنترل کند و برای آن ها محدوده تعریف کند. به عنوان مثال وقتی که قرار است سن تعدادی از مصرف کنندگان را وارد کنیم میتوانیم بر روی سل مربوطه محدوده ۱۲ تا ۷۰ را بگذاریم و یا برای نوشتن جنسیت دو گزینه زن و مرد را قرار دهیم تا وارد کننده اطلاعات فقط از بین زن و مرد انتخاب کند. این کار نه تنها باعث یکسان شده داده های ورودی میشود بلکه سرعت وارد کردن داده ها به نرم افزار را نیز بالا میبرد.

برای تهیه drop down list در excel 2007 ابتدا سل مورد نظر را نتخاب کنید و سپس:

Data -> Data Validation --> Data Validation

و سپس در قسمت Validation Criteria نوع داده هایی که باید در سل مورد نظر وارد شوند را انتخاب کنید. در این قسمت ما بر روی گزینه List تمرکز میکنیم. پس در قسمت Allow در تب اول پنجره Data Validation بر روی گزینه List کلیک میکنیم.

و در انتها لیست مورد نظر را در قسمت Data وارد میکنیم. لازم به ذکر است برای داده های انگلیسی از کاما جهت جداسازی داده ها استفاده میکنیم و برای داده های فارسی از کامای انگلیسی(زبان کیبرد انگلیسی) و برای نوشتن داده ها از زبان فارسی. همچنین تا اونجایی که من اطلاع دارم روی بعضی ویندوزها باید برای جدا کردن داده ها از semicolon یا ; استفاده کنیم.

همچنین میتوانیم به جای وارد کردن داده ها به صورت دستی اکسل را از طریق گزینه سمت راست قسمت Data اکسل را به گروهی از سل ها ارجاع دهیم.

+ نوشته شده در چهارشنبه یازدهم اسفند 1389ساعت 10:23 توسط پانته آ |
صفحه نخست
پست الکترونیک
آرشیو وبلاگ
عناوین مطالب وبلاگ

نوشته های پیشین

شهریور 1390
اسفند 1389

پیوندها

آموزش جامع نرم افزار excel
RSS

POWERED BY
BLOGFA.COM


Google Image Result for http://www.guidesandtutorials.com/image-files/excel_screen1.gif

Go to Google Images Home
Back to image results
See full size image

See full size image

600 × 442 - 41k - gif - www.guidesandtutorials.com/.../excel_screen1.gif

Image may be subject to copyright.

Below is the image at: www.guidesandtutorials.com/excel-2003-tutoria...

Remove frame


GuidesandTutorials: Microsoft Excel 2003 Tutorial

Site Build It!
  • Home
  • Audacity
  • Dreamweaver
  • PowerPoint
  • Excel
  • Digital Photography
  • Podcasting
  • RSS
  • Word

Ben Hi, My name is Ben Anderson and I make over $1,300 per month from a couple of websites like GuidesandTutorials. I do it from home in my spare time.

If you'd like to learn how to do the same, look at my new website:
createagreatwebsite.com

Site Build It!

Microsoft Excel 2003 Tutorial - Excel Basics

Also see your new Excel 2007 Tutorial. This Excel 2003 Tutorial will introduce you to the basics of using the Excel 2003 spreadsheet program. You'll learn to create a spreadsheet, basic Excel workbook skills, work with cells, enter and manipulate data, apply formulas, format data, create and work with charts, and manage Excel workbooks. You can also view the Excel 2003 Video Tutorials as they come on line.

Excel 2003 Tutorial

Our Free Microsoft Excel 2003 tutorial will help you learn and use the Microsoft Excel 2003 spreadsheet program.

Microsoft Excel 2003 is a powerful spreadsheet software program that allows you to manipulate data and make quick and accurate numerical calculations. Excel spreadsheets allow you to organize information in rows and tables. Entering data into the spreadsheet is quick and easy. After the data has been entered, Excel offers tools to perform any type of calculation on it. Excel 2003 also has many formatting tools to display the data in various formats to always keep it looking sharp and professional.

Excel 2003 Tutorial: Excel 2003 Basics

  • The Excel Program Screen
  • Excel Toolbars
  • Create a new Workbook
  • Moving Around the Excel Workbook
  • Adjusting Column Widths and Row Heights
  • Selecting and Editing Cells in Excel 2003
  • Entering Labels in Excel Worksheets
  • Saving an Excel Workseet
  • Excel Keyboard Shortcuts
  • Video Lesson: Making Bar and Circle Graphs
  • Video Lesson: Making a Gantt Chart

Excel 2003 Tutorial: Lesson 1 - The Excel Basics

There are many uses for Excel. Businesses use it for crating financial reports and budgeting. School administrators can use it for preparing school budgets. Teachers use it to analyze data about student performance and adjust their teaching. Scientists use it analyze data. Economists use it for statistical analysis. Families use it to manage their investment portfolios. Microsoft Excel is be far the most widely used, most powerful spreadsheet program available.

Excel Advanced Training

Instant Download! - Place your order right now and you'll have access to your videos online, immediately.

Two Volumes, One Low Price - These two volumes normally sell for $67 each, but if you act quickly you'll be able to purchase BOTH sets for only $59.95. Click Here!

These Excel 2003 tutorials will introduce you to the Excel "basics." They will cover the information that would be covered in an introductory course on Microsoft Excel 2003.

Excel 2003 Tutorial
The Excel 2003 Program Area

Excel 2003 Tutorial: Excel Program Screen

When you launch Excel, the program opens to a blank document that looks like the one below. From this point, you can add data, change how it looks, have Excel perform mathematical calculations or summarize the data or find information in Excel's help files.

The image below shows the most important parts of the Excel workbook window. Note that it's possible that depending on the way your computer is configured, not every toolbar that you see below may look the same on your machine. You can select the toolbars to view by selecting View from the Menu Bar and then choosing "Toolbars."

The most basic part of an Excel document is the box that holds a piece of data, called a cell. A cell is the box represented by the intersection of a column and a row. Rows are identified by the numbers down the left side and columns are identified by letters across the top. Each cell is indicated by a cell reference. For example, in the image below the Active Cell at the intersection of Column A and Row 1 is given the cell reference of A1.

Excel 2003 screen

Excel 2003 Tutorial: The Excel Toolbars

Title Bar - The title bar displays the name of the program you are currently using and the name of the Excel workbook that is open. It appears at the top of all Windows programs. By default, Excel opens with Book 1.

Excel title bar
Title Bar

Menu Bar - The menu bar is directly below the Title bar and displays a list of the menus that you can use to give commands to Excel. Clicking on a menu name displays a drop down menu of commands. You can move across the menu bar and down the drop-down menus with your mouse of by highlighting one of the menu items and using the arrow keys on your keyboard.

Excel menu bar
Menu Bar

The menus found on the Menu Bar include the following:

  • File - File-related commands to open, save, close, print, and create new files.
  • Edit - Commands to copy, cut, past, find, and replace text.
  • View - Commands to change how the workbook is displayed on the screen.
  • Insert - Lists items that you can insert into a workbook, such as graphics and charts.
  • Format - Commands to format fonts, cell alignment, and borders.
  • Tools - Lists tools such as the spell checker and macros.
  • Data - Commands to analyze and work with data information.
  • Window - Commands to display and arrange multiple windows.
  • Help - Get help on using the Excel program
  • Adobe PDF - Options file menu if you have Adobe Acrobat installed.

Standard Toolbar - The Standard toolbar includes buttons that are shortcuts for the most commonly used commands. It contains buttons for the tools you use most frequently, such as saving, opening, and printing workbooks.

Excel tool bar
Standard Toolbar

The tools found on the Standard Toolbar include the following:

  • New - Creates a new, blank spreadsheet
  • Open - Open a previously saved spreadsheet
  • Save - Save your current spreadsheet
  • Permission - To restrict access to your spreadsheet
  • Print - Prints the current document
  • Print Preview - Preview the current spreadsheet to see how it will print
  • Spelling - Performs a spell check of cells in the current document
  • Research - Enables information rights management which can help protect sensitive documents from begin copied or forwarded.
  • Copy - Copies the current selection to the clipboard, which can then be pasted elsewhere in the document
  • Paste - Takes the current clipboard contents and insert them
  • Undo - Undoes the last action in the document
  • Redo - Redoes the last undone action
  • Insert Hyperlink - Inserts a hyperlink to an Internet Web location
  • Auto Sum - A drop-down menu of available mathematical operations to perform
  • Sort Ascending - Sorts the current selection in ascending order
  • Chart Wizard - Opens the "Chart Wizard," which will walk you through the creation of charts and diagrams using the selected data.
  • Other Options - There are a variety of other options you can call or add to the toolbar, such as Cut, Email, Sort Descending, etc. By clicking on the triangle at the far right side of the toolbar, you can access these options.

Formatting Toolbar - The Formatting toolbar contains buttons for the most commonly used formatting commands, such as making text bold or italicized.

Excel formatting bar

Formatting Toolbar

The Formatting Toolbar includes commonly used buttons for formatting the information in cells. These include the following:

  • Font - Changes the font of the selected cells
  • Size - Changes the font size of the selection
  • Bold - Puts the selection in bold face
  • Italics - Puts the selection in Italics
  • Underline - Places an underline beneath the selection
  • Align Left - Aligns the current selection to the left
  • Align Right - Aligns the current selection to the right
  • Merge & Center - Combines two selected cells into one new cell that spans the width of both and center the contents of this new cell
  • Currency Style - Changes the style in which currency is displayed
  • Percent Style - Changes the style in which percents are displayed
  • Decrease Indent - Decrease the indent of a cell by approximately one character
  • Border - Adds or alters the style of borders around selected cells
  • Fill Color - Select a color to fill the background of a cell
  • Font Color - Select a color to apply to a selection of text

Excel task pane

Task Pane - The Task pane lists commands that are relevant to whatever you're doing in Excel. You can easily hide the task pane if you want to have more room to work on a workbook. Click the close button in the upper right corner of the Task pane. To open it again, choose View, Task pane.

Worksheet Window - You can have multiple worksheets in an Excel file. The worksheet window is where you enter data into the cells on the worksheet. You can have more than one worksheet open at a time. Each worksheet contains columns and rows.

Excel worksheet window

Formula Bar - The Formula Bar allows you to view, enter, and edit data in the selected cell. If the cell contains a formula, it will be displayed here. If there is no formula then the content of the cell is displayed. Cell content can be edited directly in the cells or in the Formula bar.

Excel formula bar

The Formula Bar

The mathematical formula will appear in the Formula Bar when a cell that includes a formula is selected in the worksheet. In the example below, the formula to average grades is in cell E2. When cell E2 is selected, the formula appears in the Formula Bar.

Excel Formula Bar

Name Box - The Name Box displays the active cell address. For example, the selected cell in the image below is at the intersection of column D and row 3. "D3" will appear in the name box, indicating that the active cell is D3. The content of the selected cell appears in the Formula bar to the right of the Name box.

Excel name box

Worksheet Tabs - You can keep multiple worksheets together in a group called a workbook. For example you could have a separate worksheet for each month of the year in a workbook for the year 2007. You can give worksheets your own meaningful names by placing your cursor over the sheet name and typing. By default, Excel opens with three worksheets.

Excel worksheet tabs

Scroll Bars - Horizontal and Vertical scroll bars are available to help you move around your spreadsheet. The scroll box shows where you are in the workbook. For example, if the scroll box is near the bottom of the scroll bar, you're at the beginning of a workbook.

Status Bar - If the Status bar is on, it will appear at the bottom of the screen. It displays messages and feedback. Do the following exercise to learn how to use the Status bar.

  1. Point to View in the Menu bar.
  2. Click the mouse button. A drop-down menu will open.
  3. On the drop-down menu, if the Status Bar has a check mark next to it, it is turned on. Press the Escape key to close the menu.
  4. If the Status Bar does not have a check mark next to it, press the down arrow until it is highlighted, then press enter. The Status Bar should now appear at the bottom of the screen.

You should see the work "Ready" on the Status Bar at the left side of the screen. This tells you that Excel is in Ready mode and waiting for your next command. There are other indicators that appear on the Status Bar in the lower right of the screen.

Excel Status Bar

Num Lock Key - The Num Lock key is a toggle key. When you turn it on and off, the Status Bar let you know the Num Lock key status.

Caps Lock Key - The Caps Lock key is also a toggle key. The Status Bar will also indicate whether or not it is on or off. When it is on, you will see "CAPS" in the Status Bar.

Excel 2003 Tutorial: Create a New Workbook

Excel provides several ways to create a new workbook. Commands can be given to Excel using the menus or the toolbars.

Excel New Workbook Button

You can position the cursor over the New Button on the Standard Tool bar. A Screen Tip appears over the button to identify what the button is.

Click the New Button and a new, blank workbook appears.

Create a New Workbook from the File Menu

You can also click on the File menu and choose the New command. This will also open a new Excel workbook. You can navigate the menus by using the arrow key

Excel File Menu

When you click on the word File on the Menu bar, a menu drops down. The File menu contains a list of file-related commands. Click on New or use the key commands Ctrl + N to create a new, blank workbook.

You can also use the File menu to close a workbook. Choose File, Close.

Excel 2003 Tutorial: Moving Around the Excel Worksheet

Before you start entering data into a worksheet, you need to learn how to move around in a worksheet. Before you can enter information into a cell, you must make the cell active by selecting it. You can make a cell active by using the mouse and clicking in a cell or you can use the keyboard to move the cell pointer using the keyboard's arrow keys.

Excel provide several ways to move about the cells in the Excel Workspace. Open Excel and practice moving around the worksheet by following the steps below:

Using the Arrow Keys

You can use the arrow keys on the keyboard to move around the Excel worksheet one cell at a time. Press the down arrow to Keyboard Arrow Keys move down one cell at a time. Press the up arrow several times to move up one cell at a time. Press the right and left arrow keys to move left and right one cell at a time.

You can use the End Key in conjunction with the Arrow keys to move the cursor to the far end of the spreadsheet in the direction of the arrow.

Using the Tab Key

You can use the Tab key to move across the page to the right one cell at a time. Hold the Shift key + Tab to move to the left one cell at a time.

Using the Page Up and Page Down Keys

You can use the Page Up and Page Down keys to move the cursor up and down the worksheet one page at a time.

Using the Home Key

The Home key used in conjunction with the End key moves the cursor to cell A1 or to the beginning of any data that has been entered into the worksheet.

Keyboard Shortcuts for Moving Around a Worksheet

Press | To Move
Right arrow or Tab | One cell to the right
Left arrow or Shift+Tab | One cell to the left
Up arrow key | Up one row
Down arrow key | Down one row
Home | Jump to the cell in column A in the current row

Excel 2003 Tutorial: Adjusting Column Widths and Row Heights

If you enter text or numbers into a cell and you find that it spans beyond the width of the cell, you can make the column wider by clicking and dragging the dividing line between the two columns. Place your cursor over the dividing line, click, and than drag it to the desired width and then release your mouse.

Excel Column Width

Excel 2003 Tutorial: Editing Cells in Excel

Before you can perform a function on cells, you must select them. You can do that by clicking on a column label to select all cells in that column, a row label to select all cells in a particular row, or you can click and drag your mouse over a group of cell. Selected cells turned blue and have a black border line around the them.

Excel selected cells

Excel 2003 Tutorial: Selecting Cells in Excel

There are several ways to select cells in Excel. To select a column, simply click on the letter of the column you wish to select. To select a row, click on the row number on the left side of the workspace. All of the cells in that row will be selected. You can also click and drag the mouse over the cells you wish to select.

Another way to select cells is to place the cursor in the upper left cell that you want to highlight. Press the F8 key. This anchors the cursor. Notice that "EXT" appears in the Status bar in the lower right of the screen. This indicates that you are in the Extend mode. Click in the cell on the lower right corner of the group of cells that you want to select.

For example, click in cell A1. Then hit the F8 key to anchor the cursor. Click in cell F8 and all of the cells between A1 and F8 will be selected. To release the cells, hit the Escape key.

Excel 2003 Tutorial: Entering Labels in an Excel 2003 Worksheet

Now that you've learned to navigate around an Excel 2003 spreadsheet, you're ready to start entering data. There are two basic types of information you can enter in a cell.

  1. Labels: Labels are any type of text or information that is not used in any calculations.
  2. Values: Any type of numerical data, such as numbers, percentages, fractions, divisors, dates, currencies, times, etc.

Labels are used for worksheet headings and make your worksheets organized and easy to read. They usually contain text, but can also contain numerical information not used for calculations, such as numbers or dates. See the sample headings below for Grades across the top row and Students down the first column.

Excell Spreadsheet This is what a basic spreadsheet may look like. Notice that numbers automatically align to the right, while text automatically aligns to the left. A row has been allowed at the top for column headings and a column has been allowed on the left for row headings. These have been placed in bold.

The grade average in cell E2 was not entered. Instead a formula was entered to add the three grade columns and divide the total by three to find the average grade. When that formula was copied into each of the rows in column E, Excel automatically calculated the average for each student.

Excell 2003 Tutorial: Saving an Excel Workbook

After you've created a worksheet, you need to save it if you intend on using it again. Saving a worksheet stores in in a file on your computer's hard disk. Once you've saved a worksheet the first time, it's a good idea to save it often so you don't lose your work should something happen to the file or your computer. You don't want to lose all your work if the power goes out or something else unexpected happens.

Select File > Save As from the menu bar. The Save As dialog box will appear and you will be given the opportunity to give the file a name and choose the location on your hard drive where you want to save the file. Once you've given the file a name and saved it, in the future, when you make any changes to the file, you only need to click the save button to save the most recent changes to the file.

Search for Tutorials

Excel 2003 Tutorials

Excel 2007 Tutorials
Excel 2007 Charts
Excel 2007 Graphics
Excel 2007 Worksheets
Excel 2007 Worksheet Views
Excel 2007 Formulas
Excel 2007 Named Ranges
Excel 2007 Cell Comments

Excel Video Tutorials
Lesson 1: Excel Basics
Lesson 2: Editing a Worksheet
Lesson 3: Making Bar and Circle Graphs
Lesson 4: Making a Gantt Chart
Lesson 5: Excel Keyboard Shortcuts

More Excel Tutorials at GuidesandTutorials.net

All Other Guides and Tutorials

Guides and Tutorials Blog
Listing of the latest tutorials published on the GuidesandTutorials website.
GuidesandTutorials: Audacity Tutorial - Record and Edit Audio
This Audacity tutorial will show you how to use the basic tools and procedures in the open source audio editing program, Audacity. Not just screen shots, but free narrated multimedia tutorials - You'll learn to use Audacity for recording and editing audio files that can be used for podcasting, mixing music and vocals, creating sound tracks, and other audio projects.
Audacity Tips & Tricks
Audacity tips and tricks submitted by users
Digital Photography Guide
This Digital Photography Guide will provide you with the basic information you need to take professional quality photogrphs with your digital camera.
GuidesandTutorials: Dreamweaver Tutorial
Dreamweaver Tutorial - this series of free Dreamweaver tutorials is just what you need to get up and running with Dreamweaver to create interesting and compelling web sites
GuidesandTutorials: Microsoft Excel 2003 Tutorial
This Excel 2003 Tutorial will introduce you to the basics of using the Excel 2003 spreadsheet program. You'll learn to create a spreadsheet, basic Excel workbook skills, work with cells, enter and manipulate data, apply formulas, format data, create and work with charts, and manage Excel workbooks.
Podcasting Tutorial
This Podcasting tutorial includes a step by step guide that will show you how to record, publish and promote your podcast. Using inexpensive equipment and free software, you'll be publishing podcasts in no time.
The PowerPoint 2007 Window
This PowerPoint 2007 tutorial will show you the features and how to get around the PowerPoint Window.
GuidesandTutorials: Free PowerPoint Templates
Free PowerPoint templates that you can download and use today. This is a growing library of free resources for PowerPoint users.
LCD Projector Guide and Tutorial
This LCD Projector Guide will assist you in the use and purchase of a digital LCD projector or DLP projector. It will discuss the differences between LCD and DLP projectors, size and portability considerations, lamp types and brightness, resolution, image quality and other considerations in the use and purchase of a digital projector.
Word Tutorial: Microsoft Word 2003
This Word tutorial is just what you need to learn how to use Word 2003 to create professional looking documents.
Word 2007 Workspace
This Microsoft Word 2007 Workspace tutorial will acquaint you with the new tools and features in the Word 2007 Window. It's changed significantly from previus versions and even experienced users will find this helpful.
Work at Home Jobs
This Work at Home Jobs tutorial will provide information on ways that you can put your skills and knowledge to use in creating part or full time income while working from home.
Guides and Tutorials: Free Guides and Tutoials Site Map
Free guides and tutorials on podcasting, digital video and audio, Audacity, RSS, multimedia development, educational technology, technology integration, K12 Technology, PowerPoint.
Suggest a New Technology Tutorial
Free Technology Tutorials on software and technology applications including PowerPoint tutorials, Podcasting tutorials, Dreamweaver tutorials, Audacity, Non-Linear PowerPoint, Digital Photography, RSS tutorial, and everything educational technology.
Adobe Acrobat 9 Tutorial
This Adobe Acrobat 9 Tutorial will show you how to create PDFs from MS Office applications, from Multipe files, from web pages and from several other types of documents.
GuidesandTutorials: Free Tutorials
Free Tutorials, software, hardware, and technology applications including PowerPoint, Podcasting, Dreamweaver, Audacity,
Excel 2007 Tutorial | GuidesandTutorials: Free Tutorials
This free Excel 2007 Tutorial will show you how to use all of the begginer and intermediate features in Excel 2007

This site proudly build with Site Build It!

Powered By SiteBuildIt

  • Home
  • Adobe Acrobat 9 Tutorial
  • Audacity Tutorial
  • Audacity Tips
  • Advance Organizers
  • Create a Great Website
  • CSS Tutorial
  • Digital Photography
  • Dreamweaver Tutorial
  • Dreamweaver CS4
  • Dreamweaver CS5
  • Excel 2003 Tutorial
  • Excel 2007 Tutorial
  • Podcasting Tutorial
  • PowerPoint 2003
  • PowerPoint 2007
  • PowerPoint Tips
  • PowerPoint Templates
  • Non-Linear PowerPoint
  • LCD Projector Guide
  • RSS Tutorial
  • Suggest a Tutorial
  • Word 2003 Tutorial
  • Word 2007 Tutorial
  • Site Map

Special Web Tutorials
at Our Sister Site

  • Planning a Website
  • Building a Website
  • Promoting a Website
  • Website Income
  • Website Tutorials

Excel 2007 Ebook: The Ultimate Guide - $12.95

Excel 2007 Ebook

Get the Excel 2007 Ebook: The Ultimate Guide and receive all of the Excel 2007 tutorials in one handy reference guide. Purchase online easily with your credit card or PayPal and have the Ebook emailed to your email address (pdf format)

Price: $12.95. California residents pay 7.25% Sales tax. Delivered via email.

Excel Video Tutorials
1. Excel Basics
2. Editing a Worksheet
3. Making a Gantt Chart
5. Excel Keyboard Shortcuts

Excel 2007 Tutorials
Excel 2007 Charts
Excel 2007 Graphics
Excel 2007 Worksheets
Excel 2007 Worksheet Views
Excel 2007 Formulas
Excel 2007 Named Ranges
Excel 2007 Cell Comments

More Excel Tutorials at
GuidesandTutorials.net
[?] Subscribe To This Site

Add to Google
Add to My Yahoo!
Add to My MSN
Subscribe with Bloglines

Copyright 2009 - GuidesandTutorials - All Rights Reserved
GuidesandTutorials Home | About| Contact | Privacy Policy


No Such URL

Excel 3003 Tutorial

LCD Projector Guide

Word 2007 Tutorial
Work at Home Jobs

Suggest a Tutorial
Adobe Acrobat 9 Tutorial
Convert PowerPoint to Flash
Excel 2007 Tutorial

No Such URL at This Domain

Sorry,

There's no such page at www.guidesandtutorials.com

Click here to link to guidesandtutorials.com's Home Page. Then just click on the right button to go wherever you'd like within the site.

Sorry for the bother.

footer for Free tutorials page


Free Microsoft Excel Templates and Spreadsheets

Vertex42.com - The Guide to Excel in Everything
Home > Excel Spreadsheet Templates

Excel Templates

Looking for free Microsoft Excel ® templates? Here you will find a list of all the popular spreadsheet templates and calculators created by Vertex42.com, along with other places where you can find free Excel templates and spreadsheets. If you are looking for solutions for your business, see our Business Templates page.

Featured Templates

Money Management Template

Money Management Template

The ultimate money management spreadsheet! Create and monitor your budget. A free alternative to Quicken.
Gantt Chart Template

Gantt Chart Template

A very simple alternative to Microsoft Project if you need a simple project schedule.
Perpetual Calendar Template

Perpetual Calendar

Create both yearly and monthly calendars. Keep track of yearly events.
Home Mortgage Calculator

Home Mortgage Calculator

Analyze fixed-rate and adjustable-rate mortgages, print an amortization schedule, include extra payments.

Excel Templates by Vertex42®

* All of our templates were originally created for Microsoft Excel, but most of them are also available for OpenOffice.org and Google Docs as well.

Calendars & Schedules

  • Excel Calendar Template
  • Yearly Calendar
  • Monthly Calendar
  • Weekly Calendar Template
  • Work Schedule *
  • Weekly Schedule *
  • Shift Schedule *
  • Daily Planner *
  • Weekly Planner *
  • Monthly Planner Template *
  • New Year's Resolution Calendar
  • Photo Calendar Template *
  • Perpetual Calendar Template
  • Baby Feeding Schedule *
Personal Budget Template

Budgets / Personal Finance

  • Money Management Template
  • Budget Calculator
  • Personal Budget *
  • Personal Monthly Budget *
  • Family Budget Planner *
  • Household Budget Worksheet *
  • Home Budget Worksheet
  • Wedding Budget Template *
  • Checkbook *
  • Expense Tracker
  • Business Budget Template
  • Savings Goal Tracker
  • Christmas Gift Budget *
  • Money Manager for Kids *

Invoices & Inventory

  • Excel Invoice Template *
  • Service Invoice Template *
  • Sales Invoice Template *
  • Quote Template *
  • Proforma Invoice Template *
  • Work Order Template *
  • Purchase Order *
  • Packing Slip Template *
  • Billing Statement *
  • Cash and Rent Receipt Form *
  • Asset Tracking Template
  • Home Inventory *

Timesheets & HR

  • Employee Payroll Register *
  • Employee Time Sheet *
  • Timesheet with Breaks *
  • Timecard *
  • Expense Report *
  • Reimbursement Form *
  • Vacation Tracking
  • Organization Chart
  • Fax Cover Sheet Template *
  • Take Home Pay Calculator *

Education

  • Gradebook Template *
  • Lesson Plan Template *
  • Class Schedule *
  • Class Attendance Tracking *
  • School Calendar
  • Academic Calendar
  • Calculate GPA *
  • Printable Periodic Table
Gantt Chart Template

Project Management

  • Gantt Chart
  • Critical Path Analysis
  • To Do List*
  • Timeline Template
  • Timeline Examples
Line of Credit Calculator

Loan Calculators

  • Amortization Schedule
  • Car Loan Calculator
  • Simple Loan Calculator *
  • Amortization Table
  • Simple Interest Calculator
  • Interest Only Loan
  • Balloon Loan Mortgage Calculator
  • Boat Loan Calculator
Home Mortgage Calculator

Mortgage Calculators

  • Home Mortgage Calculator
  • Mortgage Payment Calculator *
  • ARM Loan Calculator
  • Home Equity Loan Calculator
  • Line of Credit Calculator
  • Extra Payments
  • Canadian Mortgage Calculator
  • Simple Interest Mortgage
  • More Mortgage Spreadsheets
College Savings Calculator

Retirement & Savings

  • College Savings Calculator
  • Simple Savings Interest Calculator
  • 401(k) Savings Calculator
  • Retirement Savings Calculator
  • Annuity Payment Calculator
Credit Card Minimum Payment Calculator

Personal Finance

  • Debt Reduction Snowball Calculator
  • Credit Card Payoff Calculator
  • Home Expense Calculator
  • Stock Quotes
Balance Sheet Template

Financial Statements

  • Startup Costs *
  • Balance Sheet *
  • Income Statement *
  • Cash Flow Statement *
  • Break Even Point
  • Net Worth Statement *
  • Profit and Loss Statement *
  • Net Present Value Calculator
  • Depreciation Schedule
Blood Sugar Chart

Exercise / Health

  • Weight Loss Log
  • Food Log
  • Weight Chart
  • Exercise Chart
  • Exercise Log
  • Running Log
  • Weight Lifting Chart
  • Weight Lifting Log
  • Body Mass Index Chart
  • Ideal Weight Chart
  • Menu Planner *
  • Blood Sugar Level Chart *
  • Blood Pressure Chart & Log *
  • Immunization Record *

Lists and Checklists

  • Baby Checklist *
  • Wedding Checklist Template *
  • Guest List *
  • Grocery Shopping List *
  • Moving Checklist *

Attendance

  • Sign In Sheet *
  • Sign Up Sheet *
  • Attendance Record *

Quality Control & Statistics

  • Control Chart
  • Pareto Chart
  • Box and Whisker Plot
  • Dot Plot
  • PICK Chart
  • Cause and Effect Diagram

Other Templates

  • Family Tree Template
  • Gas Mileage Log & Calculator
  • Blank Sudoku Grid
  • Graph Paper Template *
  • Gift Certificate Tracking Log *
  • Contact List Template *

Other Places to Find Free Excel Templates and Other Spreadsheet Templates

  • Microsoft Office Template Gallery
  • Google Spreadsheet Templates
  • OpenOffice.org Template Gallery

Link to Our Spreadsheet Templates

We created this page specifically so that if you have a website about Excel, you can link to our list of spreadsheet templates. Here is a suggestion for how to link to this page:

Excel Templates - http://www.vertex42.com/ExcelTemplates/
Download free Excel templates and spreadsheets from Vertex42 including calendar, loan, mortgage, budget, invoice, timeline, timesheet, gantt, and schedule templates.

Like This Page?

Tweet

Bookmark & Share

Become a Fan

Vertex42 Articles

Amortization Formulas Dashboard Reports Using Excel Solver Dynamic Named Ranges Financial Modeling Debt Consolidation Simple Interest Monte Carlo Simulation
Histograms in Excel Random Numbers Normal Distribution Graph
Excel Web Queries Custom Excel Functions Excel Training Toolbar Buttons Significant Figures Sparklines Excel Shortcuts Fun and Games
VERTEX42.com
© 2003-2011 Vertex42 LLC. All rights reserved.
Vertex42® is a registered trademark of Vertex42 LLC. Microsoft® and Microsoft Excel® and Microsoft Word® are registered trademarks of Microsoft Corporation. Vertex42.com is not associated with Microsoft.
About/Contact Us . Support/FAQ . Sitemap . Links . Privacy . Legal Stuff

Excel Templates, Spreadsheets, and Calculators


Error 404: File Not Found

Vertex42.com - The Guide to Excel in Everything
Home

404: File Not Found

If you are having trouble finding what you are looking for on Vertex42.com, please try using our site-specific SEARCH tool located in the upper right of this page.

If you want to report an error to Vertex42.com, please contact us via email.

Free Calendars

2011 Calendar 2012 Calendar Printable Calendars Blank Calendars Monthly Calendar Yearly Calendar Weekly Calendar School Calendars Academic Calendars Excel Calendar Daily Planner Photo Calendar Annual Calendar Daily Calendar Calendars for Blogs Perpetual Calendar Spanish:Calendario Gratis French:Calendrier Gratuit

Schedules & Planners

Daily Planner Weekly Planner Monthly Planner Meal Planner Baby Schedule Immunization Schedule Class Schedule Shift Schedule Weekly Schedule Work Schedule

Checklists

Camping Checklist New Baby Checklist Moving Checklist Wedding Checklist Guest List Grocery List To Do List Resolution Checklist

Exercise Charts & Logs

Exercise Chart Workout Chart Ideal Weight Chart BMI Chart Weight Loss Chart BMI Calculator Meal Planner Daily Food Log Exercise Log Workout Log Running Log Grocery List Blood Sugar Chart Blood Pressure Chart Immunization Record Golf Score Tracker Headache Log

Invoice Templates

Free Invoice Template Service Invoice Sales Invoice Pro Forma Invoice Quote Template Purchase Order Packing Slip Billing Statement Receipt Template Work Order Template Easy Invoicing Spanish:Factura

Timesheets & Payroll

Timesheet Template Timesheet with Breaks Time Card Shift Schedule Vacation Accrual Paycheck Calculator Payroll Register Travel Expense Report Expense Reimbursement

Financial Statements

Start Up Costs Break Even Analysis Balance Sheet Income Statement Cash Flow Statement Net Worth Expense Tracking Business Budget Profit and Loss Projection Depreciation Schedule

Attendance Sheets

School Attendance (daily, weekly, monthly) Sign In Sheets (meetings, visitors, patients) Sign Up Sheets (potlucks, volunteer, parties) Attendance Records (meetings, clubs, classes) Time Sheets (weekly, biweekly)

Budgets

Money Management Personal Budget Personal Monthly Budget Household Budget Family Budget Planner Home Budget Worksheet Wedding Budget Business Budget Expense & Budget Tracking Budget Calculator Savings Goal Tracker Debt Reduction Christmas Gift Budget info Make a Budget info How to Budget info Budget Software

Finance Articles

Make a Budget How to Budget Financial Modeling Excel Financial Functions Simple Interest Amortization Formulas Amortization Calculation Negative Amortization Debt Consolidation Growth Rate Discount Factors Depreciation NPV

Resumes

  • info How to Write a Resume
  • info Resume Tips
  • info Resume Action Verbs
  • info Sample Resume Objectives
  • help Handling Employment Gaps
  • help Should I Include My GPA?

Resume Templates

Free Resume Template CV Template

Resume Types

Chronological Resume Functional Resume

Sample Resumes

Student Resume

Financial Calculators

Mortgage Calculators

Home Mortgage Calculator Mortgage Payment Calculator Canadian Mortgage Calculator Extra Payment Calculator Adjustable Rate Mortgage (ARM) Simple Interest Loan Calculator Home Equity Loan Calculator Home Expense Calculator Line of Credit Calculator

Loan Calculators

Auto Loan Calculator Balloon Loan Calculator Interest-Only Calculator Simple Loan Calculator Simple Interest Calculator

Amortization

Amortization Schedule Amortization Chart

Retirement & Savings

College Savings 401k Calculator Savings Calculator Retirement Savings Annuity Calculator Inflation Calculator Net Worth Calculator

Debt Calculators

Debt Reduction Calculator Credit Repair Credit Card Payoff Calculator Credit Card Minimum Payment Calculator

Budgets

Budget Calculator Monthly Budget Calculator Family Budget Planner Personal Budget Spreadsheet Home Budget

Business Tools

Paycheck Calculator Payroll Calculator NPV Calculator Depreciation Calculator
VERTEX42.com
© 2003-2011 Vertex42 LLC. All rights reserved.
Vertex42® is a registered trademark of Vertex42 LLC. Microsoft® and Microsoft Excel® and Microsoft Word® are registered trademarks of Microsoft Corporation. Vertex42.com is not associated with Microsoft.
About/Contact Us . Support/FAQ . Sitemap . Links . Privacy . Legal Stuff


�� Page not found

Welcome to FreeFileUpload.net. Helping people find the Best places to upload files for storage and sharing is what we do!

Free File Upload

File Uploading Sites & Free File Hosting services

  • Home

Not Found

Sorry, but you are looking for something that isn't here.

  • Recent Posts

    • Use Free File Upload for Hosting, Sharing, & Uploading Files Online
    • Privacy Policy for FreeFileUpload.net

  • Free File Hosts

    File Serve
    Uploading
    Hot File

© 2010-2011 Free File Upload, Privacy Policy


صفحه مورد نظر یافت نشد.

تبلیغات

بلاگ مورد نظر شما یافت نشد. ممکن است آدرس وبلاگ اشتباه باشد و یا وبلاگ پیش از این حذف شده باشد

The page you have requested could not be found. (404)


file { upload / storage / sharing } service

upload large files for free
registration not mandatory
min size - 1 Mb
max size - 2 Gb


sendover.com - .sendo ver أحسن مرجع و إعلام لل !هذه ااصفحة معرودة للبيع

روابط مقترحة

sendover.com

اشتر هذا النطاق

اسم النطاق sendover.com للبيع!

روابط مقترحة

اشتر هذا النطاق

اسم النطاق sendover.com للبيع!

مزيد من التفاصيل...

روابط مقترحة

مزودة مجانا من برنامج سيدو العربي لركنالنطاقات. Disclaimer: Domain owner and Sedo maintain no relationship with third party advertisers. Reference to any specific service or trade mark is not controlled by Sedo or domain owner and does not constitute or imply its association, endorsement or recommendation.
By using our site, you consent to this privacy policy: This website allows third-party advertising companies for the purpose of reporting website traffic, statistics, advertisements, "click-throughs" and/or other activities to use Cookies and /or Web Beacons and other monitoring technologies to serve ads and to compile anonymous statistics about you when you visit this website. Cookies are small text files stored on your local internet browser cache. A Web Beacon is an often-transparent graphic image, usually no larger than 1 pixel x 1 pixel that is placed on a Web site. Both are created for the main purpose of helping your browser process the special features of websites that use Cookies or Web Beacons. The gathered information about your visits to this and other websites are used by these third party companies in order to provide advertisements about goods and services of interest to you. The information do not include any personal data like your name, address, email address, or telephone number. If you would like more information about this practice and to know your choices about not having this information used by these companies, click here.
Privacy Policies